diff options
author | Joe Slater <jslater@windriver.com> | 2016-08-18 14:56:06 -0700 |
---|---|---|
committer | Joe MacDonald <joe_macdonald@mentor.com> | 2016-09-05 13:34:11 -0400 |
commit | 490d792737a9ed00cab3d9e33d4843746150b14b (patch) | |
tree | ff63f8b04c6485c9931f0a8edb0246a251fa8fa1 /meta-networking | |
parent | c7e8da38198deb4b8da3536ac348623cfd306c5a (diff) | |
download | meta-openembedded-490d792737a9ed00cab3d9e33d4843746150b14b.tar.gz |
yp-tools: fix compile errors
Fix two fatal warnings. The cast error only
occurs for some architectures.
Not applicable to yp-tools-4.x.
Signed-off-by: Joe Slater <jslater@windriver.com>
Signed-off-by: Martin Jansa <Martin.Jansa@gmail.com>
Signed-off-by: Joe MacDonald <joe_macdonald@mentor.com>
Diffstat (limited to 'meta-networking')
-rw-r--r-- | meta-networking/recipes-support/nis/yp-tools/alignment-cheat.patch | 52 | ||||
-rw-r--r-- | meta-networking/recipes-support/nis/yp-tools_3.3.bb | 3 |
2 files changed, 53 insertions, 2 deletions
diff --git a/meta-networking/recipes-support/nis/yp-tools/alignment-cheat.patch b/meta-networking/recipes-support/nis/yp-tools/alignment-cheat.patch new file mode 100644 index 000000000..be9b62b8c --- /dev/null +++ b/meta-networking/recipes-support/nis/yp-tools/alignment-cheat.patch | |||
@@ -0,0 +1,52 @@ | |||
1 | yp-tools: avoid fatal cast warning | ||
2 | |||
3 | The way casting is done, we will get a fatal alignment warning on some | ||
4 | architectures. This patch cheats our way around this. | ||
5 | |||
6 | We also eliminate an unused constant which causes a fatal warning. | ||
7 | |||
8 | Upstream-status: Inappropriate [code does not exist in version 4.x] | ||
9 | |||
10 | Signed-off-by: Joe Slater <jslater@windriver.com> | ||
11 | |||
12 | --- a/lib/do_ypcall.c | ||
13 | +++ b/lib/do_ypcall.c | ||
14 | @@ -44,7 +44,6 @@ struct dom_binding | ||
15 | typedef struct dom_binding dom_binding; | ||
16 | |||
17 | static const struct timeval RPCTIMEOUT = {25, 0}; | ||
18 | -static const struct timeval UDPTIMEOUT = {5, 0}; | ||
19 | static int const MAXTRIES = 2; | ||
20 | static pthread_mutex_t ypbindlist_lock = PTHREAD_MUTEX_INITIALIZER; | ||
21 | static dom_binding *ypbindlist = NULL; | ||
22 | @@ -381,7 +380,7 @@ __ypclnt_call (u_long prog, xdrproc_t xa | ||
23 | |||
24 | int | ||
25 | do_ypcall (const char *domain, u_long prog, xdrproc_t xargs, | ||
26 | - caddr_t req, xdrproc_t xres, caddr_t resp) | ||
27 | + caddr_t req, xdrproc_t xres, void *resp) | ||
28 | { | ||
29 | dom_binding *ydb; | ||
30 | int status; | ||
31 | @@ -450,7 +449,7 @@ do_ypcall (const char *domain, u_long pr | ||
32 | /* Like do_ypcall, but translate the status value if necessary. */ | ||
33 | int | ||
34 | do_ypcall_tr (const char *domain, u_long prog, xdrproc_t xargs, | ||
35 | - caddr_t req, xdrproc_t xres, caddr_t resp) | ||
36 | + caddr_t req, xdrproc_t xres, void *resp) | ||
37 | { | ||
38 | int status = do_ypcall (domain, prog, xargs, req, xres, resp); | ||
39 | if (status == YPERR_SUCCESS) | ||
40 | --- a/lib/internal.h | ||
41 | +++ b/lib/internal.h | ||
42 | @@ -17,8 +17,8 @@ | ||
43 | #define _INTERNAL_H_ | ||
44 | |||
45 | extern int do_ypcall (const char *domain, u_long prog, xdrproc_t xargs, | ||
46 | - caddr_t req, xdrproc_t xres, caddr_t resp); | ||
47 | + caddr_t req, xdrproc_t xres, void *resp); | ||
48 | extern int do_ypcall_tr (const char *domain, u_long prog, xdrproc_t xargs, | ||
49 | - caddr_t req, xdrproc_t xres, caddr_t resp); | ||
50 | + caddr_t req, xdrproc_t xres, void *resp); | ||
51 | extern int yp_maplist (const char *, struct ypmaplist **); | ||
52 | #endif | ||
diff --git a/meta-networking/recipes-support/nis/yp-tools_3.3.bb b/meta-networking/recipes-support/nis/yp-tools_3.3.bb index b89f0b84a..69217fad1 100644 --- a/meta-networking/recipes-support/nis/yp-tools_3.3.bb +++ b/meta-networking/recipes-support/nis/yp-tools_3.3.bb | |||
@@ -11,11 +11,10 @@ ypwhich, yppasswd, domainname, nisdomainname \ | |||
11 | and ypdomainname. \ | 11 | and ypdomainname. \ |
12 | " | 12 | " |
13 | 13 | ||
14 | PNBLACKLIST[yp-tools] ?= "BROKEN: fails to build for qemuarm." | ||
15 | |||
16 | SRC_URI = "http://www.linux-nis.org/download/yp-tools/${BP}.tar.bz2 \ | 14 | SRC_URI = "http://www.linux-nis.org/download/yp-tools/${BP}.tar.bz2 \ |
17 | file://domainname.service \ | 15 | file://domainname.service \ |
18 | file://yp-tools-ipv4-ipv6-Provide-an-in-place-version-of-mapv4v6addr.patch \ | 16 | file://yp-tools-ipv4-ipv6-Provide-an-in-place-version-of-mapv4v6addr.patch \ |
17 | file://alignment-cheat.patch \ | ||
19 | " | 18 | " |
20 | SRC_URI[md5sum] = "acebeecc11a73fb8097503670344834c" | 19 | SRC_URI[md5sum] = "acebeecc11a73fb8097503670344834c" |
21 | SRC_URI[sha256sum] = "812be817df3d4c25813552be336c6c6ad5aedaf65611b81af3ad9f98fb3c2e50" | 20 | SRC_URI[sha256sum] = "812be817df3d4c25813552be336c6c6ad5aedaf65611b81af3ad9f98fb3c2e50" |