summaryrefslogtreecommitdiffstats
path: root/meta-networking
diff options
context:
space:
mode:
authorKhem Raj <raj.khem@gmail.com>2022-08-22 21:29:32 -0700
committerKhem Raj <raj.khem@gmail.com>2022-08-23 09:55:28 -0700
commit375be9fd60e22fb60b53d664983cb70d26d8a288 (patch)
treeae857d29be164a911f10a74cb214408fddf719e5 /meta-networking
parentf6eb4c82bb86c2b09b6ec5e0adf7c332af53b2aa (diff)
downloadmeta-openembedded-375be9fd60e22fb60b53d664983cb70d26d8a288.tar.gz
ntpsec: Add -D_GNU_SOURCE and fix building with devtool
wscript detects .git directory and if its present them invokes git describe --dirty which does not work on the devtool created git repository, since its synthesized. Add GNU_SOURCE define to get strptime() definition Signed-off-by: Khem Raj <raj.khem@gmail.com>
Diffstat (limited to 'meta-networking')
-rw-r--r--meta-networking/recipes-support/ntpsec/ntpsec/0001-wscript-Widen-the-search-for-tags.patch29
-rw-r--r--meta-networking/recipes-support/ntpsec/ntpsec_1.2.1.bb6
2 files changed, 33 insertions, 2 deletions
diff --git a/meta-networking/recipes-support/ntpsec/ntpsec/0001-wscript-Widen-the-search-for-tags.patch b/meta-networking/recipes-support/ntpsec/ntpsec/0001-wscript-Widen-the-search-for-tags.patch
new file mode 100644
index 000000000..98c62eed4
--- /dev/null
+++ b/meta-networking/recipes-support/ntpsec/ntpsec/0001-wscript-Widen-the-search-for-tags.patch
@@ -0,0 +1,29 @@
1From 9a7dead72f41e79979625c9bdef2fb638427d3d6 Mon Sep 17 00:00:00 2001
2From: Khem Raj <raj.khem@gmail.com>
3Date: Mon, 22 Aug 2022 20:54:17 -0700
4Subject: [PATCH] wscript: Widen the search for tags
5
6Default is to look for annotated tags, howveer when using devtool we
7create our own git tree from release tarballs which will have tags but
8they are not annotated, therefore broaden the search to include all tags
9
10Upstream-Status: Inappropriate [OE-specific]
11
12Signed-off-by: Khem Raj <raj.khem@gmail.com>
13---
14 wscript | 2 +-
15 1 file changed, 1 insertion(+), 1 deletion(-)
16
17diff --git a/wscript b/wscript
18index 879ded1..dff835d 100644
19--- a/wscript
20+++ b/wscript
21@@ -177,7 +177,7 @@ def configure(ctx):
22 if build_desc:
23 build_desc = ' ' + build_desc
24 if ctx.env.BIN_GIT:
25- cmd = ctx.env.BIN_GIT + shlex.split("describe --dirty")
26+ cmd = ctx.env.BIN_GIT + shlex.split("describe --tags --dirty")
27 git_short_hash = ctx.cmd_and_log(cmd).strip()
28 git_short_hash = '-'.join(git_short_hash.split('-')[1:])
29
diff --git a/meta-networking/recipes-support/ntpsec/ntpsec_1.2.1.bb b/meta-networking/recipes-support/ntpsec/ntpsec_1.2.1.bb
index cd8b396f1..e975f903f 100644
--- a/meta-networking/recipes-support/ntpsec/ntpsec_1.2.1.bb
+++ b/meta-networking/recipes-support/ntpsec/ntpsec_1.2.1.bb
@@ -16,7 +16,9 @@ SRC_URI = "https://ftp.ntpsec.org/pub/releases/ntpsec-${PV}.tar.gz \
16 file://0001-ntpd-ntp_sandbox.c-allow-clone3-for-glibc-2.34-in-se.patch \ 16 file://0001-ntpd-ntp_sandbox.c-allow-clone3-for-glibc-2.34-in-se.patch \
17 file://0001-ntpd-ntp_sandbox.c-allow-newfstatat-on-all-archs-for.patch \ 17 file://0001-ntpd-ntp_sandbox.c-allow-newfstatat-on-all-archs-for.patch \
18 file://0002-ntpd-ntp_sandbox.c-match-riscv-to-aarch-in-seccomp-f.patch \ 18 file://0002-ntpd-ntp_sandbox.c-match-riscv-to-aarch-in-seccomp-f.patch \
19 file://volatiles.ntpsec" 19 file://volatiles.ntpsec \
20 file://0001-wscript-Widen-the-search-for-tags.patch \
21 "
20 22
21SRC_URI[sha256sum] = "f2684835116c80b8f21782a5959a805ba3c44e3a681dd6c17c7cb00cc242c27a" 23SRC_URI[sha256sum] = "f2684835116c80b8f21782a5959a805ba3c44e3a681dd6c17c7cb00cc242c27a"
22 24
@@ -56,7 +58,7 @@ export PYTAG = "cpython${@ d.getVar('PYTHON_BASEVERSION').replace('.', '')}"
56export pyext_PATTERN = "%s.so" 58export pyext_PATTERN = "%s.so"
57export PYTHON_LDFLAGS = "-lpthread -ldl" 59export PYTHON_LDFLAGS = "-lpthread -ldl"
58 60
59CFLAGS:append = " -I${PYTHON_INCLUDE_DIR}" 61CFLAGS:append = " -I${PYTHON_INCLUDE_DIR} -D_GNU_SOURCE"
60 62
61EXTRA_OECONF = "--cross-compiler='${CC}' \ 63EXTRA_OECONF = "--cross-compiler='${CC}' \
62 --cross-cflags='${CFLAGS}' \ 64 --cross-cflags='${CFLAGS}' \