diff options
author | Khem Raj <raj.khem@gmail.com> | 2017-06-17 10:21:37 -0700 |
---|---|---|
committer | Joe MacDonald <joe_macdonald@mentor.com> | 2017-06-28 10:28:48 -0400 |
commit | 371fbfdec217a0eed9bd43d596f1fef074db6714 (patch) | |
tree | c11ce6ccf82a10478989686a0b904dd80436ea80 /meta-networking | |
parent | 58e9a525809cdc5db6d52bf21262d52fcb03a231 (diff) | |
download | meta-openembedded-371fbfdec217a0eed9bd43d596f1fef074db6714.tar.gz |
vlan: Fix build with security flags turned on
Limit the license checksum to the file header
Signed-off-by: Khem Raj <raj.khem@gmail.com>
Signed-off-by: Martin Jansa <Martin.Jansa@gmail.com>
Signed-off-by: Joe MacDonald <joe_macdonald@mentor.com>
Diffstat (limited to 'meta-networking')
-rw-r--r-- | meta-networking/recipes-connectivity/vlan/vlan-1.9/0001-Add-printf-format-and-silence-format-security-warnin.patch | 34 | ||||
-rw-r--r-- | meta-networking/recipes-connectivity/vlan/vlan_1.9.bb | 6 |
2 files changed, 38 insertions, 2 deletions
diff --git a/meta-networking/recipes-connectivity/vlan/vlan-1.9/0001-Add-printf-format-and-silence-format-security-warnin.patch b/meta-networking/recipes-connectivity/vlan/vlan-1.9/0001-Add-printf-format-and-silence-format-security-warnin.patch new file mode 100644 index 000000000..ebcfc7c2f --- /dev/null +++ b/meta-networking/recipes-connectivity/vlan/vlan-1.9/0001-Add-printf-format-and-silence-format-security-warnin.patch | |||
@@ -0,0 +1,34 @@ | |||
1 | From 400b8f235377f677a7a760f1e3a1cd26d95140bc Mon Sep 17 00:00:00 2001 | ||
2 | From: Khem Raj <raj.khem@gmail.com> | ||
3 | Date: Fri, 16 Jun 2017 22:58:18 -0700 | ||
4 | Subject: [PATCH] Add printf format and silence format-security warnings | ||
5 | |||
6 | Fix | ||
7 | |||
8 | vconfig.c:66:4: error: format not a string literal and no format arguments [-Werror=format-security] | ||
9 | fprintf(stdout,usage); | ||
10 | ^~~~~~~ | ||
11 | |||
12 | Upstream-Status: Pending | ||
13 | |||
14 | Signed-off-by: Khem Raj <raj.khem@gmail.com> | ||
15 | --- | ||
16 | vconfig.c | 2 +- | ||
17 | 1 file changed, 1 insertion(+), 1 deletion(-) | ||
18 | |||
19 | diff --git a/vconfig.c b/vconfig.c | ||
20 | index 5057cfd..83137ba 100644 | ||
21 | --- a/vconfig.c | ||
22 | +++ b/vconfig.c | ||
23 | @@ -63,7 +63,7 @@ static char* usage = | ||
24 | " is OFF.\n"; | ||
25 | |||
26 | void show_usage() { | ||
27 | - fprintf(stdout,usage); | ||
28 | + fprintf(stdout, "%s", usage); | ||
29 | } | ||
30 | |||
31 | int hex_to_bytes(char* bytes, int bytes_length, char* hex_str) { | ||
32 | -- | ||
33 | 2.13.1 | ||
34 | |||
diff --git a/meta-networking/recipes-connectivity/vlan/vlan_1.9.bb b/meta-networking/recipes-connectivity/vlan/vlan_1.9.bb index 09c4007ef..3f688b360 100644 --- a/meta-networking/recipes-connectivity/vlan/vlan_1.9.bb +++ b/meta-networking/recipes-connectivity/vlan/vlan_1.9.bb | |||
@@ -1,10 +1,12 @@ | |||
1 | SUMMARY = "VLAN provides vconfig utility" | 1 | SUMMARY = "VLAN provides vconfig utility" |
2 | SECTION = "misc" | 2 | SECTION = "misc" |
3 | LICENSE = "GPLv2" | 3 | LICENSE = "GPLv2" |
4 | LIC_FILES_CHKSUM = "file://vconfig.c;md5=293ef69c4e88434d37a5ee577a5288cb" | 4 | LIC_FILES_CHKSUM = "file://vconfig.c;beginline=1;endline=19;md5=094ca47de36c20c598b15b32c270ce0a" |
5 | 5 | ||
6 | SRC_URI = "http://${BPN}.sourcearchive.com/downloads/${PV}-3ubuntu9/${BPN}_${PV}.orig.tar.gz \ | 6 | SRC_URI = "http://${BPN}.sourcearchive.com/downloads/${PV}-3ubuntu9/${BPN}_${PV}.orig.tar.gz \ |
7 | file://no-HOME-includes.patch" | 7 | file://no-HOME-includes.patch \ |
8 | file://0001-Add-printf-format-and-silence-format-security-warnin.patch \ | ||
9 | " | ||
8 | 10 | ||
9 | SRC_URI[md5sum] = "5f0c6060b33956fb16e11a15467dd394" | 11 | SRC_URI[md5sum] = "5f0c6060b33956fb16e11a15467dd394" |
10 | SRC_URI[sha256sum] = "3b8f0a1bf0d3642764e5f646e1f3bbc8b1eeec474a77392d9aeb4868842b4cca" | 12 | SRC_URI[sha256sum] = "3b8f0a1bf0d3642764e5f646e1f3bbc8b1eeec474a77392d9aeb4868842b4cca" |