diff options
author | Armin Kuster <akuster808@gmail.com> | 2022-05-02 07:33:38 -0700 |
---|---|---|
committer | Khem Raj <raj.khem@gmail.com> | 2022-05-02 17:51:58 -0700 |
commit | 32160a06de6c076918bb748fd943bbfc724b4f59 (patch) | |
tree | 6f4abb2f7ea2605ad5941b3caaeee49d0dcf4720 /meta-networking | |
parent | eaa0fd9c2f91eac8b2e83e7d1a45119613f9ad14 (diff) | |
download | meta-openembedded-32160a06de6c076918bb748fd943bbfc724b4f59.tar.gz |
netplan: move from meta-networking to meta-oe
add to the dynamic meta-pthon lot
Signed-off-by: Armin Kuster <akuster808@gmail.com>
Signed-off-by: Khem Raj <raj.khem@gmail.com>
Diffstat (limited to 'meta-networking')
4 files changed, 0 insertions, 168 deletions
diff --git a/meta-networking/recipes-connectivity/netplan/netplan/0001-Makefile-do-not-use-Werror.patch b/meta-networking/recipes-connectivity/netplan/netplan/0001-Makefile-do-not-use-Werror.patch deleted file mode 100644 index 613858f6fd..0000000000 --- a/meta-networking/recipes-connectivity/netplan/netplan/0001-Makefile-do-not-use-Werror.patch +++ /dev/null | |||
@@ -1,26 +0,0 @@ | |||
1 | From a06c77557ed951249d5b344441ad6ec57410e63f Mon Sep 17 00:00:00 2001 | ||
2 | From: Alexander Kanavin <alex@linutronix.de> | ||
3 | Date: Sun, 3 Oct 2021 21:52:16 +0200 | ||
4 | Subject: [PATCH] Makefile: do not use -Werror | ||
5 | |||
6 | Upstream-Status: Inappropriate [oe-core specific] | ||
7 | Signed-off-by: Alexander Kanavin <alex@linutronix.de> | ||
8 | --- | ||
9 | Makefile | 1 - | ||
10 | 1 file changed, 1 deletion(-) | ||
11 | |||
12 | diff --git a/Makefile b/Makefile | ||
13 | index 0368e41..53d6a9d 100644 | ||
14 | --- a/Makefile | ||
15 | +++ b/Makefile | ||
16 | @@ -8,7 +8,6 @@ BUILDFLAGS = \ | ||
17 | -DSBINDIR=\"$(SBINDIR)\" \ | ||
18 | -I${CURDIR}/include \ | ||
19 | -Wall \ | ||
20 | - -Werror \ | ||
21 | $(NULL) | ||
22 | |||
23 | SRCS = \ | ||
24 | -- | ||
25 | 2.25.1 | ||
26 | |||
diff --git a/meta-networking/recipes-connectivity/netplan/netplan/0001-Makefile-fix-parallel-build-failure.patch b/meta-networking/recipes-connectivity/netplan/netplan/0001-Makefile-fix-parallel-build-failure.patch deleted file mode 100644 index 2149ee30cd..0000000000 --- a/meta-networking/recipes-connectivity/netplan/netplan/0001-Makefile-fix-parallel-build-failure.patch +++ /dev/null | |||
@@ -1,44 +0,0 @@ | |||
1 | From 2e84550b47b475d830622f41576992a1d45d6af0 Mon Sep 17 00:00:00 2001 | ||
2 | From: Zhao Yi <38274519+yizhao1@users.noreply.github.com> | ||
3 | Date: Tue, 15 Mar 2022 19:28:26 +0800 | ||
4 | Subject: [PATCH] Makefile: fix parallel build failure (#267) | ||
5 | |||
6 | * Makefile: fix parallel build failure | ||
7 | |||
8 | Add src/_features.h as dependency for dbus.o to fix the parallel build | ||
9 | failure: | ||
10 | src/dbus.c:17:10: fatal error: _features.h: No such file or directory | ||
11 | |||
12 | Upstream-Status: Backport | ||
13 | [https://github.com/canonical/netplan/commit/2e84550b47b475d830622f41576992a1d45d6af0] | ||
14 | |||
15 | Signed-off-by: Yi Zhao <yi.zhao@windriver.com> | ||
16 | --- | ||
17 | Makefile | 4 ++-- | ||
18 | 1 file changed, 2 insertions(+), 2 deletions(-) | ||
19 | |||
20 | diff --git a/Makefile b/Makefile | ||
21 | index 0368e41..8ac7432 100644 | ||
22 | --- a/Makefile | ||
23 | +++ b/Makefile | ||
24 | @@ -52,7 +52,7 @@ NOSETESTS3 ?= $(shell command -v nosetests-3 || command -v nosetests3 || echo tr | ||
25 | |||
26 | default: netplan/_features.py generate netplan-dbus dbus/io.netplan.Netplan.service doc/netplan.html doc/netplan.5 doc/netplan-generate.8 doc/netplan-apply.8 doc/netplan-try.8 doc/netplan-dbus.8 doc/netplan-get.8 doc/netplan-set.8 | ||
27 | |||
28 | -%.o: src/%.c | ||
29 | +%.o: src/%.c src/_features.h | ||
30 | $(CC) $(BUILDFLAGS) $(CFLAGS) $(LDFLAGS) -c $^ `pkg-config --cflags --libs glib-2.0 gio-2.0 yaml-0.1 uuid` | ||
31 | |||
32 | libnetplan.so.$(NETPLAN_SOVER): $(SRCS) abicompat.lds | ||
33 | @@ -62,7 +62,7 @@ libnetplan.so.$(NETPLAN_SOVER): $(SRCS) abicompat.lds | ||
34 | generate: libnetplan.so.$(NETPLAN_SOVER) generate.o | ||
35 | $(CC) $(BUILDFLAGS) $(CFLAGS) $(LDFLAGS) -o $@ $(filter-out $<,$^) -L. -lnetplan `pkg-config --cflags --libs glib-2.0 gio-2.0 yaml-0.1 uuid` | ||
36 | |||
37 | -netplan-dbus: libnetplan.so.$(NETPLAN_SOVER) src/_features.h dbus.o | ||
38 | +netplan-dbus: libnetplan.so.$(NETPLAN_SOVER) dbus.o | ||
39 | $(CC) $(BUILDFLAGS) $(CFLAGS) $(LDFLAGS) -o $@ $(filter-out $<,$(patsubst %.h,,$^)) -L. -lnetplan `pkg-config --cflags --libs libsystemd glib-2.0 gio-2.0 yaml-0.1 uuid` | ||
40 | |||
41 | src/_features.h: src/[^_]*.[hc] | ||
42 | -- | ||
43 | 2.25.1 | ||
44 | |||
diff --git a/meta-networking/recipes-connectivity/netplan/netplan/0001-don-t-fail-if-GLOB_BRACE-is-not-defined.patch b/meta-networking/recipes-connectivity/netplan/netplan/0001-don-t-fail-if-GLOB_BRACE-is-not-defined.patch deleted file mode 100644 index 8779c251a5..0000000000 --- a/meta-networking/recipes-connectivity/netplan/netplan/0001-don-t-fail-if-GLOB_BRACE-is-not-defined.patch +++ /dev/null | |||
@@ -1,30 +0,0 @@ | |||
1 | From e0df1f07d1707d5daf0358cc60b30f06121f7e60 Mon Sep 17 00:00:00 2001 | ||
2 | From: Zang Ruochen <zangrc.fnst@cn.fujitsu.com> | ||
3 | Date: Fri, 25 Dec 2020 11:41:43 +0900 | ||
4 | Subject: [PATCH] don't fail if GLOB_BRACE is not defined | ||
5 | |||
6 | Signed-off-by: Zang Ruochen <zangrc.fnst@cn.fujitsu.com> | ||
7 | --- | ||
8 | src/util.c | 6 ++++++ | ||
9 | 1 file changed, 6 insertions(+) | ||
10 | |||
11 | diff --git a/src/util.c b/src/util.c | ||
12 | index 841ec12..59595da 100644 | ||
13 | --- a/src/util.c | ||
14 | +++ b/src/util.c | ||
15 | @@ -32,6 +32,12 @@ | ||
16 | #include "names.h" | ||
17 | #include "yaml-helpers.h" | ||
18 | |||
19 | +/* Don't fail if the standard library | ||
20 | + * doesn't provide brace expansion */ | ||
21 | +#ifndef GLOB_BRACE | ||
22 | +#define GLOB_BRACE 0 | ||
23 | +#endif | ||
24 | + | ||
25 | NETPLAN_ABI GHashTable* | ||
26 | wifi_frequency_24; | ||
27 | |||
28 | -- | ||
29 | 2.25.1 | ||
30 | |||
diff --git a/meta-networking/recipes-connectivity/netplan/netplan_0.104.bb b/meta-networking/recipes-connectivity/netplan/netplan_0.104.bb deleted file mode 100644 index ea944fa9db..0000000000 --- a/meta-networking/recipes-connectivity/netplan/netplan_0.104.bb +++ /dev/null | |||
@@ -1,68 +0,0 @@ | |||
1 | SUMMARY = "The network configuration abstraction renderer" | ||
2 | DESCRIPTION = "Netplan is a utility for easily configuring networking on a \ | ||
3 | linux system. You simply create a YAML description of the required network \ | ||
4 | interfaces and what each should be configured to do. From this description \ | ||
5 | Netplan will generate all the necessary configuration for your chosen renderer \ | ||
6 | tool." | ||
7 | HOMEPAGE = "https://netplan.io" | ||
8 | SECTION = "net/misc" | ||
9 | |||
10 | LICENSE = "GPL-3.0-only" | ||
11 | LIC_FILES_CHKSUM = "file://COPYING;md5=d32239bcb673463ab874e80d47fae504" | ||
12 | |||
13 | S = "${WORKDIR}/git" | ||
14 | SRCREV = "3e522b7255310bdecca6c781137741dfc4abc021" | ||
15 | PV = "0.104" | ||
16 | |||
17 | SRC_URI = "git://github.com/CanonicalLtd/netplan.git;branch=main;protocol=https \ | ||
18 | file://0001-Makefile-do-not-use-Werror.patch \ | ||
19 | file://0001-Makefile-fix-parallel-build-failure.patch \ | ||
20 | " | ||
21 | |||
22 | SRC_URI:append:libc-musl = " file://0001-don-t-fail-if-GLOB_BRACE-is-not-defined.patch" | ||
23 | |||
24 | DEPENDS = "glib-2.0 libyaml ${@bb.utils.filter('DISTRO_FEATURES', 'systemd', d)}" | ||
25 | |||
26 | PACKAGECONFIG ?= "" | ||
27 | |||
28 | PACKAGECONFIG[tests] = ",,,python3-nose python3-coverage python3-netifaces python3-pycodestyle python3-pyflakes python3-pyyaml" | ||
29 | |||
30 | RDEPENDS:${PN} = "python3 python3-core python3-netifaces python3-pyyaml util-linux-libuuid libnetplan" | ||
31 | |||
32 | inherit pkgconfig systemd | ||
33 | |||
34 | TARGET_CC_ARCH += "${LDFLAGS}" | ||
35 | |||
36 | EXTRA_OEMAKE = "generate netplan/_features.py" | ||
37 | EXTRA_OEMAKE =+ "${@bb.utils.contains('DISTRO_FEATURES','systemd','netplan-dbus dbus/io.netplan.Netplan.service','',d)}" | ||
38 | |||
39 | do_install() { | ||
40 | install -d ${D}${sbindir} ${D}${libdir} ${D}${base_libdir}/netplan ${D}${datadir}/netplan/netplan/cli/commands ${D}${sysconfdir}/netplan | ||
41 | install -m 755 ${S}/generate ${D}${base_libdir}/netplan/ | ||
42 | install -m 644 ${S}/netplan/*.py ${D}${datadir}/netplan/netplan | ||
43 | install -m 644 ${S}/netplan/cli/*.py ${D}${datadir}/netplan/netplan/cli | ||
44 | install -m 644 ${S}/netplan/cli/commands/*.py ${D}${datadir}/netplan/netplan/cli/commands | ||
45 | install -m 755 ${S}/src/netplan.script ${D}${datadir}/netplan/ | ||
46 | ln -srf ${D}${datadir}/netplan/netplan.script ${D}${sbindir}/netplan | ||
47 | sed -i -e "s#/lib/netplan/generate#${base_libdir}/netplan/generate#" ${D}${datadir}/netplan/netplan/cli/utils.py | ||
48 | |||
49 | install -d ${D}/${systemd_unitdir}/system ${D}${systemd_unitdir}/system-generators | ||
50 | ln -srf ${D}/${base_libdir}/netplan/generate ${D}${systemd_unitdir}/system-generators | ||
51 | |||
52 | if ${@bb.utils.contains('DISTRO_FEATURES','systemd','true','false',d)}; then | ||
53 | install -d ${D}${datadir}/dbus-1/system.d ${D}${datadir}/dbus-1/system-services | ||
54 | install -m 755 ${S}/netplan-dbus ${D}${base_libdir}/netplan | ||
55 | install -m 644 ${S}/dbus/io.netplan.Netplan.conf ${D}${datadir}/dbus-1/system.d | ||
56 | install -m 644 ${S}/dbus/io.netplan.Netplan.service ${D}${datadir}/dbus-1/system-services | ||
57 | sed -i -e "s#^Exec=/lib/#Exec=${base_libdir}/#" ${D}${datadir}/dbus-1/system-services/io.netplan.Netplan.service | ||
58 | fi | ||
59 | |||
60 | install -m 755 ${S}/libnetplan.so.0.0 ${D}${libdir} | ||
61 | ln -rfs ${D}${libdir}/libnetplan.so.0.0 ${D}${libdir}/libnetplan.so | ||
62 | } | ||
63 | |||
64 | PACKAGES += "${PN}-dbus libnetplan" | ||
65 | |||
66 | FILES:libnetplan = "${libdir}/libnetplan.so.0.0" | ||
67 | FILES:${PN} = "${sbindir} ${base_libdir}/netplan/generate ${datadir}/netplan ${sysconfdir}/netplan ${systemd_unitdir}" | ||
68 | FILES:${PN}-dbus = "${base_libdir}/netplan/netplan-dbus ${datadir}/dbus-1" | ||