summaryrefslogtreecommitdiffstats
path: root/meta-networking
diff options
context:
space:
mode:
authorQuentin Schulz <quentin.schulz@cherry.de>2024-08-21 18:33:09 +0200
committerKhem Raj <raj.khem@gmail.com>2024-08-21 12:06:12 -0700
commit21a87a422cb3144574af20463bce33f8d9c546d2 (patch)
tree29ecdcb31d3e5108c4217d7783f6c7b950dd4df6 /meta-networking
parent990955ba0941f207b5f4c9ead9f316c4afb5c6b9 (diff)
downloadmeta-openembedded-21a87a422cb3144574af20463bce33f8d9c546d2.tar.gz
nftables: fix pep517-backend warning
nftables has a pyproject.toml file since v1.0.9, c.f. https://git.netfilter.org/nftables/commit/?id=8e603e0f7eec7c0000344a004228a30fbf0ece5c Styhead has started to complain when a recipe inherits setuptools3 and a proper pyproject.toml is provided in sources. This uses python_pep517 functions instead of the setuptools3 ones, inherits the proper class (still using setuptools3 but through pep517 process). Notably, the python PACKAGECONFIG has its build dependency on python3-setuptools-native removed as it's brought in by python_setuptools_build_meta inherit, which is performed whenever the python PACKAGECONFIG is selected. This avoids a "duplicate" but no change in behavior is expected. This was only build tested. Signed-off-by: Quentin Schulz <quentin.schulz@cherry.de> Signed-off-by: Khem Raj <raj.khem@gmail.com>
Diffstat (limited to 'meta-networking')
-rw-r--r--meta-networking/recipes-filter/nftables/nftables_1.1.0.bb12
1 files changed, 6 insertions, 6 deletions
diff --git a/meta-networking/recipes-filter/nftables/nftables_1.1.0.bb b/meta-networking/recipes-filter/nftables/nftables_1.1.0.bb
index 1dfaad494..98e7a85a4 100644
--- a/meta-networking/recipes-filter/nftables/nftables_1.1.0.bb
+++ b/meta-networking/recipes-filter/nftables/nftables_1.1.0.bb
@@ -24,16 +24,16 @@ PACKAGECONFIG[json] = "--with-json, --without-json, jansson"
24PACKAGECONFIG[linenoise] = "--with-cli=linenoise, , linenoise, , , editline readline" 24PACKAGECONFIG[linenoise] = "--with-cli=linenoise, , linenoise, , , editline readline"
25PACKAGECONFIG[manpages] = "--enable-man-doc, --disable-man-doc, asciidoc-native" 25PACKAGECONFIG[manpages] = "--enable-man-doc, --disable-man-doc, asciidoc-native"
26PACKAGECONFIG[mini-gmp] = "--with-mini-gmp, --without-mini-gmp" 26PACKAGECONFIG[mini-gmp] = "--with-mini-gmp, --without-mini-gmp"
27PACKAGECONFIG[python] = ",, python3-setuptools-native" 27PACKAGECONFIG[python] = ""
28PACKAGECONFIG[readline] = "--with-cli=readline, , readline, , , editline linenoise" 28PACKAGECONFIG[readline] = "--with-cli=readline, , readline, , , editline linenoise"
29PACKAGECONFIG[xtables] = "--with-xtables, --without-xtables, iptables" 29PACKAGECONFIG[xtables] = "--with-xtables, --without-xtables, iptables"
30 30
31EXTRA_OECONF = " \ 31EXTRA_OECONF = " \
32 ${@bb.utils.contains_any('PACKAGECONFIG', 'editline linenoise readline', '', '--without-cli', d)}" 32 ${@bb.utils.contains_any('PACKAGECONFIG', 'editline linenoise readline', '', '--without-cli', d)}"
33 33
34SETUPTOOLS_SETUP_PATH = "${S}/py" 34PEP517_SOURCE_PATH = "${S}/py"
35 35
36inherit_defer ${@bb.utils.contains('PACKAGECONFIG', 'python', 'setuptools3', '', d)} 36inherit_defer ${@bb.utils.contains('PACKAGECONFIG', 'python', 'python_setuptools_build_meta', '', d)}
37 37
38PACKAGES =+ "${@bb.utils.contains('PACKAGECONFIG', 'python', '${PN}-python', '', d)}" 38PACKAGES =+ "${@bb.utils.contains('PACKAGECONFIG', 'python', '${PN}-python', '', d)}"
39FILES:${PN}-python = "${PYTHON_SITEPACKAGES_DIR}" 39FILES:${PN}-python = "${PYTHON_SITEPACKAGES_DIR}"
@@ -44,21 +44,21 @@ RDEPENDS:${PN}-python = "python3-core python3-json ${PN}"
44do_configure() { 44do_configure() {
45 autotools_do_configure 45 autotools_do_configure
46 if ${@bb.utils.contains('PACKAGECONFIG', 'python', 'true', 'false', d)}; then 46 if ${@bb.utils.contains('PACKAGECONFIG', 'python', 'true', 'false', d)}; then
47 setuptools3_do_configure 47 python_pep517_do_configure
48 fi 48 fi
49} 49}
50 50
51do_compile() { 51do_compile() {
52 autotools_do_compile 52 autotools_do_compile
53 if ${@bb.utils.contains('PACKAGECONFIG', 'python', 'true', 'false', d)}; then 53 if ${@bb.utils.contains('PACKAGECONFIG', 'python', 'true', 'false', d)}; then
54 setuptools3_do_compile 54 python_pep517_do_compile
55 fi 55 fi
56} 56}
57 57
58do_install() { 58do_install() {
59 autotools_do_install 59 autotools_do_install
60 if ${@bb.utils.contains('PACKAGECONFIG', 'python', 'true', 'false', d)}; then 60 if ${@bb.utils.contains('PACKAGECONFIG', 'python', 'true', 'false', d)}; then
61 setuptools3_do_install 61 python_pep517_do_install
62 fi 62 fi
63} 63}
64 64