diff options
author | Joe Slater <jslater@windriver.com> | 2015-01-11 11:15:21 -0800 |
---|---|---|
committer | Joe MacDonald <joe_macdonald@mentor.com> | 2015-01-26 09:32:32 -0500 |
commit | 1e67431ece594809d35bdc86d608a96fedf6e9cb (patch) | |
tree | 79a04ae64902ec1f2374098a8f085a7adde367a6 /meta-networking | |
parent | ab75a8c8d0a57411af1452f9f8f41ccf29bb0cc7 (diff) | |
download | meta-openembedded-1e67431ece594809d35bdc86d608a96fedf6e9cb.tar.gz |
geoip-perl: add recipe for version 1.45
The package includes a few data files. Despite the names,
these are very small databases only useful for running the
perl test scripts.
Signed-off-by: Joe Slater <jslater@windriver.com>
Signed-off-by: Martin Jansa <Martin.Jansa@gmail.com>
Signed-off-by: Joe MacDonald <joe_macdonald@mentor.com>
Diffstat (limited to 'meta-networking')
-rw-r--r-- | meta-networking/recipes-support/geoip/geoip-perl/run-ptest | 15 | ||||
-rw-r--r-- | meta-networking/recipes-support/geoip/geoip-perl_1.45.bb | 38 |
2 files changed, 53 insertions, 0 deletions
diff --git a/meta-networking/recipes-support/geoip/geoip-perl/run-ptest b/meta-networking/recipes-support/geoip/geoip-perl/run-ptest new file mode 100644 index 000000000..5404c247b --- /dev/null +++ b/meta-networking/recipes-support/geoip/geoip-perl/run-ptest | |||
@@ -0,0 +1,15 @@ | |||
1 | #!/bin/sh | ||
2 | |||
3 | # The tests contain hard-coded relative paths and must be | ||
4 | # executed from $pdir. | ||
5 | # | ||
6 | pdir=`dirname $0` | ||
7 | cd ${pdir} | ||
8 | for i in t/*.t ; do | ||
9 | perl ${i} 1>/dev/null 2>&1; | ||
10 | if [ $? == 0 ]; then | ||
11 | echo PASS: $i; | ||
12 | else | ||
13 | echo FAIL: $i; | ||
14 | fi; | ||
15 | done | ||
diff --git a/meta-networking/recipes-support/geoip/geoip-perl_1.45.bb b/meta-networking/recipes-support/geoip/geoip-perl_1.45.bb new file mode 100644 index 000000000..01ce11d03 --- /dev/null +++ b/meta-networking/recipes-support/geoip/geoip-perl_1.45.bb | |||
@@ -0,0 +1,38 @@ | |||
1 | # | ||
2 | # Copyright (C) 2014, 2015 Wind River Systems, Inc. | ||
3 | # Released under the MIT license (see COPYING.MIT for the terms) | ||
4 | # | ||
5 | SUMMARY = "GeoIP perl API library to access location database" | ||
6 | DESCRIPTION = "perl library for country/city/organization to IP address or hostname mapping" | ||
7 | HOMEPAGE = "http://www.maxmind.com/app/ip-location" | ||
8 | SECTION = "network" | ||
9 | LICENSE = "Artistic-1.0 | GPL-1.0+" | ||
10 | LIC_FILES_CHKSUM = "file://README;md5=b0fa745303912bd2d64430f7ae69487d" | ||
11 | |||
12 | SRC_URI = "http://github.com/maxmind/geoip-api-perl/archive/v${PV}.tar.gz \ | ||
13 | file://run-ptest \ | ||
14 | " | ||
15 | |||
16 | SRC_URI[md5sum] = "0ce57140890bf81958e0cea4fe1885b2" | ||
17 | SRC_URI[sha256sum] = "c56437b1cc8887736cb1e435d0320c1c1ff3754830249516317b99137005fb23" | ||
18 | |||
19 | S = "${WORKDIR}/geoip-api-perl-${PV}" | ||
20 | |||
21 | DEPENDS += "geoip" | ||
22 | |||
23 | inherit cpan ptest | ||
24 | |||
25 | EXTRA_CPANFLAGS = "LIBS='-L${STAGING_LIBDIR}' INC='-I${STAGING_INCDIR}'" | ||
26 | |||
27 | |||
28 | # perl scripts and some special small data files | ||
29 | # | ||
30 | do_install_ptest () { | ||
31 | install -d -m 0755 ${D}${PTEST_PATH}/t/data | ||
32 | |||
33 | install ${S}/t/*.t* ${D}${PTEST_PATH}/t | ||
34 | install ${S}/t/data/* ${D}${PTEST_PATH}/t/data | ||
35 | } | ||
36 | |||
37 | FILES_${PN}-dbg += "${libdir}/perl/vendor_perl/*/auto/Geo/IP/.debug" | ||
38 | |||