summaryrefslogtreecommitdiffstats
path: root/meta-networking
diff options
context:
space:
mode:
authorArmin Kuster <akuster808@gmail.com>2018-02-25 13:28:48 -0800
committerArmin Kuster <akuster808@gmail.com>2018-03-12 10:02:03 -0700
commite2b18f893a152bd288c18547fc248436773522e6 (patch)
treec8fead4d0ec3f70cbdb74fe83839cce084b3bf88 /meta-networking
parentadc97095885b962dfdf3c5b917f63818e8feaed4 (diff)
downloadmeta-openembedded-e2b18f893a152bd288c18547fc248436773522e6.tar.gz
openl2tp: fix compile issue with 4.15 kernel
see: http://errors.yoctoproject.org/Errors/Details/168101/ for errors. Signed-off-by: Armin Kuster <akuster808@gmail.com>
Diffstat (limited to 'meta-networking')
-rw-r--r--meta-networking/recipes-protocols/openl2tp/openl2tp/fix_linux_4.15_compile.patch44
-rw-r--r--meta-networking/recipes-protocols/openl2tp/openl2tp_1.8.bb1
2 files changed, 45 insertions, 0 deletions
diff --git a/meta-networking/recipes-protocols/openl2tp/openl2tp/fix_linux_4.15_compile.patch b/meta-networking/recipes-protocols/openl2tp/openl2tp/fix_linux_4.15_compile.patch
new file mode 100644
index 000000000..4597df80a
--- /dev/null
+++ b/meta-networking/recipes-protocols/openl2tp/openl2tp/fix_linux_4.15_compile.patch
@@ -0,0 +1,44 @@
1This fixes a compile issue introduced with linux kernel 4.15
2
3include/linux/in.h:222:8: error: redefinition of 'struct in_pktinfo'
4| struct in_pktinfo {
5
6
7Upstream-Status: Pending
8Signed-off-by: Armin Kuster <akuster808@gmail.com>
9
10Index: openl2tp-1.8/plugins/ppp_unix.c
11===================================================================
12--- openl2tp-1.8.orig/plugins/ppp_unix.c
13+++ openl2tp-1.8/plugins/ppp_unix.c
14@@ -25,9 +25,14 @@
15 #include <fcntl.h>
16 #include <sys/types.h>
17 #include <signal.h>
18+#include <linux/version.h>
19+
20+#if LINUX_VERSION_CODE < KERNEL_VERSION(4, 15, 0)
21 #include <net/ethernet.h>
22 #include <net/if.h>
23 #include <netinet/in.h>
24+#endif
25+
26 #include <arpa/inet.h>
27 #include <sys/stat.h>
28 #include <unistd.h>
29@@ -41,12 +46,12 @@
30 #define __user
31 #endif
32 #include <sys/ioctl.h>
33-#include <linux/if_ether.h>
34-#include <linux/if_pppox.h>
35 #include <linux/ppp_defs.h>
36 #include <linux/if_ppp.h>
37+#include <linux/if_pppox.h>
38+#if LINUX_VERSION_CODE < KERNEL_VERSION(4, 15, 0)
39 #include <linux/if_pppol2tp.h>
40-
41+#endif
42 #include "usl.h"
43 #include "l2tp_private.h"
44
diff --git a/meta-networking/recipes-protocols/openl2tp/openl2tp_1.8.bb b/meta-networking/recipes-protocols/openl2tp/openl2tp_1.8.bb
index bf6850b17..1f6b4ded3 100644
--- a/meta-networking/recipes-protocols/openl2tp/openl2tp_1.8.bb
+++ b/meta-networking/recipes-protocols/openl2tp/openl2tp_1.8.bb
@@ -33,6 +33,7 @@ SRC_URI = "ftp://ftp.openl2tp.org/releases/${BP}/${BP}.tar.gz \
33 file://openl2tpd.service \ 33 file://openl2tpd.service \
34 file://openl2tpd-enable-tests.patch \ 34 file://openl2tpd-enable-tests.patch \
35 file://run-ptest \ 35 file://run-ptest \
36 file://fix_linux_4.15_compile.patch \
36 " 37 "
37 38
38SRC_URI_append_libc-musl = "\ 39SRC_URI_append_libc-musl = "\