summaryrefslogtreecommitdiffstats
path: root/meta-networking
diff options
context:
space:
mode:
authorLi Zhou <li.zhou@windriver.com>2018-03-01 14:36:02 +0800
committerArmin Kuster <akuster808@gmail.com>2018-03-16 19:44:53 -0700
commit88d684c393e1975e75273e5d5bd5776f8ded8a35 (patch)
treed0f03160d7a22a172f7d9aef8fe62dadf29967f1 /meta-networking
parentb438df31b01634da194431c69dc930c9d2921015 (diff)
downloadmeta-openembedded-88d684c393e1975e75273e5d5bd5776f8ded8a35.tar.gz
ebtables: enable KERNEL_64_USERSPACE_32 for arm
On arm64 board, run the kernel as 64bit with 32bit userpace ebtables, then run ebtables command: ebtables -A OUTPUT -p arp -o eth3 -j DROP Below error occurs: kernel msg: ebtables bug: please report to author: Standard target size too big To solve this, enable KERNEL_64_USERSPACE_32 for arm as the commit <ebtables: enable KERNEL_64_USERSPACE_32 for powerpc> do. Use TARGET_ARCH to replace KARCH here because that KARCH can't always get value by default. Signed-off-by: Li Zhou <li.zhou@windriver.com> Signed-off-by: Armin Kuster <akuster808@gmail.com>
Diffstat (limited to 'meta-networking')
-rw-r--r--meta-networking/recipes-filter/ebtables/ebtables_2.0.10-4.bb4
1 files changed, 2 insertions, 2 deletions
diff --git a/meta-networking/recipes-filter/ebtables/ebtables_2.0.10-4.bb b/meta-networking/recipes-filter/ebtables/ebtables_2.0.10-4.bb
index d5e7341a0..d89ee1a20 100644
--- a/meta-networking/recipes-filter/ebtables/ebtables_2.0.10-4.bb
+++ b/meta-networking/recipes-filter/ebtables/ebtables_2.0.10-4.bb
@@ -42,10 +42,10 @@ inherit update-rc.d systemd
42python __anonymous () { 42python __anonymous () {
43 import re 43 import re
44 44
45 karch = d.getVar('KARCH') 45 karch = d.getVar('TARGET_ARCH')
46 multilib = d.getVar('MLPREFIX') 46 multilib = d.getVar('MLPREFIX')
47 47
48 if multilib and karch == 'powerpc64': 48 if multilib and ( karch == 'powerpc64' or karch == 'arm' ):
49 searchstr = "lib.?32" 49 searchstr = "lib.?32"
50 reg = re.compile(searchstr) 50 reg = re.compile(searchstr)
51 if reg.search(multilib): 51 if reg.search(multilib):