summaryrefslogtreecommitdiffstats
path: root/meta-networking
diff options
context:
space:
mode:
authorJohannes Pointner <johannes.pointner@br-automation.com>2018-02-27 08:18:42 +0100
committerArmin Kuster <akuster808@gmail.com>2018-03-16 19:44:53 -0700
commit1993808a8e346685bd79acd76220323223b9a494 (patch)
tree8172a4e91cf5cbb174863a75748f725fedec95a8 /meta-networking
parent08e4b0091af6dad1ec788180be040da7dff139c6 (diff)
downloadmeta-openembedded-1993808a8e346685bd79acd76220323223b9a494.tar.gz
libtevent: update to version 0.9.36
Version >= 0.9.34 needed to build samba 4.7.5. Signed-off-by: Johannes Pointner <johannes.pointner@br-automation.com> Signed-off-by: Armin Kuster <akuster808@gmail.com>
Diffstat (limited to 'meta-networking')
-rw-r--r--meta-networking/recipes-support/libtevent/libtevent/options-0.9.36.patch (renamed from meta-networking/recipes-support/libtevent/libtevent/options-0.9.33.patch)68
-rw-r--r--meta-networking/recipes-support/libtevent/libtevent_0.9.36.bb (renamed from meta-networking/recipes-support/libtevent/libtevent_0.9.33.bb)6
2 files changed, 35 insertions, 39 deletions
diff --git a/meta-networking/recipes-support/libtevent/libtevent/options-0.9.33.patch b/meta-networking/recipes-support/libtevent/libtevent/options-0.9.36.patch
index 84b1a3688..363c5867c 100644
--- a/meta-networking/recipes-support/libtevent/libtevent/options-0.9.33.patch
+++ b/meta-networking/recipes-support/libtevent/libtevent/options-0.9.36.patch
@@ -1,7 +1,7 @@
1From c00f6d35bdc06dffb54daa815e57b44210a5de04 Mon Sep 17 00:00:00 2001 1From c3e2e4f89cf37b27609fd02ad67eb02d0015cc1e Mon Sep 17 00:00:00 2001
2From: Jackie Huang <jackie.huang@windriver.com> 2From: Jackie Huang <jackie.huang@windriver.com>
3Date: Wed, 21 Sep 2016 09:57:49 +0800 3Date: Wed, 21 Sep 2016 09:57:49 +0800
4Subject: [PATCH] tevent: Add configure options for packages 4Subject: [PATCH 1/1] tevent: Add configure options for packages
5 5
6Add configure options for the following packages: 6Add configure options for the following packages:
7 - acl 7 - acl
@@ -19,30 +19,12 @@ Modified to apply to version 0.9.33.
19 19
20Signed-off-by: Joe Slater <joe.slater@windriver.com> 20Signed-off-by: Joe Slater <joe.slater@windriver.com>
21--- 21---
22 lib/replace/system/wscript_configure | 6 ++- 22 lib/replace/wscript | 89 ++++++++++++++++++++++++++++++++++++++++-------------
23 lib/replace/wscript | 85 ++++++++++++++++++++++++++++-------- 23 wscript | 7 ++++-
24 wscript | 7 ++- 24 2 files changed, 73 insertions(+), 23 deletions(-)
25 3 files changed, 79 insertions(+), 19 deletions(-)
26 mode change 100755 => 100644 wscript
27 25
28diff --git a/lib/replace/system/wscript_configure b/lib/replace/system/wscript_configure
29index 2035474..10f9ae7 100644
30--- a/lib/replace/system/wscript_configure
31+++ b/lib/replace/system/wscript_configure
32@@ -1,6 +1,10 @@
33 #!/usr/bin/env python
34
35-conf.CHECK_HEADERS('sys/capability.h')
36+import Options
37+
38+if Options.options.enable_libcap:
39+ conf.CHECK_HEADERS('sys/capability.h')
40+
41 conf.CHECK_FUNCS('getpwnam_r getpwuid_r getpwent_r')
42
43 # solaris varients of getXXent_r
44diff --git a/lib/replace/wscript b/lib/replace/wscript 26diff --git a/lib/replace/wscript b/lib/replace/wscript
45index fc43e1a..12d2a70 100644 27index 2c638b7..079761d 100644
46--- a/lib/replace/wscript 28--- a/lib/replace/wscript
47+++ b/lib/replace/wscript 29+++ b/lib/replace/wscript
48@@ -23,6 +23,41 @@ def set_options(opt): 30@@ -23,6 +23,41 @@ def set_options(opt):
@@ -118,32 +100,33 @@ index fc43e1a..12d2a70 100644
118 conf.CHECK_HEADERS('port.h') 100 conf.CHECK_HEADERS('port.h')
119 conf.CHECK_HEADERS('sys/fcntl.h sys/filio.h sys/filsys.h sys/fs/s5param.h sys/fs/vx/quota.h') 101 conf.CHECK_HEADERS('sys/fcntl.h sys/filio.h sys/filsys.h sys/fs/s5param.h sys/fs/vx/quota.h')
120 conf.CHECK_HEADERS('sys/id.h sys/ioctl.h sys/ipc.h sys/mman.h sys/mode.h sys/ndir.h sys/priv.h') 102 conf.CHECK_HEADERS('sys/id.h sys/ioctl.h sys/ipc.h sys/mman.h sys/mode.h sys/ndir.h sys/priv.h')
121@@ -73,7 +121,9 @@ def configure(conf): 103@@ -101,7 +149,8 @@ def configure(conf):
122 104 conf.CHECK_HEADERS('sys/fileio.h sys/filesys.h sys/dustat.h sys/sysmacros.h')
123 conf.CHECK_CODE('', headers='rpc/rpc.h rpcsvc/yp_prot.h', define='HAVE_RPCSVC_YP_PROT_H') 105 conf.CHECK_HEADERS('xfs/libxfs.h netgroup.h')
124 106
125- conf.CHECK_HEADERS('valgrind.h valgrind/valgrind.h valgrind/memcheck.h') 107- conf.CHECK_HEADERS('valgrind.h valgrind/valgrind.h valgrind/memcheck.h')
126+ if Options.options.enable_valgrind: 108+ if Options.options.enable_valgrind:
127+ conf.CHECK_HEADERS('valgrind.h valgrind/valgrind.h valgrind/memcheck.h') 109+ conf.CHECK_HEADERS('valgrind.h valgrind/valgrind.h valgrind/memcheck.h')
128+
129 conf.CHECK_HEADERS('nss_common.h nsswitch.h ns_api.h') 110 conf.CHECK_HEADERS('nss_common.h nsswitch.h ns_api.h')
130 conf.CHECK_HEADERS('sys/extattr.h sys/ea.h sys/proplist.h sys/cdefs.h') 111 conf.CHECK_HEADERS('sys/extattr.h sys/ea.h sys/proplist.h sys/cdefs.h')
131 conf.CHECK_HEADERS('utmp.h utmpx.h lastlog.h') 112 conf.CHECK_HEADERS('utmp.h utmpx.h lastlog.h')
132@@ -248,17 +298,18 @@ def configure(conf): 113@@ -294,22 +343,18 @@ def configure(conf):
133 114
134 conf.CHECK_FUNCS('prctl dirname basename') 115 conf.CHECK_FUNCS('prctl dirname basename')
135 116
117- strlcpy_in_bsd = False
118-
136- # libbsd on some platforms provides strlcpy and strlcat 119- # libbsd on some platforms provides strlcpy and strlcat
137- if not conf.CHECK_FUNCS('strlcpy strlcat'): 120- if not conf.CHECK_FUNCS('strlcpy strlcat'):
138- conf.CHECK_FUNCS_IN('strlcpy strlcat', 'bsd', headers='bsd/string.h', 121- if conf.CHECK_FUNCS_IN('strlcpy strlcat', 'bsd', headers='bsd/string.h',
139- checklibc=True) 122- checklibc=True):
123- strlcpy_in_bsd = True
140- if not conf.CHECK_FUNCS('getpeereid'): 124- if not conf.CHECK_FUNCS('getpeereid'):
141- conf.CHECK_FUNCS_IN('getpeereid', 'bsd', headers='sys/types.h bsd/unistd.h') 125- conf.CHECK_FUNCS_IN('getpeereid', 'bsd', headers='sys/types.h bsd/unistd.h')
142- if not conf.CHECK_FUNCS_IN('setproctitle', 'setproctitle', headers='setproctitle.h'): 126- if not conf.CHECK_FUNCS_IN('setproctitle', 'setproctitle', headers='setproctitle.h'):
143- conf.CHECK_FUNCS_IN('setproctitle', 'bsd', headers='sys/types.h bsd/unistd.h') 127- conf.CHECK_FUNCS_IN('setproctitle', 'bsd', headers='sys/types.h bsd/unistd.h')
144- 128- if not conf.CHECK_FUNCS('setproctitle_init'):
145- if not conf.CHECK_FUNCS('closefrom'): 129- conf.CHECK_FUNCS_IN('setproctitle_init', 'bsd', headers='sys/types.h bsd/unistd.h')
146- conf.CHECK_FUNCS_IN('closefrom', 'bsd', headers='bsd/unistd.h')
147+ if Options.options.enable_libbsd: 130+ if Options.options.enable_libbsd:
148+ # libbsd on some platforms provides strlcpy and strlcat 131+ # libbsd on some platforms provides strlcpy and strlcat
149+ if not conf.CHECK_FUNCS('strlcpy strlcat'): 132+ if not conf.CHECK_FUNCS('strlcpy strlcat'):
@@ -153,12 +136,25 @@ index fc43e1a..12d2a70 100644
153+ conf.CHECK_FUNCS_IN('getpeereid', 'bsd', headers='sys/types.h bsd/unistd.h') 136+ conf.CHECK_FUNCS_IN('getpeereid', 'bsd', headers='sys/types.h bsd/unistd.h')
154+ if not conf.CHECK_FUNCS_IN('setproctitle', 'setproctitle', headers='setproctitle.h'): 137+ if not conf.CHECK_FUNCS_IN('setproctitle', 'setproctitle', headers='setproctitle.h'):
155+ conf.CHECK_FUNCS_IN('setproctitle', 'bsd', headers='sys/types.h bsd/unistd.h') 138+ conf.CHECK_FUNCS_IN('setproctitle', 'bsd', headers='sys/types.h bsd/unistd.h')
156+ 139
140- if not conf.CHECK_FUNCS('closefrom'):
141- conf.CHECK_FUNCS_IN('closefrom', 'bsd', headers='bsd/unistd.h')
157+ if not conf.CHECK_FUNCS('closefrom'): 142+ if not conf.CHECK_FUNCS('closefrom'):
158+ conf.CHECK_FUNCS_IN('closefrom', 'bsd', headers='bsd/unistd.h') 143+ conf.CHECK_FUNCS_IN('closefrom', 'bsd', headers='bsd/unistd.h')
159 144
160 conf.CHECK_CODE(''' 145 conf.CHECK_CODE('''
161 struct ucred cred; 146 struct ucred cred;
147@@ -660,7 +705,7 @@ removeea setea
148 # look for a method of finding the list of network interfaces
149 for method in ['HAVE_IFACE_GETIFADDRS', 'HAVE_IFACE_AIX', 'HAVE_IFACE_IFCONF', 'HAVE_IFACE_IFREQ']:
150 bsd_for_strlcpy = ''
151- if strlcpy_in_bsd:
152+ if Options.options.enable_libbsd:
153 bsd_for_strlcpy = ' bsd'
154 if conf.CHECK_CODE('''
155 #define %s 1
156diff --git a/wscript b/wscript
157index 94d190f..742f779 100644
162--- a/wscript 158--- a/wscript
163+++ b/wscript 159+++ b/wscript
164@@ -22,7 +22,12 @@ def set_options(opt): 160@@ -22,7 +22,12 @@ def set_options(opt):
@@ -176,5 +172,5 @@ index fc43e1a..12d2a70 100644
176 def configure(conf): 172 def configure(conf):
177 conf.RECURSE('lib/replace') 173 conf.RECURSE('lib/replace')
178-- 174--
1792.8.3 1752.16.2
180 176
diff --git a/meta-networking/recipes-support/libtevent/libtevent_0.9.33.bb b/meta-networking/recipes-support/libtevent/libtevent_0.9.36.bb
index f50830069..a83851ea4 100644
--- a/meta-networking/recipes-support/libtevent/libtevent_0.9.33.bb
+++ b/meta-networking/recipes-support/libtevent/libtevent_0.9.36.bb
@@ -7,12 +7,12 @@ DEPENDS += "libtalloc"
7RDEPENDS_python-tevent = "python" 7RDEPENDS_python-tevent = "python"
8 8
9SRC_URI = "https://samba.org/ftp/tevent/tevent-${PV}.tar.gz \ 9SRC_URI = "https://samba.org/ftp/tevent/tevent-${PV}.tar.gz \
10 file://options-0.9.33.patch \ 10 file://options-0.9.36.patch \
11" 11"
12LIC_FILES_CHKSUM = "file://tevent.h;endline=26;md5=4e458d658cb25e21efc16f720e78b85a" 12LIC_FILES_CHKSUM = "file://tevent.h;endline=26;md5=4e458d658cb25e21efc16f720e78b85a"
13 13
14SRC_URI[md5sum] = "527a43f35b4251e46f28921342895223" 14SRC_URI[md5sum] = "87d67bca75b231814435c47bec0aff8a"
15SRC_URI[sha256sum] = "22712ee981fd4298fcd5f3afb27d87a72257cebad37812cfbd3da5d968ed1bdc" 15SRC_URI[sha256sum] = "bd2b6be3fd1601ed7f176e99111e322c57d58e425cc149ee80c7dd4fed263b4c"
16 16
17inherit waf-samba 17inherit waf-samba
18 18