summaryrefslogtreecommitdiffstats
path: root/meta-networking
diff options
context:
space:
mode:
authorMark Hatle <mark.hatle@windriver.com>2017-09-05 15:38:01 -0500
committerJoe MacDonald <joe_macdonald@mentor.com>2017-09-12 10:55:08 -0400
commitfe8db5950175f734468f3256e000843ee81cf430 (patch)
tree3f500c96cd94e916f4f5dba4fff6cf6f2e16e2ad /meta-networking
parentfbaf35875867ba88f25529f45ab1739722f601c5 (diff)
downloadmeta-openembedded-fe8db5950175f734468f3256e000843ee81cf430.tar.gz
corosync: Requires net-snmp from meta-networking
Signed-off-by: Mark Hatle <mark.hatle@windriver.com> Signed-off-by: Joe MacDonald <joe_macdonald@mentor.com>
Diffstat (limited to 'meta-networking')
-rw-r--r--meta-networking/recipes-extended/corosync/corosync/0001-Include-fcntl.h-for-F_-and-O_-defines.patch28
-rw-r--r--meta-networking/recipes-extended/corosync/corosync_2.4.2.bb80
2 files changed, 108 insertions, 0 deletions
diff --git a/meta-networking/recipes-extended/corosync/corosync/0001-Include-fcntl.h-for-F_-and-O_-defines.patch b/meta-networking/recipes-extended/corosync/corosync/0001-Include-fcntl.h-for-F_-and-O_-defines.patch
new file mode 100644
index 000000000..fe4b0793f
--- /dev/null
+++ b/meta-networking/recipes-extended/corosync/corosync/0001-Include-fcntl.h-for-F_-and-O_-defines.patch
@@ -0,0 +1,28 @@
1From 85ea47fedbc96ed9180e08b0d371d9966e3a88da Mon Sep 17 00:00:00 2001
2From: Khem Raj <raj.khem@gmail.com>
3Date: Wed, 30 Aug 2017 17:28:55 -0700
4Subject: [PATCH] Include fcntl.h for F_* and O_* defines
5
6Fixes errors like
7utils.c:95:22: error: use of undeclared identifier 'O_WRONLY'
8
9Signed-off-by: Khem Raj <raj.khem@gmail.com>
10---
11 qdevices/utils.c | 1 +
12 1 file changed, 1 insertion(+)
13
14diff --git a/qdevices/utils.c b/qdevices/utils.c
15index 41850b8c..87090853 100644
16--- a/qdevices/utils.c
17+++ b/qdevices/utils.c
18@@ -39,6 +39,7 @@
19
20 #include <err.h>
21 #include <errno.h>
22+#include <fcntl.h>
23 #include <inttypes.h>
24 #include <libgen.h>
25 #include <stdio.h>
26--
272.14.1
28
diff --git a/meta-networking/recipes-extended/corosync/corosync_2.4.2.bb b/meta-networking/recipes-extended/corosync/corosync_2.4.2.bb
new file mode 100644
index 000000000..33e74e2ff
--- /dev/null
+++ b/meta-networking/recipes-extended/corosync/corosync_2.4.2.bb
@@ -0,0 +1,80 @@
1SUMMARY = "The Corosync Cluster Engine and Application Programming Interfaces"
2DESCRIPTION = "This package contains the Corosync Cluster Engine Executive, several default \
3APIs and libraries, default configuration files, and an init script."
4HOMEPAGE = "http://corosync.github.io/corosync/"
5
6SECTION = "base"
7
8inherit autotools pkgconfig systemd useradd
9
10SRC_URI = "http://build.clusterlabs.org/corosync/releases/${BP}.tar.gz \
11 file://0001-Include-fcntl.h-for-F_-and-O_-defines.patch \
12 "
13SRC_URI[md5sum] = "547fa78704da53aa35912be58d31035f"
14SRC_URI[sha256sum] = "f26e3011309fe4bcce94b1dc20ea8c462f19483a73f3ca62f13b925d011a4ba9"
15
16LICENSE = "BSD"
17LIC_FILES_CHKSUM = "file://LICENSE;md5=a85eb4ce24033adb6088dd1d6ffc5e5d"
18
19DEPENDS = "groff-native nss libqb"
20
21SYSTEMD_SERVICE_${PN} = "corosync.service corosync-notifyd.service \
22 ${@bb.utils.contains('PACKAGECONFIG', 'qdevice', 'corosync-qdevice.service', '', d)} \
23 ${@bb.utils.contains('PACKAGECONFIG', 'qnetd', 'corosync-qnetd.service', '', d)} \
24"
25SYSTEMD_AUTO_ENABLE = "enable"
26
27INITSCRIPT_NAME = "corosync-daemon"
28
29PACKAGECONFIG ??= "${@bb.utils.filter('DISTRO_FEATURES', 'systemd', d)} \
30 dbus qdevice qnetd snmp \
31"
32
33PACKAGECONFIG[dbus] = "--enable-dbus,--disable-dbus,dbus"
34PACKAGECONFIG[qdevice] = "--enable-qdevices,--disable-qdevices"
35PACKAGECONFIG[qnetd] = "--enable-qnetd,--disable-qnetd"
36PACKAGECONFIG[rdma] = "--enable-rdma,--disable-rdma"
37PACKAGECONFIG[snmp] = "--enable-snmp,--disable-snmp,net-snmp"
38PACKAGECONFIG[systemd] = "--enable-systemd --with-systemddir=${systemd_system_unitdir},--disable-systemd --without-systemddir,systemd"
39
40EXTRA_OECONF = "ac_cv_path_BASHPATH=${base_bindir}/bash"
41EXTRA_OEMAKE = "tmpfilesdir_DATA="
42
43do_configure_prepend() {
44 ( cd ${S}
45 ${S}/autogen.sh )
46}
47
48do_install_append() {
49 install -d ${D}${sysconfdir}/sysconfig/
50 install -m 0644 ${S}/init/corosync.sysconfig.example ${D}${sysconfdir}/sysconfig/corosync
51 install -m 0644 ${S}/tools/corosync-notifyd.sysconfig.example ${D}${sysconfdir}/sysconfig/corosync-notifyd
52
53 rm -rf "${D}${localstatedir}/run"
54
55 install -d ${D}${sysconfdir}/default/volatiles
56 echo "d root root 0755 ${localstatedir}/log/cluster none" > ${D}${sysconfdir}/default/volatiles/05_corosync
57
58 if ${@bb.utils.contains('PACKAGECONFIG', 'qnetd', 'true', 'false', d)}; then
59 chown -R coroqnetd:coroqnetd ${D}${sysconfdir}/${BPN}/qnetd
60 echo "d coroqnetd coroqnetd 0770 /var/run/corosync-qnetd none" >> ${D}${sysconfdir}/default/volatiles/05_corosync
61 fi
62
63 if ${@bb.utils.contains('DISTRO_FEATURES','systemd','true','false',d)}; then
64 install -d ${D}${sysconfdir}/tmpfiles.d
65 echo "d ${localstatedir}/log/cluster - - - -" > ${D}${sysconfdir}/tmpfiles.d/corosync.conf
66
67 if ${@bb.utils.contains('PACKAGECONFIG', 'qnetd', 'true', 'false', d)}; then
68 install -m 0644 ${S}/conf/tmpfiles.d/corosync-qnetd.conf ${D}${sysconfdir}/tmpfiles.d
69 fi
70 fi
71}
72
73RDEPENDS_${PN} += "bash"
74
75FILES_${PN}-dbg += "${libexecdir}/lcrso/.debug"
76FILES_${PN}-doc += "${datadir}/snmp/mibs/COROSYNC-MIB.txt"
77
78USERADD_PACKAGES = "${PN}"
79GROUPADD_PARAM_${PN} = "--system coroqnetd"
80USERADD_PARAM_${PN} = "--system -d / -M -s /bin/nologin -c 'User for corosync-qnetd' -g coroqnetd coroqnetd"