summaryrefslogtreecommitdiffstats
path: root/meta-networking
diff options
context:
space:
mode:
authorAndreas Oberritter <obi@opendreambox.org>2016-12-23 01:04:35 +0100
committerMartin Jansa <Martin.Jansa@gmail.com>2017-01-19 09:26:15 +0100
commit9beb04e98d9a6b2dfe95966e2768f886b4092e27 (patch)
treecce324f66669a11d26f729facb486162b828916b /meta-networking
parentcc32689a5b55843eeaecda173933fd5f281ec3ff (diff)
downloadmeta-openembedded-9beb04e98d9a6b2dfe95966e2768f886b4092e27.tar.gz
waf-samba.bbclass: fix build error with PARALLEL_MAKE="-j X -l Y"
Waf doesn't handle -l. Use a function already provided by waf.bbclass in OE-Core. Inheriting waf.bbclass also makes overriding DISABLE_STATIC redundant, so drop it from recipes inheriting waf-samba. Signed-off-by: Andreas Oberritter <obi@opendreambox.org> Signed-off-by: Martin Jansa <Martin.Jansa@gmail.com>
Diffstat (limited to 'meta-networking')
-rw-r--r--meta-networking/classes/waf-samba.bbclass4
-rw-r--r--meta-networking/recipes-connectivity/samba/samba_4.4.5.bb1
-rw-r--r--meta-networking/recipes-support/libldb/libldb_1.1.29.bb1
-rw-r--r--meta-networking/recipes-support/libtalloc/libtalloc_2.1.8.bb1
-rw-r--r--meta-networking/recipes-support/libtdb/libtdb_1.3.12.bb1
-rw-r--r--meta-networking/recipes-support/libtevent/libtevent_0.9.31.bb1
6 files changed, 2 insertions, 7 deletions
diff --git a/meta-networking/classes/waf-samba.bbclass b/meta-networking/classes/waf-samba.bbclass
index af4c7d0be..b94ed4853 100644
--- a/meta-networking/classes/waf-samba.bbclass
+++ b/meta-networking/classes/waf-samba.bbclass
@@ -1,7 +1,7 @@
1# waf is a build system which is used by samba related project. 1# waf is a build system which is used by samba related project.
2# Obtain details from https://wiki.samba.org/index.php/Waf 2# Obtain details from https://wiki.samba.org/index.php/Waf
3# 3#
4inherit qemu pythonnative 4inherit qemu pythonnative waf
5 5
6DEPENDS += "qemu-native libxslt-native docbook-xsl-stylesheets-native python" 6DEPENDS += "qemu-native libxslt-native docbook-xsl-stylesheets-native python"
7 7
@@ -86,7 +86,7 @@ do_configure() {
86} 86}
87 87
88do_compile () { 88do_compile () {
89 python ./buildtools/bin/waf ${PARALLEL_MAKE} 89 python ./buildtools/bin/waf ${@get_waf_parallel_make(d)}
90} 90}
91 91
92do_install() { 92do_install() {
diff --git a/meta-networking/recipes-connectivity/samba/samba_4.4.5.bb b/meta-networking/recipes-connectivity/samba/samba_4.4.5.bb
index a199018c9..0ba59c7d3 100644
--- a/meta-networking/recipes-connectivity/samba/samba_4.4.5.bb
+++ b/meta-networking/recipes-connectivity/samba/samba_4.4.5.bb
@@ -94,7 +94,6 @@ EXTRA_OECONF += "--enable-fhs \
94 --with-libiconv=${STAGING_DIR_HOST}${prefix} \ 94 --with-libiconv=${STAGING_DIR_HOST}${prefix} \
95 --with-pam --with-pammodulesdir=${base_libdir}/security \ 95 --with-pam --with-pammodulesdir=${base_libdir}/security \
96 " 96 "
97DISABLE_STATIC = ""
98 97
99LDFLAGS += "-Wl,-z,relro,-z,now ${@bb.utils.contains('DISTRO_FEATURES', 'ld-is-gold', ' -fuse-ld=bfd ', '', d)}" 98LDFLAGS += "-Wl,-z,relro,-z,now ${@bb.utils.contains('DISTRO_FEATURES', 'ld-is-gold', ' -fuse-ld=bfd ', '', d)}"
100 99
diff --git a/meta-networking/recipes-support/libldb/libldb_1.1.29.bb b/meta-networking/recipes-support/libldb/libldb_1.1.29.bb
index 378bb8930..2269a5726 100644
--- a/meta-networking/recipes-support/libldb/libldb_1.1.29.bb
+++ b/meta-networking/recipes-support/libldb/libldb_1.1.29.bb
@@ -44,7 +44,6 @@ EXTRA_OECONF += "--disable-rpath \
44 --with-privatelibdir=${libdir}/ldb \ 44 --with-privatelibdir=${libdir}/ldb \
45 --with-libiconv=${STAGING_DIR_HOST}${prefix}\ 45 --with-libiconv=${STAGING_DIR_HOST}${prefix}\
46 " 46 "
47DISABLE_STATIC = ""
48 47
49PACKAGES += "pyldb pyldb-dbg pyldb-dev" 48PACKAGES += "pyldb pyldb-dbg pyldb-dev"
50 49
diff --git a/meta-networking/recipes-support/libtalloc/libtalloc_2.1.8.bb b/meta-networking/recipes-support/libtalloc/libtalloc_2.1.8.bb
index 97a9a758b..04e2f364d 100644
--- a/meta-networking/recipes-support/libtalloc/libtalloc_2.1.8.bb
+++ b/meta-networking/recipes-support/libtalloc/libtalloc_2.1.8.bb
@@ -37,7 +37,6 @@ EXTRA_OECONF += "--disable-rpath \
37 --disable-silent-rules \ 37 --disable-silent-rules \
38 --with-libiconv=${STAGING_DIR_HOST}${prefix}\ 38 --with-libiconv=${STAGING_DIR_HOST}${prefix}\
39 " 39 "
40DISABLE_STATIC = ""
41 40
42PACKAGES += "pytalloc pytalloc-dbg pytalloc-dev" 41PACKAGES += "pytalloc pytalloc-dbg pytalloc-dev"
43 42
diff --git a/meta-networking/recipes-support/libtdb/libtdb_1.3.12.bb b/meta-networking/recipes-support/libtdb/libtdb_1.3.12.bb
index 86f931ce9..3296bee53 100644
--- a/meta-networking/recipes-support/libtdb/libtdb_1.3.12.bb
+++ b/meta-networking/recipes-support/libtdb/libtdb_1.3.12.bb
@@ -33,7 +33,6 @@ EXTRA_OECONF += "--disable-rpath \
33 --builtin-libraries=replace \ 33 --builtin-libraries=replace \
34 --with-libiconv=${STAGING_DIR_HOST}${prefix}\ 34 --with-libiconv=${STAGING_DIR_HOST}${prefix}\
35 " 35 "
36DISABLE_STATIC = ""
37 36
38PACKAGES += "tdb-tools python-tdb python-tdb-dbg" 37PACKAGES += "tdb-tools python-tdb python-tdb-dbg"
39 38
diff --git a/meta-networking/recipes-support/libtevent/libtevent_0.9.31.bb b/meta-networking/recipes-support/libtevent/libtevent_0.9.31.bb
index 975f8f689..7939e0361 100644
--- a/meta-networking/recipes-support/libtevent/libtevent_0.9.31.bb
+++ b/meta-networking/recipes-support/libtevent/libtevent_0.9.31.bb
@@ -37,7 +37,6 @@ EXTRA_OECONF += "--disable-rpath \
37 --with-libiconv=${STAGING_DIR_HOST}${prefix}\ 37 --with-libiconv=${STAGING_DIR_HOST}${prefix}\
38 --without-gettext \ 38 --without-gettext \
39 " 39 "
40DISABLE_STATIC = ""
41 40
42PACKAGES += "python-tevent python-tevent-dbg" 41PACKAGES += "python-tevent python-tevent-dbg"
43 42