summaryrefslogtreecommitdiffstats
path: root/meta-networking
diff options
context:
space:
mode:
authorCatalin Enache <catalin.enache@windriver.com>2016-05-11 16:45:33 +0300
committerJoe MacDonald <joe_macdonald@mentor.com>2016-05-18 10:53:51 -0400
commit8fe7d1e60b2d64079a8f9c882231c2f27fc1729b (patch)
treecbd6fce71ccbb5065b6ec1925360bd6a7906ec4c /meta-networking
parent37297c3222a40b916d98ccd06b757b595aebc756 (diff)
downloadmeta-openembedded-8fe7d1e60b2d64079a8f9c882231c2f27fc1729b.tar.gz
proftpd: fix mod_tls build issue
Backported upstream commit: https://github.com/proftpd/proftpd/commit/253e6ef6a4fde5545111f7c439a9692afecc597b Signed-off-by: Catalin Enache <catalin.enache@windriver.com> Signed-off-by: Martin Jansa <Martin.Jansa@gmail.com> Signed-off-by: Joe MacDonald <joe_macdonald@mentor.com>
Diffstat (limited to 'meta-networking')
-rw-r--r--meta-networking/recipes-daemons/proftpd/files/Fix-build-errors.patch64
-rw-r--r--meta-networking/recipes-daemons/proftpd/proftpd_1.3.5a.bb1
2 files changed, 65 insertions, 0 deletions
diff --git a/meta-networking/recipes-daemons/proftpd/files/Fix-build-errors.patch b/meta-networking/recipes-daemons/proftpd/files/Fix-build-errors.patch
new file mode 100644
index 000000000..3b9856054
--- /dev/null
+++ b/meta-networking/recipes-daemons/proftpd/files/Fix-build-errors.patch
@@ -0,0 +1,64 @@
1From 253e6ef6a4fde5545111f7c439a9692afecc597b Mon Sep 17 00:00:00 2001
2From: TJ Saunders <tj@castaglia.org>
3Date: Thu, 10 Mar 2016 15:17:50 -0800
4Subject: [PATCH] Fix build errors; used wrong variable name, and pushed
5 without building. Shame.
6
7Upstream-Status: Backport
8
9Author: TJ Saunders <tj@castaglia.org>
10Signed-off-by: Catalin Enache <catalin.enache@windriver.com>
11---
12 contrib/mod_tls.c | 10 +++++-----
13 1 file changed, 5 insertions(+), 5 deletions(-)
14
15diff --git a/contrib/mod_tls.c b/contrib/mod_tls.c
16index c557454..ecd9f56 100644
17--- a/contrib/mod_tls.c
18+++ b/contrib/mod_tls.c
19@@ -2423,7 +2423,7 @@ static int tls_ctrl_renegotiate_cb(CALLBACK_FRAME) {
20 }
21 #endif
22
23-static DH *tls_dh_cb(SSL *ssl, int is_export, int keylength) {
24+static DH *tls_dh_cb(SSL *ssl, int is_export, int keylen) {
25 DH *dh = NULL;
26 EVP_PKEY *pkey;
27 int pkeylen = 0, use_pkeylen = FALSE;
28@@ -2597,7 +2597,7 @@ static DH *tls_dh_cb(SSL *ssl, int is_export, int keylength) {
29 }
30
31 #ifdef PR_USE_OPENSSL_ECC
32-static EC_KEY *tls_ecdh_cb(SSL *ssl, int is_export, int keylength) {
33+static EC_KEY *tls_ecdh_cb(SSL *ssl, int is_export, int keylen) {
34 static EC_KEY *ecdh = NULL;
35 static int init = 0;
36
37@@ -5064,7 +5064,7 @@ static ssize_t tls_read(SSL *ssl, void *buf, size_t len) {
38 return count;
39 }
40
41-static RSA *tls_rsa_cb(SSL *ssl, int is_export, int keylength) {
42+static RSA *tls_rsa_cb(SSL *ssl, int is_export, int keylen) {
43 BIGNUM *e = NULL;
44
45 if (tls_tmp_rsa) {
46@@ -5082,13 +5082,13 @@ static RSA *tls_rsa_cb(SSL *ssl, int is_export, int keylength) {
47 return NULL;
48 }
49
50- if (RSA_generate_key_ex(tls_tmp_rsa, keylength, e, NULL) != 1) {
51+ if (RSA_generate_key_ex(tls_tmp_rsa, keylen, e, NULL) != 1) {
52 BN_free(e);
53 return NULL;
54 }
55
56 #else
57- tls_tmp_rsa = RSA_generate_key(keylength, RSA_F4, NULL, NULL);
58+ tls_tmp_rsa = RSA_generate_key(keylen, RSA_F4, NULL, NULL);
59 #endif /* OpenSSL version 0.9.8 and later */
60
61 if (e != NULL) {
62--
632.7.4
64
diff --git a/meta-networking/recipes-daemons/proftpd/proftpd_1.3.5a.bb b/meta-networking/recipes-daemons/proftpd/proftpd_1.3.5a.bb
index 57d4984bd..2a360831d 100644
--- a/meta-networking/recipes-daemons/proftpd/proftpd_1.3.5a.bb
+++ b/meta-networking/recipes-daemons/proftpd/proftpd_1.3.5a.bb
@@ -13,6 +13,7 @@ SRC_URI = "ftp://ftp.proftpd.org/distrib/source/${BPN}-${PV}.tar.gz \
13 file://build_fixup.patch \ 13 file://build_fixup.patch \
14 file://proftpd.service \ 14 file://proftpd.service \
15 file://CVE-2016-3125.patch \ 15 file://CVE-2016-3125.patch \
16 file://Fix-build-errors.patch \
16 " 17 "
17 18
18SRC_URI[md5sum] = "b9d3092411478415b31d435f8e26d173" 19SRC_URI[md5sum] = "b9d3092411478415b31d435f8e26d173"