summaryrefslogtreecommitdiffstats
path: root/meta-networking
diff options
context:
space:
mode:
authorKhem Raj <raj.khem@gmail.com>2017-09-14 23:44:29 -0700
committerJoe MacDonald <joe_macdonald@mentor.com>2017-09-22 14:37:18 -0400
commit78ef2f867320384ed5cc95592ee9d709ff8c5751 (patch)
tree3da325402832ffa4b141a80293282109d8f6c2d3 /meta-networking
parenta02204eadeaffaeb9137c7b2af181f25ad5fe576 (diff)
downloadmeta-openembedded-78ef2f867320384ed5cc95592ee9d709ff8c5751.tar.gz
openhpi: Fix build with musl
Signed-off-by: Khem Raj <raj.khem@gmail.com> Signed-off-by: Martin Jansa <Martin.Jansa@gmail.com> Signed-off-by: Joe MacDonald <joe_macdonald@mentor.com>
Diffstat (limited to 'meta-networking')
-rw-r--r--meta-networking/recipes-daemons/openhpi/files/0001-ipmidirect-Replace-__STRING.patch31
-rw-r--r--meta-networking/recipes-daemons/openhpi/files/0001-plugins-Check-for-PTHREAD_RECURSIVE_MUTEX_INITIALIZE.patch47
-rw-r--r--meta-networking/recipes-daemons/openhpi/openhpi_3.6.1.bb11
3 files changed, 84 insertions, 5 deletions
diff --git a/meta-networking/recipes-daemons/openhpi/files/0001-ipmidirect-Replace-__STRING.patch b/meta-networking/recipes-daemons/openhpi/files/0001-ipmidirect-Replace-__STRING.patch
new file mode 100644
index 000000000..4d56f6535
--- /dev/null
+++ b/meta-networking/recipes-daemons/openhpi/files/0001-ipmidirect-Replace-__STRING.patch
@@ -0,0 +1,31 @@
1From be40b3f11460cf495bbbef45692e7763afda0c2b Mon Sep 17 00:00:00 2001
2From: Khem Raj <raj.khem@gmail.com>
3Date: Thu, 14 Sep 2017 17:56:31 -0700
4Subject: [PATCH] ipmidirect: Replace __STRING
5
6__STRING is not universally available e.g.
7musl does not define it
8
9Signed-off-by: Khem Raj <raj.khem@gmail.com>
10---
11Upstream-Status: Pending
12
13 plugins/ipmidirect/t/test.h | 2 +-
14 1 file changed, 1 insertion(+), 1 deletion(-)
15
16diff --git a/plugins/ipmidirect/t/test.h b/plugins/ipmidirect/t/test.h
17index 8d71381..978d5ff 100644
18--- a/plugins/ipmidirect/t/test.h
19+++ b/plugins/ipmidirect/t/test.h
20@@ -22,7 +22,7 @@ TestFunction( const char *str, const char *file, int line, bool expr )
21 }
22
23
24-#define Test(expr) TestFunction( __STRING(expr), __FILE__, __LINE__, expr )
25+#define Test(expr) TestFunction( #expr, __FILE__, __LINE__, expr )
26
27
28 static int
29--
302.14.1
31
diff --git a/meta-networking/recipes-daemons/openhpi/files/0001-plugins-Check-for-PTHREAD_RECURSIVE_MUTEX_INITIALIZE.patch b/meta-networking/recipes-daemons/openhpi/files/0001-plugins-Check-for-PTHREAD_RECURSIVE_MUTEX_INITIALIZE.patch
new file mode 100644
index 000000000..0f033ac85
--- /dev/null
+++ b/meta-networking/recipes-daemons/openhpi/files/0001-plugins-Check-for-PTHREAD_RECURSIVE_MUTEX_INITIALIZE.patch
@@ -0,0 +1,47 @@
1From be665d9513cca7e8b64c79ae424cf44ac166b052 Mon Sep 17 00:00:00 2001
2From: Khem Raj <raj.khem@gmail.com>
3Date: Thu, 14 Sep 2017 17:07:58 -0700
4Subject: [PATCH] plugins: Check for PTHREAD_RECURSIVE_MUTEX_INITIALIZER_NP
5 before use
6
7musl does not define PTHREAD_RECURSIVE_MUTEX_INITIALIZER_NP
8so we can not assume that all Linux systems support PTHREAD_RECURSIVE_MUTEX_INITIALIZER_NP
9its a glibc specific define so check for it being defined before using it
10
11Signed-off-by: Khem Raj <raj.khem@gmail.com>
12---
13Upstream-Status: Pending
14
15 plugins/dynamic_simulator/thread.cpp | 2 +-
16 plugins/ipmidirect/thread.cpp | 2 +-
17 2 files changed, 2 insertions(+), 2 deletions(-)
18
19diff --git a/plugins/dynamic_simulator/thread.cpp b/plugins/dynamic_simulator/thread.cpp
20index d663be0..9210fd7 100644
21--- a/plugins/dynamic_simulator/thread.cpp
22+++ b/plugins/dynamic_simulator/thread.cpp
23@@ -229,7 +229,7 @@ cThread::Exit( void *rv )
24 /**
25 * Constructor
26 **/
27-#if ( defined(__sun) && defined(__SVR4) ) || defined(__FreeBSD__)
28+#ifndef PTHREAD_RECURSIVE_MUTEX_INITIALIZER_NP
29 cThreadLock::cThreadLock()
30 {
31 pthread_mutexattr_t attr;
32diff --git a/plugins/ipmidirect/thread.cpp b/plugins/ipmidirect/thread.cpp
33index 5c52557..48e83fa 100644
34--- a/plugins/ipmidirect/thread.cpp
35+++ b/plugins/ipmidirect/thread.cpp
36@@ -167,7 +167,7 @@ cThread::Exit( void *rv )
37 // cThreadLock
38 //////////////////////////////////////////////////
39
40-#if ( defined(__sun) && defined(__SVR4) ) || defined(__FreeBSD__)
41+#ifndef PTHREAD_RECURSIVE_MUTEX_INITIALIZER_NP
42 cThreadLock::cThreadLock()
43 {
44 pthread_mutexattr_t attr;
45--
462.14.1
47
diff --git a/meta-networking/recipes-daemons/openhpi/openhpi_3.6.1.bb b/meta-networking/recipes-daemons/openhpi/openhpi_3.6.1.bb
index 6375c2ee0..ecf71d70f 100644
--- a/meta-networking/recipes-daemons/openhpi/openhpi_3.6.1.bb
+++ b/meta-networking/recipes-daemons/openhpi/openhpi_3.6.1.bb
@@ -23,6 +23,9 @@ LIC_FILES_CHKSUM = "file://COPYING;md5=e3c772a32386888ccb5ae1c0ba95f1a4"
23DEPENDS = "net-snmp libxml2 ncurses openssl glib-2.0 popt e2fsprogs autoconf-archive-native" 23DEPENDS = "net-snmp libxml2 ncurses openssl glib-2.0 popt e2fsprogs autoconf-archive-native"
24 24
25SRC_URI = "${SOURCEFORGE_MIRROR}/${BPN}/${BP}.tar.gz \ 25SRC_URI = "${SOURCEFORGE_MIRROR}/${BPN}/${BP}.tar.gz \
26 file://openhpi.init \
27 file://openhpid.service \
28 file://run-ptest \
26 file://openhpi-netsnmp-cross-compile.patch \ 29 file://openhpi-netsnmp-cross-compile.patch \
27 file://openhpi-sysfs-cross-compile.patch \ 30 file://openhpi-sysfs-cross-compile.patch \
28 file://openhpi-libxml2-cross-compile.patch \ 31 file://openhpi-libxml2-cross-compile.patch \
@@ -39,11 +42,9 @@ SRC_URI = "${SOURCEFORGE_MIRROR}/${BPN}/${BP}.tar.gz \
39 file://c++11.patch \ 42 file://c++11.patch \
40 file://clang-c++11.patch \ 43 file://clang-c++11.patch \
41 file://fix-narrowing-warning.patch \ 44 file://fix-narrowing-warning.patch \
42 \ 45 file://0001-plugins-Check-for-PTHREAD_RECURSIVE_MUTEX_INITIALIZE.patch \
43 file://openhpi.init \ 46 file://0001-ipmidirect-Replace-__STRING.patch \
44 file://openhpid.service \ 47 "
45 file://run-ptest \
46"
47 48
48SRC_URI[md5sum] = "4718b16e0f749b5ad214a9b04f45dd23" 49SRC_URI[md5sum] = "4718b16e0f749b5ad214a9b04f45dd23"
49SRC_URI[sha256sum] = "e0a810cb401c4bdcfc9551f2e6afd5a8ca4b411f5ee3bc60c19f82fd6e84a3dc" 50SRC_URI[sha256sum] = "e0a810cb401c4bdcfc9551f2e6afd5a8ca4b411f5ee3bc60c19f82fd6e84a3dc"