diff options
author | Khem Raj <raj.khem@gmail.com> | 2017-06-19 23:47:01 -0700 |
---|---|---|
committer | Joe MacDonald <joe_macdonald@mentor.com> | 2017-06-28 10:29:16 -0400 |
commit | 325e3ebf420e872f2c35dc242736d09bd9da8063 (patch) | |
tree | 3a7ec8708027e6ebcb1caa6577c3b6cb248c035b /meta-networking | |
parent | cf95634bf4d8641f26711a2bf8490fec0d8f0007 (diff) | |
download | meta-openembedded-325e3ebf420e872f2c35dc242736d09bd9da8063.tar.gz |
squid: Upgrade to 3.5.26
Fix build errors with gcc7 along the way
Signed-off-by: Khem Raj <raj.khem@gmail.com>
Signed-off-by: Martin Jansa <Martin.Jansa@gmail.com>
Signed-off-by: Joe MacDonald <joe_macdonald@mentor.com>
Diffstat (limited to 'meta-networking')
-rw-r--r-- | meta-networking/recipes-daemons/squid/files/0001-configure-Check-for-Wno-error-format-truncation-comp.patch | 116 | ||||
-rw-r--r-- | meta-networking/recipes-daemons/squid/files/gcc7-fixes.patch | 17 | ||||
-rw-r--r-- | meta-networking/recipes-daemons/squid/squid_3.5.26.bb (renamed from meta-networking/recipes-daemons/squid/squid_3.5.25.bb) | 6 |
3 files changed, 137 insertions, 2 deletions
diff --git a/meta-networking/recipes-daemons/squid/files/0001-configure-Check-for-Wno-error-format-truncation-comp.patch b/meta-networking/recipes-daemons/squid/files/0001-configure-Check-for-Wno-error-format-truncation-comp.patch new file mode 100644 index 0000000000..0c0a3aad10 --- /dev/null +++ b/meta-networking/recipes-daemons/squid/files/0001-configure-Check-for-Wno-error-format-truncation-comp.patch | |||
@@ -0,0 +1,116 @@ | |||
1 | From 14d469bc82c758116aef7d549abd49c131b4170f Mon Sep 17 00:00:00 2001 | ||
2 | From: Khem Raj <raj.khem@gmail.com> | ||
3 | Date: Sat, 22 Apr 2017 11:54:57 -0700 | ||
4 | Subject: [PATCH] configure: Check for -Wno-error=format-truncation compiler | ||
5 | option | ||
6 | |||
7 | If this option is supported by compiler then disable it ( gcc7+) | ||
8 | Fixes | ||
9 | client.c:834:23: error: '%s' directive output may be truncated writing up to 1023 bytes into a region of size 1010 [-Werror=format-truncation=] | ||
10 | |||
11 | Signed-off-by: Khem Raj <raj.khem@gmail.com> | ||
12 | --- | ||
13 | configure.ac | 3 +- | ||
14 | m4/ax_check_compile_flag.m4 | 74 +++++++++++++++++++++++++++++++++++++++++++++ | ||
15 | 2 files changed, 76 insertions(+), 1 deletion(-) | ||
16 | create mode 100644 m4/ax_check_compile_flag.m4 | ||
17 | |||
18 | Index: squid-3.5.26/configure.ac | ||
19 | =================================================================== | ||
20 | --- squid-3.5.26.orig/configure.ac | ||
21 | +++ squid-3.5.26/configure.ac | ||
22 | @@ -26,6 +26,7 @@ m4_include([acinclude/pkg.m4]) | ||
23 | m4_include([acinclude/lib-checks.m4]) | ||
24 | m4_include([acinclude/ax_cxx_compile_stdcxx_11.m4]) | ||
25 | m4_include([acinclude/ax_cxx_0x_types.m4]) | ||
26 | +m4_include([acinclude/ax_check_compile_flag.m4]) | ||
27 | |||
28 | HOSTCXX="$BUILD_CXX" | ||
29 | PRESET_CFLAGS="$CFLAGS" | ||
30 | @@ -44,6 +45,7 @@ AC_PROG_CXX | ||
31 | AC_LANG([C++]) | ||
32 | AC_CANONICAL_HOST | ||
33 | |||
34 | +AX_CHECK_COMPILE_FLAG([-Werror=format-truncation],[CFLAGS="$CFLAGS -Wno-error=format-truncation" CXXFLAGS="$CXXFLAGS -Wno-error=format-truncation"]) | ||
35 | # Clang 3.2 on some CPUs requires -march-native to detect correctly. | ||
36 | # GCC 4.3+ can also produce faster executables when its used. | ||
37 | # But building inside a virtual machine environment has been found to | ||
38 | Index: squid-3.5.26/acinclude/ax_check_compile_flag.m4 | ||
39 | =================================================================== | ||
40 | --- /dev/null | ||
41 | +++ squid-3.5.26/acinclude/ax_check_compile_flag.m4 | ||
42 | @@ -0,0 +1,74 @@ | ||
43 | +# =========================================================================== | ||
44 | +# https://www.gnu.org/software/autoconf-archive/ax_check_compile_flag.html | ||
45 | +# =========================================================================== | ||
46 | +# | ||
47 | +# SYNOPSIS | ||
48 | +# | ||
49 | +# AX_CHECK_COMPILE_FLAG(FLAG, [ACTION-SUCCESS], [ACTION-FAILURE], [EXTRA-FLAGS], [INPUT]) | ||
50 | +# | ||
51 | +# DESCRIPTION | ||
52 | +# | ||
53 | +# Check whether the given FLAG works with the current language's compiler | ||
54 | +# or gives an error. (Warnings, however, are ignored) | ||
55 | +# | ||
56 | +# ACTION-SUCCESS/ACTION-FAILURE are shell commands to execute on | ||
57 | +# success/failure. | ||
58 | +# | ||
59 | +# If EXTRA-FLAGS is defined, it is added to the current language's default | ||
60 | +# flags (e.g. CFLAGS) when the check is done. The check is thus made with | ||
61 | +# the flags: "CFLAGS EXTRA-FLAGS FLAG". This can for example be used to | ||
62 | +# force the compiler to issue an error when a bad flag is given. | ||
63 | +# | ||
64 | +# INPUT gives an alternative input source to AC_COMPILE_IFELSE. | ||
65 | +# | ||
66 | +# NOTE: Implementation based on AX_CFLAGS_GCC_OPTION. Please keep this | ||
67 | +# macro in sync with AX_CHECK_{PREPROC,LINK}_FLAG. | ||
68 | +# | ||
69 | +# LICENSE | ||
70 | +# | ||
71 | +# Copyright (c) 2008 Guido U. Draheim <guidod@gmx.de> | ||
72 | +# Copyright (c) 2011 Maarten Bosmans <mkbosmans@gmail.com> | ||
73 | +# | ||
74 | +# This program is free software: you can redistribute it and/or modify it | ||
75 | +# under the terms of the GNU General Public License as published by the | ||
76 | +# Free Software Foundation, either version 3 of the License, or (at your | ||
77 | +# option) any later version. | ||
78 | +# | ||
79 | +# This program is distributed in the hope that it will be useful, but | ||
80 | +# WITHOUT ANY WARRANTY; without even the implied warranty of | ||
81 | +# MERCHANTABILITY or FITNESS FOR A PARTICULAR PURPOSE. See the GNU General | ||
82 | +# Public License for more details. | ||
83 | +# | ||
84 | +# You should have received a copy of the GNU General Public License along | ||
85 | +# with this program. If not, see <https://www.gnu.org/licenses/>. | ||
86 | +# | ||
87 | +# As a special exception, the respective Autoconf Macro's copyright owner | ||
88 | +# gives unlimited permission to copy, distribute and modify the configure | ||
89 | +# scripts that are the output of Autoconf when processing the Macro. You | ||
90 | +# need not follow the terms of the GNU General Public License when using | ||
91 | +# or distributing such scripts, even though portions of the text of the | ||
92 | +# Macro appear in them. The GNU General Public License (GPL) does govern | ||
93 | +# all other use of the material that constitutes the Autoconf Macro. | ||
94 | +# | ||
95 | +# This special exception to the GPL applies to versions of the Autoconf | ||
96 | +# Macro released by the Autoconf Archive. When you make and distribute a | ||
97 | +# modified version of the Autoconf Macro, you may extend this special | ||
98 | +# exception to the GPL to apply to your modified version as well. | ||
99 | + | ||
100 | +#serial 5 | ||
101 | + | ||
102 | +AC_DEFUN([AX_CHECK_COMPILE_FLAG], | ||
103 | +[AC_PREREQ(2.64)dnl for _AC_LANG_PREFIX and AS_VAR_IF | ||
104 | +AS_VAR_PUSHDEF([CACHEVAR],[ax_cv_check_[]_AC_LANG_ABBREV[]flags_$4_$1])dnl | ||
105 | +AC_CACHE_CHECK([whether _AC_LANG compiler accepts $1], CACHEVAR, [ | ||
106 | + ax_check_save_flags=$[]_AC_LANG_PREFIX[]FLAGS | ||
107 | + _AC_LANG_PREFIX[]FLAGS="$[]_AC_LANG_PREFIX[]FLAGS $4 $1" | ||
108 | + AC_COMPILE_IFELSE([m4_default([$5],[AC_LANG_PROGRAM()])], | ||
109 | + [AS_VAR_SET(CACHEVAR,[yes])], | ||
110 | + [AS_VAR_SET(CACHEVAR,[no])]) | ||
111 | + _AC_LANG_PREFIX[]FLAGS=$ax_check_save_flags]) | ||
112 | +AS_VAR_IF(CACHEVAR,yes, | ||
113 | + [m4_default([$2], :)], | ||
114 | + [m4_default([$3], :)]) | ||
115 | +AS_VAR_POPDEF([CACHEVAR])dnl | ||
116 | +])dnl AX_CHECK_COMPILE_FLAGS | ||
diff --git a/meta-networking/recipes-daemons/squid/files/gcc7-fixes.patch b/meta-networking/recipes-daemons/squid/files/gcc7-fixes.patch new file mode 100644 index 0000000000..cc1ea78a55 --- /dev/null +++ b/meta-networking/recipes-daemons/squid/files/gcc7-fixes.patch | |||
@@ -0,0 +1,17 @@ | |||
1 | ../../squid-3.5.26/src/DiskIO/DiskThreads/aiops.cc: In function 'void squidaio_init()': ../../squid-3.5.26/src/DiskIO/DiskThreads/DiskThreads.h:30:50: error: '*' in boolean context, suggest '&&' instead [-Werror=int-in-bool-context] #define NUMTHREADS (Config.cacheSwap.n_configured*16) | ||
2 | |||
3 | |||
4 | Upstream-Status: Backport | ||
5 | Index: squid-3.5.26/src/DiskIO/DiskThreads/aiops.cc | ||
6 | =================================================================== | ||
7 | --- squid-3.5.26.orig/src/DiskIO/DiskThreads/aiops.cc | ||
8 | +++ squid-3.5.26/src/DiskIO/DiskThreads/aiops.cc | ||
9 | @@ -290,7 +290,7 @@ squidaio_init(void) | ||
10 | /* Create threads and get them to sit in their wait loop */ | ||
11 | squidaio_thread_pool = memPoolCreate("aio_thread", sizeof(squidaio_thread_t)); | ||
12 | |||
13 | - assert(NUMTHREADS); | ||
14 | + assert(NUMTHREADS != 0); | ||
15 | |||
16 | for (i = 0; i < NUMTHREADS; ++i) { | ||
17 | threadp = (squidaio_thread_t *)squidaio_thread_pool->alloc(); | ||
diff --git a/meta-networking/recipes-daemons/squid/squid_3.5.25.bb b/meta-networking/recipes-daemons/squid/squid_3.5.26.bb index 5116383b87..e1b4c06dcf 100644 --- a/meta-networking/recipes-daemons/squid/squid_3.5.25.bb +++ b/meta-networking/recipes-daemons/squid/squid_3.5.26.bb | |||
@@ -22,9 +22,11 @@ SRC_URI = "http://www.squid-cache.org/Versions/v${MAJ_VER}/${MIN_VER}/${BPN}-${P | |||
22 | file://set_sysroot_patch.patch \ | 22 | file://set_sysroot_patch.patch \ |
23 | file://squid-don-t-do-squid-conf-tests-at-build-time.patch \ | 23 | file://squid-don-t-do-squid-conf-tests-at-build-time.patch \ |
24 | file://0001-SquidNew-use-noexcept-instead-of-throw-for-C-11-comp.patch \ | 24 | file://0001-SquidNew-use-noexcept-instead-of-throw-for-C-11-comp.patch \ |
25 | file://0001-configure-Check-for-Wno-error-format-truncation-comp.patch \ | ||
26 | file://gcc7-fixes.patch \ | ||
25 | " | 27 | " |
26 | SRC_URI[md5sum] = "c34b228129a755f363367c45c46287ba" | 28 | SRC_URI[md5sum] = "dc1830cd361e077814aa39bcc3691d8b" |
27 | SRC_URI[sha256sum] = "0bfd6182154b7f29574d71c659f1cfd1b7d9be9356895dac70dc0f3696a0639b" | 29 | SRC_URI[sha256sum] = "41d8845863dcd026c856508cd1599d417c8947ffd96e86e24085f9893cb8b8c2" |
28 | 30 | ||
29 | LIC_FILES_CHKSUM = "file://COPYING;md5=c492e2d6d32ec5c1aad0e0609a141ce9 \ | 31 | LIC_FILES_CHKSUM = "file://COPYING;md5=c492e2d6d32ec5c1aad0e0609a141ce9 \ |
30 | file://errors/COPYRIGHT;md5=8861130fae91400bcf99b66f133172b3 \ | 32 | file://errors/COPYRIGHT;md5=8861130fae91400bcf99b66f133172b3 \ |