summaryrefslogtreecommitdiffstats
path: root/meta-networking
diff options
context:
space:
mode:
authorAndre McCurdy <armccurdy@gmail.com>2017-01-25 15:31:59 -0800
committerMartin Jansa <Martin.Jansa@gmail.com>2017-02-13 18:43:23 +0100
commitebef44963866d3231ccfe79d66d21c96ca0b4113 (patch)
tree3eae06de942ade83dfaac41f506f32d77b5a13e7 /meta-networking
parente79566f51dde46145cfdc3732a6e1464ff27f4f3 (diff)
downloadmeta-openembedded-ebef44963866d3231ccfe79d66d21c96ca0b4113.tar.gz
remove some more True options to getVar calls
getVar() now defaults to expanding by default, thus remove the True option from getVar() calls. Fix a small number of cases not addressed by the original patch: http://git.openembedded.org/meta-openembedded/commit/?id=efd3696e70a6603f1a45faa4a172433514f0a487 Signed-off-by: Andre McCurdy <armccurdy@gmail.com> Signed-off-by: Martin Jansa <Martin.Jansa@gmail.com>
Diffstat (limited to 'meta-networking')
-rw-r--r--meta-networking/recipes-daemons/ptpd/ptpd_2.3.1.bb2
-rw-r--r--meta-networking/recipes-support/dnsmasq/dnsmasq.inc2
2 files changed, 2 insertions, 2 deletions
diff --git a/meta-networking/recipes-daemons/ptpd/ptpd_2.3.1.bb b/meta-networking/recipes-daemons/ptpd/ptpd_2.3.1.bb
index f6aaee0eb..622db5f7d 100644
--- a/meta-networking/recipes-daemons/ptpd/ptpd_2.3.1.bb
+++ b/meta-networking/recipes-daemons/ptpd/ptpd_2.3.1.bb
@@ -15,7 +15,7 @@ inherit autotools systemd
15# return something like '1.2.3' or '1.2.3/rc1' 15# return something like '1.2.3' or '1.2.3/rc1'
16# 16#
17def get_sub(d): 17def get_sub(d):
18 parts = d.getVar('PV',True).split('-') 18 parts = d.getVar('PV').split('-')
19 try: 19 try:
20 return parts[0] + '/' + parts[1] 20 return parts[0] + '/' + parts[1]
21 except: 21 except:
diff --git a/meta-networking/recipes-support/dnsmasq/dnsmasq.inc b/meta-networking/recipes-support/dnsmasq/dnsmasq.inc
index 9ef54fe17..424a06b32 100644
--- a/meta-networking/recipes-support/dnsmasq/dnsmasq.inc
+++ b/meta-networking/recipes-support/dnsmasq/dnsmasq.inc
@@ -7,7 +7,7 @@ LIC_FILES_CHKSUM = "file://COPYING;md5=0636e73ff0215e8d672dc4c32c317bb3 \
7 file://COPYING-v3;md5=d32239bcb673463ab874e80d47fae504" 7 file://COPYING-v3;md5=d32239bcb673463ab874e80d47fae504"
8 8
9#at least versions 2.15 and prior are moved to the archive folder on the server 9#at least versions 2.15 and prior are moved to the archive folder on the server
10SRC_URI = "http://www.thekelleys.org.uk/dnsmasq/${@['archive/', ''][float(d.getVar('PV',1).split('.')[1]) > 15]}dnsmasq-${PV}.tar.gz;name=dnsmasq-${PV} \ 10SRC_URI = "http://www.thekelleys.org.uk/dnsmasq/${@['archive/', ''][float(d.getVar('PV').split('.')[1]) > 15]}dnsmasq-${PV}.tar.gz;name=dnsmasq-${PV} \
11 file://init \ 11 file://init \
12 file://dnsmasq.conf \ 12 file://dnsmasq.conf \
13 file://dnsmasq-resolvconf.service \ 13 file://dnsmasq-resolvconf.service \