summaryrefslogtreecommitdiffstats
path: root/meta-networking
diff options
context:
space:
mode:
authorKhem Raj <raj.khem@gmail.com>2017-04-23 22:20:46 -0700
committerJoe MacDonald <joe_macdonald@mentor.com>2017-04-25 16:10:26 -0400
commitdec5adef4958e144c1168ac1db187bfde3e758e7 (patch)
treec862c3d0bff9ec17ef1ca0f8531a8fc88c085f02 /meta-networking
parentb9b6ace5a132fa910b5061bf4e9e2776c435ac43 (diff)
downloadmeta-openembedded-dec5adef4958e144c1168ac1db187bfde3e758e7.tar.gz
ipsec-tools: Fix build with gcc7
Signed-off-by: Khem Raj <raj.khem@gmail.com> Signed-off-by: Martin Jansa <Martin.Jansa@gmail.com> Signed-off-by: Joe MacDonald <joe_macdonald@mentor.com>
Diffstat (limited to 'meta-networking')
-rw-r--r--meta-networking/recipes-support/ipsec-tools/ipsec-tools/0002-cfparse-clear-memory-equal-to-size-of-array.patch30
-rw-r--r--meta-networking/recipes-support/ipsec-tools/ipsec-tools_0.8.2.bb1
2 files changed, 31 insertions, 0 deletions
diff --git a/meta-networking/recipes-support/ipsec-tools/ipsec-tools/0002-cfparse-clear-memory-equal-to-size-of-array.patch b/meta-networking/recipes-support/ipsec-tools/ipsec-tools/0002-cfparse-clear-memory-equal-to-size-of-array.patch
new file mode 100644
index 000000000..e9dd84aaa
--- /dev/null
+++ b/meta-networking/recipes-support/ipsec-tools/ipsec-tools/0002-cfparse-clear-memory-equal-to-size-of-array.patch
@@ -0,0 +1,30 @@
1From a5c59f6a1479947d33dba5191724cc5fc88a614b Mon Sep 17 00:00:00 2001
2From: Khem Raj <raj.khem@gmail.com>
3Date: Sat, 22 Apr 2017 10:39:57 -0700
4Subject: [PATCH 2/2] cfparse: clear memory equal to size of array
5
6Fixes compiler error
7cfparse.y: In function 'set_isakmp_proposal':
8cfparse.y:2567:3: error: 'memset' used with length equal to number of elements without multiplication by element size [-Werror=memset-elt-size]
9
10Signed-off-by: Khem Raj <raj.khem@gmail.com>
11---
12 src/racoon/cfparse.y | 2 +-
13 1 file changed, 1 insertion(+), 1 deletion(-)
14
15diff --git a/src/racoon/cfparse.y b/src/racoon/cfparse.y
16index 0d9bd67..5d9c67b 100644
17--- a/src/racoon/cfparse.y
18+++ b/src/racoon/cfparse.y
19@@ -2564,7 +2564,7 @@ set_isakmp_proposal(rmconf)
20 plog(LLV_DEBUG2, LOCATION, NULL,
21 "encklen=%d\n", s->encklen);
22
23- memset(types, 0, ARRAYLEN(types));
24+ memset(types, 0, sizeof(types));
25 types[algclass_isakmp_enc] = s->algclass[algclass_isakmp_enc];
26 types[algclass_isakmp_hash] = s->algclass[algclass_isakmp_hash];
27 types[algclass_isakmp_dh] = s->algclass[algclass_isakmp_dh];
28--
292.12.2
30
diff --git a/meta-networking/recipes-support/ipsec-tools/ipsec-tools_0.8.2.bb b/meta-networking/recipes-support/ipsec-tools/ipsec-tools_0.8.2.bb
index 8f98b6c5c..d7e8b2596 100644
--- a/meta-networking/recipes-support/ipsec-tools/ipsec-tools_0.8.2.bb
+++ b/meta-networking/recipes-support/ipsec-tools/ipsec-tools_0.8.2.bb
@@ -23,6 +23,7 @@ SRC_URI = "http://ftp.netbsd.org/pub/NetBSD/misc/ipsec-tools/0.8/ipsec-tools-${P
23 file://fix-CVE-2015-4047.patch \ 23 file://fix-CVE-2015-4047.patch \
24 file://0001-Fix-build-with-clang.patch \ 24 file://0001-Fix-build-with-clang.patch \
25 file://0001-Fix-header-issues-found-with-musl-libc.patch \ 25 file://0001-Fix-header-issues-found-with-musl-libc.patch \
26 file://0002-cfparse-clear-memory-equal-to-size-of-array.patch \
26 " 27 "
27SRC_URI[md5sum] = "d53ec14a0a3ece64e09e5e34b3350b41" 28SRC_URI[md5sum] = "d53ec14a0a3ece64e09e5e34b3350b41"
28SRC_URI[sha256sum] = "8eb6b38716e2f3a8a72f1f549c9444c2bc28d52c9536792690564c74fe722f2d" 29SRC_URI[sha256sum] = "8eb6b38716e2f3a8a72f1f549c9444c2bc28d52c9536792690564c74fe722f2d"