summaryrefslogtreecommitdiffstats
path: root/meta-networking
diff options
context:
space:
mode:
authorBenjamin Gaignard <benjamin.gaignard@linaro.org>2017-04-20 14:25:18 +0200
committerJoe MacDonald <joe_macdonald@mentor.com>2017-04-25 16:10:26 -0400
commitb9b6ace5a132fa910b5061bf4e9e2776c435ac43 (patch)
tree11d1bca5d1f47ea53308e8a6a03e2325677f8be7 /meta-networking
parent27ac61803c6e827cc700438918a74845458eee5b (diff)
downloadmeta-openembedded-b9b6ace5a132fa910b5061bf4e9e2776c435ac43.tar.gz
tinyproxy: Add recipe
Signed-off-by: Benjamin Gaignard <benjamin.gaignard@linaro.org> Signed-off-by: Martin Jansa <Martin.Jansa@gmail.com> Signed-off-by: Joe MacDonald <joe_macdonald@mentor.com>
Diffstat (limited to 'meta-networking')
-rw-r--r--meta-networking/recipes-support/tinyproxy/tinyproxy/disable-documentation.patch37
-rw-r--r--meta-networking/recipes-support/tinyproxy/tinyproxy/tinyproxy.service14
-rw-r--r--meta-networking/recipes-support/tinyproxy/tinyproxy_1.8.4.bb38
3 files changed, 89 insertions, 0 deletions
diff --git a/meta-networking/recipes-support/tinyproxy/tinyproxy/disable-documentation.patch b/meta-networking/recipes-support/tinyproxy/tinyproxy/disable-documentation.patch
new file mode 100644
index 000000000..01d0236be
--- /dev/null
+++ b/meta-networking/recipes-support/tinyproxy/tinyproxy/disable-documentation.patch
@@ -0,0 +1,37 @@
1--- a/configure.ac 2016-01-01 17:42:27.000000000 +0100
2+++ b/configure.ac 2017-04-20 14:03:37.238254471 +0200
3@@ -284,24 +284,12 @@
4 AC_SUBST(LIBS)
5 AC_SUBST(ADDITIONAL_OBJECTS)
6
7-# Check for asciidoc
8-AC_PATH_PROG(A2X, a2x, no)
9-AM_CONDITIONAL(HAVE_A2X, test "x$A2X" != "xno")
10-if test x"$A2X" = x"no"; then
11- AC_MSG_ERROR([Test for asciidoc failed. See the file 'INSTALL' for help.])
12-fi
13-
14 AC_CONFIG_FILES([
15 Makefile
16 src/Makefile
17 data/Makefile
18 data/templates/Makefile
19 etc/Makefile
20-docs/Makefile
21-docs/man5/Makefile
22-docs/man5/tinyproxy.conf.txt
23-docs/man8/Makefile
24-docs/man8/tinyproxy.txt
25 m4macros/Makefile
26 tests/Makefile
27 tests/scripts/Makefile
28--- a/Makefile.am 2016-01-01 17:42:27.000000000 +0100
29+++ b/Makefile.am 2017-04-20 14:03:53.842822997 +0200
30@@ -2,7 +2,6 @@
31 src \
32 data \
33 etc \
34- docs \
35 m4macros \
36 tests
37
diff --git a/meta-networking/recipes-support/tinyproxy/tinyproxy/tinyproxy.service b/meta-networking/recipes-support/tinyproxy/tinyproxy/tinyproxy.service
new file mode 100644
index 000000000..ea079f955
--- /dev/null
+++ b/meta-networking/recipes-support/tinyproxy/tinyproxy/tinyproxy.service
@@ -0,0 +1,14 @@
1[Unit]
2Description=Tinyproxy, Lightweight http(s) proxy daemon
3RequiresMountsFor=/var
4
5[Service]
6Group=tinyproxy
7ExecStartPre=/bin/mkdir -p /var/log/tinyproxy
8ExecStartPre=/bin/chown -R nobody.tinyproxy /var/log/tinyproxy
9ExecStartPre=/bin/mkdir -p /var/run/tinyproxy
10ExecStartPre=/bin/chown -R nobody.tinyproxy /var/run/tinyproxy
11ExecStart=/usr/sbin/tinyproxy -d
12
13[Install]
14WantedBy=multi-user.target
diff --git a/meta-networking/recipes-support/tinyproxy/tinyproxy_1.8.4.bb b/meta-networking/recipes-support/tinyproxy/tinyproxy_1.8.4.bb
new file mode 100644
index 000000000..e8025c4b5
--- /dev/null
+++ b/meta-networking/recipes-support/tinyproxy/tinyproxy_1.8.4.bb
@@ -0,0 +1,38 @@
1SUMMARY = "Lightweight http(s) proxy daemon"
2HOMEPAGE = "https://tinyproxy.github.io/"
3LICENSE = "GPLv2"
4LIC_FILES_CHKSUM = "file://COPYING;md5=751419260aa954499f7abaabaa882bbe"
5
6SRC_URI = "https://github.com/${BPN}/${BPN}/releases/download/${PV}/${BP}.tar.gz \
7 file://disable-documentation.patch \
8 file://tinyproxy.service"
9
10SRC_URI[md5sum] = "3b60f7d08e0821ed1a3e2cf1e5778cac"
11SRC_URI[sha256sum] = "8234c879a129feee61efa98bac14a1a3e46e5cf08f01696a216940872aa70faf"
12
13EXTRA_OECONF += " \
14 --enable-filter \
15 --enable-transparent \
16 --disable-regexcheck \
17 --enable-reverse \
18 --enable-upstream \
19 --enable-xtinyproxy \
20 "
21
22inherit autotools systemd useradd
23
24#User specific
25USERADD_PACKAGES = "${PN}"
26USERADD_PARAM_${PN} = "nobody"
27GROUPADD_PARAM_${PN} = "--system tinyproxy"
28
29SYSTEMD_PACKAGES += "${BPN}"
30SYSTEMD_SERVICE_${PN} = "tinyproxy.service"
31SYSTEMD_AUTO_ENABLE_${PN} = "enable"
32
33do_install_append() {
34 if ${@bb.utils.contains('DISTRO_FEATURES', 'systemd', 'true', 'false', d)}; then
35 install -d ${D}${systemd_system_unitdir}
36 install -m 0644 ${WORKDIR}/tinyproxy.service ${D}${systemd_system_unitdir}
37 fi
38}