summaryrefslogtreecommitdiffstats
path: root/meta-networking
diff options
context:
space:
mode:
authorKhem Raj <raj.khem@gmail.com>2017-03-30 12:39:45 -0700
committerJoe MacDonald <joe_macdonald@mentor.com>2017-04-25 15:55:36 -0400
commita8d26915e8776eb94adeb87de1d23a148cdb2265 (patch)
tree0abf2ff856b8d7ab9e898d5e54c51b39531fe07b /meta-networking
parent9e69cd9c18af17f1b7e478f46f225ca863f03062 (diff)
downloadmeta-openembedded-a8d26915e8776eb94adeb87de1d23a148cdb2265.tar.gz
arptables: Upgrade to 0.0.4
Switch the SRC_URI to git based fetcher Signed-off-by: Khem Raj <raj.khem@gmail.com> Signed-off-by: Joe MacDonald <joe_macdonald@mentor.com>
Diffstat (limited to 'meta-networking')
-rw-r--r--meta-networking/recipes-support/arptables/arptables-0.0.3-4/arptables-compile-install.patch61
-rw-r--r--meta-networking/recipes-support/arptables/arptables/0001-Use-ARPCFLAGS-for-package-specific-compiler-flags.patch79
-rw-r--r--meta-networking/recipes-support/arptables/arptables/arptables-arpt-get-target-fix.patch (renamed from meta-networking/recipes-support/arptables/arptables-0.0.3-4/arptables-arpt-get-target-fix.patch)0
-rw-r--r--meta-networking/recipes-support/arptables/arptables/arptables-init-busybox.patch (renamed from meta-networking/recipes-support/arptables/arptables-0.0.3-4/arptables-init-busybox.patch)0
-rw-r--r--meta-networking/recipes-support/arptables/arptables/arptables-remove-bashism.patch (renamed from meta-networking/recipes-support/arptables/arptables-0.0.3-4/arptables-remove-bashism.patch)0
-rw-r--r--meta-networking/recipes-support/arptables/arptables/arptables.service (renamed from meta-networking/recipes-support/arptables/arptables-0.0.3-4/arptables.service)0
-rw-r--r--meta-networking/recipes-support/arptables/arptables_git.bb (renamed from meta-networking/recipes-support/arptables/arptables_0.0.3-4.bb)43
7 files changed, 98 insertions, 85 deletions
diff --git a/meta-networking/recipes-support/arptables/arptables-0.0.3-4/arptables-compile-install.patch b/meta-networking/recipes-support/arptables/arptables-0.0.3-4/arptables-compile-install.patch
deleted file mode 100644
index 80e980472..000000000
--- a/meta-networking/recipes-support/arptables/arptables-0.0.3-4/arptables-compile-install.patch
+++ /dev/null
@@ -1,61 +0,0 @@
1Index: arptables-v0.0.3-4/Makefile
2===================================================================
3--- arptables-v0.0.3-4.orig/Makefile 2010-03-08 18:49:28.000000000 +0300
4+++ arptables-v0.0.3-4/Makefile 2010-03-22 15:52:56.000000000 +0300
5@@ -6,12 +6,11 @@
6 LIBDIR:=$(PREFIX)/lib
7 BINDIR:=$(PREFIX)/sbin
8 MANDIR:=$(PREFIX)/man
9-INITDIR:=/etc/rc.d/init.d
10+INITDIR:=/etc/init.d
11 SYSCONFIGDIR:=/etc/sysconfig
12 DESTDIR:=
13
14-COPT_FLAGS:=-O2
15-CFLAGS:=$(COPT_FLAGS) -Wall -Wunused -I$(KERNEL_DIR)/include/ -Iinclude/ -DARPTABLES_VERSION=\"$(ARPTABLES_VERSION)\" #-g -DDEBUG #-pg # -DARPTC_DEBUG
16+ARPCFLAGS:=-Wall -Wunused -I$(KERNEL_DIR)/include/ -Iinclude/ -DARPTABLES_VERSION=\"$(ARPTABLES_VERSION)\"
17
18 ifndef ARPT_LIBDIR
19 ARPT_LIBDIR:=$(LIBDIR)/arptables
20@@ -22,16 +21,16 @@
21 all: arptables
22
23 arptables.o: arptables.c
24- $(CC) $(CFLAGS) -c -o $@ $<
25+ $(CC) $(CFLAGS) $(ARPCFLAGS) -c -o $@ $<
26
27 arptables-standalone.o: arptables-standalone.c
28- $(CC) $(CFLAGS) -c -o $@ $<
29+ $(CC) $(CFLAGS) $(ARPCFLAGS) -c -o $@ $<
30
31 libarptc/libarptc.o: libarptc/libarptc.c libarptc/libarptc_incl.c
32- $(CC) $(CFLAGS) -c -o $@ $<
33+ $(CC) $(CFLAGS) $(ARPCFLAGS) -c -o $@ $<
34
35 arptables: arptables-standalone.o arptables.o libarptc/libarptc.o $(EXT_OBJS)
36- $(CC) $(CFLAGS) -o $@ $^
37+ $(CC) $(LDFLAGS) $(CFLAGS) $(ARPCFLAGS) -o $@ $^
38
39 $(DESTDIR)$(MANDIR)/man8/arptables.8: arptables.8
40 mkdir -p $(@D)
41@@ -50,6 +49,7 @@
42 cat arptables-restore | sed 's/__EXEC_PATH__/$(tmp1)/g' > arptables-restore_
43 install -m 0755 -o root -g root arptables-restore_ $(DESTDIR)$(BINDIR)/arptables-restore
44 cat arptables.sysv | sed 's/__EXEC_PATH__/$(tmp1)/g' | sed 's/__SYSCONFIG__/$(tmp2)/g' > arptables.sysv_
45+ install -d $(DESTDIR)$(INITDIR)
46 if test -d $(DESTDIR)$(INITDIR); then install -m 0755 -o root -g root arptables.sysv_ $(DESTDIR)$(INITDIR)/arptables; fi
47 rm -f arptables-save_ arptables-restore_ arptables.sysv_
48
49Index: arptables-v0.0.3-4/extensions/Makefile
50===================================================================
51--- arptables-v0.0.3-4.orig/extensions/Makefile 2010-03-08 18:49:28.000000000 +0300
52+++ arptables-v0.0.3-4/extensions/Makefile 2010-03-22 15:52:38.000000000 +0300
53@@ -4,4 +4,7 @@
54 EXT_OBJS+=$(foreach T,$(EXT_FUNC), extensions/arpt_$(T).o)
55
56 extensions/ebt_%.o: extensions/arpt_%.c include/arptables.h include/arptables_common.h
57- $(CC) $(CFLAGS) $(PROGSPECS) -c -o $@ $<
58+ $(CC) $(CFLAGS) $(ARPCFLAGS) $(PROGSPECS) -c -o $@ $<
59+
60+extensions/arpt_%.o: extensions/arpt_%.c include/arptables.h include/arptables_common.h
61+ $(CC) $(CFLAGS) $(ARPCFLAGS) $(PROGSPECS) -c -o $@ $<
diff --git a/meta-networking/recipes-support/arptables/arptables/0001-Use-ARPCFLAGS-for-package-specific-compiler-flags.patch b/meta-networking/recipes-support/arptables/arptables/0001-Use-ARPCFLAGS-for-package-specific-compiler-flags.patch
new file mode 100644
index 000000000..e8be45e6b
--- /dev/null
+++ b/meta-networking/recipes-support/arptables/arptables/0001-Use-ARPCFLAGS-for-package-specific-compiler-flags.patch
@@ -0,0 +1,79 @@
1From a2021f0bc0f029dfa05dcca5db3d2ec77904d41a Mon Sep 17 00:00:00 2001
2From: Khem Raj <raj.khem@gmail.com>
3Date: Thu, 30 Mar 2017 12:33:51 -0700
4Subject: [PATCH] Use ARPCFLAGS for package specific compiler flags
5
6This leaves room for setting CFLAGS in environment
7which OE uses to pass tweaks
8
9Signed-off-by: Khem Raj <raj.khem@gmail.com>
10---
11 Makefile | 15 +++++++--------
12 extensions/Makefile | 5 ++++-
13 2 files changed, 11 insertions(+), 9 deletions(-)
14
15diff --git a/Makefile b/Makefile
16index 7bead0d..336db6b 100644
17--- a/Makefile
18+++ b/Makefile
19@@ -7,15 +7,13 @@ LIBDIR:=$(PREFIX)/lib
20 BINDIR:=$(PREFIX)/sbin
21 MANDIR:=$(PREFIX)/man
22 man8dir=$(MANDIR)/man8
23-INITDIR:=/etc/rc.d/init.d
24+INITDIR:=/etc/init.d
25 SYSCONFIGDIR:=/etc/sysconfig
26 DESTDIR:=
27
28 MANS = arptables.8 arptables-save.8 arptables-restore.8
29
30-COPT_FLAGS:=-O2
31-CFLAGS:=$(COPT_FLAGS) -Wall -Wunused -I$(KERNEL_DIR)/include/ -Iinclude/ -DARPTABLES_VERSION=\"$(ARPTABLES_VERSION)\" #-g -DDEBUG #-pg # -DARPTC_DEBUG
32-
33+ARPCFLAGS:=-Wall -Wunused -I$(KERNEL_DIR)/include/ -Iinclude/ -DARPTABLES_VERSION=\"$(ARPTABLES_VERSION)\"
34 ifndef ARPT_LIBDIR
35 ARPT_LIBDIR:=$(LIBDIR)/arptables
36 endif
37@@ -25,13 +23,13 @@ include extensions/Makefile
38 all: arptables libarptc/libarptc.a
39
40 arptables.o: arptables.c
41- $(CC) $(CFLAGS) -c -o $@ $<
42+ $(CC) $(ARPCFLAGS) $(CFLAGS) -c -o $@ $<
43
44 arptables-standalone.o: arptables-standalone.c
45- $(CC) $(CFLAGS) -c -o $@ $<
46+ $(CC) $(ARPCFLAGS) $(CFLAGS) -c -o $@ $<
47
48 libarptc/libarptc.o: libarptc/libarptc.c libarptc/libarptc_incl.c
49- $(CC) $(CFLAGS) -c -o $@ $<
50+ $(CC) $(ARPCFLAGS) $(CFLAGS) -c -o $@ $<
51
52 libarptc/libarptc.a: libarptc/libarptc.o
53 $(AR) rcs $@ $<
54@@ -53,7 +51,8 @@ scripts: arptables-save arptables-restore arptables.sysv
55 install -m 0755 arptables-restore_ $(DESTDIR)$(BINDIR)/arptables-restore
56 cat arptables.sysv | sed 's/__EXEC_PATH__/$(tmp1)/g' | sed 's/__SYSCONFIG__/$(tmp2)/g' > arptables.sysv_
57 if [ "$(DESTDIR)" != "" ]; then mkdir -p $(DESTDIR)$(INITDIR); fi
58- if test -d $(DESTDIR)$(INITDIR); then install -m 0755 arptables.sysv_ $(DESTDIR)$(INITDIR)/arptables; fi
59+ install -d $(DESTDIR)$(INITDIR)
60+ install -m 0755 arptables.sysv_ $(DESTDIR)$(INITDIR)/arptables
61 rm -f arptables-save_ arptables-restore_ arptables.sysv_
62
63 .PHONY: install-man
64diff --git a/extensions/Makefile b/extensions/Makefile
65index 0189cc9..b046425 100644
66--- a/extensions/Makefile
67+++ b/extensions/Makefile
68@@ -4,4 +4,7 @@ EXT_FUNC+=standard mangle CLASSIFY MARK
69 EXT_OBJS+=$(foreach T,$(EXT_FUNC), extensions/arpt_$(T).o)
70
71 extensions/ebt_%.o: extensions/arpt_%.c include/arptables.h include/arptables_common.h
72- $(CC) $(CFLAGS) $(PROGSPECS) -c -o $@ $<
73+ $(CC) $(CFLAGS) $(ARPCFLAGS) $(PROGSPECS) -c -o $@ $<
74+
75+extensions/arpt_%.o: extensions/arpt_%.c include/arptables.h include/arptables_common.h
76+ $(CC) $(CFLAGS) $(ARPCFLAGS) $(PROGSPECS) -c -o $@ $<
77--
782.12.1
79
diff --git a/meta-networking/recipes-support/arptables/arptables-0.0.3-4/arptables-arpt-get-target-fix.patch b/meta-networking/recipes-support/arptables/arptables/arptables-arpt-get-target-fix.patch
index 0875344fe..0875344fe 100644
--- a/meta-networking/recipes-support/arptables/arptables-0.0.3-4/arptables-arpt-get-target-fix.patch
+++ b/meta-networking/recipes-support/arptables/arptables/arptables-arpt-get-target-fix.patch
diff --git a/meta-networking/recipes-support/arptables/arptables-0.0.3-4/arptables-init-busybox.patch b/meta-networking/recipes-support/arptables/arptables/arptables-init-busybox.patch
index 24956c4ca..24956c4ca 100644
--- a/meta-networking/recipes-support/arptables/arptables-0.0.3-4/arptables-init-busybox.patch
+++ b/meta-networking/recipes-support/arptables/arptables/arptables-init-busybox.patch
diff --git a/meta-networking/recipes-support/arptables/arptables-0.0.3-4/arptables-remove-bashism.patch b/meta-networking/recipes-support/arptables/arptables/arptables-remove-bashism.patch
index f332658bc..f332658bc 100644
--- a/meta-networking/recipes-support/arptables/arptables-0.0.3-4/arptables-remove-bashism.patch
+++ b/meta-networking/recipes-support/arptables/arptables/arptables-remove-bashism.patch
diff --git a/meta-networking/recipes-support/arptables/arptables-0.0.3-4/arptables.service b/meta-networking/recipes-support/arptables/arptables/arptables.service
index f9fd56df0..f9fd56df0 100644
--- a/meta-networking/recipes-support/arptables/arptables-0.0.3-4/arptables.service
+++ b/meta-networking/recipes-support/arptables/arptables/arptables.service
diff --git a/meta-networking/recipes-support/arptables/arptables_0.0.3-4.bb b/meta-networking/recipes-support/arptables/arptables_git.bb
index f53640847..274a55d91 100644
--- a/meta-networking/recipes-support/arptables/arptables_0.0.3-4.bb
+++ b/meta-networking/recipes-support/arptables/arptables_git.bb
@@ -1,15 +1,13 @@
1SUMMARY = "Administration tool for arp packet filtering" 1SUMMARY = "Administration tool for arp packet filtering"
2LICENSE = "GPL-2.0"
3SECTION = "net" 2SECTION = "net"
4 3LICENSE = "GPL-2.0"
5PR = "r2"
6
7RDEPENDS_${PN} += "perl"
8
9LIC_FILES_CHKSUM = "file://${COREBASE}/meta/files/common-licenses/GPL-2.0;md5=801f80980d171dd6425610833a22dbe6" 4LIC_FILES_CHKSUM = "file://${COREBASE}/meta/files/common-licenses/GPL-2.0;md5=801f80980d171dd6425610833a22dbe6"
5SRCREV = "f4ab8f63f11a72f14687a6646d04ae1bae3fa45f"
6PV = "0.0.4+git${SRCPV}"
7
10SRC_URI = " \ 8SRC_URI = " \
11 ${SOURCEFORGE_MIRROR}/ebtables/arptables-v${PV}.tar.gz;name=arptables \ 9 git://git.netfilter.org/arptables \
12 file://arptables-compile-install.patch \ 10 file://0001-Use-ARPCFLAGS-for-package-specific-compiler-flags.patch \
13 file://arptables-init-busybox.patch \ 11 file://arptables-init-busybox.patch \
14 file://arptables-arpt-get-target-fix.patch \ 12 file://arptables-arpt-get-target-fix.patch \
15 file://arptables-remove-bashism.patch \ 13 file://arptables-remove-bashism.patch \
@@ -18,26 +16,23 @@ SRC_URI = " \
18SRC_URI[arptables.md5sum] = "1d4ab05761f063b0751645d8f2b8f8e5" 16SRC_URI[arptables.md5sum] = "1d4ab05761f063b0751645d8f2b8f8e5"
19SRC_URI[arptables.sha256sum] = "e529fd465c67d69ad335299a043516e6b38cdcd337a5ed21718413e96073f928" 17SRC_URI[arptables.sha256sum] = "e529fd465c67d69ad335299a043516e6b38cdcd337a5ed21718413e96073f928"
20 18
21S = "${WORKDIR}/arptables-v${PV}" 19S = "${WORKDIR}/git"
22 20SYSTEMD_SERVICE_${PN} = "arptables.service"
23do_compile () {
24 oe_runmake
25}
26 21
27# the install target is not multi-job safe, but it doesn't do much 22inherit systemd
28# so we just install serially
29#
30PARALLEL_MAKEINST = "-j1"
31 23
32fakeroot do_install () { 24EXTRA_OEMAKE = "'BINDIR=${sbindir}' 'MANDIR=${mandir}'"
33 oe_runmake 'BINDIR=${sbindir}' 'MANDIR=${mandir}/' 'DESTDIR=${D}' install
34}
35 25
36do_install_append() { 26do_install_append() {
37 install -d ${D}${systemd_unitdir}/system 27 if ${@bb.utils.contains('DISTRO_FEATURES', 'systemd', 'true', 'false', d)}; then
38 install -m 644 ${WORKDIR}/arptables.service ${D}${systemd_unitdir}/system 28 install -d ${D}${systemd_unitdir}/system
29 install -m 644 ${WORKDIR}/arptables.service ${D}${systemd_unitdir}/system
30 fi
39} 31}
40 32
41inherit systemd 33RDEPENDS_${PN} += "perl"
42 34
43SYSTEMD_SERVICE_${PN} = "arptables.service" 35# the install target is not multi-job safe, but it doesn't do much
36# so we just install serially
37#
38PARALLEL_MAKEINST = "-j1"