summaryrefslogtreecommitdiffstats
path: root/meta-networking
diff options
context:
space:
mode:
authorKhem Raj <raj.khem@gmail.com>2017-03-28 20:11:06 -0700
committerJoe MacDonald <joe_macdonald@mentor.com>2017-04-25 15:55:36 -0400
commit764c7f46da2dfd1baa091e76dedf03f4676287d6 (patch)
tree861a9cb3db67583f15a4315cf5f2d063df0542e8 /meta-networking
parentd946331bc00f89fd8f232405bd9fff6da035ae72 (diff)
downloadmeta-openembedded-764c7f46da2dfd1baa091e76dedf03f4676287d6.tar.gz
vsftpd: Fix build with musl
Signed-off-by: Khem Raj <raj.khem@gmail.com> Signed-off-by: Joe MacDonald <joe_macdonald@mentor.com>
Diffstat (limited to 'meta-networking')
-rw-r--r--meta-networking/recipes-daemons/vsftpd/vsftpd-3.0.3/0001-sysdeputil.c-Fix-with-musl-which-does-not-have-utmpx.patch28
-rw-r--r--meta-networking/recipes-daemons/vsftpd/vsftpd_3.0.3.bb7
2 files changed, 32 insertions, 3 deletions
diff --git a/meta-networking/recipes-daemons/vsftpd/vsftpd-3.0.3/0001-sysdeputil.c-Fix-with-musl-which-does-not-have-utmpx.patch b/meta-networking/recipes-daemons/vsftpd/vsftpd-3.0.3/0001-sysdeputil.c-Fix-with-musl-which-does-not-have-utmpx.patch
new file mode 100644
index 000000000..c3919e117
--- /dev/null
+++ b/meta-networking/recipes-daemons/vsftpd/vsftpd-3.0.3/0001-sysdeputil.c-Fix-with-musl-which-does-not-have-utmpx.patch
@@ -0,0 +1,28 @@
1From e55135c2a4ea7eae3cb1f4dccf69ca477ea095bf Mon Sep 17 00:00:00 2001
2From: Khem Raj <raj.khem@gmail.com>
3Date: Tue, 28 Mar 2017 20:09:12 -0700
4Subject: [PATCH] sysdeputil.c: Fix with musl which does not have utmpx
5
6Signed-off-by: Khem Raj <raj.khem@gmail.com>
7---
8 sysdeputil.c | 4 +++-
9 1 file changed, 3 insertions(+), 1 deletion(-)
10
11diff --git a/sysdeputil.c b/sysdeputil.c
12index 06f01f4..a8cff3b 100644
13--- a/sysdeputil.c
14+++ b/sysdeputil.c
15@@ -58,7 +58,9 @@
16 #define VSF_SYSDEP_HAVE_SHADOW
17 #define VSF_SYSDEP_HAVE_USERSHELL
18 #define VSF_SYSDEP_HAVE_LIBCAP
19-#define VSF_SYSDEP_HAVE_UTMPX
20+#if defined(__GLIBC__)
21+ #define VSF_SYSDEP_HAVE_UTMPX
22+#endif
23
24 #define __USE_GNU
25 #include <utmpx.h>
26--
272.12.1
28
diff --git a/meta-networking/recipes-daemons/vsftpd/vsftpd_3.0.3.bb b/meta-networking/recipes-daemons/vsftpd/vsftpd_3.0.3.bb
index 3eaaa30b6..e52461446 100644
--- a/meta-networking/recipes-daemons/vsftpd/vsftpd_3.0.3.bb
+++ b/meta-networking/recipes-daemons/vsftpd/vsftpd_3.0.3.bb
@@ -19,7 +19,10 @@ SRC_URI = "https://security.appspot.com/downloads/vsftpd-${PV}.tar.gz \
19 file://vsftpd.service \ 19 file://vsftpd.service \
20 file://vsftpd-2.1.0-filter.patch \ 20 file://vsftpd-2.1.0-filter.patch \
21 file://0001-vsftpd-allow-sysinfo-in-the-seccomp-sandbox.patch \ 21 file://0001-vsftpd-allow-sysinfo-in-the-seccomp-sandbox.patch \
22" 22 ${@bb.utils.contains('PACKAGECONFIG', 'tcp-wrappers', 'file://vsftpd-tcp_wrappers-support.patch', '', d)} \
23 ${@bb.utils.contains('DISTRO_FEATURES', 'pam', '', '${NOPAM_SRC}', d)} \
24 file://0001-sysdeputil.c-Fix-with-musl-which-does-not-have-utmpx.patch \
25 "
23 26
24LIC_FILES_CHKSUM = "file://COPYING;md5=a6067ad950b28336613aed9dd47b1271 \ 27LIC_FILES_CHKSUM = "file://COPYING;md5=a6067ad950b28336613aed9dd47b1271 \
25 file://COPYRIGHT;md5=04251b2eb0f298dae376d92454f6f72e \ 28 file://COPYRIGHT;md5=04251b2eb0f298dae376d92454f6f72e \
@@ -30,13 +33,11 @@ SRC_URI[sha256sum] = "9d4d2bf6e6e2884852ba4e69e157a2cecd68c5a7635d66a3a8cf8d898c
30 33
31PACKAGECONFIG ??= "tcp-wrappers" 34PACKAGECONFIG ??= "tcp-wrappers"
32PACKAGECONFIG[tcp-wrappers] = ",,tcp-wrappers" 35PACKAGECONFIG[tcp-wrappers] = ",,tcp-wrappers"
33SRC_URI +="${@bb.utils.contains('PACKAGECONFIG', 'tcp-wrappers', 'file://vsftpd-tcp_wrappers-support.patch', '', d)}"
34 36
35DEPENDS += "${@bb.utils.contains('DISTRO_FEATURES', 'pam', 'libpam', '', d)}" 37DEPENDS += "${@bb.utils.contains('DISTRO_FEATURES', 'pam', 'libpam', '', d)}"
36RDEPENDS_${PN} += "${@bb.utils.contains('DISTRO_FEATURES', 'pam', 'pam-plugin-listfile', '', d)}" 38RDEPENDS_${PN} += "${@bb.utils.contains('DISTRO_FEATURES', 'pam', 'pam-plugin-listfile', '', d)}"
37PAMLIB = "${@bb.utils.contains('DISTRO_FEATURES', 'pam', '-L${STAGING_BASELIBDIR} -lpam', '', d)}" 39PAMLIB = "${@bb.utils.contains('DISTRO_FEATURES', 'pam', '-L${STAGING_BASELIBDIR} -lpam', '', d)}"
38NOPAM_SRC ="${@bb.utils.contains('PACKAGECONFIG', 'tcp-wrappers', 'file://nopam-with-tcp_wrappers.patch', 'file://nopam.patch', d)}" 40NOPAM_SRC ="${@bb.utils.contains('PACKAGECONFIG', 'tcp-wrappers', 'file://nopam-with-tcp_wrappers.patch', 'file://nopam.patch', d)}"
39SRC_URI += "${@bb.utils.contains('DISTRO_FEATURES', 'pam', '', '${NOPAM_SRC}', d)}"
40 41
41inherit update-rc.d useradd systemd 42inherit update-rc.d useradd systemd
42 43