summaryrefslogtreecommitdiffstats
path: root/meta-networking
diff options
context:
space:
mode:
authorKhem Raj <raj.khem@gmail.com>2017-04-23 22:20:53 -0700
committerJoe MacDonald <joe_macdonald@mentor.com>2017-04-25 16:10:55 -0400
commit52db0e6c052e36da05348365b953f0bdfaefd54e (patch)
treec84da46595fff0ce5b3dfbb6559fca14ccaca2bf /meta-networking
parent9c022b475e6f3555f25a0294449d912efdfbc0e3 (diff)
downloadmeta-openembedded-52db0e6c052e36da05348365b953f0bdfaefd54e.tar.gz
squid: Upgrade to 3.5.25
Add patch to fix throw() errors with gcc7 Update copyright year to 2017 Signed-off-by: Khem Raj <raj.khem@gmail.com> Signed-off-by: Martin Jansa <Martin.Jansa@gmail.com> Signed-off-by: Joe MacDonald <joe_macdonald@mentor.com>
Diffstat (limited to 'meta-networking')
-rw-r--r--meta-networking/recipes-daemons/squid/files/0001-SquidNew-use-noexcept-instead-of-throw-for-C-11-comp.patch48
-rw-r--r--meta-networking/recipes-daemons/squid/squid_3.5.25.bb (renamed from meta-networking/recipes-daemons/squid/squid_3.5.23.bb)9
2 files changed, 53 insertions, 4 deletions
diff --git a/meta-networking/recipes-daemons/squid/files/0001-SquidNew-use-noexcept-instead-of-throw-for-C-11-comp.patch b/meta-networking/recipes-daemons/squid/files/0001-SquidNew-use-noexcept-instead-of-throw-for-C-11-comp.patch
new file mode 100644
index 000000000..48674c3c5
--- /dev/null
+++ b/meta-networking/recipes-daemons/squid/files/0001-SquidNew-use-noexcept-instead-of-throw-for-C-11-comp.patch
@@ -0,0 +1,48 @@
1From f9150a0dc092ab2cbd47ee428436b747dce323a9 Mon Sep 17 00:00:00 2001
2From: Khem Raj <raj.khem@gmail.com>
3Date: Sun, 23 Apr 2017 10:28:28 -0700
4Subject: [PATCH] SquidNew: use noexcept instead of throw for C++11 compilers
5
6Fixes errors with gcc7 which is more pedantic about c++11
7conformance regarding deprecated features
8
9include/SquidNew.h:21:51: error: dynamic exception specifications are deprecated in C++11
10_SQUID_EXTERNNEW_ void *operator new[] (size_t size) throw (std::bad_alloc)
11 ^~~~~
12
13Signed-off-by: Khem Raj <raj.khem@gmail.com>
14---
15 include/SquidNew.h | 8 ++++----
16 1 file changed, 4 insertions(+), 4 deletions(-)
17
18diff --git a/include/SquidNew.h b/include/SquidNew.h
19index 39fcee0..c960347 100644
20--- a/include/SquidNew.h
21+++ b/include/SquidNew.h
22@@ -18,19 +18,19 @@
23 */
24 #include <new>
25
26-_SQUID_EXTERNNEW_ void *operator new(size_t size) throw (std::bad_alloc)
27+_SQUID_EXTERNNEW_ void *operator new(size_t size) noexcept(false)
28 {
29 return xmalloc(size);
30 }
31-_SQUID_EXTERNNEW_ void operator delete (void *address) throw()
32+_SQUID_EXTERNNEW_ void operator delete (void *address) noexcept(true)
33 {
34 xfree(address);
35 }
36-_SQUID_EXTERNNEW_ void *operator new[] (size_t size) throw (std::bad_alloc)
37+_SQUID_EXTERNNEW_ void *operator new[] (size_t size) noexcept(false)
38 {
39 return xmalloc(size);
40 }
41-_SQUID_EXTERNNEW_ void operator delete[] (void *address) throw()
42+_SQUID_EXTERNNEW_ void operator delete[] (void *address) noexcept(true)
43 {
44 xfree(address);
45 }
46--
472.12.2
48
diff --git a/meta-networking/recipes-daemons/squid/squid_3.5.23.bb b/meta-networking/recipes-daemons/squid/squid_3.5.25.bb
index 0fe9673af..5116383b8 100644
--- a/meta-networking/recipes-daemons/squid/squid_3.5.23.bb
+++ b/meta-networking/recipes-daemons/squid/squid_3.5.25.bb
@@ -21,12 +21,13 @@ SRC_URI = "http://www.squid-cache.org/Versions/v${MAJ_VER}/${MIN_VER}/${BPN}-${P
21 file://volatiles.03_squid \ 21 file://volatiles.03_squid \
22 file://set_sysroot_patch.patch \ 22 file://set_sysroot_patch.patch \
23 file://squid-don-t-do-squid-conf-tests-at-build-time.patch \ 23 file://squid-don-t-do-squid-conf-tests-at-build-time.patch \
24" 24 file://0001-SquidNew-use-noexcept-instead-of-throw-for-C-11-comp.patch \
25SRC_URI[md5sum] = "b9e5603f00b0c40109610667d8693b22" 25 "
26SRC_URI[sha256sum] = "4384564e6227fbb4c18626d663e1b47912d3507b596ed997f2149f10dd8d70bd" 26SRC_URI[md5sum] = "c34b228129a755f363367c45c46287ba"
27SRC_URI[sha256sum] = "0bfd6182154b7f29574d71c659f1cfd1b7d9be9356895dac70dc0f3696a0639b"
27 28
28LIC_FILES_CHKSUM = "file://COPYING;md5=c492e2d6d32ec5c1aad0e0609a141ce9 \ 29LIC_FILES_CHKSUM = "file://COPYING;md5=c492e2d6d32ec5c1aad0e0609a141ce9 \
29 file://errors/COPYRIGHT;md5=0d98c4448c368d146f31a970bb0ced21 \ 30 file://errors/COPYRIGHT;md5=8861130fae91400bcf99b66f133172b3 \
30 " 31 "
31DEPENDS = "libtool krb5 openldap db cyrus-sasl" 32DEPENDS = "libtool krb5 openldap db cyrus-sasl"
32 33