summaryrefslogtreecommitdiffstats
path: root/meta-networking
diff options
context:
space:
mode:
authorKhem Raj <raj.khem@gmail.com>2017-04-24 20:41:25 -0700
committerJoe MacDonald <joe_macdonald@mentor.com>2017-04-25 16:10:55 -0400
commit50c15c53d9499834617b7bf1acf8d5070892f186 (patch)
tree2fbabc365b5ca43effde2a5729fea5555c3ade15 /meta-networking
parent4e9984d270f6a8cede089ec7d6b8fe0a2a71dc3d (diff)
downloadmeta-openembedded-50c15c53d9499834617b7bf1acf8d5070892f186.tar.gz
autofs: Upgrade to 5.1.2 release
Add patches to make it work when SECURITY_FLAGS are enabled Signed-off-by: Khem Raj <raj.khem@gmail.com> Signed-off-by: Joe MacDonald <joe_macdonald@mentor.com>
Diffstat (limited to 'meta-networking')
-rw-r--r--meta-networking/recipes-daemons/autofs/autofs/autofs-5.1.2-libtirpc-as-need.patch30
-rw-r--r--meta-networking/recipes-daemons/autofs/autofs/fix_disable_ldap.patch10
-rw-r--r--meta-networking/recipes-daemons/autofs/autofs/libtirpc-name-clash-backout.patch28
-rw-r--r--meta-networking/recipes-daemons/autofs/autofs/pkgconfig-libnsl.patch19
-rw-r--r--meta-networking/recipes-daemons/autofs/autofs_5.1.2.bb (renamed from meta-networking/recipes-daemons/autofs/autofs_5.1.1.bb)28
5 files changed, 69 insertions, 46 deletions
diff --git a/meta-networking/recipes-daemons/autofs/autofs/autofs-5.1.2-libtirpc-as-need.patch b/meta-networking/recipes-daemons/autofs/autofs/autofs-5.1.2-libtirpc-as-need.patch
new file mode 100644
index 000000000..cbf2bf804
--- /dev/null
+++ b/meta-networking/recipes-daemons/autofs/autofs/autofs-5.1.2-libtirpc-as-need.patch
@@ -0,0 +1,30 @@
1Make configure compatible with -Wl,--as-needed following
2https://wiki.gentoo.org/wiki/Project:Quality_Assurance/As-needed#Failure_in_..2Fconfigure
3
42016-07-05 Martin von Gagern
5
6Index: autofs-5.1.2/aclocal.m4
7===================================================================
8--- autofs-5.1.2.orig/aclocal.m4
9+++ autofs-5.1.2/aclocal.m4
10@@ -415,9 +415,9 @@ AC_DEFUN([AF_CHECK_LIBTIRPC],
11 [
12 # save current flags
13 af_check_libtirpc_save_cflags="$CFLAGS"
14-af_check_libtirpc_save_ldflags="$LDFLAGS"
15+af_check_libtirpc_save_libs="$LIBS"
16 CFLAGS="$CFLAGS -I=/usr/include/tirpc"
17-LDFLAGS="$LDFLAGS -ltirpc"
18+LIBS="$LIBS -ltirpc"
19
20 AC_TRY_LINK(
21 [ #include <rpc/rpc.h> ],
22@@ -440,7 +440,7 @@ AC_CHECK_FUNCS([getrpcbyname getservbyna
23
24 # restore flags
25 CFLAGS="$af_check_libtirpc_save_cflags"
26-LDFLAGS="$af_check_libtirpc_save_ldflags"
27+LIBS="$af_check_libtirpc_save_libs"
28 ])
29
30 AC_DEFUN([AF_WITH_LIBTIRPC],
diff --git a/meta-networking/recipes-daemons/autofs/autofs/fix_disable_ldap.patch b/meta-networking/recipes-daemons/autofs/autofs/fix_disable_ldap.patch
index 31c8510a6..94750b257 100644
--- a/meta-networking/recipes-daemons/autofs/autofs/fix_disable_ldap.patch
+++ b/meta-networking/recipes-daemons/autofs/autofs/fix_disable_ldap.patch
@@ -15,8 +15,10 @@ Signed-off-by: Amy Fong <amy.fong@windriver.com>
15 include/lookup_ldap.h | 4 ++++ 15 include/lookup_ldap.h | 4 ++++
16 1 file changed, 4 insertions(+) 16 1 file changed, 4 insertions(+)
17 17
18--- a/include/lookup_ldap.h 18Index: autofs-5.1.2/include/lookup_ldap.h
19+++ b/include/lookup_ldap.h 19===================================================================
20--- autofs-5.1.2.orig/include/lookup_ldap.h
21+++ autofs-5.1.2/include/lookup_ldap.h
20@@ -1,7 +1,9 @@ 22@@ -1,7 +1,9 @@
21 #ifndef LOOKUP_LDAP_H 23 #ifndef LOOKUP_LDAP_H
22 #define LOOKUP_LDAP_H 24 #define LOOKUP_LDAP_H
@@ -27,14 +29,14 @@ Signed-off-by: Amy Fong <amy.fong@windriver.com>
27 29
28 #ifdef WITH_SASL 30 #ifdef WITH_SASL
29 #include <openssl/ssl.h> 31 #include <openssl/ssl.h>
30@@ -109,10 +111,12 @@ 32@@ -117,10 +119,12 @@ struct lookup_context {
31 33
32 #define LDAP_AUTH_USESIMPLE 0x0008 34 #define LDAP_AUTH_USESIMPLE 0x0008
33 35
34+#ifdef WITH_LDAP 36+#ifdef WITH_LDAP
35 /* lookup_ldap.c */ 37 /* lookup_ldap.c */
36 LDAP *init_ldap_connection(unsigned logopt, const char *uri, struct lookup_context *ctxt); 38 LDAP *init_ldap_connection(unsigned logopt, const char *uri, struct lookup_context *ctxt);
37 int unbind_ldap_connection(unsigned logopt, LDAP *ldap, struct lookup_context *ctxt); 39 int unbind_ldap_connection(unsigned logopt, struct ldap_conn *conn, struct lookup_context *ctxt);
38 int authtype_requires_creds(const char *authtype); 40 int authtype_requires_creds(const char *authtype);
39+#endif 41+#endif
40 42
diff --git a/meta-networking/recipes-daemons/autofs/autofs/libtirpc-name-clash-backout.patch b/meta-networking/recipes-daemons/autofs/autofs/libtirpc-name-clash-backout.patch
deleted file mode 100644
index e93021d56..000000000
--- a/meta-networking/recipes-daemons/autofs/autofs/libtirpc-name-clash-backout.patch
+++ /dev/null
@@ -1,28 +0,0 @@
1---
2 lib/rpc_subs.c | 10 ----------
3 1 file changed, 10 deletions(-)
4
5diff --git a/lib/rpc_subs.c b/lib/rpc_subs.c
6index 5d6ead0..c7177f2 100644
7--- a/lib/rpc_subs.c
8+++ b/lib/rpc_subs.c
9@@ -34,16 +34,6 @@
10 #include <poll.h>
11
12 #ifdef WITH_LIBTIRPC
13-#undef auth_destroy
14-#define auth_destroy(auth) \
15- do { \
16- int refs; \
17- if ((refs = auth_put((auth))) == 0) \
18- ((*((auth)->ah_ops->ah_destroy))(auth));\
19- } while (0)
20-#endif
21-
22-#ifdef WITH_LIBTIRPC
23 const rpcprog_t rpcb_prog = RPCBPROG;
24 const rpcvers_t rpcb_version = RPCBVERS;
25 #else
26--
271.7.10.4
28
diff --git a/meta-networking/recipes-daemons/autofs/autofs/pkgconfig-libnsl.patch b/meta-networking/recipes-daemons/autofs/autofs/pkgconfig-libnsl.patch
new file mode 100644
index 000000000..bf2c964a0
--- /dev/null
+++ b/meta-networking/recipes-daemons/autofs/autofs/pkgconfig-libnsl.patch
@@ -0,0 +1,19 @@
1Use pkg-config first to look for external libnsl which is now
2split out from glibc, if it does not exist then see if its provided
3by glibc itself.
4
5-Khem
6
7Index: autofs-5.1.2/configure.in
8===================================================================
9--- autofs-5.1.2.orig/configure.in
10+++ autofs-5.1.2/configure.in
11@@ -186,7 +186,7 @@ fi
12 #
13 # glibc/libc 6 new libraries
14 #
15-AC_CHECK_LIB(nsl, yp_match, LIBNSL="-lnsl")
16+PKG_CHECK_MODULES([NSL], [libnsl], [], [AC_CHECK_LIB([nsl],[yp_match],[LIBNSL="-lnsl"],[LIBNSL=""])])
17 AC_SUBST(LIBNSL)
18
19 AC_CHECK_LIB(resolv, res_query, LIBRESOLV="-lresolv")
diff --git a/meta-networking/recipes-daemons/autofs/autofs_5.1.1.bb b/meta-networking/recipes-daemons/autofs/autofs_5.1.2.bb
index d85600e4c..eea7c4b83 100644
--- a/meta-networking/recipes-daemons/autofs/autofs_5.1.1.bb
+++ b/meta-networking/recipes-daemons/autofs/autofs_5.1.2.bb
@@ -3,18 +3,17 @@ SECTION = "utils"
3LICENSE = "GPL-2.0" 3LICENSE = "GPL-2.0"
4LIC_FILES_CHKSUM = "file://COPYING;md5=0636e73ff0215e8d672dc4c32c317bb3" 4LIC_FILES_CHKSUM = "file://COPYING;md5=0636e73ff0215e8d672dc4c32c317bb3"
5 5
6DEPENDS += "libtirpc flex-native bison-native" 6DEPENDS += "libtirpc flex-native bison-native e2fsprogs openssl libxml2 util-linux cyrus-sasl"
7 7
8CFLAGS_append_libc-musl = " -I${STAGING_INCDIR}/tirpc" 8CFLAGS += "-I${STAGING_INCDIR}/tirpc"
9 9
10inherit autotools-brokensep systemd 10inherit autotools-brokensep systemd update-rc.d pkgconfig
11 11
12SRC_URI = "${KERNELORG_MIRROR}/linux/daemons/autofs/v5/autofs-${PV}.tar.gz \ 12SRC_URI = "${KERNELORG_MIRROR}/linux/daemons/autofs/v5/autofs-${PV}.tar.gz \
13 file://autofs-5.0.7-include-linux-nfs.h-directly-in-rpc_sub.patch \ 13 file://autofs-5.0.7-include-linux-nfs.h-directly-in-rpc_sub.patch \
14 file://no-bash.patch \ 14 file://no-bash.patch \
15 file://cross.patch \ 15 file://cross.patch \
16 file://libtirpc.patch \ 16 file://libtirpc.patch \
17 file://libtirpc-name-clash-backout.patch \
18 file://autofs-5.0.7-do-not-check-for-modprobe.patch \ 17 file://autofs-5.0.7-do-not-check-for-modprobe.patch \
19 file://fix_disable_ldap.patch \ 18 file://fix_disable_ldap.patch \
20 file://autofs-5.0.7-fix-lib-deps.patch \ 19 file://autofs-5.0.7-fix-lib-deps.patch \
@@ -25,18 +24,17 @@ SRC_URI = "${KERNELORG_MIRROR}/linux/daemons/autofs/v5/autofs-${PV}.tar.gz \
25 file://fix-the-YACC-rule-to-fix-a-building-failure.patch \ 24 file://fix-the-YACC-rule-to-fix-a-building-failure.patch \
26 file://0001-Define-__SWORD_TYPE-and-_PATH_NSSWITCH_CONF.patch \ 25 file://0001-Define-__SWORD_TYPE-and-_PATH_NSSWITCH_CONF.patch \
27 file://0002-Replace-__S_IEXEC-with-S_IEXEC.patch \ 26 file://0002-Replace-__S_IEXEC-with-S_IEXEC.patch \
27 file://autofs-5.1.2-libtirpc-as-need.patch \
28 file://pkgconfig-libnsl.patch \
28 " 29 "
29 30SRC_URI[md5sum] = "28cf88f99eff553a8500659ba5d45a76"
30SRC_URI[md5sum] = "e143df66b614b8cdb1ff533735f8e12d" 31SRC_URI[sha256sum] = "0d57e4138c2ec8058ca92164d035546f68ce4af93acb893369993d67c7056a10"
31SRC_URI[sha256sum] = "795419383b120d15699ab3b89ea0f3d029f6fb28405a83982d305c4b7b61130f"
32
33inherit update-rc.d pkgconfig
34 32
35INITSCRIPT_NAME = "autofs" 33INITSCRIPT_NAME = "autofs"
36INITSCRIPT_PARAMS = "defaults" 34INITSCRIPT_PARAMS = "defaults"
37 35
38# FIXME: modules/Makefile has crappy rules that don't obey LDFLAGS 36# FIXME: modules/Makefile has crappy rules that don't obey LDFLAGS
39CFLAGS += "${LDFLAGS}" 37#CFLAGS += "${LDFLAGS}"
40 38
41PACKAGECONFIG[systemd] = "--with-systemd=${systemd_unitdir}/system,--without-systemd,systemd" 39PACKAGECONFIG[systemd] = "--with-systemd=${systemd_unitdir}/system,--without-systemd,systemd"
42 40
@@ -45,7 +43,7 @@ PACKAGECONFIG ?= "${@bb.utils.filter('DISTRO_FEATURES', 'systemd', d)}"
45EXTRA_OEMAKE = "DONTSTRIP=1" 43EXTRA_OEMAKE = "DONTSTRIP=1"
46EXTRA_OECONF += "--disable-mount-locking \ 44EXTRA_OECONF += "--disable-mount-locking \
47 --enable-ignore-busy --with-openldap=no \ 45 --enable-ignore-busy --with-openldap=no \
48 --with-sasl=no --with-libtirpc=yes \ 46 --with-sasl=no --with-libtirpc \
49 --with-path=${STAGING_BINDIR_NATIVE} \ 47 --with-path=${STAGING_BINDIR_NATIVE} \
50" 48"
51CACHED_CONFIGUREVARS = "ac_cv_path_RANLIB=${RANLIB} \ 49CACHED_CONFIGUREVARS = "ac_cv_path_RANLIB=${RANLIB} \
@@ -53,9 +51,9 @@ CACHED_CONFIGUREVARS = "ac_cv_path_RANLIB=${RANLIB} \
53" 51"
54 52
55do_configure_prepend () { 53do_configure_prepend () {
56 sed -e "s:filagdir:flagdir:" -i configure.in 54 sed -e "s:filagdir:flagdir:" -i ${S}/configure.in
57 if [ ! -e acinclude.m4 ]; then 55 if [ ! -e ${S}/acinclude.m4 ]; then
58 cp aclocal.m4 acinclude.m4 56 cp ${S}/aclocal.m4 ${S}/acinclude.m4
59 fi 57 fi
60} 58}
61 59
@@ -67,6 +65,7 @@ do_install_append () {
67 rmdir ${D}${localstatedir}/run 65 rmdir ${D}${localstatedir}/run
68 fi 66 fi
69} 67}
68SECURITY_CFLAGS = "${SECURITY_NO_PIE_CFLAGS}"
70 69
71INSANE_SKIP_${PN} = "dev-so" 70INSANE_SKIP_${PN} = "dev-so"
72 71
@@ -74,3 +73,4 @@ RPROVIDES_${PN} += "${PN}-systemd"
74RREPLACES_${PN} += "${PN}-systemd" 73RREPLACES_${PN} += "${PN}-systemd"
75RCONFLICTS_${PN} += "${PN}-systemd" 74RCONFLICTS_${PN} += "${PN}-systemd"
76SYSTEMD_SERVICE_${PN} = "autofs.service" 75SYSTEMD_SERVICE_${PN} = "autofs.service"
76