summaryrefslogtreecommitdiffstats
path: root/meta-networking
diff options
context:
space:
mode:
authorKhem Raj <raj.khem@gmail.com>2017-04-18 11:21:12 -0700
committerJoe MacDonald <joe_macdonald@mentor.com>2017-04-25 16:10:15 -0400
commit27ac61803c6e827cc700438918a74845458eee5b (patch)
tree1c4509e55e84a24392469bcf5ac4e67d8eee5668 /meta-networking
parent3f63557cc4b35127ed1540eaa1d4390116f41294 (diff)
downloadmeta-openembedded-27ac61803c6e827cc700438918a74845458eee5b.tar.gz
lowpan-tools: Fix build with clang
Signed-off-by: Khem Raj <raj.khem@gmail.com> Signed-off-by: Joe MacDonald <joe_macdonald@mentor.com>
Diffstat (limited to 'meta-networking')
-rw-r--r--meta-networking/recipes-support/lowpan-tools/lowpan-tools/0001-src-iz.c-Undef-dprintf-before-redefining.patch27
-rw-r--r--meta-networking/recipes-support/lowpan-tools/lowpan-tools_git.bb1
2 files changed, 28 insertions, 0 deletions
diff --git a/meta-networking/recipes-support/lowpan-tools/lowpan-tools/0001-src-iz.c-Undef-dprintf-before-redefining.patch b/meta-networking/recipes-support/lowpan-tools/lowpan-tools/0001-src-iz.c-Undef-dprintf-before-redefining.patch
new file mode 100644
index 000000000..68393067d
--- /dev/null
+++ b/meta-networking/recipes-support/lowpan-tools/lowpan-tools/0001-src-iz.c-Undef-dprintf-before-redefining.patch
@@ -0,0 +1,27 @@
1From ad088233608ba2205511da4f270f8ba29844b84c Mon Sep 17 00:00:00 2001
2From: Khem Raj <raj.khem@gmail.com>
3Date: Sat, 8 Apr 2017 09:02:02 -0700
4Subject: [PATCH] src/iz.c: Undef dprintf before redefining
5
6Clang is picky and warns about macros redefinition
7
8Signed-off-by: Khem Raj <raj.khem@gmail.com>
9---
10 src/iz.c | 1 +
11 1 file changed, 1 insertion(+)
12
13diff --git a/src/iz.c b/src/iz.c
14index 32be1a8..886f0a5 100644
15--- a/src/iz.c
16+++ b/src/iz.c
17@@ -60,6 +60,7 @@ static int iz_seq = 0;
18 /* Parsed options */
19 static int iz_debug = 0;
20
21+#undef dprintf
22 #define dprintf(lvl, fmt...) \
23 do { \
24 if (iz_debug >= lvl) \
25--
262.12.2
27
diff --git a/meta-networking/recipes-support/lowpan-tools/lowpan-tools_git.bb b/meta-networking/recipes-support/lowpan-tools/lowpan-tools_git.bb
index 139eb788f..0dcc6a785 100644
--- a/meta-networking/recipes-support/lowpan-tools/lowpan-tools_git.bb
+++ b/meta-networking/recipes-support/lowpan-tools/lowpan-tools_git.bb
@@ -12,6 +12,7 @@ SRC_URI = "git://git.code.sf.net/p/linux-zigbee/linux-zigbee \
12 file://no-help2man.patch \ 12 file://no-help2man.patch \
13 file://0001-Fix-build-errors-with-clang.patch \ 13 file://0001-Fix-build-errors-with-clang.patch \
14 file://0001-addrdb-coord-config-parse.y-add-missing-time.h-inclu.patch \ 14 file://0001-addrdb-coord-config-parse.y-add-missing-time.h-inclu.patch \
15 file://0001-src-iz.c-Undef-dprintf-before-redefining.patch \
15 " 16 "
16SRCREV = "38f42dbfce9e13629263db3bd3b81f14c69bb733" 17SRCREV = "38f42dbfce9e13629263db3bd3b81f14c69bb733"
17 18