summaryrefslogtreecommitdiffstats
path: root/meta-networking
diff options
context:
space:
mode:
authordengke.du@windriver.com <dengke.du@windriver.com>2016-11-03 17:06:05 +0800
committerJoe MacDonald <joe_macdonald@mentor.com>2016-12-15 11:01:54 -0500
commit0f817b124e82ae01f9e1f8b8640f08bfaa52aad6 (patch)
tree4489fdba57c7839941cb98e415e7a75e8ccdafa7 /meta-networking
parent8151702b66825504f9a5f076fd98d7538910830b (diff)
downloadmeta-openembedded-0f817b124e82ae01f9e1f8b8640f08bfaa52aad6.tar.gz
opensaf: fix QA Issue
Move the do_sysvinit_install contents to do_install_append. Signed-off-by: Dengke Du <dengke.du@windriver.com> Signed-off-by: Martin Jansa <Martin.Jansa@gmail.com> Signed-off-by: Joe MacDonald <joe_macdonald@mentor.com>
Diffstat (limited to 'meta-networking')
-rw-r--r--meta-networking/recipes-daemons/opensaf/opensaf_5.0.0.bb14
1 files changed, 5 insertions, 9 deletions
diff --git a/meta-networking/recipes-daemons/opensaf/opensaf_5.0.0.bb b/meta-networking/recipes-daemons/opensaf/opensaf_5.0.0.bb
index da9c10520..6ceb225e9 100644
--- a/meta-networking/recipes-daemons/opensaf/opensaf_5.0.0.bb
+++ b/meta-networking/recipes-daemons/opensaf/opensaf_5.0.0.bb
@@ -53,6 +53,11 @@ do_install_append() {
53 install -m 0644 ${B}/osaf/services/infrastructure/nid/config/opensafd.service \ 53 install -m 0644 ${B}/osaf/services/infrastructure/nid/config/opensafd.service \
54 ${D}${systemd_unitdir}/system 54 ${D}${systemd_unitdir}/system
55 install -m 0644 ${B}/contrib/plmc/config/*.service ${D}/${systemd_unitdir}/system 55 install -m 0644 ${B}/contrib/plmc/config/*.service ${D}/${systemd_unitdir}/system
56
57 if [ ! -d "${D}${sysconfdir}/init.d" ]; then
58 install -d ${D}${sysconfdir}/init.d
59 install -m 0755 ${B}/osaf/services/infrastructure/nid/scripts/opensafd ${D}${sysconfdir}/init.d/
60 fi
56} 61}
57 62
58FILES_${PN} += "${localstatedir}/run ${systemd_unitdir}/system/*.service" 63FILES_${PN} += "${localstatedir}/run ${systemd_unitdir}/system/*.service"
@@ -62,12 +67,3 @@ INSANE_SKIP_${PN} = "dev-so"
62 67
63RDEPENDS_${PN} += "bash python" 68RDEPENDS_${PN} += "bash python"
64 69
65do_sysvinit_install() {
66 if [ ! -d "${D}${sysconfdir}/init.d" ]; then
67 install -d ${D}${sysconfdir}/init.d
68 install -m 0755 ${B}/osaf/services/infrastructure/nid/scripts/opensafd ${D}${sysconfdir}/init.d/
69 fi
70}
71
72addtask sysvinit_install after do_install before do_package
73