summaryrefslogtreecommitdiffstats
path: root/meta-networking
diff options
context:
space:
mode:
authorLi Zhou <li.zhou@windriver.com>2016-11-23 12:10:40 +0800
committerArmin Kuster <akuster808@gmail.com>2017-01-29 19:30:02 -0500
commit362fdb3f438d122b029dfe4cb8a206affa9bd7c3 (patch)
tree22a54c35a2c73d28d925f0d335c0a59e590d5192 /meta-networking
parent52a4839bf725993c90ea48f7b118770ae6e247d8 (diff)
downloadmeta-openembedded-362fdb3f438d122b029dfe4cb8a206affa9bd7c3.tar.gz
net-snmp: snmplib, UDPIPv6 transport: Add a missing return statement
Backport a succeeding commit from net-snmp upstream to fix the issue introduced by commit <BUG#a2584: Fix snmptrap to use clientaddr from snmp.conf>. The missing return will cause crash when binding to a non-exist IPv6 address. Signed-off-by: Li Zhou <li.zhou@windriver.com> Signed-off-by: Martin Jansa <Martin.Jansa@gmail.com> Signed-off-by: Joe MacDonald <joe_macdonald@mentor.com> Signed-off-by: Armin Kuster <akuster808@gmail.com>
Diffstat (limited to 'meta-networking')
-rw-r--r--meta-networking/recipes-protocols/net-snmp/net-snmp/0001-snmplib-UDPIPv6-transport-Add-a-missing-return-state.patch29
-rw-r--r--meta-networking/recipes-protocols/net-snmp/net-snmp_5.7.3.bb1
2 files changed, 30 insertions, 0 deletions
diff --git a/meta-networking/recipes-protocols/net-snmp/net-snmp/0001-snmplib-UDPIPv6-transport-Add-a-missing-return-state.patch b/meta-networking/recipes-protocols/net-snmp/net-snmp/0001-snmplib-UDPIPv6-transport-Add-a-missing-return-state.patch
new file mode 100644
index 000000000..6255f7ced
--- /dev/null
+++ b/meta-networking/recipes-protocols/net-snmp/net-snmp/0001-snmplib-UDPIPv6-transport-Add-a-missing-return-state.patch
@@ -0,0 +1,29 @@
1From 1ee72102fbe722d232d74abc4660a8b134cec8d6 Mon Sep 17 00:00:00 2001
2From: Bart Van Assche <bvanassche@acm.org>
3Date: Sat, 23 May 2015 07:32:53 +0200
4Subject: [PATCH] snmplib, UDPIPv6 transport: Add a missing return statement
5
6Detected by Coverity.
7
8Upstream-Status: backport
9
10Signed-off-by: Li Zhou <li.zhou@windriver.com>
11---
12 snmplib/transports/snmpUDPIPv6Domain.c | 1 +
13 1 file changed, 1 insertion(+)
14
15diff --git a/snmplib/transports/snmpUDPIPv6Domain.c b/snmplib/transports/snmpUDPIPv6Domain.c
16index 029b164..11c39bb 100644
17--- a/snmplib/transports/snmpUDPIPv6Domain.c
18+++ b/snmplib/transports/snmpUDPIPv6Domain.c
19@@ -285,6 +285,7 @@ netsnmp_udp6_transport(struct sockaddr_in6 *addr, int local)
20 errno, strerror(errno)));
21 netsnmp_socketbase_close(t);
22 netsnmp_transport_free(t);
23+ return NULL;
24 }
25 }
26 /*
27--
282.9.3
29
diff --git a/meta-networking/recipes-protocols/net-snmp/net-snmp_5.7.3.bb b/meta-networking/recipes-protocols/net-snmp/net-snmp_5.7.3.bb
index 140028722..79e7766e9 100644
--- a/meta-networking/recipes-protocols/net-snmp/net-snmp_5.7.3.bb
+++ b/meta-networking/recipes-protocols/net-snmp/net-snmp_5.7.3.bb
@@ -25,6 +25,7 @@ SRC_URI = "${SOURCEFORGE_MIRROR}/net-snmp/net-snmp-${PV}.zip \
25 file://net-snmp-agentx-crash.patch \ 25 file://net-snmp-agentx-crash.patch \
26 file://0001-get_pid_from_inode-Include-limit.h.patch \ 26 file://0001-get_pid_from_inode-Include-limit.h.patch \
27 file://0001-BUG-a2584-Fix-snmptrap-to-use-clientaddr-from-snmp.c.patch \ 27 file://0001-BUG-a2584-Fix-snmptrap-to-use-clientaddr-from-snmp.c.patch \
28 file://0001-snmplib-UDPIPv6-transport-Add-a-missing-return-state.patch \
28 " 29 "
29SRC_URI[md5sum] = "9f682bd70c717efdd9f15b686d07baee" 30SRC_URI[md5sum] = "9f682bd70c717efdd9f15b686d07baee"
30SRC_URI[sha256sum] = "e8dfc79b6539b71a6ff335746ce63d2da2239062ad41872fff4354cafed07a3e" 31SRC_URI[sha256sum] = "e8dfc79b6539b71a6ff335746ce63d2da2239062ad41872fff4354cafed07a3e"