diff options
author | Patrick Wicki <patrick.wicki@siemens.com> | 2023-11-30 03:55:26 +0100 |
---|---|---|
committer | Khem Raj <raj.khem@gmail.com> | 2023-11-29 22:25:05 -0800 |
commit | fa560acfdb3e6922fa27aa139ad950b9f62cd53e (patch) | |
tree | 807fca13d8d5bdd3bfe1d863f755c4242d5609b7 /meta-networking | |
parent | a5f13e6231da1a480eaac3bff4f9253c9a8adbca (diff) | |
download | meta-openembedded-fa560acfdb3e6922fa27aa139ad950b9f62cd53e.tar.gz |
squid: add auth packageconfig
Introduce PACKAGECONFIG[auth] and pin the dependencies to it. This
allows building squid without authentication support and all its related
dependencies.
Signed-off-by: Patrick Wicki <patrick.wicki@siemens.com>
Signed-off-by: Khem Raj <raj.khem@gmail.com>
Diffstat (limited to 'meta-networking')
-rw-r--r-- | meta-networking/recipes-daemons/squid/squid_6.5.bb | 11 |
1 files changed, 7 insertions, 4 deletions
diff --git a/meta-networking/recipes-daemons/squid/squid_6.5.bb b/meta-networking/recipes-daemons/squid/squid_6.5.bb index 33a8bc476..66b42ebbb 100644 --- a/meta-networking/recipes-daemons/squid/squid_6.5.bb +++ b/meta-networking/recipes-daemons/squid/squid_6.5.bb | |||
@@ -30,7 +30,7 @@ SRC_URI[sha256sum] = "99acd54ec9d68b2a9080d19fcc43eca1a245146cf162dbba689510d01e | |||
30 | LIC_FILES_CHKSUM = "file://COPYING;md5=b234ee4d69f5fce4486a80fdaf4a4263 \ | 30 | LIC_FILES_CHKSUM = "file://COPYING;md5=b234ee4d69f5fce4486a80fdaf4a4263 \ |
31 | file://errors/COPYRIGHT;md5=d324bc1f9447d1d1588d75b22a678dc4 \ | 31 | file://errors/COPYRIGHT;md5=d324bc1f9447d1d1588d75b22a678dc4 \ |
32 | " | 32 | " |
33 | DEPENDS = "libtool krb5 openldap db cyrus-sasl" | 33 | DEPENDS = "libtool" |
34 | 34 | ||
35 | inherit autotools pkgconfig useradd ptest perlnative | 35 | inherit autotools pkgconfig useradd ptest perlnative |
36 | 36 | ||
@@ -42,13 +42,16 @@ LDFLAGS:append:riscv32 = " -latomic" | |||
42 | USERADD_PACKAGES = "${PN}" | 42 | USERADD_PACKAGES = "${PN}" |
43 | USERADD_PARAM:${PN} = "--system --no-create-home --home-dir /var/run/squid --shell /bin/false --user-group squid" | 43 | USERADD_PARAM:${PN} = "--system --no-create-home --home-dir /var/run/squid --shell /bin/false --user-group squid" |
44 | 44 | ||
45 | PACKAGECONFIG ??= "${@bb.utils.filter('DISTRO_FEATURES', 'ipv6', d)} \ | 45 | PACKAGECONFIG ??= "auth \ |
46 | " | 46 | ${@bb.utils.filter('DISTRO_FEATURES', 'ipv6', d)} \ |
47 | " | ||
48 | |||
47 | PACKAGECONFIG[libnetfilter-conntrack] = "--with-netfilter-conntrack=${includedir}, --without-netfilter-conntrack, libnetfilter-conntrack" | 49 | PACKAGECONFIG[libnetfilter-conntrack] = "--with-netfilter-conntrack=${includedir}, --without-netfilter-conntrack, libnetfilter-conntrack" |
48 | PACKAGECONFIG[ipv6] = "--enable-ipv6,--disable-ipv6," | 50 | PACKAGECONFIG[ipv6] = "--enable-ipv6,--disable-ipv6," |
49 | PACKAGECONFIG[werror] = "--enable-strict-error-checking,--disable-strict-error-checking," | 51 | PACKAGECONFIG[werror] = "--enable-strict-error-checking,--disable-strict-error-checking," |
50 | PACKAGECONFIG[esi] = "--enable-esi,--disable-esi,expat libxml2" | 52 | PACKAGECONFIG[esi] = "--enable-esi,--disable-esi,expat libxml2" |
51 | PACKAGECONFIG[ssl] = "--with-openssl=yes,--with-openssl=no,openssl" | 53 | PACKAGECONFIG[ssl] = "--with-openssl=yes,--with-openssl=no,openssl" |
54 | PACKAGECONFIG[auth] = "--enable-auth-basic='${BASIC_AUTH}',--disable-auth --disable-auth-basic,krb5 openldap db cyrus-sasl" | ||
52 | 55 | ||
53 | PACKAGES =+ "${PN}-networkmanager" | 56 | PACKAGES =+ "${PN}-networkmanager" |
54 | 57 | ||
@@ -57,7 +60,7 @@ BASIC_AUTH = "DB SASL LDAP" | |||
57 | DEPENDS += "${@bb.utils.contains('DISTRO_FEATURES', 'pam', 'libpam', '', d)}" | 60 | DEPENDS += "${@bb.utils.contains('DISTRO_FEATURES', 'pam', 'libpam', '', d)}" |
58 | BASIC_AUTH += "${@bb.utils.contains('DISTRO_FEATURES', 'pam', 'PAM', '', d)}" | 61 | BASIC_AUTH += "${@bb.utils.contains('DISTRO_FEATURES', 'pam', 'PAM', '', d)}" |
59 | 62 | ||
60 | EXTRA_OECONF += "--with-default-user=squid --enable-auth-basic='${BASIC_AUTH}' \ | 63 | EXTRA_OECONF += "--with-default-user=squid \ |
61 | --sysconfdir=${sysconfdir}/${BPN} \ | 64 | --sysconfdir=${sysconfdir}/${BPN} \ |
62 | --with-logdir=${localstatedir}/log/${BPN} \ | 65 | --with-logdir=${localstatedir}/log/${BPN} \ |
63 | 'PERL=${USRBINPATH}/env perl'" | 66 | 'PERL=${USRBINPATH}/env perl'" |