summaryrefslogtreecommitdiffstats
path: root/meta-networking
diff options
context:
space:
mode:
authorYi Zhao <yi.zhao@windriver.com>2022-08-30 15:22:24 +0800
committerKhem Raj <raj.khem@gmail.com>2022-08-30 15:27:08 -0700
commitea62a6b30a0c564913ea4bb548b087aa5191edc9 (patch)
tree0be525335bccc262b6d298262e534dc52652a516 /meta-networking
parent254b6cb1155961a26797ed0f6a011987008a4440 (diff)
downloadmeta-openembedded-ea62a6b30a0c564913ea4bb548b087aa5191edc9.tar.gz
tcpreplay: fix buildpaths issue
POSIX_SHELL is specified a host tool path as it searches path on build host using `which` when configure. Set it to a fixed path '/bin/sh'. Fixes: QA Issue: File /usr/bin/tcpbridge in package tcpreplay contains reference to TMPDIR File /usr/bin/tcpliveplay in package tcpreplay contains reference to TMPDIR File /usr/bin/tcprewrite in package tcpreplay contains reference to TMPDIR File /usr/bin/tcpcapinfo in package tcpreplay contains reference to TMPDIR File /usr/bin/tcpreplay in package tcpreplay contains reference to TMPDIR File /usr/bin/tcpprep in package tcpreplay contains reference to TMPDIR File /usr/bin/tcpreplay-edit in package tcpreplay contains reference to TMPDIR [buildpaths] QA Issue: File /usr/src/debug/tcpreplay/4.4.2-r0/src/defines.h in package tcpreplay-src contains reference to TMPDIR [buildpaths] Signed-off-by: Yi Zhao <yi.zhao@windriver.com> Signed-off-by: Khem Raj <raj.khem@gmail.com>
Diffstat (limited to 'meta-networking')
-rw-r--r--meta-networking/recipes-support/tcpreplay/tcpreplay/0001-libopts.m4-set-POSIX_SHELL-to-bin-sh.patch45
-rw-r--r--meta-networking/recipes-support/tcpreplay/tcpreplay_4.4.2.bb7
2 files changed, 51 insertions, 1 deletions
diff --git a/meta-networking/recipes-support/tcpreplay/tcpreplay/0001-libopts.m4-set-POSIX_SHELL-to-bin-sh.patch b/meta-networking/recipes-support/tcpreplay/tcpreplay/0001-libopts.m4-set-POSIX_SHELL-to-bin-sh.patch
new file mode 100644
index 000000000..448455fff
--- /dev/null
+++ b/meta-networking/recipes-support/tcpreplay/tcpreplay/0001-libopts.m4-set-POSIX_SHELL-to-bin-sh.patch
@@ -0,0 +1,45 @@
1From 769e96b60f631e8c208fd7f72900d0bb17760f88 Mon Sep 17 00:00:00 2001
2From: Yi Zhao <yi.zhao@windriver.com>
3Date: Tue, 30 Aug 2022 09:54:11 +0800
4Subject: [PATCH] libopts.m4: set POSIX_SHELL to /bin/sh
5
6POSIX_SHELL is specified a host tool path as it searches path on build
7host using `which` when configure. Set it to a fixed path '/bin/sh'.
8
9Upstream-Status: Inappropriate [embedded specific]
10
11Signed-off-by: Yi Zhao <yi.zhao@windriver.com>
12---
13 m4/libopts.m4 | 16 +---------------
14 1 file changed, 1 insertion(+), 15 deletions(-)
15
16diff --git a/m4/libopts.m4 b/m4/libopts.m4
17index cfbd477..c8047eb 100644
18--- a/m4/libopts.m4
19+++ b/m4/libopts.m4
20@@ -111,21 +111,7 @@ AC_DEFUN([INVOKE_LIBOPTS_MACROS_FIRST],[
21 AC_CHECK_FUNCS([mmap canonicalize_file_name snprintf strdup strchr \
22 strrchr strsignal fchmod fstat chmod])
23 AC_PROG_SED
24- [while :
25- do
26- POSIX_SHELL=`which bash`
27- test -x "$POSIX_SHELL" && break
28- POSIX_SHELL=`which dash`
29- test -x "$POSIX_SHELL" && break
30- POSIX_SHELL=/usr/xpg4/bin/sh
31- test -x "$POSIX_SHELL" && break
32- POSIX_SHELL=`/bin/sh -c '
33- exec 2>/dev/null
34- if ! true ; then exit 1 ; fi
35- echo /bin/sh'`
36- test -x "$POSIX_SHELL" && break
37- ]AC_MSG_ERROR([cannot locate a working POSIX shell])[
38- done]
39+ POSIX_SHELL='/bin/sh'
40 AC_DEFINE_UNQUOTED([POSIX_SHELL], ["${POSIX_SHELL}"],
41 [define to a working POSIX compliant shell])
42 AC_SUBST([POSIX_SHELL])
43--
442.25.1
45
diff --git a/meta-networking/recipes-support/tcpreplay/tcpreplay_4.4.2.bb b/meta-networking/recipes-support/tcpreplay/tcpreplay_4.4.2.bb
index 165a0e735..7d2a6a14d 100644
--- a/meta-networking/recipes-support/tcpreplay/tcpreplay_4.4.2.bb
+++ b/meta-networking/recipes-support/tcpreplay/tcpreplay_4.4.2.bb
@@ -7,7 +7,9 @@ SECTION = "net"
7LICENSE = "GPL-3.0-only" 7LICENSE = "GPL-3.0-only"
8LIC_FILES_CHKSUM = "file://docs/LICENSE;md5=10f0474a2f0e5dccfca20f69d6598ad8" 8LIC_FILES_CHKSUM = "file://docs/LICENSE;md5=10f0474a2f0e5dccfca20f69d6598ad8"
9 9
10SRC_URI = "https://github.com/appneta/tcpreplay/releases/download/v${PV}/tcpreplay-${PV}.tar.gz" 10SRC_URI = "https://github.com/appneta/tcpreplay/releases/download/v${PV}/tcpreplay-${PV}.tar.gz \
11 file://0001-libopts.m4-set-POSIX_SHELL-to-bin-sh.patch \
12 "
11 13
12SRC_URI[sha256sum] = "5b272cd83b67d6288a234ea15f89ecd93b4fadda65eddc44e7b5fcb2f395b615" 14SRC_URI[sha256sum] = "5b272cd83b67d6288a234ea15f89ecd93b4fadda65eddc44e7b5fcb2f395b615"
13 15
@@ -19,3 +21,6 @@ EXTRA_OECONF += "--with-libpcap=${STAGING_DIR_HOST}/usr"
19 21
20inherit siteinfo autotools-brokensep 22inherit siteinfo autotools-brokensep
21 23
24do_install:append() {
25 sed -i -e 's:${RECIPE_SYSROOT}::g' ${S}/src/defines.h
26}