summaryrefslogtreecommitdiffstats
path: root/meta-networking
diff options
context:
space:
mode:
authorKhem Raj <raj.khem@gmail.com>2023-11-13 00:12:04 -0800
committerKhem Raj <raj.khem@gmail.com>2023-11-13 00:16:50 -0800
commitd7b8a3171c04b4364f7af38963517982b2d6ce60 (patch)
treeaa384b485583a6215b62a84e702a7499c7140a5a /meta-networking
parentf1109887083d97365e3e0c292a76cb0195af269d (diff)
downloadmeta-openembedded-d7b8a3171c04b4364f7af38963517982b2d6ce60.tar.gz
cannelloni: Fix build with clang and libc++ runtime
Signed-off-by: Khem Raj <raj.khem@gmail.com>
Diffstat (limited to 'meta-networking')
-rw-r--r--meta-networking/recipes-connectivity/cannelloni/cannelloni/0001-include-bits-stdc-.h-only-when-using-libstdc.patch37
-rw-r--r--meta-networking/recipes-connectivity/cannelloni/cannelloni_1.1.0.bb4
2 files changed, 40 insertions, 1 deletions
diff --git a/meta-networking/recipes-connectivity/cannelloni/cannelloni/0001-include-bits-stdc-.h-only-when-using-libstdc.patch b/meta-networking/recipes-connectivity/cannelloni/cannelloni/0001-include-bits-stdc-.h-only-when-using-libstdc.patch
new file mode 100644
index 000000000..71f447c94
--- /dev/null
+++ b/meta-networking/recipes-connectivity/cannelloni/cannelloni/0001-include-bits-stdc-.h-only-when-using-libstdc.patch
@@ -0,0 +1,37 @@
1From 7aed36765ae44b41ede7e139da0a11b3696f2e06 Mon Sep 17 00:00:00 2001
2From: Khem Raj <raj.khem@gmail.com>
3Date: Mon, 13 Nov 2023 00:07:23 -0800
4Subject: [PATCH] include bits/stdc++.h only when using libstdc++
5
6We have other c++ runtime implementations e.g. llvm's libc++ which does
7not provide this header bits/stdc++.h, therefore make sure that this
8header is only included when using libstdc++
9
10Fixes
11| /mnt/b/yoe/master/build/tmp/work/core2-64-yoe-linux/cannelloni/1.1.0/git/tcpthread.cpp:27:10: fatal error: 'bits/stdc++.h' file not found
12| 27 | #include <bits/stdc++.h>
13| | ^~~~~~~~~~~~~~~
14
15Upstream-Status: Submitted [https://github.com/mguentner/cannelloni/pull/56]
16Signed-off-by: Khem Raj <raj.khem@gmail.com>
17---
18 tcpthread.cpp | 2 ++
19 1 file changed, 2 insertions(+)
20
21diff --git a/tcpthread.cpp b/tcpthread.cpp
22index a1b3047..bb5a7b2 100644
23--- a/tcpthread.cpp
24+++ b/tcpthread.cpp
25@@ -24,7 +24,9 @@
26 #include <cstdint>
27 #include <cstdio>
28
29+#ifdef __GLIBCXX__
30 #include <bits/stdc++.h>
31+#endif
32
33 #include <linux/can.h>
34 #include <string.h>
35--
362.42.1
37
diff --git a/meta-networking/recipes-connectivity/cannelloni/cannelloni_1.1.0.bb b/meta-networking/recipes-connectivity/cannelloni/cannelloni_1.1.0.bb
index fb457dc03..dfa7437ba 100644
--- a/meta-networking/recipes-connectivity/cannelloni/cannelloni_1.1.0.bb
+++ b/meta-networking/recipes-connectivity/cannelloni/cannelloni_1.1.0.bb
@@ -2,7 +2,9 @@ SUMMARY = "a SocketCAN over Ethernet tunnel"
2HOMEPAGE = "https://github.com/mguentner/cannelloni" 2HOMEPAGE = "https://github.com/mguentner/cannelloni"
3LICENSE = "GPL-2.0-only" 3LICENSE = "GPL-2.0-only"
4 4
5SRC_URI = "git://github.com/mguentner/cannelloni.git;protocol=https;branch=master" 5SRC_URI = "git://github.com/mguentner/cannelloni.git;protocol=https;branch=master \
6 file://0001-include-bits-stdc-.h-only-when-using-libstdc.patch \
7 "
6SRCREV = "3d4fb8c8b07f6d7c62b2bdad7e5a94de61c9a29b" 8SRCREV = "3d4fb8c8b07f6d7c62b2bdad7e5a94de61c9a29b"
7 9
8LIC_FILES_CHKSUM = "file://gpl-2.0.txt;md5=b234ee4d69f5fce4486a80fdaf4a4263" 10LIC_FILES_CHKSUM = "file://gpl-2.0.txt;md5=b234ee4d69f5fce4486a80fdaf4a4263"