diff options
author | Joe MacDonald <joe_macdonald@mentor.com> | 2015-02-25 10:39:18 -0500 |
---|---|---|
committer | Joe MacDonald <joe_macdonald@mentor.com> | 2015-02-27 09:14:22 -0500 |
commit | d1d09c11679db18955b28b9b2cc7628b8c9223df (patch) | |
tree | bc4b015010292e1e1ceb1c3124095119241c56ee /meta-networking | |
parent | 9a6775585c7e82b96109c9f9adc4e16b2f5d6cc3 (diff) | |
download | meta-openembedded-d1d09c11679db18955b28b9b2cc7628b8c9223df.tar.gz |
ptpd: use pkgconfig
pcap-config should not be used for determining how to build against
libpcap in a yocto environment.
Signed-off-by: Joe MacDonald <joe_macdonald@mentor.com>
Diffstat (limited to 'meta-networking')
-rw-r--r-- | meta-networking/recipes-daemons/ptpd/ptpd/ptpd-use-pkgconfig.patch | 35 | ||||
-rw-r--r-- | meta-networking/recipes-daemons/ptpd/ptpd_2.3.1-rc2.bb | 3 |
2 files changed, 37 insertions, 1 deletions
diff --git a/meta-networking/recipes-daemons/ptpd/ptpd/ptpd-use-pkgconfig.patch b/meta-networking/recipes-daemons/ptpd/ptpd/ptpd-use-pkgconfig.patch new file mode 100644 index 000000000..e4578dda7 --- /dev/null +++ b/meta-networking/recipes-daemons/ptpd/ptpd/ptpd-use-pkgconfig.patch | |||
@@ -0,0 +1,35 @@ | |||
1 | From 4c850b92a1cf8cfa19677c66bcde2edfab1a4490 Mon Sep 17 00:00:00 2001 | ||
2 | From: Joe MacDonald <joe_macdonald@mentor.com> | ||
3 | Date: Tue, 24 Feb 2015 23:02:14 -0500 | ||
4 | Subject: [PATCH] ptpd: use pkgconfig | ||
5 | |||
6 | Yocto uses pkg-config for libpcap, rather than pcap-config, so use that | ||
7 | instead as the source for libs and cflags. | ||
8 | |||
9 | Upstream-status: Inappropriate [ embedded specific ] | ||
10 | |||
11 | Signed-off-by: Joe MacDonald <joe_macdonald@mentor.com> | ||
12 | --- | ||
13 | configure.ac | 4 ++-- | ||
14 | 1 file changed, 2 insertions(+), 2 deletions(-) | ||
15 | |||
16 | diff --git a/configure.ac b/configure.ac | ||
17 | index dc9541f..288f547 100644 | ||
18 | --- a/configure.ac | ||
19 | +++ b/configure.ac | ||
20 | @@ -112,10 +112,10 @@ case "$try_pcap" in | ||
21 | yes) | ||
22 | case "$PATH_PCAP_CONFIG" in | ||
23 | /*) | ||
24 | - PCAP_LIBS=`$PATH_PCAP_CONFIG --libs` | ||
25 | + PCAP_LIBS=`$PATH_PCAP_CONFIG --libs libpcap` | ||
26 | AC_SUBST([PCAP_LIBS]) | ||
27 | # Separate CPPFLAGS and CFLAGS | ||
28 | - foo=`$PATH_PCAP_CONFIG --cflags` | ||
29 | + foo=`$PATH_PCAP_CONFIG --cflags libpcap` | ||
30 | PCAP_CPPFLAGS= | ||
31 | PCAP_CFLAGS= | ||
32 | for i in $foo; do | ||
33 | -- | ||
34 | 1.9.1 | ||
35 | |||
diff --git a/meta-networking/recipes-daemons/ptpd/ptpd_2.3.1-rc2.bb b/meta-networking/recipes-daemons/ptpd/ptpd_2.3.1-rc2.bb index 50cdc7f2d..0dcfc1f7d 100644 --- a/meta-networking/recipes-daemons/ptpd/ptpd_2.3.1-rc2.bb +++ b/meta-networking/recipes-daemons/ptpd/ptpd_2.3.1-rc2.bb | |||
@@ -23,6 +23,7 @@ def get_sub(d): | |||
23 | 23 | ||
24 | SRC_URI = "http://downloads.sourceforge.net/project/ptpd/ptpd/${@get_sub(d)}/ptpd-${PV}.tar.gz \ | 24 | SRC_URI = "http://downloads.sourceforge.net/project/ptpd/ptpd/${@get_sub(d)}/ptpd-${PV}.tar.gz \ |
25 | file://ptpd-add-dpaa-etsec-support.patch \ | 25 | file://ptpd-add-dpaa-etsec-support.patch \ |
26 | file://ptpd-use-pkgconfig.patch \ | ||
26 | file://ptpd.service \ | 27 | file://ptpd.service \ |
27 | file://ptpd.conf \ | 28 | file://ptpd.conf \ |
28 | " | 29 | " |
@@ -34,7 +35,7 @@ S = "${WORKDIR}/ptpd-${PV}" | |||
34 | 35 | ||
35 | EXTRA_OEMAKE = "" | 36 | EXTRA_OEMAKE = "" |
36 | 37 | ||
37 | EXTRA_OECONF += "--disable-snmp" | 38 | EXTRA_OECONF += "--disable-snmp --with-pcap-config=pkg-config" |
38 | 39 | ||
39 | do_install() { | 40 | do_install() { |
40 | install -d ${D}${bindir} ${D}${mandir}/man8 | 41 | install -d ${D}${bindir} ${D}${mandir}/man8 |