diff options
author | Chris Patterson <pattersonc@ainfosec.com> | 2015-12-18 15:49:40 -0500 |
---|---|---|
committer | Joe MacDonald <joe_macdonald@mentor.com> | 2016-01-05 12:43:33 -0500 |
commit | cfaff72a02de1181a6fe61a849d9416110dfebd6 (patch) | |
tree | b6e21e2b07241d289732677c948b20aee3beaa57 /meta-networking | |
parent | 71cebad9798894a9aac19577c1a1a6a08046390b (diff) | |
download | meta-openembedded-cfaff72a02de1181a6fe61a849d9416110dfebd6.tar.gz |
strongswan: add additional PACKAGECONFIG flags
- Add aesni, charon, gmp, openssl, scep, stroke, swanctl, and
systemd-charon.
- Organize the packageconfig list alphabetically.
- Update the default PACKAGECONFIG to match current defaults.
- If swanctl is enabled, use strongswan-swanctl.service instead of
strongswan.service.
Signed-off-by: Chris Patterson <pattersonc@ainfosec.com>
Signed-off-by: Martin Jansa <Martin.Jansa@gmail.com>
Signed-off-by: Joe MacDonald <joe_macdonald@mentor.com>
Diffstat (limited to 'meta-networking')
-rw-r--r-- | meta-networking/recipes-support/strongswan/strongswan_5.3.2.bb | 24 |
1 files changed, 17 insertions, 7 deletions
diff --git a/meta-networking/recipes-support/strongswan/strongswan_5.3.2.bb b/meta-networking/recipes-support/strongswan/strongswan_5.3.2.bb index a231a90ac..df7b4966c 100644 --- a/meta-networking/recipes-support/strongswan/strongswan_5.3.2.bb +++ b/meta-networking/recipes-support/strongswan/strongswan_5.3.2.bb | |||
@@ -14,21 +14,31 @@ SRC_URI = "http://download.strongswan.org/strongswan-${PV}.tar.bz2 \ | |||
14 | SRC_URI[md5sum] = "fab014be1477ef4ebf9a765e10f8802c" | 14 | SRC_URI[md5sum] = "fab014be1477ef4ebf9a765e10f8802c" |
15 | SRC_URI[sha256sum] = "a4a9bc8c4e42bdc4366a87a05a02bf9f425169a7ab0c6f4482d347e44acbf225" | 15 | SRC_URI[sha256sum] = "a4a9bc8c4e42bdc4366a87a05a02bf9f425169a7ab0c6f4482d347e44acbf225" |
16 | 16 | ||
17 | EXTRA_OECONF = "--enable-gmp \ | 17 | EXTRA_OECONF = " \ |
18 | --enable-openssl \ | ||
19 | --without-lib-prefix \ | 18 | --without-lib-prefix \ |
20 | " | 19 | " |
21 | 20 | ||
22 | EXTRA_OECONF += "${@base_contains('DISTRO_FEATURES', 'systemd', '--with-systemdsystemunitdir=${systemd_unitdir}/system/', '--without-systemdsystemunitdir', d)}" | 21 | EXTRA_OECONF += "${@base_contains('DISTRO_FEATURES', 'systemd', '--with-systemdsystemunitdir=${systemd_unitdir}/system/', '--without-systemdsystemunitdir', d)}" |
23 | 22 | ||
24 | PACKAGECONFIG ??= "sqlite3 curl \ | 23 | |
24 | PACKAGECONFIG ??= "charon curl gmp openssl stroke sqlite3 \ | ||
25 | ${@base_contains('DISTRO_FEATURES', 'ldap', 'ldap', '', d)} \ | 25 | ${@base_contains('DISTRO_FEATURES', 'ldap', 'ldap', '', d)} \ |
26 | " | 26 | " |
27 | PACKAGECONFIG[sqlite3] = "--enable-sqlite,--disable-sqlite,sqlite3," | 27 | PACKAGECONFIG[aesni] = "--enable-aesni,--disable-aesni," |
28 | PACKAGECONFIG[ldap] = "--enable-ldap,--disable-ldap,openldap," | 28 | PACKAGECONFIG[charon] = "--enable-charon,--disable-charon," |
29 | PACKAGECONFIG[curl] = "--enable-curl,--disable-curl,curl," | 29 | PACKAGECONFIG[curl] = "--enable-curl,--disable-curl,curl," |
30 | PACKAGECONFIG[soup] = "--enable-soup,--disable-soup,libsoup-2.4," | 30 | PACKAGECONFIG[gmp] = "--enable-gmp,--disable-gmp,gmp," |
31 | PACKAGECONFIG[ldap] = "--enable-ldap,--disable-ldap,openldap," | ||
31 | PACKAGECONFIG[mysql] = "--enable-mysql,--disable-mysql,mysql5," | 32 | PACKAGECONFIG[mysql] = "--enable-mysql,--disable-mysql,mysql5," |
33 | PACKAGECONFIG[openssl] = "--enable-openssl,--disable-openssl,openssl," | ||
34 | PACKAGECONFIG[scep] = "--enable-scepclient,--disable-scepclient," | ||
35 | PACKAGECONFIG[soup] = "--enable-soup,--disable-soup,libsoup-2.4," | ||
36 | PACKAGECONFIG[sqlite3] = "--enable-sqlite,--disable-sqlite,sqlite3," | ||
37 | PACKAGECONFIG[stroke] = "--enable-stroke,--disable-stroke," | ||
38 | PACKAGECONFIG[swanctl] = "--enable-swanctl,--disable-swanctl,,libgcc" | ||
39 | |||
40 | # requires swanctl | ||
41 | PACKAGECONFIG[systemd-charon] = "--enable-systemd,--disable-systemd,systemd," | ||
32 | 42 | ||
33 | inherit autotools systemd pkgconfig | 43 | inherit autotools systemd pkgconfig |
34 | 44 | ||
@@ -42,4 +52,4 @@ FILES_${PN}-staticdev += "${libdir}/ipsec/*.a ${libdir}/ipsec/plugins/*.a" | |||
42 | RPROVIDES_${PN} += "${PN}-systemd" | 52 | RPROVIDES_${PN} += "${PN}-systemd" |
43 | RREPLACES_${PN} += "${PN}-systemd" | 53 | RREPLACES_${PN} += "${PN}-systemd" |
44 | RCONFLICTS_${PN} += "${PN}-systemd" | 54 | RCONFLICTS_${PN} += "${PN}-systemd" |
45 | SYSTEMD_SERVICE_${PN} = "${BPN}.service" | 55 | SYSTEMD_SERVICE_${PN} = "${@bb.utils.contains('PACKAGECONFIG', 'swanctl', '${BPN}-swanctl.service', '${BPN}.service', d)}" |