summaryrefslogtreecommitdiffstats
path: root/meta-networking
diff options
context:
space:
mode:
authorKhem Raj <raj.khem@gmail.com>2022-02-15 14:31:39 -0800
committerKhem Raj <raj.khem@gmail.com>2022-02-16 08:26:02 -0800
commitcd6004014452a888e4f513ef42f8295f8fcac175 (patch)
tree80cb3abd7e75ed2f3d41b40dbb1fe04d2622fb3f /meta-networking
parent33efb90737135ba568600996addf4dceac193dca (diff)
downloadmeta-openembedded-cd6004014452a888e4f513ef42f8295f8fcac175.tar.gz
ntopng: Avoid linking libm statically
This fixes build on x86 Signed-off-by: Khem Raj <raj.khem@gmail.com>
Diffstat (limited to 'meta-networking')
-rw-r--r--meta-networking/recipes-support/ntopng/files/0001-configure.ac.in-Allow-dynamic-linking-against-ndpi-3.patch39
-rw-r--r--meta-networking/recipes-support/ntopng/ntopng_5.2.1.bb1
2 files changed, 40 insertions, 0 deletions
diff --git a/meta-networking/recipes-support/ntopng/files/0001-configure.ac.in-Allow-dynamic-linking-against-ndpi-3.patch b/meta-networking/recipes-support/ntopng/files/0001-configure.ac.in-Allow-dynamic-linking-against-ndpi-3.patch
new file mode 100644
index 000000000..c645110f2
--- /dev/null
+++ b/meta-networking/recipes-support/ntopng/files/0001-configure.ac.in-Allow-dynamic-linking-against-ndpi-3.patch
@@ -0,0 +1,39 @@
1From a913b85f720f41bf7e5819c0dc4acc252467a8a4 Mon Sep 17 00:00:00 2001
2From: Khem Raj <raj.khem@gmail.com>
3Date: Tue, 15 Feb 2022 14:25:07 -0800
4Subject: [PATCH] configure.ac.in: Allow dynamic linking against ndpi 3.0
5
6Linking statically is problematic since NDPI_LIBS is '-lndpi -lm'
7and when we use -Bstatic it also brings in -lm to use libm.a and on some
8architectures ( x86 ) which this does not work and results in missing symbols
9
10Fixes
11ipe-sysroot/usr/lib/libm.a(e_logf.o): in function `logf_ifunc_selector':
12/usr/src/debug/glibc/2.35-r0/git/math/../sysdeps/i386/i686/multiarch/ifunc-sse2.h:30: undefined reference to `_dl_x86_cpu_features'
13
14Upstream-Status: Submitted [https://github.com/ntop/ntopng/pull/6318]
15Signed-off-by: Khem Raj <raj.khem@gmail.com>
16---
17 configure.ac.in | 6 ++----
18 1 file changed, 2 insertions(+), 4 deletions(-)
19
20diff --git a/configure.ac.in b/configure.ac.in
21index 7f4c0f893..c3299fda2 100644
22--- a/configure.ac.in
23+++ b/configure.ac.in
24@@ -193,10 +193,8 @@ if test -d /usr/local/include/ndpi ; then :
25 fi
26
27 PKG_CHECK_MODULES([NDPI], [libndpi >= 2.0], [
28- NDPI_INC=`echo $NDPI_CFLAGS | sed -e "s/[ ]*$//"`
29- # Use static libndpi library as building against the dynamic library fails
30- NDPI_LIB="-Wl,-Bstatic $NDPI_LIBS -Wl,-Bdynamic"
31- #NDPI_LIB="$NDPI_LIBS"
32+ NDPI_INC="$NDPI_CFLAGS"
33+ NDPI_LIB="$NDPI_LIBS"
34 NDPI_LIB_DEP=
35 ], [
36 AC_MSG_CHECKING(for nDPI source)
37--
382.35.1
39
diff --git a/meta-networking/recipes-support/ntopng/ntopng_5.2.1.bb b/meta-networking/recipes-support/ntopng/ntopng_5.2.1.bb
index 63046e730..1c74845cc 100644
--- a/meta-networking/recipes-support/ntopng/ntopng_5.2.1.bb
+++ b/meta-networking/recipes-support/ntopng/ntopng_5.2.1.bb
@@ -18,6 +18,7 @@ SRC_URI = "git://github.com/ntop/ntopng.git;protocol=https;branch=5.2-stable \
18 file://0001-Makefile.in-don-t-use-the-internal-lua.patch \ 18 file://0001-Makefile.in-don-t-use-the-internal-lua.patch \
19 file://0001-autogen.sh-generate-configure.ac-only.patch \ 19 file://0001-autogen.sh-generate-configure.ac-only.patch \
20 file://0001-configure.ac.in-not-check-clang-on-host.patch \ 20 file://0001-configure.ac.in-not-check-clang-on-host.patch \
21 file://0001-configure.ac.in-Allow-dynamic-linking-against-ndpi-3.patch \
21 file://ntopng.service \ 22 file://ntopng.service \
22 " 23 "
23 24