diff options
author | Yi Zhao <yi.zhao@windriver.com> | 2021-06-08 14:02:01 +0800 |
---|---|---|
committer | Khem Raj <raj.khem@gmail.com> | 2021-06-09 08:49:20 -0700 |
commit | ca31e8057a181ad8e1a41ce98cacddc36e810f92 (patch) | |
tree | 1cf871ddaf51e5114de35fa860ab1f68dd8eeb3b /meta-networking | |
parent | cfb70a6bbcbcec18462c63fcc4b8d396f74384a8 (diff) | |
download | meta-openembedded-ca31e8057a181ad8e1a41ce98cacddc36e810f92.tar.gz |
dhcp-relay: update bundled bind to 9.11.32
Update the bundled bind from 9.11.14 to 9.11.32.
Fixes build error on qemuarmv5:
stats.c: In function 'setcounter':
stats.c:300:36: error: 'val' undeclared (first use in this function); did you mean 'value'?
300 | stats->counters[counter] = val;
| ^~~
| value
Signed-off-by: Yi Zhao <yi.zhao@windriver.com>
Signed-off-by: Khem Raj <raj.khem@gmail.com>
Diffstat (limited to 'meta-networking')
-rw-r--r-- | meta-networking/recipes-connectivity/dhcp/dhcp-relay_4.4.2.bb | 19 | ||||
-rw-r--r-- | meta-networking/recipes-connectivity/dhcp/files/0002-bind-version-update-to-latest-version.patch | 30 |
2 files changed, 43 insertions, 6 deletions
diff --git a/meta-networking/recipes-connectivity/dhcp/dhcp-relay_4.4.2.bb b/meta-networking/recipes-connectivity/dhcp/dhcp-relay_4.4.2.bb index b178180ec..671fbf054 100644 --- a/meta-networking/recipes-connectivity/dhcp/dhcp-relay_4.4.2.bb +++ b/meta-networking/recipes-connectivity/dhcp/dhcp-relay_4.4.2.bb | |||
@@ -11,14 +11,18 @@ LIC_FILES_CHKSUM = "file://LICENSE;beginline=4;md5=004a4db50a1e20972e924a8618747 | |||
11 | DEPENDS = "openssl libcap zlib" | 11 | DEPENDS = "openssl libcap zlib" |
12 | 12 | ||
13 | SRC_URI = "https://ftp.isc.org/isc/dhcp/${PV}/dhcp-${PV}.tar.gz \ | 13 | SRC_URI = "https://ftp.isc.org/isc/dhcp/${PV}/dhcp-${PV}.tar.gz \ |
14 | https://ftp.isc.org/isc/bind9/9.11.32/bind-9.11.32.tar.gz;name=bind;downloadfilename=bind.tar.gz;unpack=0 \ | ||
14 | file://default-relay \ | 15 | file://default-relay \ |
15 | file://init-relay \ | 16 | file://init-relay \ |
16 | file://dhcrelay.service \ | 17 | file://dhcrelay.service \ |
17 | file://0001-Makefile.am-only-build-dhcrelay.patch \ | 18 | file://0001-Makefile.am-only-build-dhcrelay.patch \ |
19 | file://0002-bind-version-update-to-latest-version.patch \ | ||
18 | " | 20 | " |
19 | 21 | ||
20 | SRC_URI[md5sum] = "2afdaf8498dc1edaf3012efdd589b3e1" | 22 | SRC_URI[md5sum] = "2afdaf8498dc1edaf3012efdd589b3e1" |
21 | SRC_URI[sha256sum] = "1a7ccd64a16e5e68f7b5e0f527fd07240a2892ea53fe245620f4f5f607004521" | 23 | SRC_URI[sha256sum] = "1a7ccd64a16e5e68f7b5e0f527fd07240a2892ea53fe245620f4f5f607004521" |
24 | SRC_URI[bind.md5sum] = "0d029dd06ca60c6739c3189c999ef757" | ||
25 | SRC_URI[bind.sha256sum] = "cbf8cb4b74dd1452d97c3a2a8c625ea346df8516b4b3508ef07443121a591342" | ||
22 | 26 | ||
23 | UPSTREAM_CHECK_URI = "http://ftp.isc.org/isc/dhcp/" | 27 | UPSTREAM_CHECK_URI = "http://ftp.isc.org/isc/dhcp/" |
24 | UPSTREAM_CHECK_REGEX = "(?P<pver>\d+\.\d+\.(\d+?))/" | 28 | UPSTREAM_CHECK_REGEX = "(?P<pver>\d+\.\d+\.(\d+?))/" |
@@ -43,15 +47,18 @@ EXTRA_OEMAKE += "LIBTOOL='${S}/${HOST_SYS}-libtool'" | |||
43 | # Enable shared libs per dhcp README | 47 | # Enable shared libs per dhcp README |
44 | do_configure_prepend () { | 48 | do_configure_prepend () { |
45 | cp configure.ac+lt configure.ac | 49 | cp configure.ac+lt configure.ac |
50 | rm ${S}/bind/bind.tar.gz | ||
51 | mv ${WORKDIR}/bind.tar.gz ${S}/bind/ | ||
46 | } | 52 | } |
53 | |||
47 | do_compile_prepend() { | 54 | do_compile_prepend() { |
48 | rm -rf ${S}/bind/bind-9.11.14/ | 55 | rm -rf ${S}/bind/bind-9.11.32/ |
49 | tar xf ${S}/bind/bind.tar.gz -C ${S}/bind | 56 | tar xf ${S}/bind/bind.tar.gz -C ${S}/bind |
50 | install -m 0755 ${STAGING_DATADIR_NATIVE}/gnu-config/config.guess ${S}/bind/bind-9.11.14/ | 57 | install -m 0755 ${STAGING_DATADIR_NATIVE}/gnu-config/config.guess ${S}/bind/bind-9.11.32/ |
51 | install -m 0755 ${STAGING_DATADIR_NATIVE}/gnu-config/config.sub ${S}/bind/bind-9.11.14/ | 58 | install -m 0755 ${STAGING_DATADIR_NATIVE}/gnu-config/config.sub ${S}/bind/bind-9.11.32/ |
52 | cp -fpR ${S}/m4/*.m4 ${S}/bind/bind-9.11.14/libtool.m4/ | 59 | cp -fpR ${S}/m4/*.m4 ${S}/bind/bind-9.11.32/libtool.m4/ |
53 | rm -rf ${S}/bind/bind-9.11.14/libtool | 60 | rm -rf ${S}/bind/bind-9.11.32/libtool |
54 | install -m 0755 ${S}/${HOST_SYS}-libtool ${S}/bind/bind-9.11.14/ | 61 | install -m 0755 ${S}/${HOST_SYS}-libtool ${S}/bind/bind-9.11.32/ |
55 | } | 62 | } |
56 | 63 | ||
57 | do_install_append () { | 64 | do_install_append () { |
diff --git a/meta-networking/recipes-connectivity/dhcp/files/0002-bind-version-update-to-latest-version.patch b/meta-networking/recipes-connectivity/dhcp/files/0002-bind-version-update-to-latest-version.patch new file mode 100644 index 000000000..5c7a5f058 --- /dev/null +++ b/meta-networking/recipes-connectivity/dhcp/files/0002-bind-version-update-to-latest-version.patch | |||
@@ -0,0 +1,30 @@ | |||
1 | From edb68972f8dc636e6208e78f02dec6f9805e4c0b Mon Sep 17 00:00:00 2001 | ||
2 | From: Yi Zhao <yi.zhao@windriver.com> | ||
3 | Date: Wed, 26 May 2021 11:39:00 +0800 | ||
4 | Subject: [PATCH] bind/version: update to latest version | ||
5 | |||
6 | Update the bundled bind from 9.11.14 to 9.11.32. | ||
7 | |||
8 | Upstream-Status: Inappropriate [embedded specific] | ||
9 | |||
10 | Signed-off-by: Yi Zhao <yi.zhao@windriver.com> | ||
11 | --- | ||
12 | bind/version.tmp | 2 +- | ||
13 | 1 file changed, 1 insertion(+), 1 deletion(-) | ||
14 | |||
15 | diff --git a/bind/version.tmp b/bind/version.tmp | ||
16 | index cf52f1b..4cc538e 100644 | ||
17 | --- a/bind/version.tmp | ||
18 | +++ b/bind/version.tmp | ||
19 | @@ -5,7 +5,7 @@ PRODUCT=BIND | ||
20 | DESCRIPTION="(Extended Support Version)" | ||
21 | MAJORVER=9 | ||
22 | MINORVER=11 | ||
23 | -PATCHVER=14 | ||
24 | +PATCHVER=32 | ||
25 | RELEASETYPE= | ||
26 | RELEASEVER= | ||
27 | EXTENSIONS= | ||
28 | -- | ||
29 | 2.17.1 | ||
30 | |||