diff options
author | leimaohui <leimaohui@fujitsu.com> | 2022-11-01 09:59:34 +0800 |
---|---|---|
committer | Khem Raj <raj.khem@gmail.com> | 2022-11-07 08:39:05 -0800 |
commit | be6245aefc7492db53b566c7f22e043828a2961c (patch) | |
tree | b7e7adfbd50c6a9cdb00352a225fb8413ff041d7 /meta-networking | |
parent | 47f58bda43a5142c857b4019ca6d0aca2547f1ce (diff) | |
download | meta-openembedded-be6245aefc7492db53b566c7f22e043828a2961c.tar.gz |
samba: Fix install conflict with multilib enabled.
Signed-off-by: Lei Maohui <leimaohui@fujitsu.com>
Signed-off-by: Khem Raj <raj.khem@gmail.com>
Diffstat (limited to 'meta-networking')
-rw-r--r-- | meta-networking/recipes-connectivity/samba/samba/0001-Deleted-settiong-of-python-to-fix-the-install-confli.patch | 122 | ||||
-rw-r--r-- | meta-networking/recipes-connectivity/samba/samba_4.14.14.bb | 1 |
2 files changed, 123 insertions, 0 deletions
diff --git a/meta-networking/recipes-connectivity/samba/samba/0001-Deleted-settiong-of-python-to-fix-the-install-confli.patch b/meta-networking/recipes-connectivity/samba/samba/0001-Deleted-settiong-of-python-to-fix-the-install-confli.patch new file mode 100644 index 000000000..6e4cdf12d --- /dev/null +++ b/meta-networking/recipes-connectivity/samba/samba/0001-Deleted-settiong-of-python-to-fix-the-install-confli.patch | |||
@@ -0,0 +1,122 @@ | |||
1 | From f8e1d71e702dfc6965ecb3109738b5d188af4267 Mon Sep 17 00:00:00 2001 | ||
2 | From: Lei Maohui <leimaohui@fujitsu.com> | ||
3 | Date: Sun, 30 Oct 2022 11:59:31 +0900 | ||
4 | Subject: [PATCH] Deleted settiong of python to fix the install conflict error | ||
5 | when enable multilib. | ||
6 | |||
7 | file /usr/bin/samba-tool conflicts between attempted installs of samba-4.14.14-r0.core2_64 and lib32-samba-4.14.14-r0.i686 | ||
8 | file /usr/sbin/samba-gpupdate conflicts between attempted installs of samba-4.14.14-r0.core2_64 and lib32-samba-4.14.14-r0.i686 | ||
9 | file /usr/sbin/samba_dnsupdate conflicts between attempted installs of samba-4.14.14-r0.core2_64 and lib32-samba-4.14.14-r0.i686 | ||
10 | file /usr/sbin/samba_downgrade_db conflicts between attempted installs of samba-4.14.14-r0.core2_64 and lib32-samba-4.14.14-r0.i686 | ||
11 | file /usr/sbin/samba_kcc conflicts between attempted installs of samba-4.14.14-r0.core2_64 and lib32-samba-4.14.14-r0.i686 | ||
12 | file /usr/sbin/samba_spnupdate conflicts between attempted installs of samba-4.14.14-r0.core2_64 and lib32-samba-4.14.14-r0.i686 | ||
13 | file /usr/sbin/samba_upgradedns conflicts between attempted installs of samba-4.14.14-r0.core2_64 and lib32-samba-4.14.14-r0.i686 | ||
14 | |||
15 | The conflict is because there is a difference between of lib32-samba-* and samba-* as the following: | ||
16 | 64bit: | ||
17 | sys.path.insert(0, "/usr/lib64/python3.10/site-packages") | ||
18 | |||
19 | 32bit: | ||
20 | sys.path.insert(0, "/usr/lib/python3.10/site-packages") | ||
21 | |||
22 | But this setting is for environment when running from source tree. There | ||
23 | is no necessary on target. | ||
24 | |||
25 | Upstream-Status: Inappropriate | ||
26 | Signed-off-by: Lei Maohui <leimaohui@fujitsu.com> | ||
27 | --- | ||
28 | source4/scripting/bin/samba-gpupdate | 1 - | ||
29 | source4/scripting/bin/samba-tool | 1 - | ||
30 | source4/scripting/bin/samba_dnsupdate | 1 - | ||
31 | source4/scripting/bin/samba_downgrade_db | 1 - | ||
32 | source4/scripting/bin/samba_kcc | 1 - | ||
33 | source4/scripting/bin/samba_spnupdate | 1 - | ||
34 | source4/scripting/bin/samba_upgradedns | 1 - | ||
35 | 7 files changed, 7 deletions(-) | ||
36 | |||
37 | diff --git a/source4/scripting/bin/samba-gpupdate b/source4/scripting/bin/samba-gpupdate | ||
38 | index 85300e1..02f40cd 100755 | ||
39 | --- a/source4/scripting/bin/samba-gpupdate | ||
40 | +++ b/source4/scripting/bin/samba-gpupdate | ||
41 | @@ -25,7 +25,6 @@ applied, have changed, or is in the right container''' | ||
42 | import os | ||
43 | import sys | ||
44 | |||
45 | -sys.path.insert(0, "bin/python") | ||
46 | |||
47 | import optparse | ||
48 | from samba import getopt as options | ||
49 | diff --git a/source4/scripting/bin/samba-tool b/source4/scripting/bin/samba-tool | ||
50 | index f8a70a6..3c818de 100755 | ||
51 | --- a/source4/scripting/bin/samba-tool | ||
52 | +++ b/source4/scripting/bin/samba-tool | ||
53 | @@ -22,7 +22,6 @@ | ||
54 | import sys | ||
55 | |||
56 | # Find right direction when running from source tree | ||
57 | -sys.path.insert(0, "bin/python") | ||
58 | |||
59 | # make sure the script dies immediately when hitting control-C, | ||
60 | # rather than raising KeyboardInterrupt. As we do all database | ||
61 | diff --git a/source4/scripting/bin/samba_dnsupdate b/source4/scripting/bin/samba_dnsupdate | ||
62 | index 518bb89..277f0ee 100755 | ||
63 | --- a/source4/scripting/bin/samba_dnsupdate | ||
64 | +++ b/source4/scripting/bin/samba_dnsupdate | ||
65 | @@ -36,7 +36,6 @@ os.environ['PYTHONUNBUFFERED'] = '1' | ||
66 | os.environ["TZ"] = "GMT" | ||
67 | |||
68 | # Find right directory when running from source tree | ||
69 | -sys.path.insert(0, "bin/python") | ||
70 | |||
71 | import samba | ||
72 | import optparse | ||
73 | diff --git a/source4/scripting/bin/samba_downgrade_db b/source4/scripting/bin/samba_downgrade_db | ||
74 | index 87a989b..93a7f8c 100755 | ||
75 | --- a/source4/scripting/bin/samba_downgrade_db | ||
76 | +++ b/source4/scripting/bin/samba_downgrade_db | ||
77 | @@ -24,7 +24,6 @@ import optparse | ||
78 | import sys | ||
79 | |||
80 | # Find right directory when running from source tree | ||
81 | -sys.path.insert(0, "bin/python") | ||
82 | |||
83 | |||
84 | import samba | ||
85 | diff --git a/source4/scripting/bin/samba_kcc b/source4/scripting/bin/samba_kcc | ||
86 | index 122a5ed..79165f3 100755 | ||
87 | --- a/source4/scripting/bin/samba_kcc | ||
88 | +++ b/source4/scripting/bin/samba_kcc | ||
89 | @@ -37,7 +37,6 @@ os.environ['PYTHONUNBUFFERED'] = '1' | ||
90 | os.environ["TZ"] = "GMT" | ||
91 | |||
92 | # Find right directory when running from source tree | ||
93 | -sys.path.insert(0, "bin/python") | ||
94 | |||
95 | import optparse | ||
96 | import time | ||
97 | diff --git a/source4/scripting/bin/samba_spnupdate b/source4/scripting/bin/samba_spnupdate | ||
98 | index 84ff771..b6fe041 100755 | ||
99 | --- a/source4/scripting/bin/samba_spnupdate | ||
100 | +++ b/source4/scripting/bin/samba_spnupdate | ||
101 | @@ -32,7 +32,6 @@ os.environ['PYTHONUNBUFFERED'] = '1' | ||
102 | os.environ["TZ"] = "GMT" | ||
103 | |||
104 | # Find right directory when running from source tree | ||
105 | -sys.path.insert(0, "bin/python") | ||
106 | |||
107 | import samba, ldb | ||
108 | import optparse | ||
109 | diff --git a/source4/scripting/bin/samba_upgradedns b/source4/scripting/bin/samba_upgradedns | ||
110 | index 308dbb0..d00244f 100755 | ||
111 | --- a/source4/scripting/bin/samba_upgradedns | ||
112 | +++ b/source4/scripting/bin/samba_upgradedns | ||
113 | @@ -27,7 +27,6 @@ import grp | ||
114 | from base64 import b64encode | ||
115 | import shlex | ||
116 | |||
117 | -sys.path.insert(0, "bin/python") | ||
118 | |||
119 | import ldb | ||
120 | import samba | ||
121 | -- | ||
122 | 2.25.1 | ||
diff --git a/meta-networking/recipes-connectivity/samba/samba_4.14.14.bb b/meta-networking/recipes-connectivity/samba/samba_4.14.14.bb index f88dee617..9d7259e96 100644 --- a/meta-networking/recipes-connectivity/samba/samba_4.14.14.bb +++ b/meta-networking/recipes-connectivity/samba/samba_4.14.14.bb | |||
@@ -23,6 +23,7 @@ SRC_URI = "${SAMBA_MIRROR}/stable/samba-${PV}.tar.gz \ | |||
23 | file://0001-Fix-pyext_PATTERN-for-cross-compilation.patch \ | 23 | file://0001-Fix-pyext_PATTERN-for-cross-compilation.patch \ |
24 | file://0001-smbtorture-skip-test-case-tfork_cmd_send.patch \ | 24 | file://0001-smbtorture-skip-test-case-tfork_cmd_send.patch \ |
25 | file://0001-waf-Fix-errors-with-Werror-implicit-function-declara.patch \ | 25 | file://0001-waf-Fix-errors-with-Werror-implicit-function-declara.patch \ |
26 | file://0001-Deleted-settiong-of-python-to-fix-the-install-confli.patch \ | ||
26 | " | 27 | " |
27 | 28 | ||
28 | SRC_URI:append:libc-musl = " \ | 29 | SRC_URI:append:libc-musl = " \ |