summaryrefslogtreecommitdiffstats
path: root/meta-networking
diff options
context:
space:
mode:
authorPetr Gotthard <petr.gotthard@advantech.cz>2023-05-13 13:17:01 +0000
committerKhem Raj <raj.khem@gmail.com>2023-05-13 13:12:15 -0700
commitb491d4b9832d29f20834bd85173ad21e700da4cf (patch)
tree137d26b33b5411b84dc77d9d56c77f31d1dd01cc /meta-networking
parent3798534696cd56db8e041ae11858d224397c9cd9 (diff)
downloadmeta-openembedded-b491d4b9832d29f20834bd85173ad21e700da4cf.tar.gz
openfortivpn: add new recipe
A client for PPP+SSL VPN tunnel services, compatible with Fortinet VPNs. https://github.com/adrienverge/openfortivpn Signed-off-by: Petr Gotthard <petr.gotthard@advantech.cz> Signed-off-by: Khem Raj <raj.khem@gmail.com>
Diffstat (limited to 'meta-networking')
-rw-r--r--meta-networking/recipes-connectivity/openfortivpn/openfortivpn_1.20.3.bb26
1 files changed, 26 insertions, 0 deletions
diff --git a/meta-networking/recipes-connectivity/openfortivpn/openfortivpn_1.20.3.bb b/meta-networking/recipes-connectivity/openfortivpn/openfortivpn_1.20.3.bb
new file mode 100644
index 000000000..bfd51f7f7
--- /dev/null
+++ b/meta-networking/recipes-connectivity/openfortivpn/openfortivpn_1.20.3.bb
@@ -0,0 +1,26 @@
1SUMMARY = "Client for PPP+SSL VPN tunnel services"
2LICENSE = "GPL-3.0-or-later"
3LIC_FILES_CHKSUM = "file://LICENSE;md5=3d575262a651a6f1a17210ce41bf907d"
4
5SRC_URI = "git://github.com/adrienverge/openfortivpn.git;protocol=https;branch=master"
6SRCREV = "45cb8e0f9984f1d54b648e499bda637d96568908"
7
8DEPENDS = "openssl"
9
10PACKAGECONFIG ??= "${@bb.utils.filter('DISTRO_FEATURES', 'systemd', d)}"
11
12PACKAGECONFIG[resolvconf] = "--with-resolvconf=${base_sbindir}/resolvconf --enable-resolvconf,--with-resolvconf=DISABLED,,"
13PACKAGECONFIG[systemd] = "--with-systemdsystemunitdir=${systemd_system_unitdir},--without-systemdsystemunitdir,,"
14
15S = "${WORKDIR}/git"
16
17inherit autotools pkgconfig systemd
18
19EXTRA_OECONF = " \
20 --with-pppd=${sbindir}/pppd \
21 --disable-proc \
22"
23
24SYSTEMD_SERVICE:${PN} = "openfortivpn@.service"
25
26RDEPENDS:${PN} = "ppp"