diff options
author | Yi Zhao <yi.zhao@windriver.com> | 2019-04-18 09:35:29 +0800 |
---|---|---|
committer | Khem Raj <raj.khem@gmail.com> | 2019-04-18 11:22:32 -0700 |
commit | a48732d3ab1c553be1439a2464dd1ff778086a0a (patch) | |
tree | 61532d1f8dea97bfdb301c821f9c64894e1255f8 /meta-networking | |
parent | 02d6caa20815877004b383ce72a4ff3234b20593 (diff) | |
download | meta-openembedded-a48732d3ab1c553be1439a2464dd1ff778086a0a.tar.gz |
openhpi: fix failure of ptest case ohpi_035
Install missing openhpi.conf to ptest directory to fix failure of ptest
case ohpi_035:
(process:3559): openhpid-CRITICAL **: 08:41:04.036:
../../openhpi-3.8.0/openhpid/conf.c:623: Configuration file
'../../../../openhpi-3.8.0/openhpid/t/ohpi/openhpi.conf' could not be
opened.
FAIL: ohpi_035
Also chage the configure files mode from 755 to 644.
Signed-off-by: Yi Zhao <yi.zhao@windriver.com>
Signed-off-by: Khem Raj <raj.khem@gmail.com>
Diffstat (limited to 'meta-networking')
-rw-r--r-- | meta-networking/recipes-daemons/openhpi/openhpi_3.8.0.bb | 11 |
1 files changed, 7 insertions, 4 deletions
diff --git a/meta-networking/recipes-daemons/openhpi/openhpi_3.8.0.bb b/meta-networking/recipes-daemons/openhpi/openhpi_3.8.0.bb index ca9130db1..14cc3d879 100644 --- a/meta-networking/recipes-daemons/openhpi/openhpi_3.8.0.bb +++ b/meta-networking/recipes-daemons/openhpi/openhpi_3.8.0.bb | |||
@@ -70,10 +70,10 @@ export DISTRO | |||
70 | 70 | ||
71 | do_install_append () { | 71 | do_install_append () { |
72 | install -m 0755 -d ${D}${sysconfdir}/${BPN} | 72 | install -m 0755 -d ${D}${sysconfdir}/${BPN} |
73 | install -m 0755 ${S}/openhpiclient.conf.example ${D}${sysconfdir}/${BPN}/openhpiclient.conf | 73 | install -m 0644 ${S}/openhpiclient.conf.example ${D}${sysconfdir}/${BPN}/openhpiclient.conf |
74 | install -m 0700 ${S}/openhpi.conf.example ${D}${sysconfdir}/${BPN}/openhpi.conf | 74 | install -m 0600 ${S}/openhpi.conf.example ${D}${sysconfdir}/${BPN}/openhpi.conf |
75 | install -m 0755 ${S}/simulation.data.example ${D}${sysconfdir}/${BPN}/simulation.data | 75 | install -m 0644 ${S}/simulation.data.example ${D}${sysconfdir}/${BPN}/simulation.data |
76 | install -m 0755 ${S}/test_agent.data.example ${D}${sysconfdir}/${BPN}/test_agent.data | 76 | install -m 0644 ${S}/test_agent.data.example ${D}${sysconfdir}/${BPN}/test_agent.data |
77 | install -m 0755 ${WORKDIR}/openhpi.init ${D}${sysconfdir}/init.d/openhpid | 77 | install -m 0755 ${WORKDIR}/openhpi.init ${D}${sysconfdir}/init.d/openhpid |
78 | 78 | ||
79 | install -d ${D}${systemd_unitdir}/system | 79 | install -d ${D}${systemd_unitdir}/system |
@@ -105,6 +105,9 @@ do_install_ptest () { | |||
105 | sed -i "s/^Makefile:/MM:/g" ${x}; | 105 | sed -i "s/^Makefile:/MM:/g" ${x}; |
106 | done; | 106 | done; |
107 | 107 | ||
108 | install -m 644 ${S}/openhpid/t/ohpi/openhpi.conf ${D}${PTEST_PATH}/openhpid/t/ohpi/ | ||
109 | sed -i "s:OPENHPI_CONF=[^ ]*:OPENHPI_CONF=./openhpi.conf:g" ${D}${PTEST_PATH}/openhpid/t/ohpi/Makefile | ||
110 | |||
108 | mkdir -p ${D}${PTEST_PATH}/plugins/watchdog/ | 111 | mkdir -p ${D}${PTEST_PATH}/plugins/watchdog/ |
109 | cp -L ${D}/${libdir}/${BPN}/libwatchdog.so ${D}${PTEST_PATH}/plugins/watchdog/ | 112 | cp -L ${D}/${libdir}/${BPN}/libwatchdog.so ${D}${PTEST_PATH}/plugins/watchdog/ |
110 | cp -L ${D}/${libdir}/${BPN}/libsimulator.so ${D}${PTEST_PATH}/plugins/watchdog/ | 113 | cp -L ${D}/${libdir}/${BPN}/libsimulator.so ${D}${PTEST_PATH}/plugins/watchdog/ |