diff options
author | Yi Zhao <yi.zhao@windriver.com> | 2023-01-01 15:27:38 +0800 |
---|---|---|
committer | Khem Raj <raj.khem@gmail.com> | 2023-01-01 02:23:29 -0800 |
commit | 9db903d8d3adca27dfd7084f6bff41f5685457a0 (patch) | |
tree | b921510e8d70c5a8351a1bf1987a77dcb7d4f7d7 /meta-networking | |
parent | cf53340f000b770faba44560e81a3d1e15138805 (diff) | |
download | meta-openembedded-9db903d8d3adca27dfd7084f6bff41f5685457a0.tar.gz |
libldb: upgrade 2.3.4 -> 2.6.1
* Refresh patches
* Add a patch to skip checking PYTHONHASHSEED
Signed-off-by: Yi Zhao <yi.zhao@windriver.com>
Signed-off-by: Khem Raj <raj.khem@gmail.com>
Diffstat (limited to 'meta-networking')
7 files changed, 68 insertions, 35 deletions
diff --git a/meta-networking/recipes-support/libldb/libldb/0001-do-not-import-target-module-while-cross-compile.patch b/meta-networking/recipes-support/libldb/libldb/0001-do-not-import-target-module-while-cross-compile.patch index 74f8d8ad0..e21524237 100644 --- a/meta-networking/recipes-support/libldb/libldb/0001-do-not-import-target-module-while-cross-compile.patch +++ b/meta-networking/recipes-support/libldb/libldb/0001-do-not-import-target-module-while-cross-compile.patch | |||
@@ -1,4 +1,4 @@ | |||
1 | From 00500909ebb0f51dd3b4e90c665f07158e7fe255 Mon Sep 17 00:00:00 2001 | 1 | From 69c409195ede704ed7e9298ed4942cc70a52e099 Mon Sep 17 00:00:00 2001 |
2 | From: Changqing Li <changqing.li@windriver.com> | 2 | From: Changqing Li <changqing.li@windriver.com> |
3 | Date: Tue, 25 Jun 2019 14:25:08 +0800 | 3 | Date: Tue, 25 Jun 2019 14:25:08 +0800 |
4 | Subject: [PATCH] do not import target module while cross compile | 4 | Subject: [PATCH] do not import target module while cross compile |
@@ -19,7 +19,7 @@ Signed-off-by: Yi Zhao <yi.zhao@windriver.com> | |||
19 | 1 file changed, 19 insertions(+), 8 deletions(-) | 19 | 1 file changed, 19 insertions(+), 8 deletions(-) |
20 | 20 | ||
21 | diff --git a/buildtools/wafsamba/samba_bundled.py b/buildtools/wafsamba/samba_bundled.py | 21 | diff --git a/buildtools/wafsamba/samba_bundled.py b/buildtools/wafsamba/samba_bundled.py |
22 | index 5f080dd..cdc115e 100644 | 22 | index 7d2d855..01dcb56 100644 |
23 | --- a/buildtools/wafsamba/samba_bundled.py | 23 | --- a/buildtools/wafsamba/samba_bundled.py |
24 | +++ b/buildtools/wafsamba/samba_bundled.py | 24 | +++ b/buildtools/wafsamba/samba_bundled.py |
25 | @@ -4,6 +4,7 @@ import sys | 25 | @@ -4,6 +4,7 @@ import sys |
@@ -28,9 +28,9 @@ index 5f080dd..cdc115e 100644 | |||
28 | from wafsamba import samba_utils | 28 | from wafsamba import samba_utils |
29 | +import importlib.util, os | 29 | +import importlib.util, os |
30 | 30 | ||
31 | def PRIVATE_NAME(bld, name, private_extension, private_library): | 31 | def PRIVATE_NAME(bld, name): |
32 | '''possibly rename a library to include a bundled extension''' | 32 | '''possibly rename a library to include a bundled extension''' |
33 | @@ -249,17 +250,27 @@ def CHECK_BUNDLED_SYSTEM_PYTHON(conf, libname, modulename, minversion='0.0.0'): | 33 | @@ -241,17 +242,27 @@ def CHECK_BUNDLED_SYSTEM_PYTHON(conf, libname, modulename, minversion='0.0.0'): |
34 | # versions | 34 | # versions |
35 | minversion = minimum_library_version(conf, libname, minversion) | 35 | minversion = minimum_library_version(conf, libname, minversion) |
36 | 36 | ||
@@ -67,5 +67,5 @@ index 5f080dd..cdc115e 100644 | |||
67 | Logs.error('ERROR: Python module %s of version %s not found, and bundling disabled' % (libname, minversion)) | 67 | Logs.error('ERROR: Python module %s of version %s not found, and bundling disabled' % (libname, minversion)) |
68 | sys.exit(1) | 68 | sys.exit(1) |
69 | -- | 69 | -- |
70 | 2.17.1 | 70 | 2.25.1 |
71 | 71 | ||
diff --git a/meta-networking/recipes-support/libldb/libldb/0002-ldb-Add-configure-options-for-packages.patch b/meta-networking/recipes-support/libldb/libldb/0002-ldb-Add-configure-options-for-packages.patch index a55d46bf7..988931c49 100644 --- a/meta-networking/recipes-support/libldb/libldb/0002-ldb-Add-configure-options-for-packages.patch +++ b/meta-networking/recipes-support/libldb/libldb/0002-ldb-Add-configure-options-for-packages.patch | |||
@@ -1,4 +1,4 @@ | |||
1 | From 100d16aaa6fe9a28a5ba77b2de2bde81a3fa3dac Mon Sep 17 00:00:00 2001 | 1 | From b4e04e5dd13c9de8b336f7d0c254973a225e3b5f Mon Sep 17 00:00:00 2001 |
2 | From: Changqing Li <changqing.li@windriver.com> | 2 | From: Changqing Li <changqing.li@windriver.com> |
3 | Date: Mon, 1 Jul 2019 16:14:16 +0800 | 3 | Date: Mon, 1 Jul 2019 16:14:16 +0800 |
4 | Subject: [PATCH] ldb: Add configure options for packages | 4 | Subject: [PATCH] ldb: Add configure options for packages |
@@ -26,7 +26,7 @@ Signed-off-by: Yi Zhao <yi.zhao@windriver.com> | |||
26 | 2 files changed, 78 insertions(+), 20 deletions(-) | 26 | 2 files changed, 78 insertions(+), 20 deletions(-) |
27 | 27 | ||
28 | diff --git a/lib/replace/wscript b/lib/replace/wscript | 28 | diff --git a/lib/replace/wscript b/lib/replace/wscript |
29 | index 2c856b6..36b696d 100644 | 29 | index 4c774d9..63c9967 100644 |
30 | --- a/lib/replace/wscript | 30 | --- a/lib/replace/wscript |
31 | +++ b/lib/replace/wscript | 31 | +++ b/lib/replace/wscript |
32 | @@ -25,6 +25,41 @@ def options(opt): | 32 | @@ -25,6 +25,41 @@ def options(opt): |
@@ -101,7 +101,7 @@ index 2c856b6..36b696d 100644 | |||
101 | conf.CHECK_HEADERS('port.h') | 101 | conf.CHECK_HEADERS('port.h') |
102 | conf.CHECK_HEADERS('sys/fcntl.h sys/filio.h sys/filsys.h sys/fs/s5param.h') | 102 | conf.CHECK_HEADERS('sys/fcntl.h sys/filio.h sys/filsys.h sys/fs/s5param.h') |
103 | conf.CHECK_HEADERS('sys/id.h sys/ioctl.h sys/ipc.h sys/mman.h sys/mode.h sys/ndir.h sys/priv.h') | 103 | conf.CHECK_HEADERS('sys/id.h sys/ioctl.h sys/ipc.h sys/mman.h sys/mode.h sys/ndir.h sys/priv.h') |
104 | @@ -121,8 +169,9 @@ def configure(conf): | 104 | @@ -110,8 +158,9 @@ def configure(conf): |
105 | conf.CHECK_HEADERS('sys/fileio.h sys/filesys.h sys/dustat.h sys/sysmacros.h') | 105 | conf.CHECK_HEADERS('sys/fileio.h sys/filesys.h sys/dustat.h sys/sysmacros.h') |
106 | conf.CHECK_HEADERS('xfs/libxfs.h netgroup.h') | 106 | conf.CHECK_HEADERS('xfs/libxfs.h netgroup.h') |
107 | 107 | ||
@@ -113,7 +113,7 @@ index 2c856b6..36b696d 100644 | |||
113 | conf.CHECK_HEADERS('nss_common.h nsswitch.h ns_api.h') | 113 | conf.CHECK_HEADERS('nss_common.h nsswitch.h ns_api.h') |
114 | conf.CHECK_HEADERS('sys/extattr.h sys/ea.h sys/proplist.h sys/cdefs.h') | 114 | conf.CHECK_HEADERS('sys/extattr.h sys/ea.h sys/proplist.h sys/cdefs.h') |
115 | conf.CHECK_HEADERS('utmp.h utmpx.h lastlog.h') | 115 | conf.CHECK_HEADERS('utmp.h utmpx.h lastlog.h') |
116 | @@ -418,20 +467,21 @@ def configure(conf): | 116 | @@ -434,20 +483,21 @@ def configure(conf): |
117 | 117 | ||
118 | strlcpy_in_bsd = False | 118 | strlcpy_in_bsd = False |
119 | 119 | ||
@@ -150,10 +150,10 @@ index 2c856b6..36b696d 100644 | |||
150 | conf.CHECK_CODE(''' | 150 | conf.CHECK_CODE(''' |
151 | struct ucred cred; | 151 | struct ucred cred; |
152 | diff --git a/wscript b/wscript | 152 | diff --git a/wscript b/wscript |
153 | index bf6129b..722fdf6 100644 | 153 | index 60bb7cf..7f14847 100644 |
154 | --- a/wscript | 154 | --- a/wscript |
155 | +++ b/wscript | 155 | +++ b/wscript |
156 | @@ -39,6 +39,14 @@ def options(opt): | 156 | @@ -40,6 +40,14 @@ def options(opt): |
157 | help='disable new LMDB backend for LDB', | 157 | help='disable new LMDB backend for LDB', |
158 | action='store_true', dest='without_ldb_lmdb', default=False) | 158 | action='store_true', dest='without_ldb_lmdb', default=False) |
159 | 159 | ||
@@ -169,5 +169,5 @@ index bf6129b..722fdf6 100644 | |||
169 | def configure(conf): | 169 | def configure(conf): |
170 | conf.RECURSE('lib/tdb') | 170 | conf.RECURSE('lib/tdb') |
171 | -- | 171 | -- |
172 | 2.17.1 | 172 | 2.25.1 |
173 | 173 | ||
diff --git a/meta-networking/recipes-support/libldb/libldb/0001-Fix-pyext_PATTERN-for-cross-compilation.patch b/meta-networking/recipes-support/libldb/libldb/0003-Fix-pyext_PATTERN-for-cross-compilation.patch index 382a19ced..acd521e69 100644 --- a/meta-networking/recipes-support/libldb/libldb/0001-Fix-pyext_PATTERN-for-cross-compilation.patch +++ b/meta-networking/recipes-support/libldb/libldb/0003-Fix-pyext_PATTERN-for-cross-compilation.patch | |||
@@ -1,4 +1,4 @@ | |||
1 | From c67c7cee024150fcbdca18764a026aed8724d7ae Mon Sep 17 00:00:00 2001 | 1 | From d9f4d5bbd3e58ca7fd7cbc4ab7656fe27bf4c346 Mon Sep 17 00:00:00 2001 |
2 | From: Yi Zhao <yi.zhao@windriver.com> | 2 | From: Yi Zhao <yi.zhao@windriver.com> |
3 | Date: Wed, 24 Nov 2021 13:33:35 +0800 | 3 | Date: Wed, 24 Nov 2021 13:33:35 +0800 |
4 | Subject: [PATCH] Fix pyext_PATTERN for cross compilation | 4 | Subject: [PATCH] Fix pyext_PATTERN for cross compilation |
@@ -42,18 +42,18 @@ Signed-off-by: Yi Zhao <yi.zhao@windriver.com> | |||
42 | 1 file changed, 1 insertion(+), 1 deletion(-) | 42 | 1 file changed, 1 insertion(+), 1 deletion(-) |
43 | 43 | ||
44 | diff --git a/third_party/waf/waflib/Tools/python.py b/third_party/waf/waflib/Tools/python.py | 44 | diff --git a/third_party/waf/waflib/Tools/python.py b/third_party/waf/waflib/Tools/python.py |
45 | index b1c8dd0..24faa31 100644 | 45 | index a23bd01..af202e0 100644 |
46 | --- a/third_party/waf/waflib/Tools/python.py | 46 | --- a/third_party/waf/waflib/Tools/python.py |
47 | +++ b/third_party/waf/waflib/Tools/python.py | 47 | +++ b/third_party/waf/waflib/Tools/python.py |
48 | @@ -328,7 +328,7 @@ def check_python_headers(conf, features='pyembed pyext'): | 48 | @@ -328,7 +328,7 @@ def check_python_headers(conf, features='pyembed pyext'): |
49 | x = 'MACOSX_DEPLOYMENT_TARGET' | 49 | x = 'MACOSX_DEPLOYMENT_TARGET' |
50 | if dct[x]: | 50 | if dct[x]: |
51 | env[x] = conf.environ[x] = dct[x] | 51 | env[x] = conf.environ[x] = str(dct[x]) |
52 | - env.pyext_PATTERN = '%s' + dct['SO'] # not a mistake | 52 | - env.pyext_PATTERN = '%s' + (dct['EXT_SUFFIX'] or dct['SO']) # SO is deprecated in 3.5 and removed in 3.11 |
53 | + env.pyext_PATTERN = '%s.so' | 53 | + env.pyext_PATTERN = '%s.so' |
54 | 54 | ||
55 | 55 | ||
56 | # Try to get pythonX.Y-config | 56 | # Try to get pythonX.Y-config |
57 | -- | 57 | -- |
58 | 2.17.1 | 58 | 2.25.1 |
59 | 59 | ||
diff --git a/meta-networking/recipes-support/libldb/libldb/0004-wscript-skip-checking-PYTHONHASHSEED.patch b/meta-networking/recipes-support/libldb/libldb/0004-wscript-skip-checking-PYTHONHASHSEED.patch new file mode 100644 index 000000000..8747175d2 --- /dev/null +++ b/meta-networking/recipes-support/libldb/libldb/0004-wscript-skip-checking-PYTHONHASHSEED.patch | |||
@@ -0,0 +1,30 @@ | |||
1 | From 6e403b3bac2edadb67776434da54ac2fc2e8de04 Mon Sep 17 00:00:00 2001 | ||
2 | From: Yi Zhao <yi.zhao@windriver.com> | ||
3 | Date: Wed, 28 Dec 2022 16:31:05 +0800 | ||
4 | Subject: [PATCH] wscript: skip checking PYTHONHASHSEED | ||
5 | |||
6 | Skip checking PYTHONHASHSEED as it is set to 0 in oe-core by default. | ||
7 | |||
8 | Signed-off-by: Yi Zhao <yi.zhao@windriver.com> | ||
9 | --- | ||
10 | buildtools/wafsamba/wscript | 4 ---- | ||
11 | 1 file changed, 4 deletions(-) | ||
12 | |||
13 | diff --git a/buildtools/wafsamba/wscript b/buildtools/wafsamba/wscript | ||
14 | index 8729b08..a4d6f3e 100644 | ||
15 | --- a/buildtools/wafsamba/wscript | ||
16 | +++ b/buildtools/wafsamba/wscript | ||
17 | @@ -8,10 +8,6 @@ import wafsamba | ||
18 | from samba_utils import symlink | ||
19 | from optparse import SUPPRESS_HELP | ||
20 | |||
21 | -phs = os.environ.get("PYTHONHASHSEED", None) | ||
22 | -if phs != "1": | ||
23 | - raise Errors.WafError('''PYTHONHASHSEED=1 missing! Don't use waf directly, use ./configure and make!''') | ||
24 | - | ||
25 | # this forces configure to be re-run if any of the configure | ||
26 | # sections of the build scripts change. We have to check | ||
27 | # for this in sys.argv as options have not yet been parsed when | ||
28 | -- | ||
29 | 2.25.1 | ||
30 | |||
diff --git a/meta-networking/recipes-support/libldb/libldb/0003-avoid-openldap-unless-wanted.patch b/meta-networking/recipes-support/libldb/libldb/avoid-openldap-unless-wanted.patch index dd1246538..87909c952 100644 --- a/meta-networking/recipes-support/libldb/libldb/0003-avoid-openldap-unless-wanted.patch +++ b/meta-networking/recipes-support/libldb/libldb/avoid-openldap-unless-wanted.patch | |||
@@ -1,20 +1,21 @@ | |||
1 | From 1f24231095a59debcf25d0e3309dc5d1056a7fad Mon Sep 17 00:00:00 2001 | 1 | From cc86b8bdd45ca30bdf65a3b8b0960b27aeb34522 Mon Sep 17 00:00:00 2001 |
2 | From: Jens Rehsack <rehsack@gmail.com> | 2 | From: Jens Rehsack <rehsack@gmail.com> |
3 | Date: Thu, 19 Nov 2015 20:45:56 +0100 | 3 | Date: Thu, 19 Nov 2015 20:45:56 +0100 |
4 | Subject: [PATCH] avoid openldap unless wanted | 4 | Subject: [PATCH] avoid openldap unless wanted |
5 | 5 | ||
6 | Upstream-Status: Inappropriate [embedded specific] | 6 | Upstream-Status: Inappropriate [embedded specific] |
7 | 7 | ||
8 | Signed-off-by: Jens Rehsack <rehsack@gmail.com> | ||
8 | Signed-off-by: Yi Zhao <yi.zhao@windriver.com> | 9 | Signed-off-by: Yi Zhao <yi.zhao@windriver.com> |
9 | --- | 10 | --- |
10 | wscript | 4 +--- | 11 | wscript | 4 +--- |
11 | 1 file changed, 1 insertion(+), 3 deletions(-) | 12 | 1 file changed, 1 insertion(+), 3 deletions(-) |
12 | 13 | ||
13 | diff --git a/wscript b/wscript | 14 | diff --git a/wscript b/wscript |
14 | index 722fdf6..22700d5 100644 | 15 | index 7f14847..092da2d 100644 |
15 | --- a/wscript | 16 | --- a/wscript |
16 | +++ b/wscript | 17 | +++ b/wscript |
17 | @@ -153,9 +153,7 @@ def configure(conf): | 18 | @@ -154,9 +154,7 @@ def configure(conf): |
18 | if conf.env.standalone_ldb: | 19 | if conf.env.standalone_ldb: |
19 | conf.CHECK_XSLTPROC_MANPAGES() | 20 | conf.CHECK_XSLTPROC_MANPAGES() |
20 | 21 | ||
@@ -26,5 +27,5 @@ index 722fdf6..22700d5 100644 | |||
26 | # we don't want any libraries or modules to rely on runtime | 27 | # we don't want any libraries or modules to rely on runtime |
27 | # resolution of symbols | 28 | # resolution of symbols |
28 | -- | 29 | -- |
29 | 2.17.1 | 30 | 2.25.1 |
30 | 31 | ||
diff --git a/meta-networking/recipes-support/libldb/libldb/libldb-fix-musl-libc-conflict-type-error.patch b/meta-networking/recipes-support/libldb/libldb/cmocka-fix-musl-libc-conflicting-types-error.patch index 444fa3ff1..8e756d8d3 100644 --- a/meta-networking/recipes-support/libldb/libldb/libldb-fix-musl-libc-conflict-type-error.patch +++ b/meta-networking/recipes-support/libldb/libldb/cmocka-fix-musl-libc-conflicting-types-error.patch | |||
@@ -1,7 +1,7 @@ | |||
1 | From 5bd7b5d04435bd593349825973ce32290f5f604d Mon Sep 17 00:00:00 2001 | 1 | From a37eb0a46669592e32ed4e004abb2698ee4f90c5 Mon Sep 17 00:00:00 2001 |
2 | From: Changqing Li <changqing.li@windriver.com> | 2 | From: Changqing Li <changqing.li@windriver.com> |
3 | Date: Wed, 25 Jul 2018 09:55:25 +0800 | 3 | Date: Wed, 25 Jul 2018 09:55:25 +0800 |
4 | Subject: [PATCH] libldb: fix musl libc conflicting types error | 4 | Subject: [PATCH] cmocka: fix musl libc conflicting types error |
5 | 5 | ||
6 | /third_party/cmocka/cmocka.h:126:28: error: conflicting types for 'uintptr_t' | 6 | /third_party/cmocka/cmocka.h:126:28: error: conflicting types for 'uintptr_t' |
7 | typedef unsigned int uintptr_t; | 7 | typedef unsigned int uintptr_t; |
@@ -16,19 +16,19 @@ Signed-off-by: Changqing Li <changqing.li@windriver.com> | |||
16 | 1 file changed, 3 insertions(+), 4 deletions(-) | 16 | 1 file changed, 3 insertions(+), 4 deletions(-) |
17 | 17 | ||
18 | diff --git a/third_party/cmocka/cmocka.h b/third_party/cmocka/cmocka.h | 18 | diff --git a/third_party/cmocka/cmocka.h b/third_party/cmocka/cmocka.h |
19 | index 4fd82a9..5443a08 100644 | 19 | index e6861c8..238201d 100644 |
20 | --- a/third_party/cmocka/cmocka.h | 20 | --- a/third_party/cmocka/cmocka.h |
21 | +++ b/third_party/cmocka/cmocka.h | 21 | +++ b/third_party/cmocka/cmocka.h |
22 | @@ -110,7 +110,7 @@ typedef uintmax_t LargestIntegralType; | 22 | @@ -111,7 +111,7 @@ typedef uintmax_t LargestIntegralType; |
23 | ((LargestIntegralType)(value)) | 23 | ((LargestIntegralType)(value)) |
24 | 24 | ||
25 | /* Smallest integral type capable of holding a pointer. */ | 25 | /* Smallest integral type capable of holding a pointer. */ |
26 | -#if !defined(_UINTPTR_T) && !defined(_UINTPTR_T_DEFINED) | 26 | -#if !defined(_UINTPTR_T) && !defined(_UINTPTR_T_DEFINED) |
27 | +#if !defined(__DEFINED_uintptr_t) | 27 | +#if !defined(__DEFINED_uintptr_t) |
28 | # if defined(_WIN32) | 28 | # if defined(_WIN32) |
29 | /* WIN32 is an ILP32 platform */ | 29 | /* WIN32 is an ILP32 platform */ |
30 | typedef unsigned int uintptr_t; | 30 | typedef unsigned int uintptr_t; |
31 | @@ -134,9 +134,8 @@ typedef uintmax_t LargestIntegralType; | 31 | @@ -135,9 +135,8 @@ typedef uintmax_t LargestIntegralType; |
32 | # endif /* __WORDSIZE */ | 32 | # endif /* __WORDSIZE */ |
33 | # endif /* _WIN32 */ | 33 | # endif /* _WIN32 */ |
34 | 34 | ||
@@ -36,10 +36,10 @@ index 4fd82a9..5443a08 100644 | |||
36 | -# define _UINTPTR_T_DEFINED | 36 | -# define _UINTPTR_T_DEFINED |
37 | -#endif /* !defined(_UINTPTR_T) || !defined(_UINTPTR_T_DEFINED) */ | 37 | -#endif /* !defined(_UINTPTR_T) || !defined(_UINTPTR_T_DEFINED) */ |
38 | +# define __DEFINED_uintptr_t | 38 | +# define __DEFINED_uintptr_t |
39 | +#endif /* !defined(__DEFINED_uintptr_t) | 39 | +#endif /* !defined(__DEFINED_uintptr_t) */ |
40 | 40 | ||
41 | /* Perform an unsigned cast to uintptr_t. */ | 41 | /* Perform an unsigned cast to uintptr_t. */ |
42 | #define cast_to_pointer_integral_type(value) \ | 42 | #define cast_to_pointer_integral_type(value) \ |
43 | -- | 43 | -- |
44 | 2.7.4 | 44 | 2.25.1 |
45 | 45 | ||
diff --git a/meta-networking/recipes-support/libldb/libldb_2.3.4.bb b/meta-networking/recipes-support/libldb/libldb_2.6.1.bb index af5f0427d..d5440cce2 100644 --- a/meta-networking/recipes-support/libldb/libldb_2.3.4.bb +++ b/meta-networking/recipes-support/libldb/libldb_2.6.1.bb | |||
@@ -1,5 +1,5 @@ | |||
1 | SUMMARY = "Hierarchical, reference counted memory pool system with destructors" | 1 | SUMMARY = "Hierarchical, reference counted memory pool system with destructors" |
2 | HOMEPAGE = "http://ldb.samba.org" | 2 | HOMEPAGE = "https://ldb.samba.org" |
3 | SECTION = "libs" | 3 | SECTION = "libs" |
4 | LICENSE = "LGPL-3.0-or-later & LGPL-2.1-or-later & GPL-3.0-or-later" | 4 | LICENSE = "LGPL-3.0-or-later & LGPL-2.1-or-later & GPL-3.0-or-later" |
5 | 5 | ||
@@ -9,10 +9,12 @@ RDEPENDS:pyldb += "python3" | |||
9 | SRC_URI = "http://samba.org/ftp/ldb/ldb-${PV}.tar.gz \ | 9 | SRC_URI = "http://samba.org/ftp/ldb/ldb-${PV}.tar.gz \ |
10 | file://0001-do-not-import-target-module-while-cross-compile.patch \ | 10 | file://0001-do-not-import-target-module-while-cross-compile.patch \ |
11 | file://0002-ldb-Add-configure-options-for-packages.patch \ | 11 | file://0002-ldb-Add-configure-options-for-packages.patch \ |
12 | file://0001-Fix-pyext_PATTERN-for-cross-compilation.patch \ | 12 | file://0003-Fix-pyext_PATTERN-for-cross-compilation.patch \ |
13 | file://libldb-fix-musl-libc-conflict-type-error.patch \ | 13 | file://0004-wscript-skip-checking-PYTHONHASHSEED.patch \ |
14 | " | 14 | " |
15 | 15 | ||
16 | SRC_URI:append:libc-musl = " file://cmocka-fix-musl-libc-conflicting-types-error.patch" | ||
17 | |||
16 | PACKAGECONFIG ??= "\ | 18 | PACKAGECONFIG ??= "\ |
17 | ${@bb.utils.filter('DISTRO_FEATURES', 'acl', d)} \ | 19 | ${@bb.utils.filter('DISTRO_FEATURES', 'acl', d)} \ |
18 | ${@bb.utils.contains('DISTRO_FEATURES', 'xattr', 'attr', '', d)} \ | 20 | ${@bb.utils.contains('DISTRO_FEATURES', 'xattr', 'attr', '', d)} \ |
@@ -26,14 +28,14 @@ PACKAGECONFIG[libcap] = "--with-libcap,--without-libcap,libcap" | |||
26 | PACKAGECONFIG[valgrind] = "--with-valgrind,--without-valgrind,valgrind" | 28 | PACKAGECONFIG[valgrind] = "--with-valgrind,--without-valgrind,valgrind" |
27 | PACKAGECONFIG[lmdb] = ",--without-ldb-lmdb,lmdb," | 29 | PACKAGECONFIG[lmdb] = ",--without-ldb-lmdb,lmdb," |
28 | 30 | ||
29 | SRC_URI += "${@bb.utils.contains('PACKAGECONFIG', 'ldap', '', 'file://0003-avoid-openldap-unless-wanted.patch', d)}" | 31 | SRC_URI += "${@bb.utils.contains('PACKAGECONFIG', 'ldap', '', 'file://avoid-openldap-unless-wanted.patch', d)}" |
30 | 32 | ||
31 | LIC_FILES_CHKSUM = "file://pyldb.h;endline=24;md5=dfbd238cecad76957f7f860fbe9adade \ | 33 | LIC_FILES_CHKSUM = "file://pyldb.h;endline=24;md5=dfbd238cecad76957f7f860fbe9adade \ |
32 | file://man/ldb.3.xml;beginline=261;endline=262;md5=137f9fd61040c1505d1aa1019663fd08 \ | 34 | file://man/ldb.3.xml;beginline=261;endline=262;md5=137f9fd61040c1505d1aa1019663fd08 \ |
33 | file://tools/ldbdump.c;endline=19;md5=a7d4fc5d1f75676b49df491575a86a42" | 35 | file://tools/ldbdump.c;endline=19;md5=a7d4fc5d1f75676b49df491575a86a42" |
34 | 36 | ||
35 | SRC_URI[md5sum] = "b01d6913a06901c22c5bc6caedc548ac" | 37 | SRC_URI[md5sum] = "3a5f54f511fb237b83e1f34e2c7e25cd" |
36 | SRC_URI[sha256sum] = "f2e88dcab7b6007d92724b62f8a16e7c6e77275885c60eb4f87097e4aa4082c1" | 38 | SRC_URI[sha256sum] = "467403f77df86782c3965bb175440baa2ed751a9feb9560194bd8c06bf1736c9" |
37 | 39 | ||
38 | inherit pkgconfig waf-samba | 40 | inherit pkgconfig waf-samba |
39 | 41 | ||