diff options
author | Khem Raj <raj.khem@gmail.com> | 2018-06-22 19:04:21 -0700 |
---|---|---|
committer | Khem Raj <raj.khem@gmail.com> | 2018-06-24 23:04:04 -0700 |
commit | 835ab5e341191b9d6c548e33d3b0e19b6fe72c47 (patch) | |
tree | a5badf722b4a5498ed15a14ead2e190aceb77a52 /meta-networking | |
parent | 7e66808136a1d800c487d181438f8f0225bac0fa (diff) | |
download | meta-openembedded-835ab5e341191b9d6c548e33d3b0e19b6fe72c47.tar.gz |
opensaf: Upgrade to 5.18.04
fix strncpy overflow errors seen with gcc8
refresh patches with devtool
Signed-off-by: Khem Raj <raj.khem@gmail.com>
Diffstat (limited to 'meta-networking')
9 files changed, 86 insertions, 59 deletions
diff --git a/meta-networking/recipes-daemons/opensaf/opensaf/0001-Catch-std-ifstream-failure-by-reference.patch b/meta-networking/recipes-daemons/opensaf/opensaf/0001-Catch-std-ifstream-failure-by-reference.patch index 8f8dba054..30fdb8bf1 100644 --- a/meta-networking/recipes-daemons/opensaf/opensaf/0001-Catch-std-ifstream-failure-by-reference.patch +++ b/meta-networking/recipes-daemons/opensaf/opensaf/0001-Catch-std-ifstream-failure-by-reference.patch | |||
@@ -1,7 +1,7 @@ | |||
1 | From 77d50b8d92ef1903cbc50d8f39e05fc828696bb9 Mon Sep 17 00:00:00 2001 | 1 | From 38c5343f84799fc5041575f3ec808f7476b6eea3 Mon Sep 17 00:00:00 2001 |
2 | From: Khem Raj <raj.khem@gmail.com> | 2 | From: Khem Raj <raj.khem@gmail.com> |
3 | Date: Mon, 16 Apr 2018 14:33:35 -0700 | 3 | Date: Mon, 16 Apr 2018 14:33:35 -0700 |
4 | Subject: [PATCH 1/2] Catch std::ifstream::failure by reference | 4 | Subject: [PATCH] Catch std::ifstream::failure by reference |
5 | 5 | ||
6 | Fixes | 6 | Fixes |
7 | error: catching polymorphic type 'class std::ios_base::failure' by value | 7 | error: catching polymorphic type 'class std::ios_base::failure' by value |
@@ -10,6 +10,7 @@ error: catching polymorphic type 'class std::ios_base::failure' by value | |||
10 | ^~~~~~~ | 10 | ^~~~~~~ |
11 | 11 | ||
12 | Signed-off-by: Khem Raj <raj.khem@gmail.com> | 12 | Signed-off-by: Khem Raj <raj.khem@gmail.com> |
13 | |||
13 | --- | 14 | --- |
14 | src/base/conf.cc | 4 ++-- | 15 | src/base/conf.cc | 4 ++-- |
15 | src/dtm/dtmnd/dtm_main.cc | 2 +- | 16 | src/dtm/dtmnd/dtm_main.cc | 2 +- |
@@ -39,10 +40,10 @@ index d5755a1..4820357 100644 | |||
39 | } | 40 | } |
40 | str.close(); | 41 | str.close(); |
41 | diff --git a/src/dtm/dtmnd/dtm_main.cc b/src/dtm/dtmnd/dtm_main.cc | 42 | diff --git a/src/dtm/dtmnd/dtm_main.cc b/src/dtm/dtmnd/dtm_main.cc |
42 | index 3260a81..a55afac 100644 | 43 | index 585e11e..5cf6ad7 100644 |
43 | --- a/src/dtm/dtmnd/dtm_main.cc | 44 | --- a/src/dtm/dtmnd/dtm_main.cc |
44 | +++ b/src/dtm/dtmnd/dtm_main.cc | 45 | +++ b/src/dtm/dtmnd/dtm_main.cc |
45 | @@ -359,7 +359,7 @@ void UpdateNodeIdFile(DTM_INTERNODE_CB *cb) { | 46 | @@ -367,7 +367,7 @@ void UpdateNodeIdFile(DTM_INTERNODE_CB *cb) { |
46 | try { | 47 | try { |
47 | str.open(PKGLOCALSTATEDIR "/node_id", std::ofstream::out); | 48 | str.open(PKGLOCALSTATEDIR "/node_id", std::ofstream::out); |
48 | str << std::hex << node_id << std::endl; | 49 | str << std::hex << node_id << std::endl; |
@@ -52,10 +53,10 @@ index 3260a81..a55afac 100644 | |||
52 | str.close(); | 53 | str.close(); |
53 | } | 54 | } |
54 | diff --git a/src/dtm/dtmnd/multicast.cc b/src/dtm/dtmnd/multicast.cc | 55 | diff --git a/src/dtm/dtmnd/multicast.cc b/src/dtm/dtmnd/multicast.cc |
55 | index bf67b9c..7232066 100644 | 56 | index cadc002..7c25fea 100644 |
56 | --- a/src/dtm/dtmnd/multicast.cc | 57 | --- a/src/dtm/dtmnd/multicast.cc |
57 | +++ b/src/dtm/dtmnd/multicast.cc | 58 | +++ b/src/dtm/dtmnd/multicast.cc |
58 | @@ -198,7 +198,7 @@ bool Multicast::GetPeersFromFile(const std::string &path_name) { | 59 | @@ -199,7 +199,7 @@ bool Multicast::GetPeersFromFile(const std::string &path_name) { |
59 | } | 60 | } |
60 | } | 61 | } |
61 | } | 62 | } |
@@ -64,6 +65,3 @@ index bf67b9c..7232066 100644 | |||
64 | LOG_ER("Caught std::ifstream::failure when reading file '%s', peers=%zu", | 65 | LOG_ER("Caught std::ifstream::failure when reading file '%s', peers=%zu", |
65 | path_name.c_str(), static_cast<size_t>(peers_.size())); | 66 | path_name.c_str(), static_cast<size_t>(peers_.size())); |
66 | peers_.clear(); | 67 | peers_.clear(); |
67 | -- | ||
68 | 2.17.0 | ||
69 | |||
diff --git a/meta-networking/recipes-daemons/opensaf/opensaf/0001-Fix-string-overflow-in-snprintf.patch b/meta-networking/recipes-daemons/opensaf/opensaf/0001-Fix-string-overflow-in-snprintf.patch index 428e46228..db6796d05 100644 --- a/meta-networking/recipes-daemons/opensaf/opensaf/0001-Fix-string-overflow-in-snprintf.patch +++ b/meta-networking/recipes-daemons/opensaf/opensaf/0001-Fix-string-overflow-in-snprintf.patch | |||
@@ -1,4 +1,4 @@ | |||
1 | From 8cf323a2d8e02ca0bd36deb38e613c6edac546ad Mon Sep 17 00:00:00 2001 | 1 | From ae7178a78aba2e5766b70191617113487fd7ad0b Mon Sep 17 00:00:00 2001 |
2 | From: Khem Raj <raj.khem@gmail.com> | 2 | From: Khem Raj <raj.khem@gmail.com> |
3 | Date: Mon, 16 Apr 2018 18:29:17 -0700 | 3 | Date: Mon, 16 Apr 2018 18:29:17 -0700 |
4 | Subject: [PATCH] Fix string overflow in snprintf | 4 | Subject: [PATCH] Fix string overflow in snprintf |
@@ -13,6 +13,7 @@ t-truncation=] | |||
13 | ~~~~~~~~ | 13 | ~~~~~~~~ |
14 | 14 | ||
15 | Signed-off-by: Khem Raj <raj.khem@gmail.com> | 15 | Signed-off-by: Khem Raj <raj.khem@gmail.com> |
16 | |||
16 | --- | 17 | --- |
17 | src/log/logd/lgs_util.cc | 4 ++-- | 18 | src/log/logd/lgs_util.cc | 4 ++-- |
18 | src/rde/rded/rde_amf.cc | 2 +- | 19 | src/rde/rded/rde_amf.cc | 2 +- |
diff --git a/meta-networking/recipes-daemons/opensaf/opensaf/0001-configure-Disable-format-overflow-if-supported-by-gc.patch b/meta-networking/recipes-daemons/opensaf/opensaf/0001-configure-Disable-format-overflow-if-supported-by-gc.patch index effe25c85..be0a58767 100644 --- a/meta-networking/recipes-daemons/opensaf/opensaf/0001-configure-Disable-format-overflow-if-supported-by-gc.patch +++ b/meta-networking/recipes-daemons/opensaf/opensaf/0001-configure-Disable-format-overflow-if-supported-by-gc.patch | |||
@@ -1,20 +1,21 @@ | |||
1 | From ab00d6f5793b2d850f975bcb6d5d0aa6d7a9eaa4 Mon Sep 17 00:00:00 2001 | 1 | From c2668f7f2ea82a61115b7cae56ed081b41ff5153 Mon Sep 17 00:00:00 2001 |
2 | From: Khem Raj <raj.khem@gmail.com> | 2 | From: Khem Raj <raj.khem@gmail.com> |
3 | Date: Sat, 22 Apr 2017 12:34:37 -0700 | 3 | Date: Sat, 22 Apr 2017 12:34:37 -0700 |
4 | Subject: [PATCH] configure: Disable format-overflow if supported by gcc | 4 | Subject: [PATCH] configure: Disable format-overflow if supported by gcc |
5 | 5 | ||
6 | Signed-off-by: Khem Raj <raj.khem@gmail.com> | 6 | Signed-off-by: Khem Raj <raj.khem@gmail.com> |
7 | |||
7 | --- | 8 | --- |
8 | Makefile.am | 6 ++-- | 9 | Makefile.am | 6 +-- |
9 | configure.ac | 2 ++ | 10 | configure.ac | 2 + |
10 | m4/ax_check_compile_flag.m4 | 74 +++++++++++++++++++++++++++++++++++++++++++++ | 11 | m4/ax_check_compile_flag.m4 | 74 +++++++++++++++++++++++++++++++++++++ |
11 | 3 files changed, 79 insertions(+), 3 deletions(-) | 12 | 3 files changed, 79 insertions(+), 3 deletions(-) |
12 | create mode 100644 m4/ax_check_compile_flag.m4 | 13 | create mode 100644 m4/ax_check_compile_flag.m4 |
13 | 14 | ||
14 | Index: opensaf-5.18.02/Makefile.am | 15 | diff --git a/Makefile.am b/Makefile.am |
15 | =================================================================== | 16 | index b3d6553..5607fc2 100644 |
16 | --- opensaf-5.18.02.orig/Makefile.am | 17 | --- a/Makefile.am |
17 | +++ opensaf-5.18.02/Makefile.am | 18 | +++ b/Makefile.am |
18 | @@ -52,10 +52,10 @@ AM_CPPFLAGS = \ | 19 | @@ -52,10 +52,10 @@ AM_CPPFLAGS = \ |
19 | -pthread \ | 20 | -pthread \ |
20 | -D_GNU_SOURCE -DINTERNAL_VERSION_ID='"@INTERNAL_VERSION_ID@"' \ | 21 | -D_GNU_SOURCE -DINTERNAL_VERSION_ID='"@INTERNAL_VERSION_ID@"' \ |
@@ -29,11 +30,11 @@ Index: opensaf-5.18.02/Makefile.am | |||
29 | 30 | ||
30 | if ENABLE_GCOV | 31 | if ENABLE_GCOV |
31 | AM_CFLAGS += --coverage | 32 | AM_CFLAGS += --coverage |
32 | Index: opensaf-5.18.02/configure.ac | 33 | diff --git a/configure.ac b/configure.ac |
33 | =================================================================== | 34 | index 5b86730..47d1002 100644 |
34 | --- opensaf-5.18.02.orig/configure.ac | 35 | --- a/configure.ac |
35 | +++ opensaf-5.18.02/configure.ac | 36 | +++ b/configure.ac |
36 | @@ -593,6 +593,8 @@ if test -z "$OSAF_HARDEN_FLAGS"; then | 37 | @@ -600,6 +600,8 @@ if test -z "$OSAF_HARDEN_FLAGS"; then |
37 | fi | 38 | fi |
38 | AC_SUBST(OSAF_HARDEN_FLAGS) | 39 | AC_SUBST(OSAF_HARDEN_FLAGS) |
39 | 40 | ||
@@ -42,10 +43,11 @@ Index: opensaf-5.18.02/configure.ac | |||
42 | ############################################# | 43 | ############################################# |
43 | # List the output Makefiles | 44 | # List the output Makefiles |
44 | ############################################# | 45 | ############################################# |
45 | Index: opensaf-5.18.02/m4/ax_check_compile_flag.m4 | 46 | diff --git a/m4/ax_check_compile_flag.m4 b/m4/ax_check_compile_flag.m4 |
46 | =================================================================== | 47 | new file mode 100644 |
48 | index 0000000..dcabb92 | ||
47 | --- /dev/null | 49 | --- /dev/null |
48 | +++ opensaf-5.18.02/m4/ax_check_compile_flag.m4 | 50 | +++ b/m4/ax_check_compile_flag.m4 |
49 | @@ -0,0 +1,74 @@ | 51 | @@ -0,0 +1,74 @@ |
50 | +# =========================================================================== | 52 | +# =========================================================================== |
51 | +# https://www.gnu.org/software/autoconf-archive/ax_check_compile_flag.html | 53 | +# https://www.gnu.org/software/autoconf-archive/ax_check_compile_flag.html |
diff --git a/meta-networking/recipes-daemons/opensaf/opensaf/0001-configure-Pass-linker-specific-options-with-Wl.patch b/meta-networking/recipes-daemons/opensaf/opensaf/0001-configure-Pass-linker-specific-options-with-Wl.patch index 5756a027b..e4bbb4c3c 100644 --- a/meta-networking/recipes-daemons/opensaf/opensaf/0001-configure-Pass-linker-specific-options-with-Wl.patch +++ b/meta-networking/recipes-daemons/opensaf/opensaf/0001-configure-Pass-linker-specific-options-with-Wl.patch | |||
@@ -1,4 +1,4 @@ | |||
1 | From 6248b717b4861d16b80235fd8e57d64e4f636428 Mon Sep 17 00:00:00 2001 | 1 | From 979b2b6a1aa574a26e8b736049c4207d568f60f3 Mon Sep 17 00:00:00 2001 |
2 | From: Khem Raj <raj.khem@gmail.com> | 2 | From: Khem Raj <raj.khem@gmail.com> |
3 | Date: Thu, 13 Apr 2017 17:39:07 -0700 | 3 | Date: Thu, 13 Apr 2017 17:39:07 -0700 |
4 | Subject: [PATCH] configure: Pass linker specific options with -Wl | 4 | Subject: [PATCH] configure: Pass linker specific options with -Wl |
@@ -7,15 +7,16 @@ This helps make it pass the options to linker correctly | |||
7 | and we can use non-gcc compilers | 7 | and we can use non-gcc compilers |
8 | 8 | ||
9 | Signed-off-by: Khem Raj <raj.khem@gmail.com> | 9 | Signed-off-by: Khem Raj <raj.khem@gmail.com> |
10 | |||
10 | --- | 11 | --- |
11 | configure.ac | 2 +- | 12 | configure.ac | 2 +- |
12 | 1 file changed, 1 insertion(+), 1 deletion(-) | 13 | 1 file changed, 1 insertion(+), 1 deletion(-) |
13 | 14 | ||
14 | diff --git a/configure.ac b/configure.ac | 15 | diff --git a/configure.ac b/configure.ac |
15 | index df4fc58..02771c6 100644 | 16 | index 12a5d5c..5b86730 100644 |
16 | --- a/configure.ac | 17 | --- a/configure.ac |
17 | +++ b/configure.ac | 18 | +++ b/configure.ac |
18 | @@ -553,7 +553,7 @@ if test -z "$OSAF_HARDEN_FLAGS"; then | 19 | @@ -596,7 +596,7 @@ if test -z "$OSAF_HARDEN_FLAGS"; then |
19 | if echo "${CFLAGS} ${CXXFLAGS}" | grep -q -- -O0; then | 20 | if echo "${CFLAGS} ${CXXFLAGS}" | grep -q -- -O0; then |
20 | OSAF_HARDEN_FLAGS="" | 21 | OSAF_HARDEN_FLAGS="" |
21 | fi | 22 | fi |
@@ -24,6 +25,3 @@ index df4fc58..02771c6 100644 | |||
24 | fi | 25 | fi |
25 | AC_SUBST(OSAF_HARDEN_FLAGS) | 26 | AC_SUBST(OSAF_HARDEN_FLAGS) |
26 | 27 | ||
27 | -- | ||
28 | 2.12.2 | ||
29 | |||
diff --git a/meta-networking/recipes-daemons/opensaf/opensaf/0001-immpbe_dump.cc-Use-sys-wait.h-instead-of-wait.h.patch b/meta-networking/recipes-daemons/opensaf/opensaf/0001-immpbe_dump.cc-Use-sys-wait.h-instead-of-wait.h.patch index 76c47c658..e40d2b319 100644 --- a/meta-networking/recipes-daemons/opensaf/opensaf/0001-immpbe_dump.cc-Use-sys-wait.h-instead-of-wait.h.patch +++ b/meta-networking/recipes-daemons/opensaf/opensaf/0001-immpbe_dump.cc-Use-sys-wait.h-instead-of-wait.h.patch | |||
@@ -1,4 +1,4 @@ | |||
1 | From 508ea7c0d67243feb1684eaa83569cb687561d64 Mon Sep 17 00:00:00 2001 | 1 | From c21f77d592415f316138c05f581192a1f061e735 Mon Sep 17 00:00:00 2001 |
2 | From: Khem Raj <raj.khem@gmail.com> | 2 | From: Khem Raj <raj.khem@gmail.com> |
3 | Date: Fri, 15 Sep 2017 10:09:03 -0700 | 3 | Date: Fri, 15 Sep 2017 10:09:03 -0700 |
4 | Subject: [PATCH] immpbe_dump.cc: Use sys/wait.h instead of wait.h | 4 | Subject: [PATCH] immpbe_dump.cc: Use sys/wait.h instead of wait.h |
@@ -7,12 +7,13 @@ Fixes | |||
7 | redirecting incorrect #include <wait.h> to <sys/wait.h> | 7 | redirecting incorrect #include <wait.h> to <sys/wait.h> |
8 | 8 | ||
9 | Signed-off-by: Khem Raj <raj.khem@gmail.com> | 9 | Signed-off-by: Khem Raj <raj.khem@gmail.com> |
10 | |||
10 | --- | 11 | --- |
11 | src/imm/common/immpbe_dump.cc | 2 +- | 12 | src/imm/common/immpbe_dump.cc | 2 +- |
12 | 1 file changed, 1 insertion(+), 1 deletion(-) | 13 | 1 file changed, 1 insertion(+), 1 deletion(-) |
13 | 14 | ||
14 | diff --git a/src/imm/common/immpbe_dump.cc b/src/imm/common/immpbe_dump.cc | 15 | diff --git a/src/imm/common/immpbe_dump.cc b/src/imm/common/immpbe_dump.cc |
15 | index 100222f37..33e47ce3c 100644 | 16 | index e6b3cc5..3956028 100644 |
16 | --- a/src/imm/common/immpbe_dump.cc | 17 | --- a/src/imm/common/immpbe_dump.cc |
17 | +++ b/src/imm/common/immpbe_dump.cc | 18 | +++ b/src/imm/common/immpbe_dump.cc |
18 | @@ -26,12 +26,12 @@ | 19 | @@ -26,12 +26,12 @@ |
@@ -27,8 +28,5 @@ index 100222f37..33e47ce3c 100644 | |||
27 | #include <sys/stat.h> | 28 | #include <sys/stat.h> |
28 | +#include <sys/wait.h> | 29 | +#include <sys/wait.h> |
29 | #include <libgen.h> | 30 | #include <libgen.h> |
30 | 31 | #include <set> | |
31 | #include <saAis.h> | 32 | #include <vector> |
32 | -- | ||
33 | 2.14.1 | ||
34 | |||
diff --git a/meta-networking/recipes-daemons/opensaf/opensaf/0001-src-Add-missing-header-limits.h-for-_POSIX_HOST_NAME.patch b/meta-networking/recipes-daemons/opensaf/opensaf/0001-src-Add-missing-header-limits.h-for-_POSIX_HOST_NAME.patch index 4a2a825f9..e4a3975da 100644 --- a/meta-networking/recipes-daemons/opensaf/opensaf/0001-src-Add-missing-header-limits.h-for-_POSIX_HOST_NAME.patch +++ b/meta-networking/recipes-daemons/opensaf/opensaf/0001-src-Add-missing-header-limits.h-for-_POSIX_HOST_NAME.patch | |||
@@ -1,4 +1,4 @@ | |||
1 | From 6442b57a855e273aa5a3d93e8596783cea128073 Mon Sep 17 00:00:00 2001 | 1 | From 7fb393c66df33110fef0cbabac7d304f12eb82e4 Mon Sep 17 00:00:00 2001 |
2 | From: Khem Raj <raj.khem@gmail.com> | 2 | From: Khem Raj <raj.khem@gmail.com> |
3 | Date: Fri, 15 Sep 2017 09:39:40 -0700 | 3 | Date: Fri, 15 Sep 2017 09:39:40 -0700 |
4 | Subject: [PATCH] src: Add missing header limits.h for _POSIX_HOST_NAME_MAX | 4 | Subject: [PATCH] src: Add missing header limits.h for _POSIX_HOST_NAME_MAX |
@@ -7,6 +7,7 @@ Use _GNU_SOURCE instead of libc internal __USE_GNU | |||
7 | Do not use the deprecated headers under include/sys | 7 | Do not use the deprecated headers under include/sys |
8 | 8 | ||
9 | Signed-off-by: Khem Raj <raj.khem@gmail.com> | 9 | Signed-off-by: Khem Raj <raj.khem@gmail.com> |
10 | |||
10 | --- | 11 | --- |
11 | src/base/os_defs.h | 5 +++-- | 12 | src/base/os_defs.h | 5 +++-- |
12 | src/mds/mds_dt_tcp.c | 1 - | 13 | src/mds/mds_dt_tcp.c | 1 - |
@@ -18,7 +19,7 @@ Signed-off-by: Khem Raj <raj.khem@gmail.com> | |||
18 | 7 files changed, 6 insertions(+), 8 deletions(-) | 19 | 7 files changed, 6 insertions(+), 8 deletions(-) |
19 | 20 | ||
20 | diff --git a/src/base/os_defs.h b/src/base/os_defs.h | 21 | diff --git a/src/base/os_defs.h b/src/base/os_defs.h |
21 | index 50a9bf5fc..af6842863 100644 | 22 | index a570c43..3559b19 100644 |
22 | --- a/src/base/os_defs.h | 23 | --- a/src/base/os_defs.h |
23 | +++ b/src/base/os_defs.h | 24 | +++ b/src/base/os_defs.h |
24 | @@ -47,17 +47,18 @@ | 25 | @@ -47,17 +47,18 @@ |
@@ -43,7 +44,7 @@ index 50a9bf5fc..af6842863 100644 | |||
43 | #include <pthread.h> | 44 | #include <pthread.h> |
44 | 45 | ||
45 | diff --git a/src/mds/mds_dt_tcp.c b/src/mds/mds_dt_tcp.c | 46 | diff --git a/src/mds/mds_dt_tcp.c b/src/mds/mds_dt_tcp.c |
46 | index 1407eb1ab..a87c22faa 100644 | 47 | index 1407eb1..a87c22f 100644 |
47 | --- a/src/mds/mds_dt_tcp.c | 48 | --- a/src/mds/mds_dt_tcp.c |
48 | +++ b/src/mds/mds_dt_tcp.c | 49 | +++ b/src/mds/mds_dt_tcp.c |
49 | @@ -27,7 +27,6 @@ | 50 | @@ -27,7 +27,6 @@ |
@@ -55,7 +56,7 @@ index 1407eb1ab..a87c22faa 100644 | |||
55 | #include <sys/types.h> | 56 | #include <sys/types.h> |
56 | #include <unistd.h> | 57 | #include <unistd.h> |
57 | diff --git a/src/mds/mds_dt_tcp_disc.h b/src/mds/mds_dt_tcp_disc.h | 58 | diff --git a/src/mds/mds_dt_tcp_disc.h b/src/mds/mds_dt_tcp_disc.h |
58 | index a6249d73e..574f52681 100644 | 59 | index a6249d7..574f526 100644 |
59 | --- a/src/mds/mds_dt_tcp_disc.h | 60 | --- a/src/mds/mds_dt_tcp_disc.h |
60 | +++ b/src/mds/mds_dt_tcp_disc.h | 61 | +++ b/src/mds/mds_dt_tcp_disc.h |
61 | @@ -24,7 +24,7 @@ | 62 | @@ -24,7 +24,7 @@ |
@@ -68,7 +69,7 @@ index a6249d73e..574f52681 100644 | |||
68 | /* mds_indentifire + mds_version + msg_type + scope_type + server_type + | 69 | /* mds_indentifire + mds_version + msg_type + scope_type + server_type + |
69 | server_instance_lower + server_instance_upper + sub_ref_val + sub_ref_val + | 70 | server_instance_lower + server_instance_upper + sub_ref_val + sub_ref_val + |
70 | diff --git a/src/mds/mds_dt_tipc.c b/src/mds/mds_dt_tipc.c | 71 | diff --git a/src/mds/mds_dt_tipc.c b/src/mds/mds_dt_tipc.c |
71 | index 37745e7f0..9b3255567 100644 | 72 | index 7714175..a0ed3b6 100644 |
72 | --- a/src/mds/mds_dt_tipc.c | 73 | --- a/src/mds/mds_dt_tipc.c |
73 | +++ b/src/mds/mds_dt_tipc.c | 74 | +++ b/src/mds/mds_dt_tipc.c |
74 | @@ -35,7 +35,6 @@ | 75 | @@ -35,7 +35,6 @@ |
@@ -80,7 +81,7 @@ index 37745e7f0..9b3255567 100644 | |||
80 | #include <sys/types.h> | 81 | #include <sys/types.h> |
81 | #include <unistd.h> | 82 | #include <unistd.h> |
82 | diff --git a/src/mds/mds_dt_tipc.h b/src/mds/mds_dt_tipc.h | 83 | diff --git a/src/mds/mds_dt_tipc.h b/src/mds/mds_dt_tipc.h |
83 | index e73a11b09..401d208c2 100644 | 84 | index e73a11b..401d208 100644 |
84 | --- a/src/mds/mds_dt_tipc.h | 85 | --- a/src/mds/mds_dt_tipc.h |
85 | +++ b/src/mds/mds_dt_tipc.h | 86 | +++ b/src/mds/mds_dt_tipc.h |
86 | @@ -32,7 +32,7 @@ | 87 | @@ -32,7 +32,7 @@ |
@@ -93,7 +94,7 @@ index e73a11b09..401d208c2 100644 | |||
93 | #include <errno.h> | 94 | #include <errno.h> |
94 | #include <fcntl.h> | 95 | #include <fcntl.h> |
95 | diff --git a/src/mds/mds_dt_trans.c b/src/mds/mds_dt_trans.c | 96 | diff --git a/src/mds/mds_dt_trans.c b/src/mds/mds_dt_trans.c |
96 | index 6f621e04e..5aacbd33e 100644 | 97 | index 6f621e0..5aacbd3 100644 |
97 | --- a/src/mds/mds_dt_trans.c | 98 | --- a/src/mds/mds_dt_trans.c |
98 | +++ b/src/mds/mds_dt_trans.c | 99 | +++ b/src/mds/mds_dt_trans.c |
99 | @@ -26,7 +26,6 @@ | 100 | @@ -26,7 +26,6 @@ |
@@ -105,7 +106,7 @@ index 6f621e04e..5aacbd33e 100644 | |||
105 | 106 | ||
106 | #define MDS_PROT_TCP 0xA0 | 107 | #define MDS_PROT_TCP 0xA0 |
107 | diff --git a/src/ntf/ntfd/NtfLogger.cc b/src/ntf/ntfd/NtfLogger.cc | 108 | diff --git a/src/ntf/ntfd/NtfLogger.cc b/src/ntf/ntfd/NtfLogger.cc |
108 | index 84014b578..31b1ccc6c 100644 | 109 | index fd17c58..1120008 100644 |
109 | --- a/src/ntf/ntfd/NtfLogger.cc | 110 | --- a/src/ntf/ntfd/NtfLogger.cc |
110 | +++ b/src/ntf/ntfd/NtfLogger.cc | 111 | +++ b/src/ntf/ntfd/NtfLogger.cc |
111 | @@ -20,7 +20,7 @@ | 112 | @@ -20,7 +20,7 @@ |
@@ -117,6 +118,3 @@ index 84014b578..31b1ccc6c 100644 | |||
117 | 118 | ||
118 | #include "base/osaf_utility.h" | 119 | #include "base/osaf_utility.h" |
119 | #include <saAis.h> | 120 | #include <saAis.h> |
120 | -- | ||
121 | 2.14.1 | ||
122 | |||
diff --git a/meta-networking/recipes-daemons/opensaf/opensaf/0002-Fix-format-truncation-errors.patch b/meta-networking/recipes-daemons/opensaf/opensaf/0002-Fix-format-truncation-errors.patch index 9865a5e1b..f98e28da9 100644 --- a/meta-networking/recipes-daemons/opensaf/opensaf/0002-Fix-format-truncation-errors.patch +++ b/meta-networking/recipes-daemons/opensaf/opensaf/0002-Fix-format-truncation-errors.patch | |||
@@ -1,12 +1,13 @@ | |||
1 | From 4d58d26cbd3622183afc2e8f85c9c81edaf135df Mon Sep 17 00:00:00 2001 | 1 | From c5034fe42df8923bcefc10e163151997d70b6241 Mon Sep 17 00:00:00 2001 |
2 | From: Khem Raj <raj.khem@gmail.com> | 2 | From: Khem Raj <raj.khem@gmail.com> |
3 | Date: Mon, 16 Apr 2018 14:56:47 -0700 | 3 | Date: Mon, 16 Apr 2018 14:56:47 -0700 |
4 | Subject: [PATCH 2/2] Fix format-truncation errors | 4 | Subject: [PATCH] Fix format-truncation errors |
5 | 5 | ||
6 | Fixes errors with gcc8 eg. | 6 | Fixes errors with gcc8 eg. |
7 | error: '%u' directive output may be truncated writing between 1 and 10 bytes into a region of size between 0 and 254 [-Werror=format-truncation=] | 7 | error: '%u' directive output may be truncated writing between 1 and 10 bytes into a region of size between 0 and 254 [-Werror=format-truncation=] |
8 | 8 | ||
9 | Signed-off-by: Khem Raj <raj.khem@gmail.com> | 9 | Signed-off-by: Khem Raj <raj.khem@gmail.com> |
10 | |||
10 | --- | 11 | --- |
11 | src/base/daemon.c | 4 ++-- | 12 | src/base/daemon.c | 4 ++-- |
12 | src/mds/mds_c_db.c | 8 ++++---- | 13 | src/mds/mds_c_db.c | 8 ++++---- |
@@ -15,10 +16,10 @@ Signed-off-by: Khem Raj <raj.khem@gmail.com> | |||
15 | 4 files changed, 9 insertions(+), 9 deletions(-) | 16 | 4 files changed, 9 insertions(+), 9 deletions(-) |
16 | 17 | ||
17 | diff --git a/src/base/daemon.c b/src/base/daemon.c | 18 | diff --git a/src/base/daemon.c b/src/base/daemon.c |
18 | index 27170d7..da97700 100644 | 19 | index 361dd8d..4001b73 100644 |
19 | --- a/src/base/daemon.c | 20 | --- a/src/base/daemon.c |
20 | +++ b/src/base/daemon.c | 21 | +++ b/src/base/daemon.c |
21 | @@ -92,11 +92,11 @@ static int __create_pidfile(const char *pidfile) | 22 | @@ -95,11 +95,11 @@ static int __create_pidfile(const char *pidfile) |
22 | { | 23 | { |
23 | FILE *file = NULL; | 24 | FILE *file = NULL; |
24 | int fd, rc = 0; | 25 | int fd, rc = 0; |
@@ -97,6 +98,3 @@ index 012999c..006b722 100644 | |||
97 | MDS_SEND_PRIORITY_TYPE pri; | 98 | MDS_SEND_PRIORITY_TYPE pri; |
98 | MDS_CLIENT_MSG_FORMAT_VER | 99 | MDS_CLIENT_MSG_FORMAT_VER |
99 | msg_fmt_ver; /* message format version specification */ | 100 | msg_fmt_ver; /* message format version specification */ |
100 | -- | ||
101 | 2.17.0 | ||
102 | |||
diff --git a/meta-networking/recipes-daemons/opensaf/opensaf/0008-check-for-size-before-using-strncpy.patch b/meta-networking/recipes-daemons/opensaf/opensaf/0008-check-for-size-before-using-strncpy.patch new file mode 100644 index 000000000..497bb07d8 --- /dev/null +++ b/meta-networking/recipes-daemons/opensaf/opensaf/0008-check-for-size-before-using-strncpy.patch | |||
@@ -0,0 +1,33 @@ | |||
1 | From 29510dd81e3a5e96151afdb0702863cbfd640766 Mon Sep 17 00:00:00 2001 | ||
2 | From: Khem Raj <raj.khem@gmail.com> | ||
3 | Date: Fri, 22 Jun 2018 18:58:59 -0700 | ||
4 | Subject: [PATCH] check for size before using strncpy | ||
5 | |||
6 | ensures that size is never execeding the string length | ||
7 | that execPath can hold | ||
8 | |||
9 | Fixes | ||
10 | error: '__builtin___strncpy_chk' specified size between 18446744071562067968 and 18446744073709551615 exceeds maximum object size 9223372036854775807 [-Werror=stringop-overflow=] | ||
11 | |||
12 | Upstream-Status: Pending | ||
13 | |||
14 | Signed-off-by: Khem Raj <raj.khem@gmail.com> | ||
15 | --- | ||
16 | src/imm/immnd/immnd_proc.c | 4 ++++ | ||
17 | 1 file changed, 4 insertions(+) | ||
18 | |||
19 | diff --git a/src/imm/immnd/immnd_proc.c b/src/imm/immnd/immnd_proc.c | ||
20 | index 015932a..c8f115e 100644 | ||
21 | --- a/src/imm/immnd/immnd_proc.c | ||
22 | +++ b/src/imm/immnd/immnd_proc.c | ||
23 | @@ -1902,6 +1902,10 @@ static int immnd_forkPbe(IMMND_CB *cb) | ||
24 | LOG_ER("Pathname too long: %u max is 1023", newLen); | ||
25 | return -1; | ||
26 | } | ||
27 | + if (execDirLen > 1023 || execDirLen < 0) { | ||
28 | + LOG_ER("Execdir name too long: %u max is 1023", execDirLen); | ||
29 | + return -1; | ||
30 | + } | ||
31 | |||
32 | strncpy(execPath, cb->mProgName, execDirLen); | ||
33 | execPath[execDirLen] = 0; | ||
diff --git a/meta-networking/recipes-daemons/opensaf/opensaf_5.18.02.bb b/meta-networking/recipes-daemons/opensaf/opensaf_5.18.04.bb index 0ef13b048..effe95699 100644 --- a/meta-networking/recipes-daemons/opensaf/opensaf_5.18.02.bb +++ b/meta-networking/recipes-daemons/opensaf/opensaf_5.18.04.bb | |||
@@ -27,9 +27,10 @@ SRC_URI = "${SOURCEFORGE_MIRROR}/${BPN}/releases/${BPN}-${PV}.tar.gz \ | |||
27 | file://0001-Catch-std-ifstream-failure-by-reference.patch \ | 27 | file://0001-Catch-std-ifstream-failure-by-reference.patch \ |
28 | file://0002-Fix-format-truncation-errors.patch \ | 28 | file://0002-Fix-format-truncation-errors.patch \ |
29 | file://0001-Fix-string-overflow-in-snprintf.patch \ | 29 | file://0001-Fix-string-overflow-in-snprintf.patch \ |
30 | file://0008-check-for-size-before-using-strncpy.patch \ | ||
30 | " | 31 | " |
31 | SRC_URI[md5sum] = "42064f5ddbc7f560bfc5ff93ea9eecc7" | 32 | SRC_URI[md5sum] = "21836e43b13ad33bed9bd0ed391e5a6e" |
32 | SRC_URI[sha256sum] = "f9e24897f9cfd63bb3115f6275c706de1702d3d9bae2fc423227db72b23c37f0" | 33 | SRC_URI[sha256sum] = "e55dc2645487fb22938e8386b99eef6eb7aff43a246ce3e92488daf6ee46247a" |
33 | 34 | ||
34 | inherit autotools useradd systemd pkgconfig | 35 | inherit autotools useradd systemd pkgconfig |
35 | 36 | ||