diff options
author | Yi Zhao <yi.zhao@windriver.com> | 2022-03-22 12:46:15 +0800 |
---|---|---|
committer | Khem Raj <raj.khem@gmail.com> | 2022-03-24 09:45:25 -0700 |
commit | 67a9629e6f44fb12ae92d5ba38b06cf049529d3f (patch) | |
tree | a0ba758a4fa392a793ac7b3eef6bad986a3bf03e /meta-networking | |
parent | 6ebe45deb4e467feb8ff85da2b9d04ccc4dd4a30 (diff) | |
download | meta-openembedded-67a9629e6f44fb12ae92d5ba38b06cf049529d3f.tar.gz |
dhcp-relay: upgrade 4.4.2p1 -> 4.4.3
License-Update: The ISC DHCP is licensed under the Mozilla Public
License, MPL 2.0 rather than ISC License now[1][2].
[1] https://www.isc.org/licenses/
[2] https://downloads.isc.org/isc/dhcp/4.4.3/dhcp-4.4.3-RELNOTES
The bundled BIND has been updated to 9.11.36. We don't need to download
it from external anymore.
Signed-off-by: Yi Zhao <yi.zhao@windriver.com>
Signed-off-by: Khem Raj <raj.khem@gmail.com>
Diffstat (limited to 'meta-networking')
-rw-r--r-- | meta-networking/recipes-connectivity/dhcp/dhcp-relay_4.4.2p1.bb | 83 | ||||
-rw-r--r-- | meta-networking/recipes-connectivity/dhcp/dhcp-relay_4.4.3.bb | 62 | ||||
-rw-r--r-- | meta-networking/recipes-connectivity/dhcp/files/0001-Makefile.am-only-build-dhcrelay.patch | 4 | ||||
-rw-r--r-- | meta-networking/recipes-connectivity/dhcp/files/0002-bind-Makefile.in-disable-backtrace.patch (renamed from meta-networking/recipes-connectivity/dhcp/files/0003-bind-Makefile.in-disable-backtrace.patch) | 6 | ||||
-rw-r--r-- | meta-networking/recipes-connectivity/dhcp/files/0002-bind-version-update-to-latest-version.patch | 30 | ||||
-rw-r--r-- | meta-networking/recipes-connectivity/dhcp/files/0003-bind-Makefile.in-regenerate-configure.patch | 30 |
6 files changed, 97 insertions, 118 deletions
diff --git a/meta-networking/recipes-connectivity/dhcp/dhcp-relay_4.4.2p1.bb b/meta-networking/recipes-connectivity/dhcp/dhcp-relay_4.4.2p1.bb deleted file mode 100644 index 8d4be95cf..000000000 --- a/meta-networking/recipes-connectivity/dhcp/dhcp-relay_4.4.2p1.bb +++ /dev/null | |||
@@ -1,83 +0,0 @@ | |||
1 | SECTION = "console/network" | ||
2 | SUMMARY = "Internet Software Consortium DHCP Relay Agent" | ||
3 | DESCRIPTION = "A DHCP relay agent passes DHCP requests from one \ | ||
4 | LAN to another, so that a DHCP server is not needed on every LAN." | ||
5 | |||
6 | HOMEPAGE = "http://www.isc.org/" | ||
7 | |||
8 | LICENSE = "ISC" | ||
9 | LIC_FILES_CHKSUM = "file://LICENSE;beginline=4;md5=004a4db50a1e20972e924a8618747c01" | ||
10 | |||
11 | DEPENDS = "openssl libcap zlib chrpath-replacement-native" | ||
12 | EXTRANATIVEPATH += "chrpath-native" | ||
13 | |||
14 | SRC_URI = "https://ftp.isc.org/isc/dhcp/4.4.2-P1/dhcp-4.4.2-P1.tar.gz \ | ||
15 | https://ftp.isc.org/isc/bind9/9.11.32/bind-9.11.32.tar.gz;name=bind;unpack=0 \ | ||
16 | file://default-relay \ | ||
17 | file://init-relay \ | ||
18 | file://dhcrelay.service \ | ||
19 | file://0001-Makefile.am-only-build-dhcrelay.patch \ | ||
20 | file://0002-bind-version-update-to-latest-version.patch \ | ||
21 | file://0003-bind-Makefile.in-disable-backtrace.patch \ | ||
22 | " | ||
23 | |||
24 | SRC_URI[md5sum] = "3089a1ebd20a802ec0870ae337d43907" | ||
25 | SRC_URI[sha256sum] = "b05e04337539545a8faa0d6ac518defc61a07e5aec66a857f455e7f218c85a1a" | ||
26 | SRC_URI[bind.md5sum] = "0d029dd06ca60c6739c3189c999ef757" | ||
27 | SRC_URI[bind.sha256sum] = "cbf8cb4b74dd1452d97c3a2a8c625ea346df8516b4b3508ef07443121a591342" | ||
28 | |||
29 | UPSTREAM_CHECK_URI = "http://ftp.isc.org/isc/dhcp/" | ||
30 | UPSTREAM_CHECK_REGEX = "(?P<pver>\d+\.\d+\.(\d+?))/" | ||
31 | |||
32 | S = "${WORKDIR}/dhcp-4.4.2-P1" | ||
33 | |||
34 | inherit autotools-brokensep systemd | ||
35 | |||
36 | SYSTEMD_SERVICE:${PN} = "dhcrelay.service" | ||
37 | SYSTEMD_AUTO_ENABLE:${PN} = "disable" | ||
38 | |||
39 | CFLAGS += "-D_GNU_SOURCE -fcommon" | ||
40 | LDFLAGS:append = " -pthread" | ||
41 | |||
42 | EXTRA_OECONF = "--enable-paranoia \ | ||
43 | --disable-static \ | ||
44 | --enable-libtool \ | ||
45 | --with-randomdev=/dev/random \ | ||
46 | " | ||
47 | |||
48 | # Enable shared libs per dhcp README | ||
49 | do_configure:prepend () { | ||
50 | cp configure.ac+lt configure.ac | ||
51 | cp ${WORKDIR}/bind-9.11.32.tar.gz ${S}/bind/bind.tar.gz | ||
52 | } | ||
53 | |||
54 | do_compile:prepend() { | ||
55 | # Need to unpack this now instead of earlier as do_configure will delete the configure script | ||
56 | rm -rf ${S}/bind/bind-9.11.32/ | ||
57 | tar xf ${S}/bind/bind.tar.gz -C ${S}/bind | ||
58 | install -m 0755 ${STAGING_DATADIR_NATIVE}/gnu-config/config.guess ${S}/bind/bind-9.11.32/ | ||
59 | install -m 0755 ${STAGING_DATADIR_NATIVE}/gnu-config/config.sub ${S}/bind/bind-9.11.32/ | ||
60 | cp -fpR ${S}/m4/*.m4 ${S}/bind/bind-9.11.32/libtool.m4/ | ||
61 | rm -rf ${S}/bind/bind-9.11.32/libtool | ||
62 | install -m 0755 ${S}/libtool ${S}/bind/bind-9.11.32/ | ||
63 | } | ||
64 | |||
65 | do_install:append () { | ||
66 | install -Dm 0644 ${WORKDIR}/default-relay ${D}${sysconfdir}/default/dhcp-relay | ||
67 | install -Dm 0755 ${B}/bind/bind-9.11.32/lib/isccfg/.libs/libisccfg.so.163 ${D}${libdir}/libisccfg.so.163 | ||
68 | install -Dm 0755 ${B}/bind/bind-9.11.32/lib/dns/.libs/libdns.so.1115 ${D}${libdir}/libdns.so.1115 | ||
69 | chrpath --delete ${D}${libdir}/libisccfg.so.163 | ||
70 | chrpath --delete ${D}${libdir}/libdns.so.1115 | ||
71 | |||
72 | if ${@bb.utils.contains('DISTRO_FEATURES','systemd','true','false',d)}; then | ||
73 | install -d ${D}${systemd_unitdir}/system | ||
74 | install -m 0644 ${WORKDIR}/dhcrelay.service ${D}${systemd_unitdir}/system | ||
75 | sed -i -e 's,@SBINDIR@,${sbindir},g' ${D}${systemd_unitdir}/system/dhcrelay.service | ||
76 | sed -i -e 's,@SYSCONFDIR@,${sysconfdir},g' ${D}${systemd_unitdir}/system/dhcrelay.service | ||
77 | else | ||
78 | install -d ${D}${sysconfdir}/init.d | ||
79 | install -m 0755 ${WORKDIR}/init-relay ${D}${sysconfdir}/init.d/dhcp-relay | ||
80 | fi | ||
81 | } | ||
82 | |||
83 | PARALLEL_MAKE = "" | ||
diff --git a/meta-networking/recipes-connectivity/dhcp/dhcp-relay_4.4.3.bb b/meta-networking/recipes-connectivity/dhcp/dhcp-relay_4.4.3.bb new file mode 100644 index 000000000..92c648708 --- /dev/null +++ b/meta-networking/recipes-connectivity/dhcp/dhcp-relay_4.4.3.bb | |||
@@ -0,0 +1,62 @@ | |||
1 | SECTION = "console/network" | ||
2 | SUMMARY = "Internet Software Consortium DHCP Relay Agent" | ||
3 | DESCRIPTION = "A DHCP relay agent passes DHCP requests from one \ | ||
4 | LAN to another, so that a DHCP server is not needed on every LAN." | ||
5 | |||
6 | HOMEPAGE = "http://www.isc.org/" | ||
7 | |||
8 | LICENSE = "MPL-2.0" | ||
9 | LIC_FILES_CHKSUM = "file://LICENSE;md5=c463f4afde26d9eb60f14f50aeb85f8f" | ||
10 | |||
11 | DEPENDS = "openssl libcap zlib" | ||
12 | |||
13 | SRC_URI = "https://downloads.isc.org/isc/dhcp/${PV}/dhcp-${PV}.tar.gz \ | ||
14 | file://default-relay \ | ||
15 | file://init-relay \ | ||
16 | file://dhcrelay.service \ | ||
17 | file://0001-Makefile.am-only-build-dhcrelay.patch \ | ||
18 | file://0002-bind-Makefile.in-disable-backtrace.patch \ | ||
19 | file://0003-bind-Makefile.in-regenerate-configure.patch \ | ||
20 | " | ||
21 | |||
22 | SRC_URI[sha256sum] = "0e3ec6b4c2a05ec0148874bcd999a66d05518378d77421f607fb0bc9d0135818" | ||
23 | |||
24 | UPSTREAM_CHECK_URI = "http://ftp.isc.org/isc/dhcp/" | ||
25 | UPSTREAM_CHECK_REGEX = "(?P<pver>\d+\.\d+\.(\d+?))/" | ||
26 | |||
27 | S = "${WORKDIR}/dhcp-${PV}" | ||
28 | |||
29 | inherit autotools-brokensep systemd pkgconfig | ||
30 | |||
31 | SYSTEMD_SERVICE:${PN} = "dhcrelay.service" | ||
32 | SYSTEMD_AUTO_ENABLE:${PN} = "disable" | ||
33 | |||
34 | CFLAGS += "-D_GNU_SOURCE -fcommon" | ||
35 | LDFLAGS:append = " -pthread" | ||
36 | |||
37 | EXTRA_OECONF = "--enable-paranoia \ | ||
38 | --disable-static \ | ||
39 | --enable-libtool \ | ||
40 | --with-randomdev=/dev/random \ | ||
41 | " | ||
42 | |||
43 | # Enable shared libs per dhcp README | ||
44 | do_configure:prepend () { | ||
45 | cp configure.ac+lt configure.ac | ||
46 | } | ||
47 | |||
48 | do_install:append () { | ||
49 | install -Dm 0644 ${WORKDIR}/default-relay ${D}${sysconfdir}/default/dhcp-relay | ||
50 | |||
51 | if ${@bb.utils.contains('DISTRO_FEATURES','systemd','true','false',d)}; then | ||
52 | install -d ${D}${systemd_unitdir}/system | ||
53 | install -m 0644 ${WORKDIR}/dhcrelay.service ${D}${systemd_unitdir}/system | ||
54 | sed -i -e 's,@SBINDIR@,${sbindir},g' ${D}${systemd_unitdir}/system/dhcrelay.service | ||
55 | sed -i -e 's,@SYSCONFDIR@,${sysconfdir},g' ${D}${systemd_unitdir}/system/dhcrelay.service | ||
56 | else | ||
57 | install -d ${D}${sysconfdir}/init.d | ||
58 | install -m 0755 ${WORKDIR}/init-relay ${D}${sysconfdir}/init.d/dhcp-relay | ||
59 | fi | ||
60 | } | ||
61 | |||
62 | PARALLEL_MAKE = "" | ||
diff --git a/meta-networking/recipes-connectivity/dhcp/files/0001-Makefile.am-only-build-dhcrelay.patch b/meta-networking/recipes-connectivity/dhcp/files/0001-Makefile.am-only-build-dhcrelay.patch index fed85d2a8..5320d7c9e 100644 --- a/meta-networking/recipes-connectivity/dhcp/files/0001-Makefile.am-only-build-dhcrelay.patch +++ b/meta-networking/recipes-connectivity/dhcp/files/0001-Makefile.am-only-build-dhcrelay.patch | |||
@@ -1,4 +1,4 @@ | |||
1 | From 17cc080e58894644dd18664ac6f3451096d5f065 Mon Sep 17 00:00:00 2001 | 1 | From 4fd67b6adb7c1d8524ba17d1a0b3894f901555a9 Mon Sep 17 00:00:00 2001 |
2 | From: Yi Zhao <yi.zhao@windriver.com> | 2 | From: Yi Zhao <yi.zhao@windriver.com> |
3 | Date: Thu, 13 May 2021 15:23:16 +0800 | 3 | Date: Thu, 13 May 2021 15:23:16 +0800 |
4 | Subject: [PATCH] Makefile.am: only build dhcrelay | 4 | Subject: [PATCH] Makefile.am: only build dhcrelay |
@@ -26,5 +26,5 @@ index ed692a5..34f9772 100644 | |||
26 | DIST_SUBDIRS = $(SUBDIRS) keama | 26 | DIST_SUBDIRS = $(SUBDIRS) keama |
27 | 27 | ||
28 | -- | 28 | -- |
29 | 2.17.1 | 29 | 2.25.1 |
30 | 30 | ||
diff --git a/meta-networking/recipes-connectivity/dhcp/files/0003-bind-Makefile.in-disable-backtrace.patch b/meta-networking/recipes-connectivity/dhcp/files/0002-bind-Makefile.in-disable-backtrace.patch index 51520bc62..631a640ec 100644 --- a/meta-networking/recipes-connectivity/dhcp/files/0003-bind-Makefile.in-disable-backtrace.patch +++ b/meta-networking/recipes-connectivity/dhcp/files/0002-bind-Makefile.in-disable-backtrace.patch | |||
@@ -1,4 +1,4 @@ | |||
1 | From bc9c5d64ad4829c7830ef70fcaff94470974247c Mon Sep 17 00:00:00 2001 | 1 | From 6c6bbfe6b33e5c7e46a4260d656593dbe610fd8a Mon Sep 17 00:00:00 2001 |
2 | From: Yi Zhao <yi.zhao@windriver.com> | 2 | From: Yi Zhao <yi.zhao@windriver.com> |
3 | Date: Tue, 8 Jun 2021 10:13:57 +0800 | 3 | Date: Tue, 8 Jun 2021 10:13:57 +0800 |
4 | Subject: [PATCH] bind/Makefile.in: disable backtrace | 4 | Subject: [PATCH] bind/Makefile.in: disable backtrace |
@@ -14,7 +14,7 @@ Signed-off-by: Yi Zhao <yi.zhao@windriver.com> | |||
14 | 1 file changed, 1 insertion(+), 1 deletion(-) | 14 | 1 file changed, 1 insertion(+), 1 deletion(-) |
15 | 15 | ||
16 | diff --git a/bind/Makefile.in b/bind/Makefile.in | 16 | diff --git a/bind/Makefile.in b/bind/Makefile.in |
17 | index 8fe8883..1058160 100644 | 17 | index 2e60091..533d55c 100644 |
18 | --- a/bind/Makefile.in | 18 | --- a/bind/Makefile.in |
19 | +++ b/bind/Makefile.in | 19 | +++ b/bind/Makefile.in |
20 | @@ -22,7 +22,7 @@ prefix = @prefix@ | 20 | @@ -22,7 +22,7 @@ prefix = @prefix@ |
@@ -27,5 +27,5 @@ index 8fe8883..1058160 100644 | |||
27 | @BINDLT@ @BINDIOMUX@ @BINDCONFIG@ --enable-full-report | 27 | @BINDLT@ @BINDIOMUX@ @BINDCONFIG@ --enable-full-report |
28 | 28 | ||
29 | -- | 29 | -- |
30 | 2.17.1 | 30 | 2.25.1 |
31 | 31 | ||
diff --git a/meta-networking/recipes-connectivity/dhcp/files/0002-bind-version-update-to-latest-version.patch b/meta-networking/recipes-connectivity/dhcp/files/0002-bind-version-update-to-latest-version.patch deleted file mode 100644 index 5c7a5f058..000000000 --- a/meta-networking/recipes-connectivity/dhcp/files/0002-bind-version-update-to-latest-version.patch +++ /dev/null | |||
@@ -1,30 +0,0 @@ | |||
1 | From edb68972f8dc636e6208e78f02dec6f9805e4c0b Mon Sep 17 00:00:00 2001 | ||
2 | From: Yi Zhao <yi.zhao@windriver.com> | ||
3 | Date: Wed, 26 May 2021 11:39:00 +0800 | ||
4 | Subject: [PATCH] bind/version: update to latest version | ||
5 | |||
6 | Update the bundled bind from 9.11.14 to 9.11.32. | ||
7 | |||
8 | Upstream-Status: Inappropriate [embedded specific] | ||
9 | |||
10 | Signed-off-by: Yi Zhao <yi.zhao@windriver.com> | ||
11 | --- | ||
12 | bind/version.tmp | 2 +- | ||
13 | 1 file changed, 1 insertion(+), 1 deletion(-) | ||
14 | |||
15 | diff --git a/bind/version.tmp b/bind/version.tmp | ||
16 | index cf52f1b..4cc538e 100644 | ||
17 | --- a/bind/version.tmp | ||
18 | +++ b/bind/version.tmp | ||
19 | @@ -5,7 +5,7 @@ PRODUCT=BIND | ||
20 | DESCRIPTION="(Extended Support Version)" | ||
21 | MAJORVER=9 | ||
22 | MINORVER=11 | ||
23 | -PATCHVER=14 | ||
24 | +PATCHVER=32 | ||
25 | RELEASETYPE= | ||
26 | RELEASEVER= | ||
27 | EXTENSIONS= | ||
28 | -- | ||
29 | 2.17.1 | ||
30 | |||
diff --git a/meta-networking/recipes-connectivity/dhcp/files/0003-bind-Makefile.in-regenerate-configure.patch b/meta-networking/recipes-connectivity/dhcp/files/0003-bind-Makefile.in-regenerate-configure.patch new file mode 100644 index 000000000..71be0276a --- /dev/null +++ b/meta-networking/recipes-connectivity/dhcp/files/0003-bind-Makefile.in-regenerate-configure.patch | |||
@@ -0,0 +1,30 @@ | |||
1 | From 6ca1b224032355521b35471d222d0b09c08369a0 Mon Sep 17 00:00:00 2001 | ||
2 | From: Yi Zhao <yi.zhao@windriver.com> | ||
3 | Date: Thu, 27 May 2021 11:38:36 +0800 | ||
4 | Subject: [PATCH] bind/Makefile.in: regenerate configure | ||
5 | |||
6 | Run autogen.sh to regenerate configure. | ||
7 | |||
8 | Upstream-Status: Inappropriate [embedded specific] | ||
9 | |||
10 | Signed-off-by: Yi Zhao <yi.zhao@windriver.com> | ||
11 | --- | ||
12 | bind/Makefile.in | 2 +- | ||
13 | 1 file changed, 1 insertion(+), 1 deletion(-) | ||
14 | |||
15 | diff --git a/bind/Makefile.in b/bind/Makefile.in | ||
16 | index 533d55c..fdffe15 100644 | ||
17 | --- a/bind/Makefile.in | ||
18 | +++ b/bind/Makefile.in | ||
19 | @@ -55,7 +55,7 @@ bind1: | ||
20 | else \ | ||
21 | echo Configuring BIND libraries for DHCP. ; \ | ||
22 | rm -rf ${cleandirs} ${cleanfiles} ; \ | ||
23 | - (cd ${bindsrcdir} && \ | ||
24 | + (cd ${bindsrcdir} && ./autogen.sh && \ | ||
25 | ./configure ${bindconfig} > ${binddir}/configure.log); \ | ||
26 | fi | ||
27 | |||
28 | -- | ||
29 | 2.25.1 | ||
30 | |||