diff options
author | Yi Zhao <yi.zhao@windriver.com> | 2022-06-13 23:12:53 +0800 |
---|---|---|
committer | Khem Raj <raj.khem@gmail.com> | 2022-06-30 13:39:27 -0400 |
commit | 63d49fd481fb99b015c86c22f65e579da43e3c24 (patch) | |
tree | ead4e98e990a08e0c0ebd86a65db38adc488ba18 /meta-networking | |
parent | ca925409619c548da3c000cdd541c7fea7d44414 (diff) | |
download | meta-openembedded-63d49fd481fb99b015c86c22f65e579da43e3c24.tar.gz |
openvpn: eliminate build path from openvpn --version option
Before the patch:
$ openvpn --version
OpenVPN 2.5.7 x86_64-poky-linux-gnu [SSL (OpenSSL)] [LZO] [LZ4] [EPOLL]
[snip]
Compile time defines: enable_async_push=no enable_comp_stub=no
[snip]
with_crypto_library=openssl with_gnu_ld=yes
with_libtool_sysroot=/buildarea/build/tmp/work/core2-64-poky-linux/openvpn/2.5.7-r0/recipe-sysroot
with_mem_check=no with_openssl_engine=auto
After the patch:
$ openvpn --version
OpenVPN 2.5.7 x86_64-poky-linux-gnu [SSL (OpenSSL)] [LZO] [LZ4] [EPOLL]
[snip]
Compile time defines: enable_async_push=no enable_comp_stub=no
[snip]
with_crypto_library=openssl with_gnu_ld=yes with_mem_check=no
with_openssl_engine=auto
Signed-off-by: Yi Zhao <yi.zhao@windriver.com>
Signed-off-by: Khem Raj <raj.khem@gmail.com>
Diffstat (limited to 'meta-networking')
-rw-r--r-- | meta-networking/recipes-support/openvpn/openvpn/0001-configure.ac-eliminate-build-path-from-openvpn-versi.patch | 48 | ||||
-rw-r--r-- | meta-networking/recipes-support/openvpn/openvpn_2.5.7.bb | 1 |
2 files changed, 49 insertions, 0 deletions
diff --git a/meta-networking/recipes-support/openvpn/openvpn/0001-configure.ac-eliminate-build-path-from-openvpn-versi.patch b/meta-networking/recipes-support/openvpn/openvpn/0001-configure.ac-eliminate-build-path-from-openvpn-versi.patch new file mode 100644 index 000000000..03b454d62 --- /dev/null +++ b/meta-networking/recipes-support/openvpn/openvpn/0001-configure.ac-eliminate-build-path-from-openvpn-versi.patch | |||
@@ -0,0 +1,48 @@ | |||
1 | From ea179d83b0aa62719d90748cd1fb260f40055f15 Mon Sep 17 00:00:00 2001 | ||
2 | From: Yi Zhao <yi.zhao@windriver.com> | ||
3 | Date: Mon, 13 Jun 2022 22:44:28 +0800 | ||
4 | Subject: [PATCH] configure.ac: eliminate build path from openvpn --version | ||
5 | option | ||
6 | |||
7 | Before the patch: | ||
8 | $ openvpn --version | ||
9 | OpenVPN 2.5.7 x86_64-poky-linux-gnu [SSL (OpenSSL)] [LZO] [LZ4] [EPOLL] | ||
10 | [snip] | ||
11 | Compile time defines: enable_async_push=no enable_comp_stub=no | ||
12 | [snip] | ||
13 | with_crypto_library=openssl with_gnu_ld=yes | ||
14 | with_libtool_sysroot=/buildarea/build/tmp/work/core2-64-poky-linux/openvpn/2.5.7-r0/recipe-sysroot | ||
15 | with_mem_check=no with_openssl_engine=auto | ||
16 | |||
17 | After the patch: | ||
18 | $ openvpn --version | ||
19 | OpenVPN 2.5.7 x86_64-poky-linux-gnu [SSL (OpenSSL)] [LZO] [LZ4] [EPOLL] | ||
20 | [snip] | ||
21 | Compile time defines: enable_async_push=no enable_comp_stub=no | ||
22 | [snip] | ||
23 | with_crypto_library=openssl with_gnu_ld=yes with_mem_check=no | ||
24 | with_openssl_engine=auto | ||
25 | |||
26 | Upstream-Status: Inappropriate [embedded specific] | ||
27 | |||
28 | Signed-off-by: Yi Zhao <yi.zhao@windriver.com> | ||
29 | --- | ||
30 | configure.ac | 2 +- | ||
31 | 1 file changed, 1 insertion(+), 1 deletion(-) | ||
32 | |||
33 | diff --git a/configure.ac b/configure.ac | ||
34 | index 2f5f6bc..eddcbc5 100644 | ||
35 | --- a/configure.ac | ||
36 | +++ b/configure.ac | ||
37 | @@ -1377,7 +1377,7 @@ if test "${enable_async_push}" = "yes"; then | ||
38 | esac | ||
39 | fi | ||
40 | |||
41 | -CONFIGURE_DEFINES="`set | grep '^enable_.*=' ; set | grep '^with_.*='`" | ||
42 | +CONFIGURE_DEFINES="`set | grep '^enable_.*=' ; set | grep '^with_.*=' | grep -v 'libtool_sysroot'`" | ||
43 | AC_DEFINE_UNQUOTED([CONFIGURE_DEFINES], ["`echo ${CONFIGURE_DEFINES}`"], [Configuration settings]) | ||
44 | |||
45 | TAP_WIN_COMPONENT_ID="PRODUCT_TAP_WIN_COMPONENT_ID" | ||
46 | -- | ||
47 | 2.25.1 | ||
48 | |||
diff --git a/meta-networking/recipes-support/openvpn/openvpn_2.5.7.bb b/meta-networking/recipes-support/openvpn/openvpn_2.5.7.bb index 3ed90a7c8..f9998aaa8 100644 --- a/meta-networking/recipes-support/openvpn/openvpn_2.5.7.bb +++ b/meta-networking/recipes-support/openvpn/openvpn_2.5.7.bb | |||
@@ -8,6 +8,7 @@ DEPENDS = "lzo openssl iproute2 ${@bb.utils.contains('DISTRO_FEATURES', 'pam', ' | |||
8 | inherit autotools systemd update-rc.d | 8 | inherit autotools systemd update-rc.d |
9 | 9 | ||
10 | SRC_URI = "http://swupdate.openvpn.org/community/releases/${BP}.tar.gz \ | 10 | SRC_URI = "http://swupdate.openvpn.org/community/releases/${BP}.tar.gz \ |
11 | file://0001-configure.ac-eliminate-build-path-from-openvpn-versi.patch \ | ||
11 | file://openvpn \ | 12 | file://openvpn \ |
12 | file://openvpn@.service \ | 13 | file://openvpn@.service \ |
13 | file://openvpn-volatile.conf" | 14 | file://openvpn-volatile.conf" |