diff options
author | Carlos Rafael Giani <dv@pseudoterminal.org> | 2018-07-15 17:46:43 +0200 |
---|---|---|
committer | Khem Raj <raj.khem@gmail.com> | 2018-07-15 11:58:02 -0700 |
commit | 2de6f8d1b4608dbdce391c3d89d01402eb641f52 (patch) | |
tree | 28a0a063ce73103fee81a39c3201ca3ae647087e /meta-networking | |
parent | cccf8fc305fb3da9bdaf26284488f03698b986dc (diff) | |
download | meta-openembedded-2de6f8d1b4608dbdce391c3d89d01402eb641f52.tar.gz |
nanomsg: add recipe
nanomsg is a socket library that provides several common communication
patterns. It is a rewrite of the ZeroMQ library. For differences between
ZeroMQ and nanomsg, consult https://nanomsg.org/documentation-zeromq.html
Signed-off-by: Carlos Rafael Giani <dv@pseudoterminal.org>
Signed-off-by: Khem Raj <raj.khem@gmail.com>
Diffstat (limited to 'meta-networking')
-rw-r--r-- | meta-networking/recipes-connectivity/nanomsg/nanomsg_1.1.4.bb | 28 |
1 files changed, 28 insertions, 0 deletions
diff --git a/meta-networking/recipes-connectivity/nanomsg/nanomsg_1.1.4.bb b/meta-networking/recipes-connectivity/nanomsg/nanomsg_1.1.4.bb new file mode 100644 index 000000000..fa6b43ace --- /dev/null +++ b/meta-networking/recipes-connectivity/nanomsg/nanomsg_1.1.4.bb | |||
@@ -0,0 +1,28 @@ | |||
1 | SUMMARY = "nanomsg socket library" | ||
2 | DESCRIPTION = "nanomsg is a socket library that provides several common \ | ||
3 | communication patterns. It aims to make the networking layer fast, scalable, \ | ||
4 | and easy to use. Implemented in C, it works on a wide range of operating \ | ||
5 | systems with no further dependencies." | ||
6 | HOMEPAGE = "https://nanomsg.org/" | ||
7 | LICENSE = "MIT-X" | ||
8 | LIC_FILES_CHKSUM = "file://COPYING;md5=587b3fd7fd291e418ff4d2b8f3904755" | ||
9 | |||
10 | SECTION = "libs/networking" | ||
11 | |||
12 | SRC_URI = "git://github.com/nanomsg/nanomsg.git;protocol=https" | ||
13 | SRCREV = "e7f8a751316b942d8962cd0232c2d606c1d9a9db" | ||
14 | |||
15 | S = "${WORKDIR}/git" | ||
16 | |||
17 | inherit cmake pkgconfig | ||
18 | |||
19 | # nanomsg documentation generation requires asciidoctor, | ||
20 | # not asciidoc, and currently there's no asciidoctor-native | ||
21 | # recipe anywhere in openembedded-core or meta-openembedded | ||
22 | EXTRA_OECMAKE = " -DNN_ENABLE_DOC=OFF " | ||
23 | |||
24 | # we don't want nanomsg-tools to be renamed to libnanomsg-tools | ||
25 | DEBIAN_NOAUTONAME_${PN}-tools = "1" | ||
26 | |||
27 | PACKAGES =+ "${PN}-tools" | ||
28 | FILES_${PN}-tools = "${bindir}/*" | ||