summaryrefslogtreecommitdiffstats
path: root/meta-networking
diff options
context:
space:
mode:
authorMartin Jansa <Martin.Jansa@gmail.com>2015-11-15 16:20:38 +0100
committerMartin Jansa <Martin.Jansa@gmail.com>2015-11-16 21:57:48 +0100
commite155307338c339b10a2d998fc6e0a00eafa465ef (patch)
tree69c920e312ee4fa1d1d7cb29ec47e741effbf654 /meta-networking
parent89163f1a8f3a45b8ce56cf77d6ae464dbd32890d (diff)
downloadmeta-openembedded-e155307338c339b10a2d998fc6e0a00eafa465ef.tar.gz
samba: add dependency on libbsd cyrus-sasl and PACKAGECONFIG for dmapi
* dmapi is in meta-filesystems * hopefully fixes: WARN: samba: samba rdepends on cyrus-sasl, but it isn't a build dependency? WARN: samba: samba rdepends on dmapi, but it isn't a build dependency? WARN: samba: samba rdepends on libbsd, but it isn't a build dependency? WARN: samba: samba rdepends on libpam, but it isn't a build dependency? WARN: samba: samba-python rdepends on libbsd, but it isn't a build dependency? Signed-off-by: Martin Jansa <Martin.Jansa@gmail.com>
Diffstat (limited to 'meta-networking')
-rw-r--r--meta-networking/recipes-connectivity/samba/samba_4.1.12.bb7
1 files changed, 4 insertions, 3 deletions
diff --git a/meta-networking/recipes-connectivity/samba/samba_4.1.12.bb b/meta-networking/recipes-connectivity/samba/samba_4.1.12.bb
index 04df8a3ce..cb29ab9d9 100644
--- a/meta-networking/recipes-connectivity/samba/samba_4.1.12.bb
+++ b/meta-networking/recipes-connectivity/samba/samba_4.1.12.bb
@@ -40,7 +40,8 @@ SRC_URI[sha256sum] = "033604674936bf5c77d7df299b0626052b84a41505a6a6afe902f6274f
40 40
41inherit systemd waf-samba cpan-base perlnative 41inherit systemd waf-samba cpan-base perlnative
42 42
43DEPENDS += "readline virtual/libiconv zlib popt talloc libtdb libtevent libldb krb5 ctdb" 43DEPENDS += "readline virtual/libiconv zlib popt talloc libtdb libtevent libldb krb5 ctdb libbsd cyrus-sasl"
44
44 45
45SYSVINITTYPE_linuxstdbase = "lsb" 46SYSVINITTYPE_linuxstdbase = "lsb"
46SYSVINITTYPE = "sysv" 47SYSVINITTYPE = "sysv"
@@ -57,11 +58,12 @@ RDEPENDS_${PN} += "${@bb.utils.contains('PACKAGECONFIG', 'lsb', 'lsb', '', d)}"
57PACKAGECONFIG[acl] = "--with-acl-support,---without-acl-support,acl" 58PACKAGECONFIG[acl] = "--with-acl-support,---without-acl-support,acl"
58PACKAGECONFIG[aio] = "--with-aio-support,---without-aio-support,libaio" 59PACKAGECONFIG[aio] = "--with-aio-support,---without-aio-support,libaio"
59PACKAGECONFIG[fam] = "--with-fam,--without-fam,gamin" 60PACKAGECONFIG[fam] = "--with-fam,--without-fam,gamin"
60PACKAGECONFIG[pam] = "--with-pam,--without-pam,libpam" 61PACKAGECONFIG[pam] = "--with-pam --with-pam_smbpass --with-pammodulesdir=${base_libdir}/security,--without-pam --without-pam_smbpass,libpam"
61PACKAGECONFIG[lsb] = ",,lsb" 62PACKAGECONFIG[lsb] = ",,lsb"
62PACKAGECONFIG[cups] = "--enable-cups,--disable-cups,cups" 63PACKAGECONFIG[cups] = "--enable-cups,--disable-cups,cups"
63PACKAGECONFIG[ldap] = "--with-ldap,--without-ldap,openldap" 64PACKAGECONFIG[ldap] = "--with-ldap,--without-ldap,openldap"
64PACKAGECONFIG[systemd] = "--with-systemd,--without-systemd,systemd" 65PACKAGECONFIG[systemd] = "--with-systemd,--without-systemd,systemd"
66PACKAGECONFIG[dmapi] = "--with-dmapi,--without-dmapi,dmapi"
65PACKAGECONFIG[zeroconf] = "--enable-avahi,--disable-avahi,avahi" 67PACKAGECONFIG[zeroconf] = "--enable-avahi,--disable-avahi,avahi"
66 68
67SAMBA4_IDMAP_MODULES="idmap_ad,idmap_rid,idmap_adex,idmap_hash,idmap_tdb2" 69SAMBA4_IDMAP_MODULES="idmap_ad,idmap_rid,idmap_adex,idmap_hash,idmap_tdb2"
@@ -77,7 +79,6 @@ EXTRA_OECONF += "--enable-fhs \
77 --with-piddir=${localstatedir}/run \ 79 --with-piddir=${localstatedir}/run \
78 --with-sockets-dir=${localstatedir}/run/samba \ 80 --with-sockets-dir=${localstatedir}/run/samba \
79 --with-modulesdir=${libdir}/samba \ 81 --with-modulesdir=${libdir}/samba \
80 --with-pammodulesdir=${base_libdir}/security \
81 --with-lockdir=${localstatedir}/lib/samba \ 82 --with-lockdir=${localstatedir}/lib/samba \
82 --with-cachedir=${localstatedir}/lib/samba \ 83 --with-cachedir=${localstatedir}/lib/samba \
83 --with-perl-lib-install-dir=${PERL_VERNDORLIB} \ 84 --with-perl-lib-install-dir=${PERL_VERNDORLIB} \