summaryrefslogtreecommitdiffstats
path: root/meta-networking
diff options
context:
space:
mode:
authorDai Caiyun <daicy.fnst@cn.fujitsu.com>2016-04-28 13:30:08 +0300
committerJoe MacDonald <joe_macdonald@mentor.com>2016-08-16 21:26:12 -0400
commite86c7ef20f90813146a565e9e9f5912d9a6c7b42 (patch)
treee525004bab4d1f6af7e4bf1ff87af999bbffa4f9 /meta-networking
parent35326fa74dee53ffa4bd454e5fc95fdcbf0d5da6 (diff)
downloadmeta-openembedded-e86c7ef20f90813146a565e9e9f5912d9a6c7b42.tar.gz
opensaf: make sure /etc/init.d/opensafd exist
when disable sysvinit and specify "systemd" in DISTRO_FEATURES, the recipe "inhert systemd" will delete "/etc/init.d/opensafd",but "/etc/init.d/opensafd" is needed to start opensafd.service. Signed-off-by: Dai Caiyun <daicy.fnst@cn.fujitsu.com> Signed-off-by: Martin Jansa <Martin.Jansa@gmail.com> Signed-off-by: Joe MacDonald <joe_macdonald@mentor.com>
Diffstat (limited to 'meta-networking')
-rw-r--r--meta-networking/recipes-daemons/opensaf/opensaf_5.0.0.bb12
1 files changed, 11 insertions, 1 deletions
diff --git a/meta-networking/recipes-daemons/opensaf/opensaf_5.0.0.bb b/meta-networking/recipes-daemons/opensaf/opensaf_5.0.0.bb
index f6873781d..da9c10520 100644
--- a/meta-networking/recipes-daemons/opensaf/opensaf_5.0.0.bb
+++ b/meta-networking/recipes-daemons/opensaf/opensaf_5.0.0.bb
@@ -55,9 +55,19 @@ do_install_append() {
55 install -m 0644 ${B}/contrib/plmc/config/*.service ${D}/${systemd_unitdir}/system 55 install -m 0644 ${B}/contrib/plmc/config/*.service ${D}/${systemd_unitdir}/system
56} 56}
57 57
58FILES_${PN} += "${localstatedir}/run" 58FILES_${PN} += "${localstatedir}/run ${systemd_unitdir}/system/*.service"
59FILES_${PN}-staticdev += "${PKGLIBDIR}/*.a" 59FILES_${PN}-staticdev += "${PKGLIBDIR}/*.a"
60 60
61INSANE_SKIP_${PN} = "dev-so" 61INSANE_SKIP_${PN} = "dev-so"
62 62
63RDEPENDS_${PN} += "bash python" 63RDEPENDS_${PN} += "bash python"
64
65do_sysvinit_install() {
66 if [ ! -d "${D}${sysconfdir}/init.d" ]; then
67 install -d ${D}${sysconfdir}/init.d
68 install -m 0755 ${B}/osaf/services/infrastructure/nid/scripts/opensafd ${D}${sysconfdir}/init.d/
69 fi
70}
71
72addtask sysvinit_install after do_install before do_package
73