summaryrefslogtreecommitdiffstats
path: root/meta-networking
diff options
context:
space:
mode:
authorKhem Raj <raj.khem@gmail.com>2021-07-31 17:44:35 -0700
committerKhem Raj <raj.khem@gmail.com>2021-08-03 08:53:04 -0700
commitdaf661d19b78d013a6af6ff0a9e9bee3473ee3ab (patch)
tree06d870466d1f3ee618d1dc392c9f8044c5889185 /meta-networking
parent7055c764c83150f9310ce04bcfb19330460582fc (diff)
downloadmeta-openembedded-daf661d19b78d013a6af6ff0a9e9bee3473ee3ab.tar.gz
ntp: Fix make check
Some test code is not yet ported to build with gcc 11 Signed-off-by: Khem Raj <raj.khem@gmail.com>
Diffstat (limited to 'meta-networking')
-rw-r--r--meta-networking/recipes-support/ntp/ntp/0001-test-Fix-build-with-new-compiler-defaults-to-fno-com.patch66
-rw-r--r--meta-networking/recipes-support/ntp/ntp_4.2.8p15.bb1
2 files changed, 67 insertions, 0 deletions
diff --git a/meta-networking/recipes-support/ntp/ntp/0001-test-Fix-build-with-new-compiler-defaults-to-fno-com.patch b/meta-networking/recipes-support/ntp/ntp/0001-test-Fix-build-with-new-compiler-defaults-to-fno-com.patch
new file mode 100644
index 000000000..42e1efd8b
--- /dev/null
+++ b/meta-networking/recipes-support/ntp/ntp/0001-test-Fix-build-with-new-compiler-defaults-to-fno-com.patch
@@ -0,0 +1,66 @@
1From 778f3cddc20930185a917fa3f8ffe1ef2b0b0ea0 Mon Sep 17 00:00:00 2001
2From: Khem Raj <raj.khem@gmail.com>
3Date: Sat, 31 Jul 2021 13:27:16 -0700
4Subject: [PATCH] test: Fix build with new compiler defaults to -fno-common
5
6Upstream-Status: Pending
7Signed-off-by: Khem Raj <raj.khem@gmail.com>
8---
9 sntp/tests/run-packetHandling.c | 2 +-
10 sntp/tests/run-t-log.c | 2 +-
11 sntp/tests/run-utilities.c | 2 +-
12 tests/libntp/test-libntp.h | 2 +-
13 4 files changed, 4 insertions(+), 4 deletions(-)
14
15diff --git a/sntp/tests/run-packetHandling.c b/sntp/tests/run-packetHandling.c
16index 7790b20..c58380c 100644
17--- a/sntp/tests/run-packetHandling.c
18+++ b/sntp/tests/run-packetHandling.c
19@@ -64,7 +64,7 @@ void resetTest(void)
20 setUp();
21 }
22
23-char const *progname;
24+extern char const *progname;
25
26
27 //=======MAIN=====
28diff --git a/sntp/tests/run-t-log.c b/sntp/tests/run-t-log.c
29index 268bf41..cd835bc 100644
30--- a/sntp/tests/run-t-log.c
31+++ b/sntp/tests/run-t-log.c
32@@ -50,7 +50,7 @@ void resetTest(void)
33 setUp();
34 }
35
36-char const *progname;
37+extern char const *progname;
38
39
40 //=======MAIN=====
41diff --git a/sntp/tests/run-utilities.c b/sntp/tests/run-utilities.c
42index f717882..98d9bf1 100644
43--- a/sntp/tests/run-utilities.c
44+++ b/sntp/tests/run-utilities.c
45@@ -58,7 +58,7 @@ void resetTest(void)
46 setUp();
47 }
48
49-char const *progname;
50+extern char const *progname;
51
52
53 //=======MAIN=====
54diff --git a/tests/libntp/test-libntp.h b/tests/libntp/test-libntp.h
55index 93050b3..60461d8 100644
56--- a/tests/libntp/test-libntp.h
57+++ b/tests/libntp/test-libntp.h
58@@ -5,4 +5,4 @@
59
60 time_t timefunc(time_t *ptr);
61 void settime(int y, int m, int d, int H, int M, int S);
62-time_t nowtime;
63+extern time_t nowtime;
64--
652.32.0
66
diff --git a/meta-networking/recipes-support/ntp/ntp_4.2.8p15.bb b/meta-networking/recipes-support/ntp/ntp_4.2.8p15.bb
index 6129bab26..37f67095c 100644
--- a/meta-networking/recipes-support/ntp/ntp_4.2.8p15.bb
+++ b/meta-networking/recipes-support/ntp/ntp_4.2.8p15.bb
@@ -14,6 +14,7 @@ SRC_URI = "http://www.eecis.udel.edu/~ntp/ntp_spool/ntp4/ntp-4.2/ntp-${PV}.tar.g
14 file://ntp-4.2.4_p6-nano.patch \ 14 file://ntp-4.2.4_p6-nano.patch \
15 file://reproducibility-fixed-path-to-posix-shell.patch \ 15 file://reproducibility-fixed-path-to-posix-shell.patch \
16 file://0001-libntp-Do-not-use-PTHREAD_STACK_MIN-on-glibc.patch \ 16 file://0001-libntp-Do-not-use-PTHREAD_STACK_MIN-on-glibc.patch \
17 file://0001-test-Fix-build-with-new-compiler-defaults-to-fno-com.patch \
17 file://ntpd \ 18 file://ntpd \
18 file://ntp.conf \ 19 file://ntp.conf \
19 file://ntpdate \ 20 file://ntpdate \