summaryrefslogtreecommitdiffstats
path: root/meta-networking
diff options
context:
space:
mode:
authorKhem Raj <raj.khem@gmail.com>2021-07-31 09:06:00 -0700
committerKhem Raj <raj.khem@gmail.com>2021-08-03 08:53:03 -0700
commit96e37f4a59af820f86671c46f25187ed3eaec272 (patch)
tree7c88e89d4fc98016621f75a2a76a47a15b4c6310 /meta-networking
parent80957c276a7b8288172b544338b0bf88050a9540 (diff)
downloadmeta-openembedded-96e37f4a59af820f86671c46f25187ed3eaec272.tar.gz
addcli: check for ns_get16 and ns_get32
Fixes build with glibc 2.34+ Signed-off-by: Khem Raj <raj.khem@gmail.com>
Diffstat (limited to 'meta-networking')
-rw-r--r--meta-networking/recipes-connectivity/adcli/adcli_0.9.0.bb3
-rw-r--r--meta-networking/recipes-connectivity/adcli/files/0001-configure-check-for-ns_get16-and-ns_get32-as-well.patch39
2 files changed, 41 insertions, 1 deletions
diff --git a/meta-networking/recipes-connectivity/adcli/adcli_0.9.0.bb b/meta-networking/recipes-connectivity/adcli/adcli_0.9.0.bb
index 76df27851..074292b43 100644
--- a/meta-networking/recipes-connectivity/adcli/adcli_0.9.0.bb
+++ b/meta-networking/recipes-connectivity/adcli/adcli_0.9.0.bb
@@ -8,6 +8,7 @@ SRCREV = "1b1528038e084a9f81ea108cffca9c2707623b9c"
8 8
9SRC_URI = "git://gitlab.freedesktop.org/realmd/adcli;branch=master \ 9SRC_URI = "git://gitlab.freedesktop.org/realmd/adcli;branch=master \
10 file://Fixed-build-error-on-musl.patch \ 10 file://Fixed-build-error-on-musl.patch \
11 file://0001-configure-check-for-ns_get16-and-ns_get32-as-well.patch \
11 " 12 "
12 13
13S = "${WORKDIR}/git" 14S = "${WORKDIR}/git"
@@ -15,7 +16,7 @@ S = "${WORKDIR}/git"
15LICENSE = "LGPLv2+" 16LICENSE = "LGPLv2+"
16LIC_FILES_CHKSUM = "file://COPYING;md5=23c2a5e0106b99d75238986559bb5fc6" 17LIC_FILES_CHKSUM = "file://COPYING;md5=23c2a5e0106b99d75238986559bb5fc6"
17 18
18inherit autotools xmlcatalog 19inherit autotools xmlcatalog
19 20
20DEPENDS += "virtual/crypt krb5 openldap gettext libxslt xmlto libxml2-native \ 21DEPENDS += "virtual/crypt krb5 openldap gettext libxslt xmlto libxml2-native \
21 cyrus-sasl libxslt-native xmlto-native coreutils-native\ 22 cyrus-sasl libxslt-native xmlto-native coreutils-native\
diff --git a/meta-networking/recipes-connectivity/adcli/files/0001-configure-check-for-ns_get16-and-ns_get32-as-well.patch b/meta-networking/recipes-connectivity/adcli/files/0001-configure-check-for-ns_get16-and-ns_get32-as-well.patch
new file mode 100644
index 000000000..8cc859318
--- /dev/null
+++ b/meta-networking/recipes-connectivity/adcli/files/0001-configure-check-for-ns_get16-and-ns_get32-as-well.patch
@@ -0,0 +1,39 @@
1From 98660f57a98f45dbf55414cfde46338019adcc33 Mon Sep 17 00:00:00 2001
2From: Sumit Bose <sbose@redhat.com>
3Date: Wed, 28 Jul 2021 12:55:16 +0200
4Subject: [PATCH] configure: check for ns_get16 and ns_get32 as well
5
6With newer versions of glibc res_query() might ba already available in
7glibc with ns_get16() and ns_get32() still requires libresolv.
8
9Upstream-Status: Backport [https://gitlab.freedesktop.org/realmd/adcli/-/commit/e841ba7513f3f8b6393183d2dea9adcbf7ba2e44]
10Resolves: https://bugzilla.redhat.com/show_bug.cgi?id=1984891
11Signed-off-by: Khem Raj <raj.khem@gmail.com>
12---
13 configure.ac | 6 ++++--
14 1 file changed, 4 insertions(+), 2 deletions(-)
15
16diff --git a/configure.ac b/configure.ac
17index ebc6cb4..e8775d0 100644
18--- a/configure.ac
19+++ b/configure.ac
20@@ -98,13 +98,15 @@ AC_SUBST(LDAP_CFLAGS)
21 # -------------------------------------------------------------------
22 # resolv
23
24-AC_MSG_CHECKING(for which library has res_query)
25+AC_MSG_CHECKING([for which library has res_query, ns_get16 and ns_get32])
26 for lib in "" "-lresolv"; do
27 saved_LIBS="$LIBS"
28 LIBS="$LIBS $lib"
29 AC_LINK_IFELSE([
30 AC_LANG_PROGRAM([#include <resolv.h>],
31- [res_query (0, 0, 0, 0, 0)])
32+ [res_query (0, 0, 0, 0, 0);
33+ ns_get32 (NULL);
34+ ns_get16 (NULL);])
35 ],
36 [ AC_MSG_RESULT(${lib:-libc}); have_res_query="yes"; break; ],
37 [ LIBS="$saved_LIBS" ])
38--
392.32.0