summaryrefslogtreecommitdiffstats
path: root/meta-networking
diff options
context:
space:
mode:
authorKhem Raj <raj.khem@gmail.com>2021-07-31 10:56:53 -0700
committerKhem Raj <raj.khem@gmail.com>2021-08-03 08:53:04 -0700
commit7055c764c83150f9310ce04bcfb19330460582fc (patch)
tree64bbf64db88ca3575d2703a162a7155d302e5483 /meta-networking
parentd94bafe1f91457d272cc87224a359abf7ea9d364 (diff)
downloadmeta-openembedded-7055c764c83150f9310ce04bcfb19330460582fc.tar.gz
ntp: Do not use PTHREAD_STACK_MIN on glibc
Int not a compile time constant in glibc 2.34+ Signed-off-by: Khem Raj <raj.khem@gmail.com>
Diffstat (limited to 'meta-networking')
-rw-r--r--meta-networking/recipes-support/ntp/ntp/0001-libntp-Do-not-use-PTHREAD_STACK_MIN-on-glibc.patch32
-rw-r--r--meta-networking/recipes-support/ntp/ntp_4.2.8p15.bb1
2 files changed, 33 insertions, 0 deletions
diff --git a/meta-networking/recipes-support/ntp/ntp/0001-libntp-Do-not-use-PTHREAD_STACK_MIN-on-glibc.patch b/meta-networking/recipes-support/ntp/ntp/0001-libntp-Do-not-use-PTHREAD_STACK_MIN-on-glibc.patch
new file mode 100644
index 000000000..372938c6d
--- /dev/null
+++ b/meta-networking/recipes-support/ntp/ntp/0001-libntp-Do-not-use-PTHREAD_STACK_MIN-on-glibc.patch
@@ -0,0 +1,32 @@
1From 082a504cfcc046c3d8adaae1164268bc94e5108a Mon Sep 17 00:00:00 2001
2From: Khem Raj <raj.khem@gmail.com>
3Date: Sat, 31 Jul 2021 10:51:41 -0700
4Subject: [PATCH] libntp: Do not use PTHREAD_STACK_MIN on glibc
5
6In glibc 2.34+ PTHREAD_STACK_MIN is not a compile-time constant which
7could mean different stack sizes at runtime on different architectures
8and it also causes compile failure. Default glibc thread stack size
9or 64Kb set by ntp should be good in glibc these days.
10
11Upstream-Status: Pending
12Signed-off-by: Khem Raj <raj.khem@gmail.com>
13---
14 libntp/work_thread.c | 2 +-
15 1 file changed, 1 insertion(+), 1 deletion(-)
16
17diff --git a/libntp/work_thread.c b/libntp/work_thread.c
18index 03a5647..3ddd751 100644
19--- a/libntp/work_thread.c
20+++ b/libntp/work_thread.c
21@@ -41,7 +41,7 @@
22 #ifndef THREAD_MINSTACKSIZE
23 # define THREAD_MINSTACKSIZE (64U * 1024)
24 #endif
25-#ifndef __sun
26+#if !defined(__sun) && !defined(__GLIBC__)
27 #if defined(PTHREAD_STACK_MIN) && THREAD_MINSTACKSIZE < PTHREAD_STACK_MIN
28 # undef THREAD_MINSTACKSIZE
29 # define THREAD_MINSTACKSIZE PTHREAD_STACK_MIN
30--
312.32.0
32
diff --git a/meta-networking/recipes-support/ntp/ntp_4.2.8p15.bb b/meta-networking/recipes-support/ntp/ntp_4.2.8p15.bb
index e668113c5..6129bab26 100644
--- a/meta-networking/recipes-support/ntp/ntp_4.2.8p15.bb
+++ b/meta-networking/recipes-support/ntp/ntp_4.2.8p15.bb
@@ -13,6 +13,7 @@ DEPENDS = "libevent"
13SRC_URI = "http://www.eecis.udel.edu/~ntp/ntp_spool/ntp4/ntp-4.2/ntp-${PV}.tar.gz \ 13SRC_URI = "http://www.eecis.udel.edu/~ntp/ntp_spool/ntp4/ntp-4.2/ntp-${PV}.tar.gz \
14 file://ntp-4.2.4_p6-nano.patch \ 14 file://ntp-4.2.4_p6-nano.patch \
15 file://reproducibility-fixed-path-to-posix-shell.patch \ 15 file://reproducibility-fixed-path-to-posix-shell.patch \
16 file://0001-libntp-Do-not-use-PTHREAD_STACK_MIN-on-glibc.patch \
16 file://ntpd \ 17 file://ntpd \
17 file://ntp.conf \ 18 file://ntp.conf \
18 file://ntpdate \ 19 file://ntpdate \