diff options
author | Khem Raj <raj.khem@gmail.com> | 2017-09-15 15:58:26 -0700 |
---|---|---|
committer | Joe MacDonald <joe_macdonald@mentor.com> | 2017-09-22 14:37:18 -0400 |
commit | 67cd47880b0bbbcbaec54b61cac6ab00afeb7c0e (patch) | |
tree | afff67042fae7a5817c59f68c1e56a3339124301 /meta-networking | |
parent | 78ef2f867320384ed5cc95592ee9d709ff8c5751 (diff) | |
download | meta-openembedded-67cd47880b0bbbcbaec54b61cac6ab00afeb7c0e.tar.gz |
opensaf: Upgrade to 5.17.07
Signed-off-by: Khem Raj <raj.khem@gmail.com>
Signed-off-by: Martin Jansa <Martin.Jansa@gmail.com>
Signed-off-by: Joe MacDonald <joe_macdonald@mentor.com>
Diffstat (limited to 'meta-networking')
-rw-r--r-- | meta-networking/recipes-daemons/opensaf/opensaf/0001-Remove-unused-variables.patch | 43 | ||||
-rw-r--r-- | meta-networking/recipes-daemons/opensaf/opensaf/0001-immpbe_dump.cc-Use-sys-wait.h-instead-of-wait.h.patch | 34 | ||||
-rw-r--r-- | meta-networking/recipes-daemons/opensaf/opensaf/0001-src-Add-missing-header-limits.h-for-_POSIX_HOST_NAME.patch | 122 | ||||
-rw-r--r-- | meta-networking/recipes-daemons/opensaf/opensaf_5.17.07.bb (renamed from meta-networking/recipes-daemons/opensaf/opensaf_5.2.0.bb) | 7 |
4 files changed, 160 insertions, 46 deletions
diff --git a/meta-networking/recipes-daemons/opensaf/opensaf/0001-Remove-unused-variables.patch b/meta-networking/recipes-daemons/opensaf/opensaf/0001-Remove-unused-variables.patch deleted file mode 100644 index 1c88b81cd..000000000 --- a/meta-networking/recipes-daemons/opensaf/opensaf/0001-Remove-unused-variables.patch +++ /dev/null | |||
@@ -1,43 +0,0 @@ | |||
1 | From a441a75fbb8451268a8a57616c7158cddc1823aa Mon Sep 17 00:00:00 2001 | ||
2 | From: Khem Raj <raj.khem@gmail.com> | ||
3 | Date: Sat, 22 Apr 2017 12:40:19 -0700 | ||
4 | Subject: [PATCH] Remove unused variables | ||
5 | |||
6 | Fixes build errors with gcc7 e.g. | ||
7 | |||
8 | ../opensaf-5.2.0/src/amf/amfd/imm.cc: In member function 'bool ImmObjCreate::immobj_update_required()': | ||
9 | ../opensaf-5.2.0/src/amf/amfd/imm.cc:2174:28: error: unused variable 'pos' [-Werror=unused-variable] | ||
10 | std::string::size_type pos; | ||
11 | ^~~ | ||
12 | ../opensaf-5.2.0/src/amf/amfd/imm.cc:2215:28: error: unused variable 'pos' [-Werror=unused-variable] | ||
13 | std::string::size_type pos; | ||
14 | ^~~ | ||
15 | |||
16 | Signed-off-by: Khem Raj <raj.khem@gmail.com> | ||
17 | --- | ||
18 | src/amf/amfd/imm.cc | 2 -- | ||
19 | 1 file changed, 2 deletions(-) | ||
20 | |||
21 | diff --git a/src/amf/amfd/imm.cc b/src/amf/amfd/imm.cc | ||
22 | index 7932364..4f47b65 100644 | ||
23 | --- a/src/amf/amfd/imm.cc | ||
24 | +++ b/src/amf/amfd/imm.cc | ||
25 | @@ -2171,7 +2171,6 @@ bool ImmObjCreate::immobj_update_required() { | ||
26 | if (class_type == AVSV_SA_AMF_SI_ASSIGNMENT) { | ||
27 | std::string su_name; | ||
28 | std::string sisu_name; | ||
29 | - std::string::size_type pos; | ||
30 | while ((attribute = attrValues_[i++]) != nullptr) { | ||
31 | if (!strcmp(attribute->attrName, "safSISU")) { | ||
32 | sisu_name = Amf::to_string( | ||
33 | @@ -2212,7 +2211,6 @@ bool ImmObjCreate::immobj_update_required() { | ||
34 | } else if (class_type == AVSV_SA_AMF_CSI_ASSIGNMENT) { | ||
35 | std::string comp_name; | ||
36 | std::string csicomp_name; | ||
37 | - std::string::size_type pos; | ||
38 | AVD_CSI *csi = nullptr; | ||
39 | AVD_COMP *comp = nullptr; | ||
40 | AVD_COMP_CSI_REL *compcsi = nullptr; | ||
41 | -- | ||
42 | 2.12.2 | ||
43 | |||
diff --git a/meta-networking/recipes-daemons/opensaf/opensaf/0001-immpbe_dump.cc-Use-sys-wait.h-instead-of-wait.h.patch b/meta-networking/recipes-daemons/opensaf/opensaf/0001-immpbe_dump.cc-Use-sys-wait.h-instead-of-wait.h.patch new file mode 100644 index 000000000..76c47c658 --- /dev/null +++ b/meta-networking/recipes-daemons/opensaf/opensaf/0001-immpbe_dump.cc-Use-sys-wait.h-instead-of-wait.h.patch | |||
@@ -0,0 +1,34 @@ | |||
1 | From 508ea7c0d67243feb1684eaa83569cb687561d64 Mon Sep 17 00:00:00 2001 | ||
2 | From: Khem Raj <raj.khem@gmail.com> | ||
3 | Date: Fri, 15 Sep 2017 10:09:03 -0700 | ||
4 | Subject: [PATCH] immpbe_dump.cc: Use sys/wait.h instead of wait.h | ||
5 | |||
6 | Fixes | ||
7 | redirecting incorrect #include <wait.h> to <sys/wait.h> | ||
8 | |||
9 | Signed-off-by: Khem Raj <raj.khem@gmail.com> | ||
10 | --- | ||
11 | src/imm/common/immpbe_dump.cc | 2 +- | ||
12 | 1 file changed, 1 insertion(+), 1 deletion(-) | ||
13 | |||
14 | diff --git a/src/imm/common/immpbe_dump.cc b/src/imm/common/immpbe_dump.cc | ||
15 | index 100222f37..33e47ce3c 100644 | ||
16 | --- a/src/imm/common/immpbe_dump.cc | ||
17 | +++ b/src/imm/common/immpbe_dump.cc | ||
18 | @@ -26,12 +26,12 @@ | ||
19 | #include <stdlib.h> | ||
20 | #include <stdio.h> | ||
21 | #include <time.h> | ||
22 | -#include <wait.h> | ||
23 | #include <unistd.h> | ||
24 | #include <iostream> | ||
25 | #include <sstream> | ||
26 | #include <stdint.h> | ||
27 | #include <sys/stat.h> | ||
28 | +#include <sys/wait.h> | ||
29 | #include <libgen.h> | ||
30 | |||
31 | #include <saAis.h> | ||
32 | -- | ||
33 | 2.14.1 | ||
34 | |||
diff --git a/meta-networking/recipes-daemons/opensaf/opensaf/0001-src-Add-missing-header-limits.h-for-_POSIX_HOST_NAME.patch b/meta-networking/recipes-daemons/opensaf/opensaf/0001-src-Add-missing-header-limits.h-for-_POSIX_HOST_NAME.patch new file mode 100644 index 000000000..4a2a825f9 --- /dev/null +++ b/meta-networking/recipes-daemons/opensaf/opensaf/0001-src-Add-missing-header-limits.h-for-_POSIX_HOST_NAME.patch | |||
@@ -0,0 +1,122 @@ | |||
1 | From 6442b57a855e273aa5a3d93e8596783cea128073 Mon Sep 17 00:00:00 2001 | ||
2 | From: Khem Raj <raj.khem@gmail.com> | ||
3 | Date: Fri, 15 Sep 2017 09:39:40 -0700 | ||
4 | Subject: [PATCH] src: Add missing header limits.h for _POSIX_HOST_NAME_MAX | ||
5 | |||
6 | Use _GNU_SOURCE instead of libc internal __USE_GNU | ||
7 | Do not use the deprecated headers under include/sys | ||
8 | |||
9 | Signed-off-by: Khem Raj <raj.khem@gmail.com> | ||
10 | --- | ||
11 | src/base/os_defs.h | 5 +++-- | ||
12 | src/mds/mds_dt_tcp.c | 1 - | ||
13 | src/mds/mds_dt_tcp_disc.h | 2 +- | ||
14 | src/mds/mds_dt_tipc.c | 1 - | ||
15 | src/mds/mds_dt_tipc.h | 2 +- | ||
16 | src/mds/mds_dt_trans.c | 1 - | ||
17 | src/ntf/ntfd/NtfLogger.cc | 2 +- | ||
18 | 7 files changed, 6 insertions(+), 8 deletions(-) | ||
19 | |||
20 | diff --git a/src/base/os_defs.h b/src/base/os_defs.h | ||
21 | index 50a9bf5fc..af6842863 100644 | ||
22 | --- a/src/base/os_defs.h | ||
23 | +++ b/src/base/os_defs.h | ||
24 | @@ -47,17 +47,18 @@ | ||
25 | #include <sys/stat.h> | ||
26 | #include <sys/msg.h> /* Added for message-queues : PM : 28/10/03 */ | ||
27 | #include <syslog.h> | ||
28 | -#ifndef __USE_GNU | ||
29 | +#include <limits.h> | ||
30 | +#ifndef _GNU_SOURCE | ||
31 | struct msgbuf { | ||
32 | long int mtype; | ||
33 | char mtext[1]; | ||
34 | }; | ||
35 | #endif /* else defined in <sys/msg.h> */ | ||
36 | #include <sys/time.h> | ||
37 | -#include <sys/fcntl.h> | ||
38 | #include <sys/socket.h> | ||
39 | #include <netinet/in.h> | ||
40 | |||
41 | +#include <fcntl.h> | ||
42 | #include <signal.h> | ||
43 | #include <pthread.h> | ||
44 | |||
45 | diff --git a/src/mds/mds_dt_tcp.c b/src/mds/mds_dt_tcp.c | ||
46 | index 1407eb1ab..a87c22faa 100644 | ||
47 | --- a/src/mds/mds_dt_tcp.c | ||
48 | +++ b/src/mds/mds_dt_tcp.c | ||
49 | @@ -27,7 +27,6 @@ | ||
50 | |||
51 | #include <stdlib.h> | ||
52 | #include <sched.h> | ||
53 | -#include <sys/poll.h> | ||
54 | #include <poll.h> | ||
55 | #include <sys/types.h> | ||
56 | #include <unistd.h> | ||
57 | diff --git a/src/mds/mds_dt_tcp_disc.h b/src/mds/mds_dt_tcp_disc.h | ||
58 | index a6249d73e..574f52681 100644 | ||
59 | --- a/src/mds/mds_dt_tcp_disc.h | ||
60 | +++ b/src/mds/mds_dt_tcp_disc.h | ||
61 | @@ -24,7 +24,7 @@ | ||
62 | #include "base/ncssysf_tsk.h" | ||
63 | #include "base/ncssysf_mem.h" | ||
64 | #include "mds_dt_tcp_disc.h" | ||
65 | -#include "sys/poll.h" | ||
66 | +#include <poll.h> | ||
67 | |||
68 | /* mds_indentifire + mds_version + msg_type + scope_type + server_type + | ||
69 | server_instance_lower + server_instance_upper + sub_ref_val + sub_ref_val + | ||
70 | diff --git a/src/mds/mds_dt_tipc.c b/src/mds/mds_dt_tipc.c | ||
71 | index 37745e7f0..9b3255567 100644 | ||
72 | --- a/src/mds/mds_dt_tipc.c | ||
73 | +++ b/src/mds/mds_dt_tipc.c | ||
74 | @@ -35,7 +35,6 @@ | ||
75 | #include <stdbool.h> | ||
76 | #include <stdlib.h> | ||
77 | #include <sched.h> | ||
78 | -#include <sys/poll.h> | ||
79 | #include <poll.h> | ||
80 | #include <sys/types.h> | ||
81 | #include <unistd.h> | ||
82 | diff --git a/src/mds/mds_dt_tipc.h b/src/mds/mds_dt_tipc.h | ||
83 | index e73a11b09..401d208c2 100644 | ||
84 | --- a/src/mds/mds_dt_tipc.h | ||
85 | +++ b/src/mds/mds_dt_tipc.h | ||
86 | @@ -32,7 +32,7 @@ | ||
87 | #include <assert.h> | ||
88 | #include <string.h> | ||
89 | #include <sys/param.h> | ||
90 | -#include <sys/poll.h> | ||
91 | +#include <poll.h> | ||
92 | #include <netdb.h> | ||
93 | #include <errno.h> | ||
94 | #include <fcntl.h> | ||
95 | diff --git a/src/mds/mds_dt_trans.c b/src/mds/mds_dt_trans.c | ||
96 | index 6f621e04e..5aacbd33e 100644 | ||
97 | --- a/src/mds/mds_dt_trans.c | ||
98 | +++ b/src/mds/mds_dt_trans.c | ||
99 | @@ -26,7 +26,6 @@ | ||
100 | #include "mds_core.h" | ||
101 | #include "base/osaf_utility.h" | ||
102 | |||
103 | -#include <sys/poll.h> | ||
104 | #include <poll.h> | ||
105 | |||
106 | #define MDS_PROT_TCP 0xA0 | ||
107 | diff --git a/src/ntf/ntfd/NtfLogger.cc b/src/ntf/ntfd/NtfLogger.cc | ||
108 | index 84014b578..31b1ccc6c 100644 | ||
109 | --- a/src/ntf/ntfd/NtfLogger.cc | ||
110 | +++ b/src/ntf/ntfd/NtfLogger.cc | ||
111 | @@ -20,7 +20,7 @@ | ||
112 | * INCLUDE FILES | ||
113 | * ======================================================================== | ||
114 | */ | ||
115 | -#include <sys/poll.h> | ||
116 | +#include <poll.h> | ||
117 | |||
118 | #include "base/osaf_utility.h" | ||
119 | #include <saAis.h> | ||
120 | -- | ||
121 | 2.14.1 | ||
122 | |||
diff --git a/meta-networking/recipes-daemons/opensaf/opensaf_5.2.0.bb b/meta-networking/recipes-daemons/opensaf/opensaf_5.17.07.bb index be79ba8cb..74483d778 100644 --- a/meta-networking/recipes-daemons/opensaf/opensaf_5.2.0.bb +++ b/meta-networking/recipes-daemons/opensaf/opensaf_5.17.07.bb | |||
@@ -22,10 +22,11 @@ SECURITY_CFLAGS = "${SECURITY_NO_PIE_CFLAGS}" | |||
22 | SRC_URI = "${SOURCEFORGE_MIRROR}/${BPN}/releases/${BPN}-${PV}.tar.gz \ | 22 | SRC_URI = "${SOURCEFORGE_MIRROR}/${BPN}/releases/${BPN}-${PV}.tar.gz \ |
23 | file://0001-configure-Pass-linker-specific-options-with-Wl.patch \ | 23 | file://0001-configure-Pass-linker-specific-options-with-Wl.patch \ |
24 | file://0001-configure-Disable-format-overflow-if-supported-by-gc.patch \ | 24 | file://0001-configure-Disable-format-overflow-if-supported-by-gc.patch \ |
25 | file://0001-Remove-unused-variables.patch \ | 25 | file://0001-src-Add-missing-header-limits.h-for-_POSIX_HOST_NAME.patch \ |
26 | file://0001-immpbe_dump.cc-Use-sys-wait.h-instead-of-wait.h.patch \ | ||
26 | " | 27 | " |
27 | SRC_URI[md5sum] = "08991fd467ae9dcea3c8747be8e3981e" | 28 | SRC_URI[md5sum] = "125bcd9aabd7412aedcbfbf73f4e6196" |
28 | SRC_URI[sha256sum] = "903478244afe37e329be93050f1d48fa18c84ea17862134c4217b920e267a04a" | 29 | SRC_URI[sha256sum] = "3fb2239bb2c9328c8b45368ff8d8de979ea286a27edc9871d218200e88bb91cc" |
29 | 30 | ||
30 | inherit autotools useradd systemd pkgconfig | 31 | inherit autotools useradd systemd pkgconfig |
31 | 32 | ||