diff options
author | Martin Jansa <Martin.Jansa@gmail.com> | 2013-04-13 13:49:05 +0200 |
---|---|---|
committer | Martin Jansa <Martin.Jansa@gmail.com> | 2013-04-15 16:22:03 +0200 |
commit | 5f26b009643d8a1a73aecb3aa0b7c5873943e7a1 (patch) | |
tree | 8e0954985027fab490e9cf1549c25455a6da9425 /meta-networking | |
parent | 4188d725513fb660348df16c290618dd0e6198ba (diff) | |
download | meta-openembedded-5f26b009643d8a1a73aecb3aa0b7c5873943e7a1.tar.gz |
yp-tools, ypbind-mt: move systemd support from meta-systemd back to meta-networking
Signed-off-by: Martin Jansa <Martin.Jansa@gmail.com>
Diffstat (limited to 'meta-networking')
4 files changed, 60 insertions, 7 deletions
diff --git a/meta-networking/recipes-support/nis/yp-tools/domainname.service b/meta-networking/recipes-support/nis/yp-tools/domainname.service new file mode 100644 index 000000000..21aa92cb3 --- /dev/null +++ b/meta-networking/recipes-support/nis/yp-tools/domainname.service | |||
@@ -0,0 +1,12 @@ | |||
1 | [Unit] | ||
2 | Description=NIS Domainname | ||
3 | |||
4 | [Service] | ||
5 | Type=oneshot | ||
6 | EnvironmentFile=/etc/nisdomainname | ||
7 | ExecStart=/usr/bin/domainname $NISDOMAINNAME | ||
8 | RemainAfterExit=true | ||
9 | |||
10 | [Install] | ||
11 | WantedBy=multi-user.target | ||
12 | |||
diff --git a/meta-networking/recipes-support/nis/yp-tools_2.12.bb b/meta-networking/recipes-support/nis/yp-tools_2.12.bb index fb7ebc230..8593c6ba4 100644 --- a/meta-networking/recipes-support/nis/yp-tools_2.12.bb +++ b/meta-networking/recipes-support/nis/yp-tools_2.12.bb | |||
@@ -1,7 +1,7 @@ | |||
1 | # This package builds tools to manage NIS | 1 | # This package builds tools to manage NIS |
2 | # The source package is utils/net/NIS/yp-tools | 2 | # The source package is utils/net/NIS/yp-tools |
3 | # | 3 | # |
4 | PR = "r0" | 4 | PR = "r3" |
5 | DESCRIPTION="\ | 5 | DESCRIPTION="\ |
6 | Network Information Service tools. \ | 6 | Network Information Service tools. \ |
7 | This package contains ypcat, ypmatch, ypset, \ | 7 | This package contains ypcat, ypmatch, ypset, \ |
@@ -9,9 +9,23 @@ ypwhich, yppasswd, domainname, nisdomainname \ | |||
9 | and ypdomainname." | 9 | and ypdomainname." |
10 | 10 | ||
11 | require nis.inc | 11 | require nis.inc |
12 | SRC_URI = "http://www.linux-nis.org/download/yp-tools/${BP}.tar.bz2" | 12 | SRC_URI = "http://www.linux-nis.org/download/yp-tools/${BP}.tar.bz2 \ |
13 | file://domainname.service \ | ||
14 | " | ||
13 | 15 | ||
14 | SRC_URI[md5sum] = "ce1e06d86caa285fa8cd76fdf103f51e" | 16 | SRC_URI[md5sum] = "ce1e06d86caa285fa8cd76fdf103f51e" |
15 | SRC_URI[sha256sum] = "6ae8321666eea7837da343eea90ea30273fb74943ad111d5a4befd2afb252063" | 17 | SRC_URI[sha256sum] = "6ae8321666eea7837da343eea90ea30273fb74943ad111d5a4befd2afb252063" |
16 | 18 | ||
17 | CACHED_CONFIGUREVARS += "ac_cv_prog_STRIP=/bin/true" | 19 | CACHED_CONFIGUREVARS += "ac_cv_prog_STRIP=/bin/true" |
20 | |||
21 | inherit systemd | ||
22 | |||
23 | RPROVIDES_${PN} += "${PN}-systemd" | ||
24 | RREPLACES_${PN} += "${PN}-systemd" | ||
25 | RCONFLICTS_${PN} += "${PN}-systemd" | ||
26 | SYSTEMD_SERVICE_${PN} = "domainname.service" | ||
27 | |||
28 | do_install_append() { | ||
29 | install -d ${D}${systemd_unitdir}/system | ||
30 | install -m 0644 ${WORKDIR}/domainname.service ${D}${systemd_unitdir}/system | ||
31 | } | ||
diff --git a/meta-networking/recipes-support/nis/ypbind-mt/ypbind.service b/meta-networking/recipes-support/nis/ypbind-mt/ypbind.service new file mode 100644 index 000000000..1f8df42af --- /dev/null +++ b/meta-networking/recipes-support/nis/ypbind-mt/ypbind.service | |||
@@ -0,0 +1,14 @@ | |||
1 | [Unit] | ||
2 | Description=YP Bind | ||
3 | Requires=domainname.service | ||
4 | After=domainname.service network.target | ||
5 | Before=systemd-user-sessions.service | ||
6 | |||
7 | [Service] | ||
8 | Type=forking | ||
9 | PIDFile=/var/run/ypbind.pid | ||
10 | ExecStart=/usr/sbin/ypbind | ||
11 | |||
12 | [Install] | ||
13 | WantedBy=multi-user.target | ||
14 | |||
diff --git a/meta-networking/recipes-support/nis/ypbind-mt_1.36.bb b/meta-networking/recipes-support/nis/ypbind-mt_1.36.bb index e2f654c61..35ef16a89 100644 --- a/meta-networking/recipes-support/nis/ypbind-mt_1.36.bb +++ b/meta-networking/recipes-support/nis/ypbind-mt_1.36.bb | |||
@@ -1,7 +1,7 @@ | |||
1 | # This package builds the NIS ypbind daemon | 1 | # This package builds the NIS ypbind daemon |
2 | # The source package is utils/net/NIS/ypbind-mt | 2 | # The source package is utils/net/NIS/ypbind-mt |
3 | # | 3 | # |
4 | PR = "r0" | 4 | PR = "r3" |
5 | DESCRIPTION="\ | 5 | DESCRIPTION="\ |
6 | Multithreaded NIS bind service (ypbind-mt). \ | 6 | Multithreaded NIS bind service (ypbind-mt). \ |
7 | ypbind-mt is a complete new implementation of a NIS \ | 7 | ypbind-mt is a complete new implementation of a NIS \ |
@@ -16,10 +16,13 @@ HOMEPAGE="http://www.linux-nis.org/nis/ypbind-mt/index.html" | |||
16 | 16 | ||
17 | require nis.inc | 17 | require nis.inc |
18 | 18 | ||
19 | SRC_URI = "http://www.linux-nis.org/download/ypbind-mt/${BP}.tar.bz2" | ||
20 | SRC_URI[md5sum] = "135834db97d78ff6d79fdee2810b4056" | ||
21 | |||
22 | LIC_FILES_CHKSUM = "file://COPYING;md5=082c9a0886c7c3db1bc862b5b62ffe08" | 19 | LIC_FILES_CHKSUM = "file://COPYING;md5=082c9a0886c7c3db1bc862b5b62ffe08" |
20 | |||
21 | SRC_URI = "http://www.linux-nis.org/download/ypbind-mt/${BP}.tar.bz2 \ | ||
22 | file://ypbind-yocto.init \ | ||
23 | file://ypbind.service \ | ||
24 | " | ||
25 | SRC_URI[md5sum] = "135834db97d78ff6d79fdee2810b4056" | ||
23 | SRC_URI[sha256sum] = "0eff76c1849f4b38ea1a60280d8397c4240369c641fe5402ce57edf1a90958c7" | 26 | SRC_URI[sha256sum] = "0eff76c1849f4b38ea1a60280d8397c4240369c641fe5402ce57edf1a90958c7" |
24 | 27 | ||
25 | # ypbind-mt now provides all the functionality of ypbind | 28 | # ypbind-mt now provides all the functionality of ypbind |
@@ -27,7 +30,6 @@ SRC_URI[sha256sum] = "0eff76c1849f4b38ea1a60280d8397c4240369c641fe5402ce57edf1a9 | |||
27 | PROVIDES += "ypbind" | 30 | PROVIDES += "ypbind" |
28 | 31 | ||
29 | CACHED_CONFIGUREVARS = "ac_cv_prog_STRIP=/bin/true" | 32 | CACHED_CONFIGUREVARS = "ac_cv_prog_STRIP=/bin/true" |
30 | SRC_URI += "file://ypbind-yocto.init" | ||
31 | 33 | ||
32 | do_install_append () { | 34 | do_install_append () { |
33 | install -d ${D}${sysconfdir}/init.d | 35 | install -d ${D}${sysconfdir}/init.d |
@@ -35,5 +37,16 @@ do_install_append () { | |||
35 | 37 | ||
36 | install -m 0755 ${WORKDIR}/ypbind-yocto.init ${D}${sysconfdir}/init.d/ypbind | 38 | install -m 0755 ${WORKDIR}/ypbind-yocto.init ${D}${sysconfdir}/init.d/ypbind |
37 | 39 | ||
40 | # TODO, use update-rc.d | ||
38 | ln -s ../init.d/ypbind ${D}${sysconfdir}/rcS.d/S44ypbind | 41 | ln -s ../init.d/ypbind ${D}${sysconfdir}/rcS.d/S44ypbind |
42 | |||
43 | install -d ${D}${systemd_unitdir}/system | ||
44 | install -m 0644 ${WORKDIR}/ypbind.service ${D}${systemd_unitdir}/system | ||
39 | } | 45 | } |
46 | |||
47 | inherit systemd | ||
48 | |||
49 | RPROVIDES_${PN} += "${PN}-systemd" | ||
50 | RREPLACES_${PN} += "${PN}-systemd" | ||
51 | RCONFLICTS_${PN} += "${PN}-systemd" | ||
52 | SYSTEMD_SERVICE_${PN} = "ypbind.service" | ||