diff options
author | Wenzong Fan <wenzong.fan@windriver.com> | 2014-07-15 08:59:46 +0800 |
---|---|---|
committer | Martin Jansa <Martin.Jansa@gmail.com> | 2014-07-22 00:01:47 +0200 |
commit | 27981cbef19db115fa81704468721580dedfb1fd (patch) | |
tree | b86f685c5abd3ed05c30251c651039248440d3ee /meta-networking | |
parent | 717fe1ff766f71f18a2d80f23baec39fb79117e2 (diff) | |
download | meta-openembedded-27981cbef19db115fa81704468721580dedfb1fd.tar.gz |
vsftpd: fix install warning
WARNING: QA Issue: vsftpd: Files/directories were installed but not shipped
/run
/run/vsftpd
/run/vsftpd/empty
Signed-off-by: Roy Li <rongqing.li@windriver.com>
Signed-off-by: Martin Jansa <Martin.Jansa@gmail.com>
Diffstat (limited to 'meta-networking')
-rw-r--r-- | meta-networking/recipes-daemons/vsftpd/vsftpd_3.0.0.bb | 16 |
1 files changed, 15 insertions, 1 deletions
diff --git a/meta-networking/recipes-daemons/vsftpd/vsftpd_3.0.0.bb b/meta-networking/recipes-daemons/vsftpd/vsftpd_3.0.0.bb index 0698a63258..5df8211569 100644 --- a/meta-networking/recipes-daemons/vsftpd/vsftpd_3.0.0.bb +++ b/meta-networking/recipes-daemons/vsftpd/vsftpd_3.0.0.bb | |||
@@ -70,7 +70,11 @@ do_install() { | |||
70 | sed -i "s:/lib/security:${base_libdir}/security:" ${D}${sysconfdir}/pam.d/vsftpd | 70 | sed -i "s:/lib/security:${base_libdir}/security:" ${D}${sysconfdir}/pam.d/vsftpd |
71 | sed -i "s:ftpusers:vsftpd.ftpusers:" ${D}${sysconfdir}/pam.d/vsftpd | 71 | sed -i "s:ftpusers:vsftpd.ftpusers:" ${D}${sysconfdir}/pam.d/vsftpd |
72 | fi | 72 | fi |
73 | install -d ${D}${localstatedir}/run/vsftpd/empty | 73 | if ${@base_contains('DISTRO_FEATURES', 'systemd', 'true', 'false', d)}; then |
74 | install -d ${D}${sysconfdir}/tmpfiles.d | ||
75 | echo "d /var/run/vsftpd/empty 0755 root root -" \ | ||
76 | > ${D}${sysconfdir}/tmpfiles.d/${BPN}.conf | ||
77 | fi | ||
74 | } | 78 | } |
75 | 79 | ||
76 | INITSCRIPT_PACKAGES = "${PN}" | 80 | INITSCRIPT_PACKAGES = "${PN}" |
@@ -82,3 +86,13 @@ USERADD_PARAM_${PN} = "--system --home-dir /var/lib/ftp --no-create-home -g ftp | |||
82 | --shell /bin/false ftp " | 86 | --shell /bin/false ftp " |
83 | GROUPADD_PARAM_${PN} = "-r ftp" | 87 | GROUPADD_PARAM_${PN} = "-r ftp" |
84 | 88 | ||
89 | pkg_postinst_${PN}() { | ||
90 | if [ -n "$D" ]; then | ||
91 | exit 0 | ||
92 | fi | ||
93 | if type systemd-tmpfiles >/dev/null; then | ||
94 | systemd-tmpfiles --create | ||
95 | elif [ -e ${sysconfdir}/init.d/populate-volatile.sh ]; then | ||
96 | ${sysconfdir}/init.d/populate-volatile.sh update | ||
97 | fi | ||
98 | } | ||