diff options
author | Jackie Huang <jackie.huang@windriver.com> | 2014-04-02 15:27:25 +0800 |
---|---|---|
committer | Joe MacDonald <joe@deserted.net> | 2014-04-02 11:18:54 -0400 |
commit | bc969d3705c45928de8525ef3d2d9d2867311864 (patch) | |
tree | fb92ebe8feb4c4725832bcc126290423ac539b6b /meta-networking | |
parent | 5be3c1373688f0f1e2bbb0384ca3e681a1850ded (diff) | |
download | meta-openembedded-bc969d3705c45928de8525ef3d2d9d2867311864.tar.gz |
inetutils: add -dbg packages for tftpd, telnetd and rshd
The packages tftpd, telnetd and rshd conflict with the ones
provided by netkit, so add the corresponding -dbg packages
for them to avoid the following confliction between the dbg
package of inetutils and netkit:
error: file /usr/sbin/.debug/in.rexecd conflicts between attempted installs of inetutils-dbg-1.9.1-r1.0.armv7a_vfp_neon and netkit-rsh-dbg-0.17-r0.0.armv7a_vfp_neon
error: file /usr/sbin/.debug/in.telnetd conflicts between attempted installs of inetutils-dbg-1.9.1-r1.0.armv7a_vfp_neon and netkit-telnet-dbg-0.17-r0.0.armv7a_vfp_neon
Signed-off-by: Jackie Huang <jackie.huang@windriver.com>
Signed-off-by: Joe MacDonald <joe@deserted.net>
Diffstat (limited to 'meta-networking')
-rw-r--r-- | meta-networking/recipes-connectivity/inetutils/inetutils_1.9.1.bb | 10 |
1 files changed, 10 insertions, 0 deletions
diff --git a/meta-networking/recipes-connectivity/inetutils/inetutils_1.9.1.bb b/meta-networking/recipes-connectivity/inetutils/inetutils_1.9.1.bb index e7f19870c..0e47015c0 100644 --- a/meta-networking/recipes-connectivity/inetutils/inetutils_1.9.1.bb +++ b/meta-networking/recipes-connectivity/inetutils/inetutils_1.9.1.bb | |||
@@ -80,6 +80,12 @@ ${PN}-tftp ${PN}-logger ${PN}-traceroute ${PN}-syslogd \ | |||
80 | ${PN}-ftp ${PN}-ftpd ${PN}-tftpd ${PN}-telnet ${PN}-telnetd ${PN}-inetd \ | 80 | ${PN}-ftp ${PN}-ftpd ${PN}-tftpd ${PN}-telnet ${PN}-telnetd ${PN}-inetd \ |
81 | ${PN}-rsh ${PN}-rshd" | 81 | ${PN}-rsh ${PN}-rshd" |
82 | 82 | ||
83 | # The packages tftpd, telnetd and rshd conflict with the ones | ||
84 | # provided by netkit, so add the corresponding -dbg packages | ||
85 | # for them to avoid the confliction between the dbg package | ||
86 | # of inetutils and netkit. | ||
87 | PACKAGES += "${PN}-tftpd-dbg ${PN}-telnetd-dbg ${PN}-rshd-dbg" | ||
88 | |||
83 | ALTERNATIVE_PRIORITY = "80" | 89 | ALTERNATIVE_PRIORITY = "80" |
84 | ALTERNATIVE_${PN} = "talk whois" | 90 | ALTERNATIVE_${PN} = "talk whois" |
85 | ALTERNATIVE_LINK_NAME[talkd] = "${sbindir}/in.talkd" | 91 | ALTERNATIVE_LINK_NAME[talkd] = "${sbindir}/in.talkd" |
@@ -141,18 +147,22 @@ FILES_${PN}-rsh = "${bindir}/rsh.${BPN} ${bindir}/rlogin.${BPN} ${bindir}/rexec. | |||
141 | 147 | ||
142 | FILES_${PN}-rshd = "${sbindir}/in.rshd ${sbindir}/in.rlogind ${sbindir}/in.rexecd \ | 148 | FILES_${PN}-rshd = "${sbindir}/in.rshd ${sbindir}/in.rlogind ${sbindir}/in.rexecd \ |
143 | ${sysconfdir}/xinetd.d/rsh ${sysconfdir}/xinetd.d/rlogin ${sysconfdir}/xinetd.d/rexec" | 149 | ${sysconfdir}/xinetd.d/rsh ${sysconfdir}/xinetd.d/rlogin ${sysconfdir}/xinetd.d/rexec" |
150 | FILES_${PN}-rshd-dbg = "${sbindir}/.debug/in.rshd ${sbindir}/.debug/in.rlogind ${sbindir}/.debug/in.rexecd" | ||
144 | RDEPENDS_${PN}-rshd += "xinetd tcp-wrappers" | 151 | RDEPENDS_${PN}-rshd += "xinetd tcp-wrappers" |
145 | RCONFLICTS_${PN}-rshd += "netkit-rshd" | 152 | RCONFLICTS_${PN}-rshd += "netkit-rshd" |
146 | RPROVIDES_${PN}-rshd = "rshd" | 153 | RPROVIDES_${PN}-rshd = "rshd" |
147 | 154 | ||
148 | FILES_${PN}-ftpd = "${bindir}/ftpd.${BPN}" | 155 | FILES_${PN}-ftpd = "${bindir}/ftpd.${BPN}" |
156 | FILES_${PN}-ftpd-dbg = "${bindir}/.debug/ftpd.${BPN}" | ||
149 | RDEPENDS_${PN}-ftpd += "xinetd" | 157 | RDEPENDS_${PN}-ftpd += "xinetd" |
150 | 158 | ||
151 | FILES_${PN}-tftpd = "${sbindir}/in.tftpd ${sysconfdir}/xinetd.d/tftpd" | 159 | FILES_${PN}-tftpd = "${sbindir}/in.tftpd ${sysconfdir}/xinetd.d/tftpd" |
160 | FILES_${PN}-tftpd-dbg = "${sbindir}/.debug/in.tftpd" | ||
152 | RCONFLICTS_${PN}-tftpd += "netkit-tftpd" | 161 | RCONFLICTS_${PN}-tftpd += "netkit-tftpd" |
153 | RDEPENDS_${PN}-tftpd += "xinetd" | 162 | RDEPENDS_${PN}-tftpd += "xinetd" |
154 | 163 | ||
155 | FILES_${PN}-telnetd = "${sbindir}/in.telnetd ${sysconfdir}/xinetd.d/telnet" | 164 | FILES_${PN}-telnetd = "${sbindir}/in.telnetd ${sysconfdir}/xinetd.d/telnet" |
165 | FILES_${PN}-telnetd-dbg = "${sbindir}/.debug/in.telnetd" | ||
156 | RCONFLICTS_${PN}-telnetd += "netkit-telnetd" | 166 | RCONFLICTS_${PN}-telnetd += "netkit-telnetd" |
157 | RPROVIDES_${PN}-telnetd = "telnetd" | 167 | RPROVIDES_${PN}-telnetd = "telnetd" |
158 | RDEPENDS_${PN}-telnetd += "xinetd" | 168 | RDEPENDS_${PN}-telnetd += "xinetd" |