summaryrefslogtreecommitdiffstats
path: root/meta-networking
diff options
context:
space:
mode:
authorPaul Eggleton <paul.eggleton@linux.intel.com>2013-04-16 10:54:01 +0000
committerMartin Jansa <Martin.Jansa@gmail.com>2013-04-19 02:45:27 +0200
commitbd790d44d2b07d660ee8c1d799d38ace22e0c455 (patch)
treed8bb08612d0b437acc4607103b4579b075b3dace /meta-networking
parentd48c95da5873a5674c264f788c0f1dda12025a25 (diff)
downloadmeta-openembedded-bd790d44d2b07d660ee8c1d799d38ace22e0c455.tar.gz
ipsec-tools: move to meta-networking and tweak
* Add purpose and Upstream-Status to patch Signed-off-by: Paul Eggleton <paul.eggleton@linux.intel.com> Signed-off-by: Martin Jansa <Martin.Jansa@gmail.com>
Diffstat (limited to 'meta-networking')
-rw-r--r--meta-networking/recipes-support/ipsec-tools/files/ipsec-tools-install.patch18
-rw-r--r--meta-networking/recipes-support/ipsec-tools/ipsec-tools.inc51
-rw-r--r--meta-networking/recipes-support/ipsec-tools/ipsec-tools_0.7.2.bb7
3 files changed, 76 insertions, 0 deletions
diff --git a/meta-networking/recipes-support/ipsec-tools/files/ipsec-tools-install.patch b/meta-networking/recipes-support/ipsec-tools/files/ipsec-tools-install.patch
new file mode 100644
index 000000000..85035b110
--- /dev/null
+++ b/meta-networking/recipes-support/ipsec-tools/files/ipsec-tools-install.patch
@@ -0,0 +1,18 @@
1Avoid attempting to install vmbuf.h twice
2
3Upstream-Status: Accepted
4
5Taken from pld-linux.org:
6http://cvs.pld-linux.org/cgi-bin/cvsweb.cgi/packages/ipsec-tools/ipsec-tools-install.patch
7
8--- ipsec-tools-0.7.2/src/racoon/Makefile.am~ 2008-07-23 13:48:40.000000000 +0200
9+++ ipsec-tools-0.7.2/src/racoon/Makefile.am 2009-07-04 01:43:48.148433975 +0200
10@@ -3,7 +3,7 @@
11 sbin_PROGRAMS = racoon racoonctl plainrsa-gen
12 noinst_PROGRAMS = eaytest
13 include_racoon_HEADERS = racoonctl.h var.h vmbuf.h misc.h gcmalloc.h admin.h \
14- schedule.h sockmisc.h vmbuf.h isakmp_var.h isakmp.h isakmp_xauth.h \
15+ schedule.h sockmisc.h isakmp_var.h isakmp.h isakmp_xauth.h \
16 isakmp_cfg.h isakmp_unity.h ipsec_doi.h evt.h
17 lib_LTLIBRARIES = libracoon.la
18
diff --git a/meta-networking/recipes-support/ipsec-tools/ipsec-tools.inc b/meta-networking/recipes-support/ipsec-tools/ipsec-tools.inc
new file mode 100644
index 000000000..264b49a53
--- /dev/null
+++ b/meta-networking/recipes-support/ipsec-tools/ipsec-tools.inc
@@ -0,0 +1,51 @@
1DESCRIPTION = "IPsec-Tools is a port of KAME's IPsec utilities to the \
2Linux-2.6 IPsec implementation."
3HOMEPAGE = "http://ipsec-tools.sourceforge.net/"
4SECTION = "console/network"
5LICENSE = "BSD"
6DEPENDS = "virtual/kernel openssl readline flex"
7
8SRC_URI = "${SOURCEFORGE_MIRROR}/ipsec-tools/ipsec-tools-${PV}.tar.bz2;name=ipsec-tools-${PV}"
9
10inherit autotools
11
12# Options:
13# --enable-adminport enable admin port
14# --enable-rc5 enable RC5 encryption (patented)
15# --enable-idea enable IDEA encryption (patented)
16# --enable-gssapi enable GSS-API authentication
17# --enable-hybrid enable hybrid, both mode-cfg and xauth support
18# --enable-frag enable IKE fragmentation payload support
19# --enable-stats enable statistics logging function
20# --enable-dpd enable dead peer detection
21# --enable-samode-unspec enable to use unspecified a mode of SA
22# --disable-ipv6 disable ipv6 support
23# --enable-natt enable NAT-Traversal (yes/no/kernel)
24# --enable-natt-versions=list list of supported NAT-T versions delimited by coma.
25# --with-kernel-headers=/lib/modules/<uname>/build/include
26# where your Linux Kernel headers are installed
27# --with-readline support readline input (yes by default)
28# --with-flex use directiory (default: no)
29# --with-flexlib=<LIB> specify flex library.
30# --with-openssl=DIR specify OpenSSL directory
31# --with-libradius=DIR specify libradius path (like/usr/pkg)
32# --with-libpam=DIR specify libpam path (like/usr/pkg)
33#
34# Note: if you give it the actual kernel headers it won't build, it actually
35# needs to point at the linux-libc-headers version of the kernel headers.
36#
37EXTRA_OECONF = "--with-kernel-headers=${STAGING_INCDIR} \
38 --with-readline \
39 --with-openssl=${STAGING_LIBDIR}/.. \
40 --without-libradius \
41 --without-gssapi \
42 --without-libpam \
43 --disable-security-context"
44
45# See http://bugs.debian.org/cgi-bin/bugreport.cgi?bug=530527
46CFLAGS += "-fno-strict-aliasing"
47
48# Sometimes it attempts to use y.tab.c before it is actually
49# generated. Note that the failure case is very rare, but it does
50# happen.
51PARALLEL_MAKE = ""
diff --git a/meta-networking/recipes-support/ipsec-tools/ipsec-tools_0.7.2.bb b/meta-networking/recipes-support/ipsec-tools/ipsec-tools_0.7.2.bb
new file mode 100644
index 000000000..255246e39
--- /dev/null
+++ b/meta-networking/recipes-support/ipsec-tools/ipsec-tools_0.7.2.bb
@@ -0,0 +1,7 @@
1require ipsec-tools.inc
2
3LIC_FILES_CHKSUM = "file://src/libipsec/pfkey.c;beginline=6;endline=31;md5=bc9b7ff40beff19fe6bc6aef26bd2b24"
4
5SRC_URI += "file://ipsec-tools-install.patch"
6SRC_URI[ipsec-tools-0.7.2.md5sum] = "72861f005746ee27984b2ee715ecc629"
7SRC_URI[ipsec-tools-0.7.2.sha256sum] = "08722ff6c62de3e042fef337454f03622a79053108d6dcc686c9c854f9f9e031"