summaryrefslogtreecommitdiffstats
path: root/meta-networking
diff options
context:
space:
mode:
authorRoy.Li <rongqing.li@windriver.com>2013-06-25 09:22:59 +0800
committerEric BĂ©nard <eric@eukrea.com>2013-08-22 09:51:25 +0200
commit83e17efbdc5181eb1e99191faef4d6ab84993a16 (patch)
tree2afd602f4ed9c92bd55164d8a70e570c23be28d6 /meta-networking
parenta6edcf250cdb3ca656299f41f069daac54014a5f (diff)
downloadmeta-openembedded-83e17efbdc5181eb1e99191faef4d6ab84993a16.tar.gz
cyrus-sasl: Avoid to call AC_TRY_RUN
If the gssapi libraries are compiled before cyrus-sasl, configure will call AC_TRY_RUN to check if gssapi libraries support SPNEGO, but calling AC_TRY_RUN will fail on cross-compile environment. Signed-off-by: Roy.Li <rongqing.li@windriver.com> Signed-off-by: Joe MacDonald <joe.macdonald@windriver.com>
Diffstat (limited to 'meta-networking')
-rw-r--r--meta-networking/recipes-daemons/cyrus-sasl/cyrus-sasl_2.1.26.bb6
-rw-r--r--meta-networking/recipes-daemons/cyrus-sasl/files/avoid-to-call-AC_TRY_RUN.patch46
2 files changed, 51 insertions, 1 deletions
diff --git a/meta-networking/recipes-daemons/cyrus-sasl/cyrus-sasl_2.1.26.bb b/meta-networking/recipes-daemons/cyrus-sasl/cyrus-sasl_2.1.26.bb
index 011302534..6793e85fc 100644
--- a/meta-networking/recipes-daemons/cyrus-sasl/cyrus-sasl_2.1.26.bb
+++ b/meta-networking/recipes-daemons/cyrus-sasl/cyrus-sasl_2.1.26.bb
@@ -4,7 +4,8 @@ DEPENDS = "openssl virtual/db"
4LICENSE = "BSD" 4LICENSE = "BSD"
5LIC_FILES_CHKSUM = "file://COPYING;md5=3f55e0974e3d6db00ca6f57f2d206396" 5LIC_FILES_CHKSUM = "file://COPYING;md5=3f55e0974e3d6db00ca6f57f2d206396"
6 6
7SRC_URI = "ftp://ftp.cyrusimap.org/cyrus-sasl/cyrus-sasl-${PV}.tar.gz " 7SRC_URI = "ftp://ftp.cyrusimap.org/cyrus-sasl/cyrus-sasl-${PV}.tar.gz \
8 file://avoid-to-call-AC_TRY_RUN.patch"
8 9
9inherit autotools pkgconfig 10inherit autotools pkgconfig
10 11
@@ -14,6 +15,9 @@ EXTRA_OECONF += "--with-dblib=berkeley \
14 --without-pam --without-opie --without-des \ 15 --without-pam --without-opie --without-des \
15 andrew_cv_runpath_switch=none" 16 andrew_cv_runpath_switch=none"
16 17
18PACKAGECONFIG ??= ""
19PACKAGECONFIG[gssapi] = "--enable-gssapi=yes,--enable-gssapi=no,krb5,"
20
17do_configure_prepend () { 21do_configure_prepend () {
18 rm -f acinclude.m4 config/libtool.m4 22 rm -f acinclude.m4 config/libtool.m4
19} 23}
diff --git a/meta-networking/recipes-daemons/cyrus-sasl/files/avoid-to-call-AC_TRY_RUN.patch b/meta-networking/recipes-daemons/cyrus-sasl/files/avoid-to-call-AC_TRY_RUN.patch
new file mode 100644
index 000000000..6407721ae
--- /dev/null
+++ b/meta-networking/recipes-daemons/cyrus-sasl/files/avoid-to-call-AC_TRY_RUN.patch
@@ -0,0 +1,46 @@
1Avoid to call AC_TRY_RUN
2
3Upstream-Status: Inappropriate [configuration]
4
5Avoid to call AC_TRY_RUN to check if GSSAPI libraries support SPNEGO
6on cross-compile environment by definition AC_ARG_ENABLE enable-spnego
7
8Signed-off-by: Roy.Li <rongqing.li@windriver.com>
9---
10 cmulocal/sasl2.m4 | 13 ++++++++++++-
11 1 file changed, 12 insertions(+), 1 deletion(-)
12
13diff --git a/cmulocal/sasl2.m4 b/cmulocal/sasl2.m4
14index 3c2841a..a5ecf81 100644
15--- a/cmulocal/sasl2.m4
16+++ b/cmulocal/sasl2.m4
17@@ -281,6 +281,17 @@ if test "$gssapi" != no; then
18
19 cmu_save_LIBS="$LIBS"
20 LIBS="$LIBS $GSSAPIBASE_LIBS"
21+ AC_ARG_ENABLE([spnego],
22+ [AC_HELP_STRING([--enable-spnego=<DIR>],
23+ [enable SPNEGO support in GSSAPI libraries [no]])],
24+ [spnego=$enableval],
25+ [spnego=no])
26+
27+ if test "$spnego" = no; then
28+ echo "no"
29+ elif test "$spnego" = yes; then
30+ AC_DEFINE(HAVE_GSS_SPNEGO,,[Define if your GSSAPI implementation supports SPNEGO])
31+ else
32 AC_MSG_CHECKING([for SPNEGO support in GSSAPI libraries])
33 AC_TRY_RUN([
34 #ifdef HAVE_GSSAPI_H
35@@ -308,7 +319,7 @@ int main(void)
36 AC_MSG_RESULT(yes) ],
37 AC_MSG_RESULT(no))
38 LIBS="$cmu_save_LIBS"
39-
40+ fi
41 else
42 AC_MSG_RESULT([disabled])
43 fi
44--
451.7.10.4
46